math/lingeling: New port: Lingeling SAT Solver

This commit is contained in:
Yuri Victorovich 2023-01-03 07:39:38 -08:00
parent 9906e01ff0
commit ade9f5ec10
6 changed files with 82 additions and 0 deletions

View File

@ -458,6 +458,7 @@
SUBDIR += libxsmm
SUBDIR += lidia
SUBDIR += linbox
SUBDIR += lingeling
SUBDIR += linpack
SUBDIR += lis
SUBDIR += lll_spect

43
math/lingeling/Makefile Normal file
View File

@ -0,0 +1,43 @@
PORTNAME= lingeling
DISTVERSION= g20220515
CATEGORIES= math
MAINTAINER= yuri@FreeBSD.org
COMMENT= Lingeling SAT Solver
WWW= http://fmv.jku.at/lingeling/
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/COPYING
USES= gmake
USE_GITHUB= yes
GH_ACCOUNT= arminbiere
GH_TAGNAME= 72d2b13
BINARY_ALIAS= gcc=${CC}
EXECUTABLES= ilingeling lglddtrace lglmbt lgluntrace lingeling plingeling treengeling
CFLAGS+= -fPIC
PLIST_FILES= ${EXECUTABLES:S/^/bin\//} \
include/lglib.h \
lib/liblgl.a
do-configure:
@cd ${WRKSRC} && \
${SETENV} ${MAKE_ENV} ./configure.sh
do-build:
@cd ${WRKSRC} && \
${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_ARGS} -j${MAKE_JOBS_NUMBER}
do-install:
.for e in ${EXECUTABLES}
${INSTALL_PROGRAM} ${WRKSRC}/${e} ${STAGEDIR}${PREFIX}/bin
.endfor
${INSTALL_DATA} ${WRKSRC}/lglib.h ${STAGEDIR}${PREFIX}/include
${INSTALL_DATA} ${WRKSRC}/liblgl.a ${STAGEDIR}${PREFIX}/lib
.include <bsd.port.mk>

3
math/lingeling/distinfo Normal file
View File

@ -0,0 +1,3 @@
TIMESTAMP = 1672783599
SHA256 (arminbiere-lingeling-g20220515-72d2b13_GH0.tar.gz) = ad6a7e9ed10e7c49f9c901365bee639508d999f32c0d59b8a43805e6d327c797
SIZE (arminbiere-lingeling-g20220515-72d2b13_GH0.tar.gz) = 248128

View File

@ -0,0 +1,20 @@
--- configure.sh.orig 2022-05-15 14:42:39 UTC
+++ configure.sh
@@ -183,7 +183,7 @@ fi
[ x"$CC" = x ] && CC=gcc
-CFLAGS="-W -Wall"
+CFLAGS="$CFLAGS -W -Wall"
if [ $debug = yes ]
then
CFLAGS="$CFLAGS -ggdb3"
@@ -194,7 +194,7 @@ else
[ $lto = yes ] && CFLAGS="$CFLAGS -flto -fwhole-program"
fi
-LIBS="-lm"
+LIBS="$LDFLAGS -lm"
HDEPS=""
LDEPS=""

View File

@ -0,0 +1,10 @@
--- lglib.h.orig 2023-01-03 22:21:39 UTC
+++ lglib.h
@@ -7,6 +7,7 @@
#include <stdio.h> // for 'FILE'
#include <stdlib.h> // for 'int64_t'
+#include <sys/types.h>
//--------------------------------------------------------------------------

5
math/lingeling/pkg-descr Normal file
View File

@ -0,0 +1,5 @@
Lingeling, Plingeling and Treengeling.
The parallel portfolio front-end Plingeling was ranked on the first place on
unsatisfiable instances in the parallel track of the SAT Competition 2020, and
second place overall in the parallel track.