MFH: r522273 r522545 r522582 r523727
sysutils/lsof: fix build following base r356337. I took the patch from 243122 as it was more correct. PR: 243122, 243083 Submitted by: cy, yasu@utahime.org sysutils/lsof: fix after base r356432. PR: 243172 Submitted by: mjg Reported by: yasu@utahime.org sysutils/lsof: add a PPC64 work around for needing -lzpool PR: 242833 Submitted by: luciano@vespaperitivo.it sysutils/lsof: fix build on powerpc, powerpc64, powerpcse PR: 242758 Submitted by: pkubaj Approved by: ports-secteam (joneum)
This commit is contained in:
parent
fac373fbda
commit
ade18df41c
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/branches/2020Q1/; revision=523728
@ -1,9 +1,12 @@
|
||||
# Created by: David O'Brien <obrien@FreeBSD.org>
|
||||
# $FreeBSD$
|
||||
|
||||
# note: If someone has a fix for a particular ARCH please feel free
|
||||
# to commit it. I (ler) don't have access to all the ARCH's
|
||||
|
||||
PORTNAME= lsof
|
||||
DISTVERSION= 4.93.2
|
||||
PORTREVISION= 6
|
||||
PORTREVISION= 9
|
||||
PORTEPOCH= 8
|
||||
CATEGORIES= sysutils
|
||||
|
||||
@ -22,6 +25,17 @@ HAS_CONFIGURE= yes
|
||||
USE_GITHUB= yes
|
||||
GH_ACCOUNT= lsof-org
|
||||
|
||||
OPTIONS_DEFINE_powerpc64= AIM BOOKE
|
||||
OPTIONS_DEFAULT_powerpc64= AIM
|
||||
|
||||
AIM_DESC= Set for AIM hardware
|
||||
AIM_CFLAGS= -DAIM
|
||||
BOOKE_DESC= Set for BOOKE hardware
|
||||
BOOKE_CFLAGS= -DBOOKE
|
||||
|
||||
CFLAGS_powerpc= -DAIM
|
||||
CFLAGS_powerpcspe= -DBOOKE
|
||||
|
||||
SHEBANG_FILES= scripts/sort_res.perl5
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
@ -30,6 +44,12 @@ CONFIGURE_SCRIPT= Configure
|
||||
CONFIGURE_ARGS= -n freebsd
|
||||
CONFIGURE_ENV= LSOF_CC="${CC}" FREEBSD_SYS="${SRC_BASE}/sys"
|
||||
|
||||
# PPC64 needs -lzpool for reasons unknown. If someone can
|
||||
# figure out why, I (ler) am all ears.
|
||||
.if ${ARCH} == powerpc64 || ${ARCH} == powerpc
|
||||
CONFIGURE_ENV+= LSOF_CFGL="-lzpool"
|
||||
. endif
|
||||
|
||||
.if !exists(${SRC_BASE}/sys/kern/kern_lockf.c)
|
||||
IGNORE+= requires kernel sources
|
||||
.endif
|
||||
|
@ -1,4 +1,4 @@
|
||||
--- dialects/freebsd/dnode.c.orig 2019-12-19 21:29:42 UTC
|
||||
--- dialects/freebsd/dnode.c.orig 2019-05-08 07:32:25 UTC
|
||||
+++ dialects/freebsd/dnode.c
|
||||
@@ -58,9 +58,7 @@ _PROTOTYPE(static int lkup_dev_tty,(dev_t *dr, INODETY
|
||||
|
||||
@ -10,3 +10,12 @@
|
||||
#endif /* defined(HAS_TMPFS) */
|
||||
|
||||
_PROTOTYPE(static void get_lock_state,(KA_T f));
|
||||
@@ -562,7 +560,7 @@ process_overlaid_node:
|
||||
* Get the pseudo vnode tag type for FreeBSD >= 5.
|
||||
*/
|
||||
vtag = VT_UNKNOWN;
|
||||
- if (v->v_tag && !kread((KA_T)v->v_tag, (char *)&vtbuf, sizeof(vtbuf)))
|
||||
+ if (!kread((KA_T)v->v_lock.lock_object.lo_name, (char *)&vtbuf, sizeof(vtbuf)))
|
||||
{
|
||||
vtbuf[sizeof(vtbuf) - 1] = '\0';
|
||||
vtbp = vtbuf;
|
||||
|
17
sysutils/lsof/files/patch-dialects_freebsd_dnode2.c
Normal file
17
sysutils/lsof/files/patch-dialects_freebsd_dnode2.c
Normal file
@ -0,0 +1,17 @@
|
||||
--- dialects/freebsd/dnode2.c.orig 2019-05-08 07:32:25 UTC
|
||||
+++ dialects/freebsd/dnode2.c
|
||||
@@ -49,7 +49,13 @@ static char *rcsid = "$Id: dnode2.c,v 1.7 2018/02/14 1
|
||||
*
|
||||
* Note: clang's complaint about VOP_FSYNC can't be avoided.
|
||||
*/
|
||||
-#define VOP_UNLOCK(vp, f) ((void)0)
|
||||
+#include <sys/param.h>
|
||||
+#if __FreeBSD_version >= 1300074
|
||||
+#define VOP_UNLOCK_FLAGS(vp, f) ((void)0)
|
||||
+#define VOP_UNLOCK(vp) ((void)0)
|
||||
+#else
|
||||
+#define VOP_UNLOCK(vp, f) ((void)0)
|
||||
+#endif
|
||||
# endif /* defined(__clang__) */
|
||||
|
||||
#define KLD_MODULE /* for ARM: prevent "ARM_NARCH is 0 " error */
|
Loading…
Reference in New Issue
Block a user