- Update to 4.1.1

PR:		ports/145923
Submitted by:	Sunpoet Po-Chuan Hsieh <sunpoet@sunpoet.net> (maintainer)
This commit is contained in:
Wen Heping 2010-04-22 03:25:38 +00:00
parent bc749fa5cb
commit adbba925de
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=253045
4 changed files with 51 additions and 33 deletions

View File

@ -6,8 +6,7 @@
#
PORTNAME= netcdf
PORTVERSION= 4.0.1
PORTREVISION= 1
PORTVERSION= 4.1.1
CATEGORIES= science
MASTER_SITES= http://www.unidata.ucar.edu/downloads/netcdf/ftp/ \
ftp://ftp.unidata.ucar.edu/pub/netcdf/ \
@ -20,8 +19,8 @@ CONFLICTS= hdf-4.* netcdf-3.*
LATEST_LINK= netcdf4
CONFIGURE_ARGS= --disable-f77 --disable-f90 \
--enable-cxx --enable-cxx-4 --enable-ncgen4 --enable-netcdf-4 \
--enable-shared --with-hdf5=${LOCALBASE} --with-zlib=/usr
--enable-cxx --enable-cxx-4 --enable-netcdf-4 --enable-shared \
--with-hdf5=${LOCALBASE} --with-zlib=/usr
CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include -fPIC -DPIC -Df2cFortran"
MAKE_ENV+= MAKEINFOFLAGS="--no-split" INFODIR="${PREFIX}/${INFO_PATH}"
@ -30,13 +29,13 @@ USE_LDCONFIG= yes
LIB_DEPENDS+= hdf5.6:${PORTSDIR}/science/hdf5-18
INFO= netcdf netcdf-c netcdf-cxx netcdf-cxx4 netcdf-f77 \
INFO= netcdf netcdf-c netcdf-cxx netcdf-f77 \
netcdf-f90 netcdf-install netcdf-tutorial
MAN1= ncdump.1 ncgen.1 ncgen4.1
MAN1= ncdump.1 ncgen.1 ncgen3.1 nccopy.1
MAN3= netcdf.3
OPTIONS= HDF5_CONVERT "Do data conversion through HDF5" off
OPTIONS= SZIP "SZIP support (required if HDF5 was built with SZIP)" off
.if !defined(NOPORTDOCS)
CONFIGURE_ARGS+=--enable-docs-install
@ -44,18 +43,19 @@ CONFIGURE_ARGS+=--enable-docs-install
CONFIGURE_ARGS+=--disable-docs-install
.endif
.if defined(WITH_HDF5_CONVERT)
CONFIGURE_ARGS+=--enable-hdf5-convert
.if defined(WITH_SZIP)
CONFIGURE_ARGS+= --with-szlib=${LOCALBASE}
LIB_DEPEND+= sz.2:${PORTSDIR}/science/szip
.endif
post-patch:
@${REINPLACE_CMD} -e \
's|$$(libdir)/pkgconfig|$$(prefix)/libdata/pkgconfig|' \
${WRKSRC}/Makefile.in
@${REINPLACE_CMD} -e '288 s/\(info_docs\).*/html_docs\)/' \
@${REINPLACE_CMD} -e '297 s/\(info_docs\).*/html_docs\)/' \
${WRKSRC}/man4/Makefile.in
.if defined(NOPORTDOCS)
@${REINPLACE_CMD} -e '829 s/install-docDATA //' \
@${REINPLACE_CMD} -e '839 s/install-docDATA //' \
${WRKSRC}/man4/Makefile.in
.endif

View File

@ -1,3 +1,3 @@
MD5 (netcdf-4.0.1.tar.gz) = a251453c5477599f050fa4e593295186
SHA256 (netcdf-4.0.1.tar.gz) = 290e377aa2e9419bb50a2fa1038d6e77d36f239a8a9c3be9e3a9319f1e484d19
SIZE (netcdf-4.0.1.tar.gz) = 8018998
MD5 (netcdf-4.1.1.tar.gz) = 79c5ff14c80d5e18dd8f1fceeae1c8e1
SHA256 (netcdf-4.1.1.tar.gz) = 7933d69d378c57f038375bae4dd78c52442a06e2647fce4b75c13a225e342fb0
SIZE (netcdf-4.1.1.tar.gz) = 11201096

View File

@ -1,12 +0,0 @@
--- libsrc4/nc4hdf.c.orig 2008-06-10 23:38:34.000000000 +0800
+++ libsrc4/nc4hdf.c 2008-12-04 00:10:23.755371693 +0800
@@ -465,6 +465,9 @@
int need_to_extend = 0, fill_value_recs = 0;
int scalar = 0, retval = NC_NOERR, range_error = 0, i, d2;
void *bufr = NULL;
+#ifdef HDF5_CONVERT
+ H5T_conv_except_func_t except_func;
+#endif
#ifndef HDF5_CONVERT
int need_to_convert = 0;
size_t len = 1;

View File

@ -1,12 +1,39 @@
bin/nc-config
bin/nccopy
bin/ncdump
bin/ncgen
bin/ncgen4
bin/ncgen3
include/ncAtt.h
include/ncByte.h
include/ncChar.h
include/ncCheck.h
include/ncCompoundType.h
include/ncDim.h
include/ncDouble.h
include/ncEnumType.h
include/ncException.h
include/ncFile.h
include/ncFloat.h
include/ncGroup.h
include/ncGroupAtt.h
include/ncInt.h
include/ncInt64.h
include/ncOpaqueType.h
include/ncShort.h
include/ncString.h
include/ncType.h
include/ncUbyte.h
include/ncUint.h
include/ncUint64.h
include/ncUshort.h
include/ncVar.h
include/ncVarAtt.h
include/ncVlenType.h
include/netcdf
include/ncvalues.h
include/netcdf.h
include/netcdf.hh
include/netcdfcpp.h
include/netcdfcpp4.h
lib/libnetcdf.a
lib/libnetcdf.la
lib/libnetcdf.so
@ -22,37 +49,40 @@ lib/libnetcdf_c++4.so.1
libdata/pkgconfig/netcdf.pc
%%PORTDOCS%%%%DOCSDIR%%/ncdump-man-1.html
%%PORTDOCS%%%%DOCSDIR%%/ncgen-man-1.html
%%PORTDOCS%%%%DOCSDIR%%/ncgen4-man-1.html
%%PORTDOCS%%%%DOCSDIR%%/ncgen3-man-1.html
%%PORTDOCS%%%%DOCSDIR%%/netcdf-c.html
%%PORTDOCS%%%%DOCSDIR%%/netcdf-c.info
%%PORTDOCS%%%%DOCSDIR%%/netcdf-c.pdf
%%PORTDOCS%%%%DOCSDIR%%/netcdf-c.ps
%%PORTDOCS%%%%DOCSDIR%%/netcdf-c.txt
%%PORTDOCS%%%%DOCSDIR%%/netcdf-cxx.html
%%PORTDOCS%%%%DOCSDIR%%/netcdf-cxx.info
%%PORTDOCS%%%%DOCSDIR%%/netcdf-cxx.pdf
%%PORTDOCS%%%%DOCSDIR%%/netcdf-cxx.ps
%%PORTDOCS%%%%DOCSDIR%%/netcdf-cxx.txt
%%PORTDOCS%%%%DOCSDIR%%/netcdf-cxx4.html
%%PORTDOCS%%%%DOCSDIR%%/netcdf-cxx4.pdf
%%PORTDOCS%%%%DOCSDIR%%/netcdf-cxx4.ps
%%PORTDOCS%%%%DOCSDIR%%/netcdf-cxx4.txt
%%PORTDOCS%%%%DOCSDIR%%/netcdf-f77.html
%%PORTDOCS%%%%DOCSDIR%%/netcdf-f77.info
%%PORTDOCS%%%%DOCSDIR%%/netcdf-f77.pdf
%%PORTDOCS%%%%DOCSDIR%%/netcdf-f77.ps
%%PORTDOCS%%%%DOCSDIR%%/netcdf-f77.txt
%%PORTDOCS%%%%DOCSDIR%%/netcdf-f90.html
%%PORTDOCS%%%%DOCSDIR%%/netcdf-f90.info
%%PORTDOCS%%%%DOCSDIR%%/netcdf-f90.pdf
%%PORTDOCS%%%%DOCSDIR%%/netcdf-f90.ps
%%PORTDOCS%%%%DOCSDIR%%/netcdf-f90.txt
%%PORTDOCS%%%%DOCSDIR%%/netcdf-install.html
%%PORTDOCS%%%%DOCSDIR%%/netcdf-install.info
%%PORTDOCS%%%%DOCSDIR%%/netcdf-install.pdf
%%PORTDOCS%%%%DOCSDIR%%/netcdf-install.ps
%%PORTDOCS%%%%DOCSDIR%%/netcdf-install.txt
%%PORTDOCS%%%%DOCSDIR%%/netcdf-man-3.html
%%PORTDOCS%%%%DOCSDIR%%/netcdf-tutorial.html
%%PORTDOCS%%%%DOCSDIR%%/netcdf-tutorial.info
%%PORTDOCS%%%%DOCSDIR%%/netcdf-tutorial.pdf
%%PORTDOCS%%%%DOCSDIR%%/netcdf-tutorial.ps
%%PORTDOCS%%%%DOCSDIR%%/netcdf-tutorial.txt
%%PORTDOCS%%%%DOCSDIR%%/netcdf.html
%%PORTDOCS%%%%DOCSDIR%%/netcdf.info
%%PORTDOCS%%%%DOCSDIR%%/netcdf.pdf
%%PORTDOCS%%%%DOCSDIR%%/netcdf.ps
%%PORTDOCS%%%%DOCSDIR%%/netcdf.txt