Add impress 1.1b9
ImPressTM is a WYSIWYG layout program designed especially for Linux [sic]. It allows you to create presentations and Postscript documents using fully scalable graphics similar to programs like Macromedia Freehand, Corel Draw, Adobe Illustrator and Visio. It is different from raster graphic packages like gimp, Adobe PhotoShop and Jasc's PaintShop Pro in that it deals with graphical objects which can be manipulated on a canvas rather than just layers of paint. Obtained from: OpenBSD
This commit is contained in:
parent
fec8d07b9a
commit
ad75835a64
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=46704
@ -60,6 +60,7 @@
|
||||
SUBDIR += hnb
|
||||
SUBDIR += hte
|
||||
SUBDIR += iiimecf
|
||||
SUBDIR += impress
|
||||
SUBDIR += jed
|
||||
SUBDIR += jedit
|
||||
SUBDIR += jext
|
||||
|
20
editors/impress/Makefile
Normal file
20
editors/impress/Makefile
Normal file
@ -0,0 +1,20 @@
|
||||
# Ports collection makefile for: impress
|
||||
# Date created: 23 Aug 2001
|
||||
# Whom: Kris Kennaway <kris@FreeBSD.org>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= impress
|
||||
PORTVERSION= 1.1b9
|
||||
CATEGORIES= editors
|
||||
MASTER_SITES= http://www.ntlug.org/~ccox/impress/
|
||||
DISTNAME= imp${PORTVERSION}
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
|
||||
RUN_DEPENDS= wish8.3:${PORTSDIR}/x11-toolkits/tk83
|
||||
|
||||
WRKSRC= ${WRKDIR}/${PKGNAME}
|
||||
|
||||
.include <bsd.port.mk>
|
1
editors/impress/distinfo
Normal file
1
editors/impress/distinfo
Normal file
@ -0,0 +1 @@
|
||||
MD5 (imp1.1b9.tar.gz) = 46f09f26ed036f5ec491693390285dec
|
43
editors/impress/files/patch-Makefile
Normal file
43
editors/impress/files/patch-Makefile
Normal file
@ -0,0 +1,43 @@
|
||||
--- Makefile.orig Fri Jun 29 10:22:48 2001
|
||||
+++ Makefile Fri Jun 29 10:25:52 2001
|
||||
@@ -1,33 +1,11 @@
|
||||
-cmp=/usr/bin/cmp
|
||||
-cp=/bin/cp
|
||||
-mv=/bin/mv
|
||||
-strip=/usr/bin/strip
|
||||
-ln=/bin/ln
|
||||
-PREFIX=/usr
|
||||
+PREFIX?=/usr/local
|
||||
|
||||
-all: make_impress make_font3d make_pstoedit
|
||||
+all: make_impress
|
||||
|
||||
-make_font3d:
|
||||
- (cd font3d;make LDFLAGS=-static)
|
||||
- @-${strip} font3d/font3d
|
||||
- @-${cmp} font3d/font3d bin/font3d 2>/dev/null || \
|
||||
- ${cp} font3d/font3d bin/font3d
|
||||
-
|
||||
-make_pstoedit:
|
||||
- (cd pstoedit/config;./configure)
|
||||
- (cd pstoedit/src;make LINK="c++ -static")
|
||||
- @-${strip} pstoedit/src/pstoedit
|
||||
- @-${cmp} pstoedit/src/pstoedit bin/pstoedit 2>/dev/null || \
|
||||
- ${cp} pstoedit/src/pstoedit bin/pstoedit
|
||||
-
|
||||
make_impress:
|
||||
- (cd src;make all install)
|
||||
-
|
||||
-$(PREFIX)/bin/pstoedit.orig:
|
||||
- @-mv $(PREFIX)/bin/pstoedit $(PREFIX)/bin/pstoedit.orig
|
||||
+ (cd src;make all)
|
||||
|
||||
-install: $(PREFIX)/bin/pstoedit.orig
|
||||
- install -c bin/impress $(PREFIX)/bin && rm -f $(PREFIX)/bin/impress.tcl && ${ln} -s $(PREFIX)/bin/impress $(PREFIX)/bin/impress.tcl
|
||||
- install -c bin/transeps $(PREFIX)/bin
|
||||
- install -c bin/font3d $(PREFIX)/bin
|
||||
- install -c bin/pstoedit $(PREFIX)/bin
|
||||
+install:
|
||||
+ install -c -m 755 src/impress $(PREFIX)/bin
|
||||
+ @mkdir $(PREFIX)/share/doc/impress
|
||||
+ @cp src/doc/* $(PREFIX)/share/doc/impress
|
98
editors/impress/files/patch-src_Makefile
Normal file
98
editors/impress/files/patch-src_Makefile
Normal file
@ -0,0 +1,98 @@
|
||||
--- src/Makefile.orig Fri Jun 29 10:26:19 2001
|
||||
+++ src/Makefile Fri Jun 29 10:27:01 2001
|
||||
@@ -1,94 +1,8 @@
|
||||
-cmp=/usr/bin/cmp
|
||||
-cp=/bin/cp
|
||||
-mv=/bin/mv
|
||||
-ln=/bin/ln
|
||||
-
|
||||
-all: impress transeps
|
||||
+all: impress
|
||||
|
||||
impress: impress.tcl
|
||||
cat impress.tcl >impress
|
||||
chmod a+x impress
|
||||
-
|
||||
-../pstoedit/src/drvbase.h.orig:
|
||||
- @-${mv} ../pstoedit/src/drvbase.h ../pstoedit/src/drvbase.h.orig
|
||||
-
|
||||
-../pstoedit/src/drvtk.cpp.orig:
|
||||
- @-${mv} ../pstoedit/src/drvtk.cpp ../pstoedit/src/drvtk.cpp.orig
|
||||
-
|
||||
-../pstoedit/src/drvtk.h.orig:
|
||||
- @-${mv} ../pstoedit/src/drvtk.h ../pstoedit/src/drvtk.h.orig
|
||||
-
|
||||
-installdrvtk: ../pstoedit/src/drvtk.cpp.orig ../pstoedit/src/drvtk.h.orig
|
||||
- @-${cmp} drvtk.cpp ../pstoedit/src/drvtk.cpp 2>/dev/null || \
|
||||
- echo "Updating drvtk.cpp" >&2 && ${cp} drvtk.cpp ../pstoedit/src
|
||||
- @-${cmp} drvtk.h ../pstoedit/src/drvtk.h 2>/dev/null || \
|
||||
- echo "Updating drvtk.h" >&2 && ${cp} drvtk.h ../pstoedit/src
|
||||
- @-${cmp} drvbase.h ../pstoedit/src/drvbase.h 2>/dev/null || \
|
||||
- echo "Updating drvbase.h" >&2 && ${cp} drvbase.h ../pstoedit/src
|
||||
-
|
||||
-install: impress impress.tcl transeps COPYING CHANGES OPTIONS README tkFont-patch.diff tkUnixWm-patch.diff installdrvtk
|
||||
- @-mkdir ../bin
|
||||
- @-${cmp} impress ../bin/impress 2>/dev/null || \
|
||||
- echo "Updating impress" >&2 && ${cp} impress ../bin
|
||||
- @-${cmp} transeps ../bin/transeps 2>/dev/null || \
|
||||
- echo "Updating transeps" >&2 && ${cp} transeps ../bin
|
||||
- @-${cmp} COPYING ../COPYING 2>/dev/null || \
|
||||
- echo "Updating COPYING" >&2 && ${cp} COPYING ..
|
||||
- @-${cmp} README ../README 2>/dev/null || \
|
||||
- echo "Updating README" >&2 && ${cp} README ..
|
||||
- @-${cmp} CHANGES ../CHANGES 2>/dev/null || \
|
||||
- echo "Updating CHANGES" >&2 && ${cp} CHANGES ..
|
||||
- @-${cmp} OPTIONS ../OPTIONS 2>/dev/null || \
|
||||
- echo "Updating OPTIONS" >&2 && ${cp} OPTIONS ..
|
||||
- @-${cmp} tkFont-patch.diff ../tkFont-patch.diff 2>/dev/null || \
|
||||
- echo "Updating tkFont-patch.diff" >&2 && ${cp} tkFont-patch.diff ..
|
||||
- @-${cmp} tkUnixWm-patch.diff ../tkUnixWm-patch.diff 2>/dev/null || \
|
||||
- echo "Updating tkUnixWm-patch.diff" >&2 && ${cp} tkUnixWm-patch.diff ..
|
||||
- @-mkdir ../doc
|
||||
- @-${cmp} doc/arrows.jpg ../doc/arrows.jpg 2>/dev/null || \
|
||||
- echo "Updating arrows.jpg" >&2 && ${cp} doc/arrows.jpg ../doc
|
||||
- @-${cmp} doc/custcolor.jpg ../doc/custcolor.jpg 2>/dev/null || \
|
||||
- echo "Updating custcolor.jpg" >&2 && ${cp} doc/custcolor.jpg ../doc
|
||||
- @-${cmp} doc/file.jpg ../doc/file.jpg 2>/dev/null || \
|
||||
- echo "Updating file.jpg" >&2 && ${cp} doc/file.jpg ../doc
|
||||
- @-${cmp} doc/fonts.jpg ../doc/fonts.jpg 2>/dev/null || \
|
||||
- echo "Updating fonts.jpg" >&2 && ${cp} doc/fonts.jpg ../doc
|
||||
- @-${cmp} doc/grid.jpg ../doc/grid.jpg 2>/dev/null || \
|
||||
- echo "Updating grid.jpg" >&2 && ${cp} doc/grid.jpg ../doc
|
||||
- @-${cmp} doc/impdoc.html ../doc/impdoc.html 2>/dev/null || \
|
||||
- echo "Updating impdoc.html" >&2 && ${cp} doc/impdoc.html ../doc
|
||||
- @-${cmp} doc/implogo.gif ../doc/implogo.gif 2>/dev/null || \
|
||||
- echo "Updating implogo.gif" >&2 && ${cp} doc/implogo.gif ../doc
|
||||
- @-${cmp} doc/impressbuttons.jpg ../doc/impressbuttons.jpg 2>/dev/null || \
|
||||
- echo "Updating impressbuttons.jpg" >&2 && ${cp} doc/impressbuttons.jpg ../doc
|
||||
- @-${cmp} doc/impressmain2.jpg ../doc/impressmain2.jpg 2>/dev/null || \
|
||||
- echo "Updating impressmain2.jpg" >&2 && ${cp} doc/impressmain2.jpg ../doc
|
||||
- @-${cmp} doc/lgtoolbar.jpg ../doc/lgtoolbar.jpg 2>/dev/null || \
|
||||
- echo "Updating lgtoolbar.jpg" >&2 && ${cp} doc/lgtoolbar.jpg ../doc
|
||||
- @-${cmp} doc/openurldialog.jpg ../doc/openurldialog.jpg 2>/dev/null || \
|
||||
- echo "Updating openurldialog.jpg" >&2 && ${cp} doc/openurldialog.jpg ../doc
|
||||
- @-${cmp} doc/page.jpg ../doc/page.jpg 2>/dev/null || \
|
||||
- echo "Updating page.jpg" >&2 && ${cp} doc/page.jpg ../doc
|
||||
- @-${cmp} doc/palette.jpg ../doc/palette.jpg 2>/dev/null || \
|
||||
- echo "Updating palette.jpg" >&2 && ${cp} doc/palette.jpg ../doc
|
||||
- @-${cmp} doc/print.jpg ../doc/print.jpg 2>/dev/null || \
|
||||
- echo "Updating print.jpg" >&2 && ${cp} doc/print.jpg ../doc
|
||||
- @-${cmp} doc/props.jpg ../doc/props.jpg 2>/dev/null || \
|
||||
- echo "Updating props.jpg" >&2 && ${cp} doc/props.jpg ../doc
|
||||
- @-${cmp} doc/pstoedit.jpg ../doc/pstoedit.jpg 2>/dev/null || \
|
||||
- echo "Updating pstoedit.jpg" >&2 && ${cp} doc/pstoedit.jpg ../doc
|
||||
- @-${cmp} doc/selection.jpg ../doc/selection.jpg 2>/dev/null || \
|
||||
- echo "Updating selection.jpg" >&2 && ${cp} doc/selection.jpg ../doc
|
||||
- @-${cmp} doc/slide.jpg ../doc/slide.jpg 2>/dev/null || \
|
||||
- echo "Updating slide.jpg" >&2 && ${cp} doc/slide.jpg ../doc
|
||||
- @-${cmp} doc/tclet.jpg ../doc/tclet.jpg 2>/dev/null || \
|
||||
- echo "Updating tclet.jpg" >&2 && ${cp} doc/tclet.jpg ../doc
|
||||
- @-${cmp} doc/toolbarpref.jpg ../doc/toolbarpref.jpg 2>/dev/null || \
|
||||
- echo "Updating toolbarpref.jpg" >&2 && ${cp} doc/toolbarpref.jpg ../doc
|
||||
- @-${cmp} doc/urldialog.jpg ../doc/urldialog.jpg 2>/dev/null || \
|
||||
- echo "Updating urldialog.jpg" >&2 && ${cp} doc/urldialog.jpg ../doc
|
||||
- @-${cmp} doc/miniview.jpg ../doc/miniview.jpg 2>/dev/null || \
|
||||
- echo "Updating miniview.jpg" >&2 && ${cp} doc/miniview.jpg ../doc
|
||||
|
||||
clean:
|
||||
rm -f impress transeps
|
11
editors/impress/files/patch-src_impress_tcl
Normal file
11
editors/impress/files/patch-src_impress_tcl
Normal file
@ -0,0 +1,11 @@
|
||||
--- src/impress.tcl.orig Fri Jun 29 10:21:58 2001
|
||||
+++ src/impress.tcl Fri Jun 29 10:22:10 2001
|
||||
@@ -19,7 +19,7 @@
|
||||
# Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
|
||||
#
|
||||
# restart trick \
|
||||
-exec wish "$0" "$@"
|
||||
+exec wish8.3 "$0" "$@"
|
||||
|
||||
option add *Radiobutton*borderWidth 1
|
||||
option add *Button*borderWidth 1
|
1
editors/impress/pkg-comment
Normal file
1
editors/impress/pkg-comment
Normal file
@ -0,0 +1 @@
|
||||
Publishing and presentation tool
|
11
editors/impress/pkg-descr
Normal file
11
editors/impress/pkg-descr
Normal file
@ -0,0 +1,11 @@
|
||||
ImPress is the WYSIWYG Publishing and Presentation for UNIX.
|
||||
It can also be used within a WWW browser (e.g. Netscape) that is
|
||||
capable of running the Tcl Plugin. The Tcl Plugin can be obtained from
|
||||
the web site at: http://dev.scriptics.com/
|
||||
|
||||
ImPress can be significantly enhanced through use of several modified utilities:
|
||||
o Pstoedit - Allows you to translate EPS files to Tk for ImPress use.
|
||||
o Font3D - Translates TrueType font strings to vectorized Tk.
|
||||
o Type1inst - Aids in maintaining Ghostscript Fontmaps and X11 fonts.dir files.
|
||||
|
||||
WWW: http://www.ntlug.org/~ccox/impress/
|
26
editors/impress/pkg-plist
Normal file
26
editors/impress/pkg-plist
Normal file
@ -0,0 +1,26 @@
|
||||
bin/impress
|
||||
share/doc/impress/add.txt
|
||||
share/doc/impress/arrows.jpg
|
||||
share/doc/impress/custcolor.jpg
|
||||
share/doc/impress/file.jpg
|
||||
share/doc/impress/fonts.jpg
|
||||
share/doc/impress/grid.jpg
|
||||
share/doc/impress/impdoc.html
|
||||
share/doc/impress/implogo.gif
|
||||
share/doc/impress/impressbuttons.jpg
|
||||
share/doc/impress/impressmain2.jpg
|
||||
share/doc/impress/keys.jpg
|
||||
share/doc/impress/lgtoolbar.jpg
|
||||
share/doc/impress/miniview.jpg
|
||||
share/doc/impress/openurldialog.jpg
|
||||
share/doc/impress/page.jpg
|
||||
share/doc/impress/palette.jpg
|
||||
share/doc/impress/print.jpg
|
||||
share/doc/impress/props.jpg
|
||||
share/doc/impress/pstoedit.jpg
|
||||
share/doc/impress/selection.jpg
|
||||
share/doc/impress/slide.jpg
|
||||
share/doc/impress/tclet.jpg
|
||||
share/doc/impress/toolbarpref.jpg
|
||||
share/doc/impress/urldialog.jpg
|
||||
@dirrm share/doc/impress
|
Loading…
Reference in New Issue
Block a user