Update to 0.5.6a

PR: ports/88074
Submitted by: Vasil Dimov <vd@datamax.bg>
This commit is contained in:
Kevin Lo 2005-10-31 02:07:46 +00:00
parent 973fbf4c3c
commit ad5a28a3f1
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=146796
5 changed files with 25 additions and 49 deletions

View File

@ -6,15 +6,15 @@
#
PORTNAME= libextractor
PORTVERSION= 0.5.0
PORTREVISION= 1
PORTVERSION= 0.5.6a
CATEGORIES= textproc
MASTER_SITES= http://gnunet.org/libextractor/download/
MASTER_SITES= http://gnunet.org/libextractor/download/ \
${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= kevlo@FreeBSD.org
COMMENT= Library for keyword extraction
USE_BZIP2= yes
USE_GNOME= glib20
USE_PYTHON= yes
USE_REINPLACE= yes
@ -40,6 +40,9 @@ post-patch:
@${REINPLACE_CMD} -e 's|-lc_r|${PTHREAD_LIBS}|g' \
${WRKSRC}/configure
check: build
@(cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} check)
.include <bsd.port.pre.mk>
.if exists(${LOCALBASE}/include/wand/magick-wand.h)

View File

@ -1,2 +1,2 @@
MD5 (libextractor-0.5.0.tar.bz2) = b7c1288a63a08c35ba8ba9ec7df9c2ae
SIZE (libextractor-0.5.0.tar.bz2) = 6303024
MD5 (libextractor-0.5.6a.tar.gz) = 1e8022f10d58cc9f83ca3700b6645263
SIZE (libextractor-0.5.6a.tar.gz) = 6115101

View File

@ -1,34 +1,6 @@
--- src/include/plibc.h.orig Tue Oct 4 23:37:40 2005
+++ src/include/plibc.h Tue Oct 4 23:41:22 2005
@@ -451,20 +451,20 @@
#define STRERROR(i) strerror(i)
#define READLINK(p, b, s) readlink(p, b, s)
#define LSTAT(p, b) lstat(p, b)
- #define PRINTF(f, ...) printf(f , __VA_ARGS__)
- #define FPRINTF(fil, fmt, ...) fprintf(fil, fmt, __VA_ARGS__)
+ #define PRINTF(f, ARGS...) printf(f , ##ARGS)
+ #define FPRINTF(fil, fmt, ARGS...) fprintf(fil, fmt, ##ARGS)
#define VPRINTF(f, a) vprintf(f, a)
#define VFPRINTF(s, f, a) vfprintf(s, f, a)
#define VSPRINTF(d, f, a) vsprintf(d, f, a)
#define VSNPRINTF(str, size, fmt, a) vsnprintf(str, size, fmt, a)
- #define _REAL_SNPRINTF(str, size, fmt, ...) snprintf(str, size, fmt, __VA_ARGS__)
- #define SPRINTF(d, f, ...) sprintf(d, f, __VA_ARGS__)
+ #define _REAL_SNPRINTF(str, size, fmt, ARGS...) snprintf(str, size, fmt, ##ARGS)
+ #define SPRINTF(d, f, ARGS...) sprintf(d, f, ##ARGS)
#define VSSCANF(s, f, a) vsscanf(s, f, a)
- #define SSCANF(s, f, ...) sscanf(s, f, __VA_ARGS__)
+ #define SSCANF(s, f, ARGS...) sscanf(s, f, ##ARGS)
#define VFSCANF(s, f, a) vfscanf(s, f, a)
#define VSCANF(f, a) vscanf(f, a)
- #define SCANF(f, ...) scanf(f, __VA_ARGS__)
- #define FSCANF(s, f, ...) fscanf(s, f, __VA_ARGS__)
+ #define SCANF(f, ARGS...) scanf(f, ##ARGS)
+ #define FSCANF(s, f, ARGS...) fscanf(s, f, ##ARGS)
#define ACCEPT(s, a, l) accept(s, a, l)
#define BIND(s, n, l) bind(s, n, l)
#define CONNECT(s, n, l) connect(s, n, l)
@@ -515,20 +515,20 @@
--- src/include/plibc.h.orig Wed Oct 26 18:55:22 2005
+++ src/include/plibc.h Wed Oct 26 19:04:33 2005
@@ -506,20 +506,20 @@
#define STRERROR(i) _win_strerror(i)
#define READLINK(p, b, s) _win_readlink(p, b, s)
#define LSTAT(p, b) _win_lstat(p, b)
@ -53,6 +25,6 @@
- #define FSCANF(s, f, ...) _win_fscanf(s, f, __VA_ARGS__)
+ #define SCANF(f, ARGS...) _win_scanf(f, ##ARGS)
+ #define FSCANF(s, f, ARGS...) _win_fscanf(s, f, ##ARGS)
#define WAITPID(p, s, o) _win_waitpid(p, s, o)
#define ACCEPT(s, a, l) _win_accept(s, a, l)
#define BIND(s, n, l) _win_bind(s, n, l)
#define CONNECT(s, n, l) _win_connect(s, n, l)

View File

@ -1,11 +1,11 @@
--- src/main/Makefile.in.orig Sat May 21 15:43:44 2005
+++ src/main/Makefile.in Fri Jul 15 21:04:42 2005
@@ -703,8 +703,6 @@
--- src/main/Makefile.in.orig Wed Oct 26 19:19:12 2005
+++ src/main/Makefile.in Wed Oct 26 19:19:28 2005
@@ -263,7 +263,7 @@
extract_LDADD = \
$(top_builddir)/src/main/libextractor.la
-@MINGW_FALSE@dlflag = -ldl
+@MINGW_FALSE@dlflag =
install-exec-local:
- python libextractor_python_setup.py $(libdir) build
- python libextractor_python_setup.py $(libdir) install --prefix=$(PYTHON_PREFIX)
# Tell versions [3.59,3.63) of GNU make to not export all variables.
# Otherwise a system limit (for SysV at least) may be exceeded.
.NOEXPORT:
#if HAVE_ZLIB
zlib = -lz

View File

@ -2,11 +2,12 @@ bin/extract
include/extractor.h
lib/libextractor.a
lib/libextractor.so
lib/libextractor.so.1
lib/libextractor.so.2
lib/libextractor/libextractor_asf.so
lib/libextractor/libextractor_deb.so
lib/libextractor/libextractor_dvi.so
lib/libextractor/libextractor_elf.so
lib/libextractor/libextractor_exiv2.so
lib/libextractor/libextractor_filename.so
lib/libextractor/libextractor_gif.so
lib/libextractor/libextractor_hash_md5.so
@ -24,7 +25,6 @@ lib/libextractor/libextractor_mp3.so
lib/libextractor/libextractor_mpeg.so
%%VORBIS:%%lib/libextractor/libextractor_ogg.so
lib/libextractor/libextractor_oo.so
lib/libextractor/libextractor_pdf.a
lib/libextractor/libextractor_pdf.so
lib/libextractor/libextractor_png.so
lib/libextractor/libextractor_printable_da.so
@ -33,6 +33,7 @@ lib/libextractor/libextractor_printable_en.so
lib/libextractor/libextractor_printable_es.so
lib/libextractor/libextractor_printable_it.so
lib/libextractor/libextractor_printable_no.so
lib/libextractor/libextractor_printable_pt.so
lib/libextractor/libextractor_ps.so
lib/libextractor/libextractor_qt.so
lib/libextractor/libextractor_real.so