Add as31, a free 8051 assembler originally written by Ken Stauffer.

AS31 is a good tool for building small 8051-based projects that are
written in 100% 8051 assembly language.

PR:		ports/59549
Submitted by:	Volker Stolz <stolz@i2.informatik.rwth-aachen.de>
This commit is contained in:
Pav Lucistnik 2003-12-06 13:26:11 +00:00
parent 0d9a1d7920
commit ad529cf229
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=95187
6 changed files with 58 additions and 0 deletions

View File

@ -38,6 +38,7 @@
SUBDIR += arm-rtems-gcc
SUBDIR += arm-rtems-gdb
SUBDIR += arm-rtems-objc
SUBDIR += as31
SUBDIR += as80
SUBDIR += asis
SUBDIR += asl

34
devel/as31/Makefile Normal file
View File

@ -0,0 +1,34 @@
# New ports collection makefile for: as31
# Date created: Nov 21, 2003
# Whom: Volker Stolz <stolz@i2.informatik.rwth-aachen.de>
#
# $FreeBSD$
#
PORTNAME= as31
PORTVERSION= 2.0.b3
CATEGORIES= devel
MASTER_SITES= http://www.pjrc.com/tech/8051/tools/
DISTNAME= ${PORTNAME}_beta3
MAINTAINER= stolz@i2.informatik.rwth-aachen.de
COMMENT= A free 8051 assembler
.ifndef(WITHOUT_X11)
USE_GNOME= gtk12
PLIST_SUB+= X11=""
.else
ALL_TARGET= as31
PLIST_SUB+= X11="@comment "
.endif
USE_BISON= YES
WRKSRC= ${WRKDIR}/${PORTNAME}
do-install:
@${INSTALL} ${WRKSRC}/as31 ${PREFIX}/bin
.ifndef(WITHOUT_X11)
@${INSTALL} ${WRKSRC}/as31_gtk ${PREFIX}/bin
.endif
.include <bsd.port.mk>

1
devel/as31/distinfo Normal file
View File

@ -0,0 +1 @@
MD5 (as31_beta3.tar.gz) = 24e2d74747e0b3672cdb581138e50d8f

View File

@ -0,0 +1,13 @@
--- Makefile.orig Fri Nov 21 14:10:27 2003
+++ Makefile Fri Nov 21 14:10:55 2003
@@ -20,8 +20,8 @@
#Use this CFLAGS line with gcc on linux
-CFLAGS=-O3 -Wall
-CC=gcc
+#CFLAGS=-O3 -Wall
+#CC=gcc
#Use this CFLAGS line on solaris, etc
#CFLAGS=-O

7
devel/as31/pkg-descr Normal file
View File

@ -0,0 +1,7 @@
AS31 is a free 8051 assembler originally written by Ken Stauffer.
Versions of AS31 found here include important bug fixes and added
features, such as standard intel-hex output format for use with
PAULMON2 and EPROM programmers. AS31 is a good tool for building
small 8051-based projects that are written in 100% 8051 assembly language.
WWW: http://www.pjrc.com/tech/8051/

2
devel/as31/pkg-plist Normal file
View File

@ -0,0 +1,2 @@
bin/as31
%%X11%%bin/as31_gtk