Allow pwlib to work on ARCHS != i386.

Tested on alpha, i386, and ia64.

Submitted by:	marcel
Approved by:	maintainer (implicit)
This commit is contained in:
Joe Marcus Clarke 2004-03-05 02:37:57 +00:00
parent 0a072e6e9a
commit ad0bbce2c7
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=102966
10 changed files with 118 additions and 114 deletions

View File

@ -33,9 +33,13 @@ MAKE_ENV= PWLIBDIR=${WRKDIR}/pwlib
THE_MACHTYPE= ${ARCH:S/i386/x86/}
MAKE_ARGS= OSTYPE=${OPSYS} MACHTYPE=${THE_MACHTYPE} OSRELEASE=${OSVERSION} CPLUS=${CXX}
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 502101
ONLY_FOR_ARCHS= i386
.endif
do-install:
# ${INSTALL_PROGRAM} ${WRKSRC}/samples/simple/obj_${OPSYS}_${THE_MACHTYPE}_r/simph323 ${PREFIX}/bin
.include <bsd.port.mk>
.include <bsd.port.post.mk>

View File

@ -1,19 +1,26 @@
*** configure.in.orig Sun Aug 31 09:31:23 2003
--- configure.in Sun Aug 31 09:31:50 2003
*************** case "$target_os" in
*** 39,45 ****
STDCCFLAGS="-DP_LINUX=$OSRELEASE" ;;
freebsd* ) OSTYPE=FreeBSD ;
! OSRELEASE=`sysctl -n kern.osreldate` ;
STDCCFLAGS="-DP_FREEBSD=$OSRELEASE" ;;
openbsd* ) OSTYPE=OpenBSD ;
--- 39,45 ----
STDCCFLAGS="-DP_LINUX=$OSRELEASE" ;;
freebsd* ) OSTYPE=FreeBSD ;
! ## use enviroment variable OSRELEASE=`sysctl -n kern.osreldate` ;
STDCCFLAGS="-DP_FREEBSD=$OSRELEASE" ;;
openbsd* ) OSTYPE=OpenBSD ;
--- configure.in.orig Thu May 22 05:19:16 2003
+++ configure.in Sun Feb 15 23:57:20 2004
@@ -39,7 +39,7 @@
STDCCFLAGS="-DP_LINUX=$OSRELEASE" ;;
freebsd* ) OSTYPE=FreeBSD ;
- OSRELEASE=`sysctl -n kern.osreldate` ;
+## use enviroment variable OSRELEASE=`sysctl -n kern.osreldate` ;
STDCCFLAGS="-DP_FREEBSD=$OSRELEASE" ;;
openbsd* ) OSTYPE=OpenBSD ;
@@ -452,12 +452,13 @@
dnl ########################################################################
dnl check for video capture support.
dnl videodev.h on linux
-dnl machine/ioctl_meteor on FreeBSD
+dnl dev/bktr/ioctl_meteor or machine/ioctl_meteor on FreeBSD
dnl i386/ioctl_meteor on OpenBSD
dnl dev/ic/bt8xx on NetBSD
HAS_VIDEO_CAPTURE=no
AC_CHECK_HEADER(linux/videodev.h, HAS_VIDEO_CAPTURE=yes)
+AC_CHECK_HEADER(dev/bktr/ioctl_meteor.h, HAS_VIDEO_CAPTURE=yes)
AC_CHECK_HEADER(machine/ioctl_meteor.h, HAS_VIDEO_CAPTURE=yes)
AC_CHECK_HEADER(i386/ioctl_meteor.h, HAS_VIDEO_CAPTURE=yes)
AC_CHECK_HEADER(dev/ic/bt8xx.h, HAS_VIDEO_CAPTURE=yes)

View File

@ -6,7 +6,7 @@
endif
ifeq ($(OSTYPE),FreeBSD)
+ ifneq (,$(wildcard $(SYSINCDIR)/machine/ioctl_meteor.h))
+ ifneq (,$(wildcard $(SYSINCDIR)/dev/bktr/ioctl_meteor.h $(SYSINCDIR)/machine/ioctl_meteor.h))
VIDEO_CAPTURE_SOURCE = video4bsd.cxx
+ endif
endif

View File

@ -1,36 +1,26 @@
*** include/ptlib/unix/ptlib/videoio.h.orig Mon Jan 6 18:41:08 2003
--- include/ptlib/unix/ptlib/videoio.h Tue Dec 2 09:42:10 2003
***************
*** 106,112 ****
#include <linux/videodev.h> /* change this to "videodev2.h" for v4l2 */
#endif
! #if defined(P_FREEBSD)
#include <machine/ioctl_meteor.h>
#endif
--- 106,112 ----
#include <linux/videodev.h> /* change this to "videodev2.h" for v4l2 */
#endif
! #if defined(P_FREEBSD) && !defined(NO_VIDEO_CAPTURE)
#include <machine/ioctl_meteor.h>
#endif
***************
*** 186,192 ****
struct video_mmap frameBuffer[2];
#endif
! #if defined(P_FREEBSD) || defined(P_OPENBSD) || defined(P_NETBSD)
struct video_capability
{
int channels; /* Num channels */
--- 186,192 ----
struct video_mmap frameBuffer[2];
#endif
! #if (defined(P_FREEBSD) || defined(P_OPENBSD) || defined(P_NETBSD)) && !defined(NO_VIDEO_CAPTURE)
struct video_capability
{
int channels; /* Num channels */
--- include/ptlib/unix/ptlib/videoio.h.orig Mon Jan 6 10:41:08 2003
+++ include/ptlib/unix/ptlib/videoio.h Sun Feb 15 23:42:39 2004
@@ -106,9 +106,13 @@
#include <linux/videodev.h> /* change this to "videodev2.h" for v4l2 */
#endif
-#if defined(P_FREEBSD)
+#if defined(P_FREEBSD) && !defined(NO_VIDEO_CAPTURE)
+#if P_FREEBSD >= 502101
+#include <dev/bktr/ioctl_meteor.h>
+#else
#include <machine/ioctl_meteor.h>
#endif
+#endif
#if defined(P_OPENBSD) || defined(P_NETBSD)
#if P_OPENBSD >= 200105
@@ -186,7 +190,7 @@
struct video_mmap frameBuffer[2];
#endif
-#if defined(P_FREEBSD) || defined(P_OPENBSD) || defined(P_NETBSD)
+#if (defined(P_FREEBSD) || defined(P_OPENBSD) || defined(P_NETBSD)) && !defined(NO_VIDEO_CAPTURE)
struct video_capability
{
int channels; /* Num channels */

View File

@ -0,0 +1 @@
@comment this plist intentionally left empty

View File

@ -33,9 +33,13 @@ MAKE_ENV= PWLIBDIR=${WRKDIR}/pwlib
THE_MACHTYPE= ${ARCH:S/i386/x86/}
MAKE_ARGS= OSTYPE=${OPSYS} MACHTYPE=${THE_MACHTYPE} OSRELEASE=${OSVERSION} CPLUS=${CXX}
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 502101
ONLY_FOR_ARCHS= i386
.endif
do-install:
# ${INSTALL_PROGRAM} ${WRKSRC}/samples/simple/obj_${OPSYS}_${THE_MACHTYPE}_r/simph323 ${PREFIX}/bin
.include <bsd.port.mk>
.include <bsd.port.post.mk>

View File

@ -1,19 +1,26 @@
*** configure.in.orig Sun Aug 31 09:31:23 2003
--- configure.in Sun Aug 31 09:31:50 2003
*************** case "$target_os" in
*** 39,45 ****
STDCCFLAGS="-DP_LINUX=$OSRELEASE" ;;
freebsd* ) OSTYPE=FreeBSD ;
! OSRELEASE=`sysctl -n kern.osreldate` ;
STDCCFLAGS="-DP_FREEBSD=$OSRELEASE" ;;
openbsd* ) OSTYPE=OpenBSD ;
--- 39,45 ----
STDCCFLAGS="-DP_LINUX=$OSRELEASE" ;;
freebsd* ) OSTYPE=FreeBSD ;
! ## use enviroment variable OSRELEASE=`sysctl -n kern.osreldate` ;
STDCCFLAGS="-DP_FREEBSD=$OSRELEASE" ;;
openbsd* ) OSTYPE=OpenBSD ;
--- configure.in.orig Thu May 22 05:19:16 2003
+++ configure.in Sun Feb 15 23:57:20 2004
@@ -39,7 +39,7 @@
STDCCFLAGS="-DP_LINUX=$OSRELEASE" ;;
freebsd* ) OSTYPE=FreeBSD ;
- OSRELEASE=`sysctl -n kern.osreldate` ;
+## use enviroment variable OSRELEASE=`sysctl -n kern.osreldate` ;
STDCCFLAGS="-DP_FREEBSD=$OSRELEASE" ;;
openbsd* ) OSTYPE=OpenBSD ;
@@ -452,12 +452,13 @@
dnl ########################################################################
dnl check for video capture support.
dnl videodev.h on linux
-dnl machine/ioctl_meteor on FreeBSD
+dnl dev/bktr/ioctl_meteor or machine/ioctl_meteor on FreeBSD
dnl i386/ioctl_meteor on OpenBSD
dnl dev/ic/bt8xx on NetBSD
HAS_VIDEO_CAPTURE=no
AC_CHECK_HEADER(linux/videodev.h, HAS_VIDEO_CAPTURE=yes)
+AC_CHECK_HEADER(dev/bktr/ioctl_meteor.h, HAS_VIDEO_CAPTURE=yes)
AC_CHECK_HEADER(machine/ioctl_meteor.h, HAS_VIDEO_CAPTURE=yes)
AC_CHECK_HEADER(i386/ioctl_meteor.h, HAS_VIDEO_CAPTURE=yes)
AC_CHECK_HEADER(dev/ic/bt8xx.h, HAS_VIDEO_CAPTURE=yes)

View File

@ -6,7 +6,7 @@
endif
ifeq ($(OSTYPE),FreeBSD)
+ ifneq (,$(wildcard $(SYSINCDIR)/machine/ioctl_meteor.h))
+ ifneq (,$(wildcard $(SYSINCDIR)/dev/bktr/ioctl_meteor.h $(SYSINCDIR)/machine/ioctl_meteor.h))
VIDEO_CAPTURE_SOURCE = video4bsd.cxx
+ endif
endif

View File

@ -1,36 +1,26 @@
*** include/ptlib/unix/ptlib/videoio.h.orig Mon Jan 6 18:41:08 2003
--- include/ptlib/unix/ptlib/videoio.h Tue Dec 2 09:42:10 2003
***************
*** 106,112 ****
#include <linux/videodev.h> /* change this to "videodev2.h" for v4l2 */
#endif
! #if defined(P_FREEBSD)
#include <machine/ioctl_meteor.h>
#endif
--- 106,112 ----
#include <linux/videodev.h> /* change this to "videodev2.h" for v4l2 */
#endif
! #if defined(P_FREEBSD) && !defined(NO_VIDEO_CAPTURE)
#include <machine/ioctl_meteor.h>
#endif
***************
*** 186,192 ****
struct video_mmap frameBuffer[2];
#endif
! #if defined(P_FREEBSD) || defined(P_OPENBSD) || defined(P_NETBSD)
struct video_capability
{
int channels; /* Num channels */
--- 186,192 ----
struct video_mmap frameBuffer[2];
#endif
! #if (defined(P_FREEBSD) || defined(P_OPENBSD) || defined(P_NETBSD)) && !defined(NO_VIDEO_CAPTURE)
struct video_capability
{
int channels; /* Num channels */
--- include/ptlib/unix/ptlib/videoio.h.orig Mon Jan 6 10:41:08 2003
+++ include/ptlib/unix/ptlib/videoio.h Sun Feb 15 23:42:39 2004
@@ -106,9 +106,13 @@
#include <linux/videodev.h> /* change this to "videodev2.h" for v4l2 */
#endif
-#if defined(P_FREEBSD)
+#if defined(P_FREEBSD) && !defined(NO_VIDEO_CAPTURE)
+#if P_FREEBSD >= 502101
+#include <dev/bktr/ioctl_meteor.h>
+#else
#include <machine/ioctl_meteor.h>
#endif
+#endif
#if defined(P_OPENBSD) || defined(P_NETBSD)
#if P_OPENBSD >= 200105
@@ -186,7 +190,7 @@
struct video_mmap frameBuffer[2];
#endif
-#if defined(P_FREEBSD) || defined(P_OPENBSD) || defined(P_NETBSD)
+#if (defined(P_FREEBSD) || defined(P_OPENBSD) || defined(P_NETBSD)) && !defined(NO_VIDEO_CAPTURE)
struct video_capability
{
int channels; /* Num channels */

View File

@ -0,0 +1 @@
@comment this plist intentionally left empty