- Update to 0.9.1
This commit is contained in:
parent
ee9844c8f2
commit
acf6cb5b38
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=357298
@ -2,55 +2,64 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= love
|
||||
PORTVERSION= 0.8.0
|
||||
PORTREVISION= 5
|
||||
PORTVERSION= 0.9.1
|
||||
CATEGORIES= devel games
|
||||
MASTER_SITES= http://cdn.bitbucket.org/rude/love/downloads/ \
|
||||
MASTER_SITES= https://bitbucket.org/rude/love/downloads/ \
|
||||
http://mirror.amdmi3.ru/distfiles/
|
||||
DISTNAME= ${PORTNAME}-${PORTVERSION}-linux-src
|
||||
|
||||
MAINTAINER= amdmi3@FreeBSD.org
|
||||
COMMENT= Open-source 2D game engine
|
||||
|
||||
LICENSE= ZLIB
|
||||
LICENSE_FILE= ${WRKSRC}/license.txt
|
||||
|
||||
LIB_DEPENDS= libIL.so:${PORTSDIR}/graphics/devil \
|
||||
libmodplug.so:${PORTSDIR}/audio/libmodplug \
|
||||
libmpg123.so:${PORTSDIR}/audio/mpg123 \
|
||||
libvorbisfile.so:${PORTSDIR}/audio/libvorbis \
|
||||
libphysfs.so:${PORTSDIR}/devel/physfs \
|
||||
libfreetype.so:${PORTSDIR}/print/freetype2
|
||||
BUILD_DEPENDS= ${LOCALBASE}/include/boost/shared_ptr.hpp:${PORTSDIR}/devel/boost-libs
|
||||
|
||||
USES= gmake openal dos2unix lua:51
|
||||
USE_SDL= sdl mixer
|
||||
USES= gmake openal libtool pkgconfig compiler:c++11-lib \
|
||||
desktop-file-utils shared-mime-info
|
||||
USE_SDL= sdl2
|
||||
USE_GL= gl glu
|
||||
GNU_CONFIGURE= yes
|
||||
CPPFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/freetype2 \
|
||||
-I${LUA_INCDIR} `${SDL_CONFIG} --cflags`
|
||||
LDFLAGS+= -L${LOCALBASE}/lib -L${LUA_LIBDIR}
|
||||
CONFIGURE_ARGS= --bindir=${PREFIX}/bin --libdir=${PREFIX}/lib
|
||||
WRKSRC= ${WRKDIR}/love-${PORTVERSION}
|
||||
DOS2UNIX_FILES= src/modules/graphics/opengl/GLee.h
|
||||
INSTALL_TARGET= install-strip
|
||||
|
||||
PLIST_FILES= bin/love
|
||||
CPPFLAGS+= -I${LOCALBASE}/include
|
||||
LDFLAGS+= -L${LOCALBASE}/lib
|
||||
|
||||
PORTDOCS= *
|
||||
|
||||
OPTIONS_DEFINE= DOCS
|
||||
OPTIONS_DEFINE= DOCS LUAJIT
|
||||
OPTIONS_DEFAULT_i386= LUAJIT
|
||||
OPTIONS_DEFAULT_amd64= LUAJIT
|
||||
|
||||
LUAJIT_DESC= Use luajit
|
||||
|
||||
.include <bsd.port.options.mk>
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e '/^prefix=/ d; /^bindir=/ d; /^libdir=/ d; \
|
||||
/test/ s|==|=|' \
|
||||
-e "s/lua5.1/lua-${LUA_VER}/g" \
|
||||
${WRKSRC}/configure
|
||||
.if ${PORT_OPTIONS:MLUAJIT}
|
||||
CONFIGURE_ARGS= --with-lua=luajit
|
||||
LIB_DEPENDS+= libluajit-5.1.so:${PORTSDIR}/lang/luajit
|
||||
.else
|
||||
USES+= lua
|
||||
CONFIGURE_ARGS= --with-lua=lua \
|
||||
--with-luaversion="${LUA_VER}"
|
||||
CONFIGURE_ENV= LUA_EXECUTABLE="${LUA_CMD}"
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's|$${with_lua}$${with_luaversion}|$${with_lua}-$${with_luaversion}|g' \
|
||||
${WRKSRC}/configure
|
||||
.endif
|
||||
|
||||
.if ${PORT_OPTIONS:MDOCS}
|
||||
post-install:
|
||||
${MKDIR} ${STAGEDIR}${DOCSDIR}
|
||||
.for f in changes.txt readme.md
|
||||
${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}
|
||||
.endfor
|
||||
.endif
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
@ -1,2 +1,2 @@
|
||||
SHA256 (love-0.8.0-linux-src.tar.gz) = 9167ca1cc7893ff1fdcf3b6fc7e2a88be10d899075a513942420fe8f94668ecc
|
||||
SIZE (love-0.8.0-linux-src.tar.gz) = 1027356
|
||||
SHA256 (love-0.9.1-linux-src.tar.gz) = 04dd0946bd82ec839c454c161bf0e5da870f393af62d09dc229990f5176833de
|
||||
SIZE (love-0.9.1-linux-src.tar.gz) = 1405469
|
||||
|
@ -1,11 +0,0 @@
|
||||
--- src/modules/graphics/opengl/GLee.h.orig 2011-05-04 20:00:10.000000000 +0400
|
||||
+++ src/modules/graphics/opengl/GLee.h 2011-09-20 00:16:46.000000000 +0400
|
||||
@@ -799,8 +799,6 @@
|
||||
|
||||
/* GLX */
|
||||
|
||||
- typedef void (*__GLXextFuncPtr)(void);
|
||||
-
|
||||
#ifndef GLX_ARB_get_proc_address
|
||||
#define GLX_ARB_get_proc_address 1
|
||||
extern __GLXextFuncPtr glXGetProcAddressARB (const GLubyte *);
|
11
devel/love/files/patch-src__common__config.h
Normal file
11
devel/love/files/patch-src__common__config.h
Normal file
@ -0,0 +1,11 @@
|
||||
--- src/common/config.h.orig 2014-04-01 22:24:54.000000000 +0400
|
||||
+++ src/common/config.h 2014-06-10 14:49:32.000000000 +0400
|
||||
@@ -25,7 +25,7 @@
|
||||
#if defined(WIN32) || defined(_WIN32)
|
||||
# define LOVE_WINDOWS 1
|
||||
#endif
|
||||
-#if defined(linux) || defined(__linux) || defined(__linux__)
|
||||
+#if defined(linux) || defined(__linux) || defined(__linux__) || defined(__FreeBSD__)
|
||||
# define LOVE_LINUX 1
|
||||
#endif
|
||||
#if defined(__APPLE__)
|
@ -1,17 +0,0 @@
|
||||
--- src/modules/font/freetype/Font.h.orig 2013-12-13 10:24:12.000000000 +0100
|
||||
+++ src/modules/font/freetype/Font.h 2013-12-13 10:25:51.000000000 +0100
|
||||
@@ -30,10 +30,10 @@
|
||||
#else
|
||||
#include <ft2build.h>
|
||||
#endif
|
||||
-#include <freetype/freetype.h>
|
||||
-#include <freetype/ftglyph.h>
|
||||
-#include <freetype/ftoutln.h>
|
||||
-#include <freetype/fttrigon.h>
|
||||
+#include FT_FREETYPE_H
|
||||
+#include FT_GLYPH_H
|
||||
+#include FT_OUTLINE_H
|
||||
+#include FT_TRIGONOMETRY_H
|
||||
|
||||
namespace love
|
||||
{
|
@ -1,17 +0,0 @@
|
||||
--- src/modules/font/freetype/TrueTypeRasterizer.h.orig 2013-12-13 10:24:01.000000000 +0100
|
||||
+++ src/modules/font/freetype/TrueTypeRasterizer.h 2013-12-13 10:26:35.000000000 +0100
|
||||
@@ -27,10 +27,10 @@
|
||||
|
||||
// TrueType2
|
||||
#include <ft2build.h>
|
||||
-#include <freetype/freetype.h>
|
||||
-#include <freetype/ftglyph.h>
|
||||
-#include <freetype/ftoutln.h>
|
||||
-#include <freetype/fttrigon.h>
|
||||
+#include FT_FREETYPE_H
|
||||
+#include FT_GLYPH_H
|
||||
+#include FT_OUTLINE_H
|
||||
+#include FT_TRIGONOMETRY_H
|
||||
|
||||
namespace love
|
||||
{
|
16
devel/love/pkg-plist
Normal file
16
devel/love/pkg-plist
Normal file
@ -0,0 +1,16 @@
|
||||
bin/love
|
||||
lib/liblove.a
|
||||
lib/liblove.so
|
||||
lib/liblove.so.0
|
||||
lib/liblove.so.0.0.0
|
||||
man/man1/love.1.gz
|
||||
share/applications/love.desktop
|
||||
share/icons/hicolor/scalable/mimetypes/application-x-love-game.svg
|
||||
share/mime/packages/love.xml
|
||||
share/pixmaps/love.svg
|
||||
@dirrmtry share/icons/hicolor/scalable/mimetypes
|
||||
@dirrmtry share/icons/hicolor/scalable
|
||||
@dirrmtry share/icons/hicolor
|
||||
@dirrmtry share/icons
|
||||
@dirrmtry share/mime/packages
|
||||
@dirrmtry share/mime
|
Loading…
Reference in New Issue
Block a user