- Update to 1.09

- Add LICENSE
- Sort PLIST

Changes:	http://search.cpan.org/dist/IO-Interface/Changes
This commit is contained in:
Sunpoet Po-Chuan Hsieh 2015-01-04 17:12:02 +00:00
parent 3b7671c780
commit acdf55dae2
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=376251
4 changed files with 9 additions and 35 deletions

View File

@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= IO-Interface
PORTVERSION= 1.06
PORTREVISION= 2
PORTVERSION= 1.09
CATEGORIES= net perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@ -11,7 +10,10 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Perl extension for access to network card configuration information
LICENSE= ART10 GPLv1
LICENSE_COMB= dual
USES= perl5
USE_PERL5= configure
USE_PERL5= modbuild
.include <bsd.port.mk>

View File

@ -1,2 +1,2 @@
SHA256 (IO-Interface-1.06.tar.gz) = 6c07bc9cebcec2ec58a6e6969a14c8d4f4959869332d53eab3b65079541cdf77
SIZE (IO-Interface-1.06.tar.gz) = 10339
SHA256 (IO-Interface-1.09.tar.gz) = e63e81c52eb1e0e60ec2d983f5552d2493e117179925c96757f23c4bd9fa713a
SIZE (IO-Interface-1.09.tar.gz) = 16414

View File

@ -1,27 +0,0 @@
--- ./Interface.xs.orig 2008-06-06 08:51:42.000000000 -0700
+++ ./Interface.xs 2012-05-15 13:16:22.856348098 -0700
@@ -567,6 +567,7 @@
struct ifreq ifr;
#if (defined(USE_GETIFADDRS) && defined(HAVE_SOCKADDR_DL_STRUCT))
struct ifaddrs* ifap = NULL;
+ struct ifaddrs* saved_ifap = NULL;
struct sockaddr_dl* sdl;
sa_family_t family;
char *sdlname, *haddr, *s;
@@ -581,6 +582,7 @@
#endif
#if (defined(USE_GETIFADDRS) && defined(HAVE_SOCKADDR_DL_STRUCT))
getifaddrs(&ifap);
+ saved_ifap = ifap;
while(1) {
if (ifap == NULL) break;
@@ -595,7 +597,7 @@
}
ifap = ifap -> ifa_next;
}
- freeifaddrs(ifap);
+ freeifaddrs(saved_ifap);
s = hwaddr;
s[0] = '\0';

View File

@ -1,6 +1,5 @@
%%PERL5_MAN3%%/IO::Interface.3.gz
%%PERL5_MAN3%%/IO::Interface::Simple.3.gz
%%SITE_ARCH%%/IO/Interface.pm
%%SITE_ARCH%%/IO/Interface/Simple.pm
%%SITE_ARCH%%/auto/IO/Interface/Interface.so
%%SITE_ARCH%%/auto/IO/Interface/autosplit.ix
%%PERL5_MAN3%%/IO::Interface.3.gz
%%PERL5_MAN3%%/IO::Interface::Simple.3.gz