- Fix build on non-i386 arch

PR:		ports/63591
Submitted by:	Ports Fury
This commit is contained in:
Kirill Ponomarev 2004-03-01 18:11:52 +00:00
parent 42b20e5280
commit acc88dbac4
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=102661
2 changed files with 15 additions and 17 deletions

View File

@ -24,14 +24,8 @@ USE_GMAKE= yes
DATAVERSION= 0.8.6
.include <bsd.port.pre.mk>
.if ${ARCH} != "i386"
BROKEN= "Does not compile on !i386"
.endif
post-install:
@cd ${WRKDIR}/amph && ${FIND} . | \
${CPIO} -pdm -L -R ${SHAREOWN}:${SHAREGRP} ${PREFIX}/share/amph
.include <bsd.port.post.mk>
.include <bsd.port.mk>

View File

@ -1,27 +1,31 @@
--- src/Main.cpp.orig Mon Jun 5 14:34:38 2000
+++ src/Main.cpp Mon Jun 5 14:34:30 2000
@@ -1,3 +1,5 @@
--- src/Main.cpp.orig Sun Mar 24 17:49:09 2002
+++ src/Main.cpp Mon Mar 1 19:51:09 2004
@@ -1,3 +1,7 @@
+#if defined(__FreeBSD__) && ( defined(__i386__) || defined(__amd64__) )
+#include <floatingpoint.h>
+#endif
+
#include "System.hpp"
#include "Appl.hpp"
#include "Clut.hpp"
@@ -74,7 +76,7 @@
my_argc = argc;
@@ -75,6 +79,9 @@
my_argv = argv;
if (checkCommandLine()) return 0;
-
+#if defined(__FreeBSD__) && ( defined(__i386__) || defined(__amd64__) )
+ fpsetmask(fpgetmask() & ~(FP_X_DZ|FP_X_INV));
+#endif
gApplication = new CApplication();
gApplication->InitGraphics();
gApplication->LoadData();
@@ -82,6 +84,9 @@
gApplication->UnloadData();
@@ -83,5 +90,10 @@
gApplication->Quit();
delete gApplication;
+
+#if defined(__FreeBSD__) && ( defined(__i386__) || defined(__amd64__) )
+ fpresetsticky(FP_X_DZ|FP_X_INV);
+ fpsetmask(FP_X_DZ|FP_X_INV);
+#endif
+
return 0;
}