updated to current version

This commit is contained in:
Alan Eldridge 2003-01-01 15:52:55 +00:00
parent 93f3d914eb
commit acc65d3fda
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=72017
10 changed files with 252 additions and 235 deletions

View File

@ -1,31 +1,37 @@
# ex:ts=8
# ex:ts=8 -*-mode: makefile-*-
#
# New ports collection makefile for: c2lib
# Date created: Feb 16, 2001
# Whom: Ying-Chieh Liao <ijliao@FreeBSD.org>
# Date created: 2002-12-22
# Whom: Alan Eldridge <alane@FreeBSD.org>
#
# $FreeBSD$
#
PORTNAME= c2lib
PORTVERSION= 1.2.15
PORTVERSION= 1.3.0
PORTREVISION= 0
PORTEPOCH= 0
CATEGORIES= devel
MASTER_SITES= http://www.annexia.org/freeware/c2lib/
MASTER_SITES= http://www.annexia.org/freeware/${PORTNAME}/
MAINTAINER= alane@FreeBSD.org
USE_LIBTOOL= yes
BUILD_REQUIRES+=cdoc:${.CURDIR}/../../devel/cdoc
BUILD_REQUIRES+=make+:${.CURDIR}/../../devel/makeplus
USE_GMAKE= yes
INSTALLS_SHLIB= yes
SCRIPTS_ENV= WRKDIRPREFIX="${WRKDIRPREFIX}" \
REALCURDIR="${.CURDIR}" \
DISTNAME="${DISTNAME}"
post-install:
${RM} ${PREFIX}/lib/libc2.la
PREFIX?= ${LOCALBASE}
MAKE_ENV+= CC="${CC}"
.include <bsd.port.pre.mk>
MAN3!= ${CAT} ${FILESDIR}/man3
do-build:
cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} make+
do-install:
cd ${WRKSRC}; ${SETENV} ${MAKE_ENV}\
make+ install prefix=${PREFIX} manprefix=${PREFIX}
.include "${.CURDIR}/manpages.mk"
.include <bsd.port.post.mk>
#EOF

View File

@ -1 +1 @@
MD5 (c2lib-1.2.15.tar.gz) = 3702b24b1efd63af176b60c6a40fc0d3
MD5 (c2lib-1.3.0.tar.gz) = 7a1bc849168fd81c64685c7ad13bb708

View File

@ -1,171 +0,0 @@
_hash_erase.3
_hash_get.3
_hash_get_ptr.3
_hash_insert.3
_hash_new.3
_sash_get.3
_shash_get.3
_shash_get_ptr.3
_shash_insert.3
_vector_compare.3
_vector_fill.3
_vector_get.3
_vector_get_ptr.3
_vector_insert.3
_vector_map.3
_vector_map_pool.3
_vector_new.3
_vector_pop_back.3
_vector_pop_front.3
_vector_push_back.3
_vector_push_front.3
_vector_replace.3
_vector_sort.3
collision_moving_sphere_and_face.3
copy_hash.3
copy_sash.3
copy_shash.3
copy_vector.3
delete_pool.3
face_translate_along_normal.3
global_pool.3
hash_erase.3
hash_exists.3
hash_get.3
hash_get_buckets_allocated.3
hash_get_buckets_used.3
hash_get_ptr.3
hash_insert.3
hash_keys.3
hash_keys_in_pool.3
hash_set_buckets_allocated.3
hash_size.3
hash_values.3
hash_values_in_pool.3
identity_matrix.3
make_identity_matrix.3
make_zero_vec.3
new_hash.3
new_identity_matrix.3
new_matrix.3
new_pool.3
new_sash.3
new_shash.3
new_subpool.3
new_subvector.3
new_vec.3
new_vector.3
new_zero_vec.3
pcalloc.3
pchomp.3
pchrs.3
pconcat.3
pdtoa.3
pgetline.3
pgetlinec.3
pgetlinex.3
pitoa.3
pjoin.3
plane_coefficients.3
plane_translate_along_normal.3
pmalloc.3
pmatch.3
pmatchx.3
pmemdup.3
point_distance_to_face.3
point_distance_to_line.3
point_distance_to_line_segment.3
point_distance_to_plane.3
point_face_angle_sum.3
point_is_inside_plane.3
point_lies_in_face.3
pool_get_stats.3
pool_register_cleanup_fn.3
pool_register_fd.3
pool_register_malloc.3
pool_set_bad_malloc_handler.3
prealloc.3
psort.3
psprintf.3
pstrcat.3
pstrcsplit.3
pstrdup.3
pstrlwr.3
pstrncat.3
pstrndup.3
pstrresplit.3
pstrs.3
pstrsplit.3
pstrupr.3
psubst.3
psubstr.3
psubstx.3
ptrim.3
ptrimback.3
ptrimfront.3
pvdtostr.3
pvector.3
pvectora.3
pvitostr.3
pvsprintf.3
pvxtostr.3
pxtoa.3
sash_erase.3
sash_exists.3
sash_get.3
sash_get_buckets_allocated.3
sash_get_buckets_used.3
sash_insert.3
sash_keys.3
sash_keys_in_pool.3
sash_set_buckets_allocated.3
sash_size.3
sash_values.3
sash_values_in_pool.3
shash_erase.3
shash_exists.3
shash_get.3
shash_get_buckets_allocated.3
shash_get_buckets_used.3
shash_get_ptr.3
shash_insert.3
shash_keys.3
shash_keys_in_pool.3
shash_set_buckets_allocated.3
shash_size.3
shash_values.3
shash_values_in_pool.3
vec_angle_between.3
vec_dot_product.3
vec_magnitude.3
vec_magnitude2d.3
vec_magnitude_in_direction.3
vec_normalize.3
vec_normalize2d.3
vector_allocated.3
vector_clear.3
vector_compare.3
vector_element_size.3
vector_erase.3
vector_erase_range.3
vector_fill.3
vector_get.3
vector_get_ptr.3
vector_grep.3
vector_grep_pool.3
vector_insert.3
vector_insert_array.3
vector_map.3
vector_map_pool.3
vector_pop_back.3
vector_pop_front.3
vector_push_back.3
vector_push_front.3
vector_reallocate.3
vector_replace.3
vector_replace_array.3
vector_reverse.3
vector_size.3
vector_sort.3
vector_swap.3
zero_vec.3

View File

@ -0,0 +1,18 @@
--- Makefile+~ Sun Dec 8 12:45:43 2002
+++ Makefile+ Fri Dec 27 01:34:48 2002
@@ -103,13 +103,13 @@
install:
install -d $(DESTDIR)$(libdir)
- install -d $(DESTDIR)$(includedir)
+ install -d $(DESTDIR)$(pkgincludedir)
install -d $(DESTDIR)$(man3dir)
install -d $(DESTDIR)$(datadir)/rws/symtabs/
$(MP_INSTALL_STATIC_LIB) libc2.a
$(MP_INSTALL_DYNAMIC_LIB) libc2.so
- install -m 0644 $(HEADERS) $(DESTDIR)$(includedir)
+ install -m 0644 $(HEADERS) $(DESTDIR)$(pkgincludedir)
install -m 0644 *.3 $(DESTDIR)$(man3dir)
install -m 0644 *.syms $(DESTDIR)$(datadir)/rws/symtabs/

View File

@ -1,11 +0,0 @@
--- Makefile.in.orig Fri Feb 16 18:51:26 2001
+++ Makefile.in Fri Feb 16 18:51:06 2001
@@ -141,7 +141,7 @@
DEFS = @DEFS@ -I. -I$(srcdir) -I.
CPPFLAGS = @CPPFLAGS@
LDFLAGS = @LDFLAGS@
-LIBS = @LIBS@
+LIBS = @LIBS@ -lm
libc2_la_LIBADD =
libc2_la_OBJECTS = hash.lo matvec.lo pool.lo pstring.lo vector.lo
PROGRAMS = $(noinst_PROGRAMS)

View File

@ -1,10 +0,0 @@
--- pstring.c.orig Fri Feb 16 18:46:50 2001
+++ pstring.c Fri Feb 16 18:48:10 2001
@@ -32,6 +32,7 @@
#endif
#ifdef HAVE_REGEX_H
+#include <sys/types.h>
#include <regex.h>
#endif

View File

@ -1,10 +0,0 @@
--- pstring.h.orig Fri Feb 16 18:46:13 2001
+++ pstring.h Fri Feb 16 18:45:20 2001
@@ -21,6 +21,7 @@
#ifndef PSTRING_H
#define PSTRING_H
+#include <sys/types.h>
#include <regex.h>
#include <pool.h>

View File

@ -1,10 +0,0 @@
--- test_pstring.c.orig Fri Feb 16 18:48:56 2001
+++ test_pstring.c Fri Feb 16 18:49:18 2001
@@ -22,6 +22,7 @@
#include <stdlib.h>
#include <string.h>
#include <assert.h>
+#include <sys/types.h>
#include <regex.h>
#include "pstring.h"

200
devel/c2lib/manpages.mk Normal file
View File

@ -0,0 +1,200 @@
MAN3+= _hash_erase.3
MAN3+= _hash_get.3
MAN3+= _hash_get_ptr.3
MAN3+= _hash_insert.3
MAN3+= _hash_new.3
MAN3+= _sash_get.3
MAN3+= _shash_get.3
MAN3+= _shash_get_ptr.3
MAN3+= _shash_insert.3
MAN3+= _tree_get_data.3
MAN3+= _tree_new.3
MAN3+= _tree_set_data.3
MAN3+= _vector_compare.3
MAN3+= _vector_fill.3
MAN3+= _vector_get.3
MAN3+= _vector_get_ptr.3
MAN3+= _vector_insert.3
MAN3+= _vector_map.3
MAN3+= _vector_map_pool.3
MAN3+= copy_hash.3
MAN3+= _vector_new.3
MAN3+= _vector_pop_back.3
MAN3+= _vector_pop_front.3
MAN3+= _vector_push_back.3
MAN3+= _vector_push_front.3
MAN3+= _vector_replace.3
MAN3+= _vector_sort.3
MAN3+= collision_moving_sphere_and_face.3
MAN3+= copy_sash.3
MAN3+= copy_shash.3
MAN3+= copy_tree.3
MAN3+= copy_vector.3
MAN3+= delete_pool.3
MAN3+= face_translate_along_normal.3
MAN3+= global_pool.3
MAN3+= hash_erase.3
MAN3+= hash_exists.3
MAN3+= hash_get.3
MAN3+= hash_get_buckets_used.3
MAN3+= hash_get_buckets_allocated.3
MAN3+= hash_get_ptr.3
MAN3+= hash_insert.3
MAN3+= hash_keys.3
MAN3+= hash_keys_in_pool.3
MAN3+= hash_set_buckets_allocated.3
MAN3+= hash_size.3
MAN3+= hash_values.3
MAN3+= hash_values_in_pool.3
MAN3+= identity_matrix.3
MAN3+= make_identity_matrix.3
MAN3+= make_zero_vec.3
MAN3+= new_hash.3
MAN3+= new_identity_matrix.3
MAN3+= new_matrix.3
MAN3+= new_pool.3
MAN3+= new_sash.3
MAN3+= new_shash.3
MAN3+= new_subpool.3
MAN3+= pchrs.3
MAN3+= new_subvector.3
MAN3+= new_tree.3
MAN3+= new_vec.3
MAN3+= new_vector.3
MAN3+= new_zero_vec.3
MAN3+= pcalloc.3
MAN3+= pchomp.3
MAN3+= pconcat.3
MAN3+= pdtoa.3
MAN3+= pgetline.3
MAN3+= pgetlinec.3
MAN3+= pgetlinex.3
MAN3+= pgrep.3
MAN3+= pitoa.3
MAN3+= pjoin.3
MAN3+= plane_coefficients.3
MAN3+= plane_translate_along_normal.3
MAN3+= pmalloc.3
MAN3+= pmap.3
MAN3+= pmemdup.3
MAN3+= point_distance_to_face.3
MAN3+= point_distance_to_line.3
MAN3+= psort.3
MAN3+= point_distance_to_line_segment.3
MAN3+= point_distance_to_plane.3
MAN3+= point_face_angle_sum.3
MAN3+= point_is_inside_plane.3
MAN3+= point_lies_in_face.3
MAN3+= pool_get_stats.3
MAN3+= pool_register_cleanup_fn.3
MAN3+= pool_register_fd.3
MAN3+= pool_register_malloc.3
MAN3+= pool_set_bad_malloc_handler.3
MAN3+= prealloc.3
MAN3+= precomp.3
MAN3+= prematch.3
MAN3+= presubst.3
MAN3+= psprintf.3
MAN3+= pstrcat.3
MAN3+= pstrcsplit.3
MAN3+= pstrcsplit2.3
MAN3+= pstrdup.3
MAN3+= pstrlwr.3
MAN3+= pstrncat.3
MAN3+= pstrndup.3
MAN3+= pstrresplit.3
MAN3+= pstrresplit2.3
MAN3+= pstrs.3
MAN3+= pstrsplit.3
MAN3+= pstrsplit2.3
MAN3+= pstrupr.3
MAN3+= psubstr.3
MAN3+= ptrim.3
MAN3+= ptrimback.3
MAN3+= ptrimfront.3
MAN3+= pvdtostr.3
MAN3+= pvector.3
MAN3+= pvectora.3
MAN3+= pvitostr.3
MAN3+= pvsprintf.3
MAN3+= pvxtostr.3
MAN3+= pxtoa.3
MAN3+= sash_erase.3
MAN3+= sash_exists.3
MAN3+= sash_get.3
MAN3+= sash_keys.3
MAN3+= sash_get_buckets_allocated.3
MAN3+= sash_get_buckets_used.3
MAN3+= sash_insert.3
MAN3+= sash_keys_in_pool.3
MAN3+= sash_set_buckets_allocated.3
MAN3+= sash_size.3
MAN3+= sash_values.3
MAN3+= sash_values_in_pool.3
MAN3+= shash_erase.3
MAN3+= shash_exists.3
MAN3+= shash_get.3
MAN3+= shash_get_buckets_allocated.3
MAN3+= shash_get_buckets_used.3
MAN3+= shash_get_ptr.3
MAN3+= shash_insert.3
MAN3+= shash_keys.3
MAN3+= shash_keys_in_pool.3
MAN3+= shash_size.3
MAN3+= shash_set_buckets_allocated.3
MAN3+= shash_values.3
MAN3+= shash_values_in_pool.3
MAN3+= tree_clear.3
MAN3+= tree_erase.3
MAN3+= tree_erase_range.3
MAN3+= tree_get.3
MAN3+= tree_get_data.3
MAN3+= tree_get_subnode.3
MAN3+= tree_insert.3
MAN3+= tree_insert_array.3
MAN3+= tree_nr_subnodes.3
MAN3+= tree_pop_back.3
MAN3+= tree_pop_front.3
MAN3+= tree_push_back.3
MAN3+= tree_push_front.3
MAN3+= tree_replace.3
MAN3+= tree_replace_array.3
MAN3+= tree_set_data.3
MAN3+= tree_size.3
MAN3+= tree_swap.3
MAN3+= vec_angle_between.3
MAN3+= vec_dot_product.3
MAN3+= vec_magnitude.3
MAN3+= vec_magnitude2d.3
MAN3+= vec_magnitude_in_direction.3
MAN3+= vec_normalize.3
MAN3+= vec_normalize2d.3
MAN3+= vector_allocated.3
MAN3+= vector_clear.3
MAN3+= vector_compare.3
MAN3+= vector_element_size.3
MAN3+= vector_erase.3
MAN3+= vector_erase_range.3
MAN3+= vector_fill.3
MAN3+= vector_get.3
MAN3+= vector_get_ptr.3
MAN3+= vector_grep.3
MAN3+= vector_grep_pool.3
MAN3+= vector_insert.3
MAN3+= vector_insert_array.3
MAN3+= vector_map.3
MAN3+= vector_map_pool.3
MAN3+= vector_pop_back.3
MAN3+= vector_pop_front.3
MAN3+= vector_push_back.3
MAN3+= vector_push_back_vector.3
MAN3+= vector_push_front.3
MAN3+= vector_push_front_vector.3
MAN3+= vector_reallocate.3
MAN3+= vector_replace.3
MAN3+= vector_replace_array.3
MAN3+= vector_reverse.3
MAN3+= vector_size.3
MAN3+= vector_sort.3
MAN3+= vector_swap.3
MAN3+= zero_vec.3

View File

@ -1,9 +1,14 @@
include/c2lib_version.h
include/hash.h
include/matvec.h
include/pool.h
include/pstring.h
include/vector.h
include/c2lib/hash.h
include/c2lib/matvec.h
include/c2lib/pool.h
include/c2lib/pre.h
include/c2lib/pstring.h
include/c2lib/tree.h
include/c2lib/vector.h
lib/libc2.a
lib/libc2.so
lib/libc2.so.1
lib/libc2.so.1.3.0
share/rws/symtabs/libc2.syms
@unexec /bin/rmdir %D/share/rws/symtabs 2>/dev/null || true
@unexec /bin/rmdir %D/share/rws 2>/dev/null || true