New port: Cross-platform extension loading library for OpenGL
This commit is contained in:
parent
716fcf78a6
commit
acaf54c175
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=490822
@ -266,6 +266,7 @@
|
||||
SUBDIR += gkrellkam2
|
||||
SUBDIR += gle
|
||||
SUBDIR += gle-graphics
|
||||
SUBDIR += glee
|
||||
SUBDIR += glew
|
||||
SUBDIR += glexcess
|
||||
SUBDIR += glfw
|
||||
|
39
graphics/glee/Makefile
Normal file
39
graphics/glee/Makefile
Normal file
@ -0,0 +1,39 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= GLee
|
||||
DISTVERSION= 5.4.0
|
||||
CATEGORIES= graphics
|
||||
MASTER_SITES= https://elf-stone.com/downloads/${PORTNAME}/
|
||||
DISTNAME= ${PORTNAME}-${DISTVERSION}-src
|
||||
|
||||
MAINTAINER= yuri@FreeBSD.org
|
||||
COMMENT= Cross-platform extension loading library for OpenGL
|
||||
|
||||
LICENSE= BSD2CLAUSE
|
||||
|
||||
USES= gl gmake
|
||||
GNU_CONFIGURE= yes
|
||||
USE_LDCONFIG= yes
|
||||
USE_GL= gl
|
||||
|
||||
NO_WRKSUBDIR= yes
|
||||
|
||||
CFLAGS+= -fPIC
|
||||
LDFLAGS+= -Wl,-z,defs -Wl,--as-needed -Wl,--no-undefined -L${LOCALBASE}/lib -lGL
|
||||
|
||||
SUB_FILES= glee.pc
|
||||
|
||||
PLIST_FILES= include/GL/GLee.h \
|
||||
lib/libGLee.so \
|
||||
lib/libGLee.so.5 \
|
||||
lib/libGLee.so.5.4 \
|
||||
libdata/pkgconfig/glee.pc
|
||||
|
||||
post-install:
|
||||
cd ${STAGEDIR}${PREFIX}/lib && \
|
||||
${MV} libGLee.so libGLee.so.${DISTVERSION:R} && \
|
||||
${LN} -s libGLee.so.${DISTVERSION:R} libGLee.so.${DISTVERSION:R:R} && \
|
||||
${LN} -s libGLee.so.${DISTVERSION:R} libGLee.so
|
||||
${INSTALL_DATA} ${WRKDIR}/glee.pc ${STAGEDIR}${PREFIX}/libdata/pkgconfig
|
||||
|
||||
.include <bsd.port.mk>
|
3
graphics/glee/distinfo
Normal file
3
graphics/glee/distinfo
Normal file
@ -0,0 +1,3 @@
|
||||
TIMESTAMP = 1548012607
|
||||
SHA256 (GLee-5.4.0-src.tar.gz) = 3b58430172392ec75acdad5fd833ecf494c5518382bc27932f48d46dbb01cd29
|
||||
SIZE (GLee-5.4.0-src.tar.gz) = 269529
|
12
graphics/glee/files/glee.pc.in
Normal file
12
graphics/glee/files/glee.pc.in
Normal file
@ -0,0 +1,12 @@
|
||||
prefix=%%PREFIX%%
|
||||
exec_prefix=${prefix}
|
||||
libdir=${exec_prefix}/lib
|
||||
includedir=${prefix}/include
|
||||
|
||||
Name: GLee
|
||||
Description: GL Easy Extension library
|
||||
Version: 5.4.0
|
||||
Requires:
|
||||
Conflicts:
|
||||
Libs: -L${libdir} -lGLee
|
||||
Cflags: -I${includedir}
|
24
graphics/glee/files/patch-Makefile.in
Normal file
24
graphics/glee/files/patch-Makefile.in
Normal file
@ -0,0 +1,24 @@
|
||||
--- Makefile.in.orig 2009-02-07 20:45:53 UTC
|
||||
+++ Makefile.in
|
||||
@@ -38,14 +38,15 @@ BINDISTFILES=glee/${LIBNAME} glee/${READ
|
||||
|
||||
all:
|
||||
${CXX} ${SRCDIR}/${SOURCE} -shared -I${SRCDIR} -I${INCLUDEDIR} ${LIBS} \
|
||||
- ${CXXFLAGS} ${DEFS} -o ${SRCDIR}/${LIBNAME}
|
||||
+ ${CXXFLAGS} ${LDFLAGS} ${DEFS} -Wl,-soname,libGLee.so.5 -o ${SRCDIR}/${LIBNAME}
|
||||
|
||||
install:
|
||||
- ${INSTALLD} ${HEADER} ${INCLUDEDIR}/GL
|
||||
- ${INSTALLP} ${LIBNAME} ${LIBDIR}
|
||||
- ${MKDIR} -p ${DATADIR}/doc/GLee
|
||||
- ${INSTALLD} ${README} ${DATADIR}/doc/GLee
|
||||
- ${LDCONFIG}
|
||||
+ ${MKDIR} -p ${DESTDIR}${INCLUDEDIR}/GL
|
||||
+ ${INSTALLD} ${HEADER} ${DESTDIR}${INCLUDEDIR}/GL
|
||||
+ ${INSTALLP} ${LIBNAME} ${DESTDIR}${LIBDIR}
|
||||
+ #${MKDIR} -p ${DATADIR}/doc/GLee
|
||||
+ #${INSTALLD} ${README} ${DATADIR}/doc/GLee
|
||||
+ #${LDCONFIG}
|
||||
|
||||
dists: dist bindist redist
|
||||
|
4
graphics/glee/pkg-descr
Normal file
4
graphics/glee/pkg-descr
Normal file
@ -0,0 +1,4 @@
|
||||
GLee facilitates OpenGL extension loading, and
|
||||
can be used by any code using OpenGL.
|
||||
|
||||
WWW: https://elf-stone.com/glee.php
|
Loading…
Reference in New Issue
Block a user