Add lzop, a fast file compressor similar to gzip that uses the LZO lib.

Obtained from:	NetBSD
This commit is contained in:
Will Andrews 2000-06-02 22:58:15 +00:00
parent 2e079a0471
commit ac5bfb9a2b
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=29123
7 changed files with 44 additions and 0 deletions

View File

@ -14,6 +14,7 @@
SUBDIR += liblzo
SUBDIR += linux_rar
SUBDIR += lzo
SUBDIR += lzop
SUBDIR += makeself
SUBDIR += mscompress
SUBDIR += nulib

22
archivers/lzop/Makefile Normal file
View File

@ -0,0 +1,22 @@
# New ports collection makefile for: lzop
# Date created: Fri 2 June 2000
# Whom: will
#
# $FreeBSD$
#
PORTNAME= lzop
PORTVERSION= 1.00
CATEGORIES= archivers
MASTER_SITES= http://wildsau.idv.uni-linz.ac.at/mfx/lzo-download/
MAINTAINER= will@FreeBSD.org
LIB_DEPENDS= lzo.1:${PORTSDIR}/archivers/liblzo
GNU_CONFIGURE= YES
CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
MAN1= lzop.1
.include <bsd.port.mk>

1
archivers/lzop/distinfo Normal file
View File

@ -0,0 +1 @@
MD5 (lzop-1.00.tar.gz) = ef267ac5ea24ccf4ae779f4afb0ab48e

View File

@ -0,0 +1,11 @@
--- configure Sat Apr 25 12:23:14 1998
+++ configure.new Fri Jun 2 18:55:17 2000
@@ -2265,7 +2265,7 @@
fi
done
-for ac_func in access atoi chmod chown fchmod fileno fstat getumask isatty setmode stat umask utime
+for ac_func in access atoi chmod chown fchmod fileno fstat getumask isatty stat umask utime
do
echo $ac_n "checking for $ac_func""... $ac_c" 1>&6
echo "configure:2272: checking for $ac_func" >&5

View File

@ -0,0 +1 @@
Fast file compressor similar to gzip, using the LZO library

7
archivers/lzop/pkg-descr Normal file
View File

@ -0,0 +1,7 @@
lzop is a file compressor which is very similar to gzip. It uses the LZO
library for compression services and its main advantages over gzip are much
higher compression and decompression speed (at the cost of some compression
ratio).
lzop is distributed under the terms of the GNU General Public License
(GPL).

1
archivers/lzop/pkg-plist Normal file
View File

@ -0,0 +1 @@
bin/lzop