Add garnaxfs 1.1.0,

Garnaxbot (File Server) is a file serving bot for IRC (commonly
referred to as a DCC bot). It uses the DCC chat/send features
of IRC to send files to other users. Garnaxbot will connect to
an IRC server and allow people to request files via DCC chat.

PR:		ports/68101
Submitted by:	Travis Poppe <tlp@liquidx.org>
This commit is contained in:
Kirill Ponomarev 2004-06-20 16:48:02 +00:00
parent f8ec1d6881
commit ac315ed6a7
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=111867
5 changed files with 71 additions and 0 deletions

View File

@ -21,6 +21,7 @@
SUBDIR += epic4
SUBDIR += erc
SUBDIR += ezbounce
SUBDIR += garnaxfs
SUBDIR += gdesklets-irc
SUBDIR += gruftistats
SUBDIR += gseen.mod

29
irc/garnaxfs/Makefile Normal file
View File

@ -0,0 +1,29 @@
# New ports collection makefile for: garnaxfs
# Date created: 19 Jun 2004
# Whom: Travis Poppe <tlp@liquidx.org>
#
# $FreeBSD$
#
PORTNAME= garnaxfs
PORTVERSION= 1.1.0
CATEGORIES= irc
MASTER_SITES= http://garnax.mircx.com/
DISTNAME= garnax-f1.1
MAINTAINER= tlp@liquidx.org
COMMENT= A file serving bot for IRC
USE_REINPLACE= yes
MAKE_ENV= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" PTHREAD_LIBS="${PTHREAD_LIBS}"
PLIST_FILES= bin/garnaxfs etc/garnaxfs.sample
post-patch:
@${REINPLACE_CMD} -e 's|-pthread|${PTHREAD_CFLAGS}|g' ${WRKSRC}/Makefile
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/garnax ${PREFIX}/bin/garnaxfs
${INSTALL_DATA} ${WRKSRC}/example.conf ${PREFIX}/etc/garnaxfs.sample
.include <bsd.port.mk>

2
irc/garnaxfs/distinfo Normal file
View File

@ -0,0 +1,2 @@
MD5 (garnax-f1.1.tar.gz) = fabf3775b7a6e598f9dbf3061b82e747
SIZE (garnax-f1.1.tar.gz) = 51422

View File

@ -0,0 +1,29 @@
$FreeBSD$
--- Makefile.orig Sun Jun 20 18:38:31 2004
+++ Makefile Sun Jun 20 18:39:44 2004
@@ -2,11 +2,12 @@
OBJDIR = ./work/
BUILD = garnax-f1.1
TARFILE = $(BUILD).tar
-CC = gcc
+CC ?= gcc
# Note: -lpthread may be needed instead of -pthread
#CFLAGS = -Wall -pedantic -ansi -pthread -g
-CFLAGS = -Wall -pthread -g
+CFLAGS += -Wall -pthread -g
+LIBS= ${PTHREAD_LIBS}
# Arguments for SunOS
# CC = cc
@@ -19,7 +20,7 @@
install : garnax
garnax : work $(objects)
- $(CC) $(CFLAGS) $(objects) -o garnax
+ $(CC) $(CFLAGS) $(LIBS) $(objects) -o garnax
work :
mkdir -p work

10
irc/garnaxfs/pkg-descr Normal file
View File

@ -0,0 +1,10 @@
Garnaxbot (File Server) is a file serving bot for IRC (commonly referred
to as a DCC bot). It uses the DCC chat/send features of IRC to send files
to other users. Garnaxbot will connect to an IRC server and allow people
to request files via DCC chat. This is not a script, it is a standalone
executable written in C.
WWW: http://garnax.mircx.com/
- Travis Poppe
tlp@liquidx.org