* Set maintainership to Anders Nordby <anders@fix.no>.
* Add info about PAM session support. * Add two more master sites that I control myself, to bring some much needed stability there too (UW has been removing snapshots without putting them in the old dir). * Add the file files/imap-uw.cnf, so that "make cert" actually works as intended. * Add -drac to PKGNAMESUFFIX if DRAC support is requested, so that people can see what they actually installed easier. * Remove some unnecessary linking parameters. Submitted by: Anders Nordby <anders@fix.no>
This commit is contained in:
parent
24ca44dfa7
commit
abdbcb5f1e
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=41473
@ -6,18 +6,24 @@
|
||||
#
|
||||
|
||||
PORTNAME= imap
|
||||
PORTVERSION= 0104051333
|
||||
PORTVERSION= 0104101757
|
||||
CATEGORIES= mail
|
||||
MASTER_SITES= ftp://ftp.cac.washington.edu/imap/%SUBDIR%/ \
|
||||
ftp://ftp.nuug.no/pub/anders/distfiles/%SUBDIR%/ \
|
||||
http://www.freenix.no/~anders/%SUBDIR%/ \
|
||||
ftp://ftp.funet.fi/pub/mirrors/ftp.cac.washington.edu/mail/%SUBDIR%/ \
|
||||
http://mirror.nucba.ac.jp/mirror/imap/%SUBDIR%/ \
|
||||
ftp://ftp.uni-halle.de/pub/mail/pine/%SUBDIR%/
|
||||
MASTER_SITE_SUBDIR= . old
|
||||
.if defined(WITH_DRAC)
|
||||
PKGNAMESUFFIX= -uw-drac
|
||||
.else
|
||||
PKGNAMESUFFIX= -uw
|
||||
.endif
|
||||
DISTNAME= imap-2001.BETA.SNAP-${PORTVERSION}
|
||||
DISTFILES= ${DISTNAME}.tar.Z imap-utils.tar.Z
|
||||
|
||||
MAINTAINER= ports@freebsd.org
|
||||
MAINTAINER= anders@fix.no
|
||||
|
||||
LIB_DEPENDS= c-client4.8:${PORTSDIR}/mail/cclient
|
||||
.if defined(WITH_DRAC)
|
||||
@ -75,7 +81,6 @@ post-install:
|
||||
@${ECHO}
|
||||
@${ECHO} "Remember to recompile and reinstall your cclient port with SSL support too, if"
|
||||
@${ECHO} "you had it installed without SSL support."
|
||||
@${ECHO}
|
||||
@${ECHO} "================================================================================"
|
||||
.endif
|
||||
|
||||
|
@ -1,2 +1,2 @@
|
||||
MD5 (imap-2001.BETA.SNAP-0104051333.tar.Z) = 81453371c29ce2c6b5aaca3a2f35dbc1
|
||||
MD5 (imap-2001.BETA.SNAP-0104101757.tar.Z) = 11c0611d1d7b4190f78b8daddd61c3d9
|
||||
MD5 (imap-utils.tar.Z) = a6453029f201b32e9ed761e662c47b0f
|
||||
|
34
mail/imap-uw/files/imap-uw.cnf
Normal file
34
mail/imap-uw/files/imap-uw.cnf
Normal file
@ -0,0 +1,34 @@
|
||||
HOME= .
|
||||
RANDFILE = $ENV::HOME/.rnd
|
||||
|
||||
[ req ]
|
||||
default_bits = 1024
|
||||
encrypt_key = yes
|
||||
distinguished_name = req_dn
|
||||
x509_extensions = cert_type
|
||||
|
||||
[ req_dn ]
|
||||
countryName = Country Name (2 letter code)
|
||||
countryName_default = NO
|
||||
countryName_min = 2
|
||||
countryName_max = 2
|
||||
|
||||
stateOrProvinceName = State or Province Name (full name)
|
||||
stateOrProvinceName_default = Some-State
|
||||
|
||||
localityName = Locality Name (eg, city)
|
||||
|
||||
0.organizationName = Organization Name (eg, company)
|
||||
0.organizationName_default = FooBar Inc.
|
||||
|
||||
organizationalUnitName = Organizational Unit Name (eg, section)
|
||||
#organizationalUnitName_default =
|
||||
|
||||
0.commonName = Common Name (FQDN of your server)
|
||||
|
||||
1.commonName = Common Name (default)
|
||||
1.commonName_value = localhost
|
||||
|
||||
[ cert_type ]
|
||||
nsCertType = server
|
||||
|
@ -1,13 +1,6 @@
|
||||
--- src/osdep/unix/Makefile.orig Thu Apr 5 00:45:53 2001
|
||||
+++ src/osdep/unix/Makefile Tue Apr 10 01:13:38 2001
|
||||
@@ -22,16 +22,16 @@
|
||||
|
||||
EXTRAAUTHENTICATORS=
|
||||
EXTRADRIVERS=mbox
|
||||
-PASSWDTYPE=std
|
||||
+PASSWDTYPE=pam
|
||||
SSLTYPE=none
|
||||
|
||||
--- src/osdep/unix/Makefile.orig Wed Apr 11 00:02:06 2001
|
||||
+++ src/osdep/unix/Makefile Sat Apr 14 03:20:57 2001
|
||||
@@ -28,12 +28,12 @@
|
||||
|
||||
# Extended flags needed for SSL. You may need to modify.
|
||||
|
||||
@ -20,14 +13,26 @@
|
||||
+SSLINCLUDE=$(OPENSSLINC)
|
||||
+SSLLIB=$(OPENSSLLIB)
|
||||
|
||||
SSLCRYPTO=-lcrypto
|
||||
-SSLCRYPTO=-lcrypto
|
||||
+SSLCRYPTO=-lcrypto -lcrypt
|
||||
|
||||
# Older versions of MIT Kerberos also have a libcrypto. If so, you may need
|
||||
# to use this instead
|
||||
@@ -46,7 +46,7 @@
|
||||
|
||||
SSLCFLAGS= -I$(SSLINCLUDE) -I$(SSLINCLUDE)/openssl\
|
||||
-DSSL_CERT_DIRECTORY=\"$(SSLCERTS)\"
|
||||
-SSLLDFLAGS= -L$(SSLLIB) -lssl $(SSLCRYPTO) $(SSLRSA)
|
||||
+SSLLDFLAGS= # -L$(SSLLIB) -lssl $(SSLCRYPTO) $(SSLRSA)
|
||||
|
||||
|
||||
# Extended flags needed for non-standard passwd types. You may need to modify.
|
||||
@@ -60,7 +60,7 @@
|
||||
# AFSLDFLAGS may also need -L/usr/ucblib -lucb
|
||||
DCECFLAGS= -DDCE_MINIMAL -DPASSWD_OVERRIDE=\"/opt/pop3/passwd/passwd\"
|
||||
DCELDFLAGS= -ldce
|
||||
-PAMLDFLAGS= -lpam -ldl
|
||||
+PAMLDFLAGS= -lpam
|
||||
+PAMLDFLAGS= # -lpam -lcrypt
|
||||
|
||||
|
||||
# Build parameters normally set by the individual port
|
||||
@ -65,12 +70,7 @@
|
||||
bs3: # BSD/i386 3.0 or higher
|
||||
$(BUILD) `$(CAT) SPECIALS` OS=bsi \
|
||||
CHECKPW=bsi LOGINPW=bsi CRXTYPE=nfs \
|
||||
@@ -213,12 +222,13 @@
|
||||
|
||||
bsf: # FreeBSD
|
||||
$(BUILD) `$(CAT) SPECIALS` OS=$@ \
|
||||
- SIGTYPE=psx CRXTYPE=nfs \
|
||||
+ SIGTYPE=psx CRXTYPE=nfs CHECKPW=pam \
|
||||
@@ -217,8 +226,9 @@
|
||||
SPOOLDIR=/var \
|
||||
ACTIVEFILE=/usr/local/news/lib/active \
|
||||
RSHPATH=/usr/bin/rsh \
|
||||
@ -78,7 +78,7 @@
|
||||
- BASELDFLAGS="-lcrypt"
|
||||
+ LOCKPGM=$(PREFIX)/libexec/mlock \
|
||||
+ BASECFLAGS="-DNFSKLUDGE" \
|
||||
+ BASELDFLAGS="-lpam -lcrypt"
|
||||
+ BASELDFLAGS=""
|
||||
|
||||
bsi: # BSD/i386
|
||||
$(BUILD) `$(CAT) SPECIALS` OS=$@ \
|
||||
|
@ -1,5 +1,5 @@
|
||||
--- src/ipopd/ipop3d.c.old Wed Apr 4 00:19:48 2001
|
||||
+++ src/ipopd/ipop3d.c Wed Apr 4 00:28:24 2001
|
||||
--- src/ipopd/ipop3d.c.orig Wed Feb 21 03:23:01 2001
|
||||
+++ src/ipopd/ipop3d.c Wed Apr 11 12:02:25 2001
|
||||
@@ -28,6 +28,11 @@
|
||||
#include <time.h>
|
||||
#include "c-client.h"
|
||||
@ -50,7 +50,7 @@
|
||||
+
|
||||
+ if ( (dracconf = fopen(ETC_DIR "/dracd.host", "r")) == NULL)
|
||||
+ {
|
||||
+ syslog (LOG_INFO, "dracd: error opening /etc/mail/dracd.host config file");
|
||||
+ syslog (LOG_INFO, "dracd: error opening %s/dracd.host config file",ETC_DIR);
|
||||
+ exit(1);
|
||||
+ }
|
||||
+
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- src/imapd/imapd.c.old Tue Apr 10 00:56:28 2001
|
||||
+++ src/imapd/imapd.c Tue Apr 10 00:59:08 2001
|
||||
@@ -29,6 +29,12 @@
|
||||
--- src/imapd/imapd.c.orig Sat Apr 7 00:27:30 2001
|
||||
+++ src/imapd/imapd.c Wed Apr 11 12:00:44 2001
|
||||
@@ -29,6 +29,11 @@
|
||||
#include "c-client.h"
|
||||
#include <sys/stat.h>
|
||||
|
||||
@ -9,11 +9,10 @@
|
||||
+#include <arpa/inet.h>
|
||||
+#include <stdlib.h>
|
||||
+#endif /* DRAC_AUTH */
|
||||
+
|
||||
|
||||
#define CRLF PSOUT ("\015\012") /* primary output terpri */
|
||||
|
||||
@@ -172,6 +178,12 @@
|
||||
@@ -173,6 +178,12 @@
|
||||
|
||||
/* Global storage */
|
||||
|
||||
@ -23,10 +22,10 @@
|
||||
+extern char *getenv ();
|
||||
+#endif /* DRAC_AUTH */
|
||||
+
|
||||
char *version = "2001.298"; /* version number of this server */
|
||||
char *version = "2001.299"; /* version number of this server */
|
||||
time_t alerttime = 0; /* time of last alert */
|
||||
time_t sysalerttime = 0; /* time of last system alert */
|
||||
@@ -1161,6 +1173,45 @@
|
||||
@@ -1161,6 +1172,45 @@
|
||||
lasterror ());
|
||||
return;
|
||||
}
|
||||
@ -42,7 +41,7 @@
|
||||
+
|
||||
+ if ( (dracconf = fopen(ETC_DIR "/dracd.host", "r")) == NULL)
|
||||
+ {
|
||||
+ syslog (LOG_INFO, "dracd: error opening /etc/mail/dracd.host config file");
|
||||
+ syslog (LOG_INFO, "dracd: error opening %s/dracd.host config file",ETC_DIR);
|
||||
+ exit(1);
|
||||
+ }
|
||||
+
|
||||
|
@ -3,5 +3,4 @@ Included are (almost) backwards-compatible POP2 and POP3 servers.
|
||||
|
||||
WWW: http://www.washington.edu/imap/
|
||||
|
||||
-Pete
|
||||
petef@databits.net
|
||||
- Anders Nordby <anders@fix.no>
|
||||
|
@ -11,5 +11,7 @@ default):
|
||||
|
||||
imap auth required pam_unix.so try_first_pass
|
||||
imap account required pam_unix.so try_first_pass
|
||||
imap session required pam_unix.so try_first_pass
|
||||
pop3 auth required pam_unix.so try_first_pass
|
||||
pop3 account required pam_unix.so try_first_pass
|
||||
pop3 session required pam_unix.so try_first_pass
|
||||
|
Loading…
Reference in New Issue
Block a user