Update to 0.17.

This commit is contained in:
Joe Marcus Clarke 2007-06-30 05:37:52 +00:00
parent fe9a2ce3b7
commit abaadb8d6e
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=194502
5 changed files with 27 additions and 53 deletions

View File

@ -6,8 +6,7 @@
# $MCom: ports/lang/librep/Makefile,v 1.2 2006/09/10 00:51:12 mezz Exp $
PORTNAME= librep
PORTVERSION= 0.16.2
PORTREVISION= 6
PORTVERSION= 0.17
CATEGORIES= lang elisp gnome
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= librep
@ -15,7 +14,8 @@ MASTER_SITE_SUBDIR= librep
MAINTAINER= gnome@FreeBSD.org
COMMENT= An Emacs Lisp like runtime library
LIB_DEPENDS= gdbm.3:${PORTSDIR}/databases/gdbm
LIB_DEPENDS= gdbm.3:${PORTSDIR}/databases/gdbm \
gmp.7:${PORTSDIR}/math/libgmp4
PLIST_SUB= GNUHOST=${ARCH}-pc-freebsd${OSREL:C/\..*//} VERSION=${PORTVERSION}
@ -36,12 +36,6 @@ INFO= librep
BROKEN= Does not build on ia64
.endif
.if ${OSVERSION} > 500023
LIB_DEPENDS+= gmp.7:${PORTSDIR}/math/libgmp4
.else
EXTRA_PATCHES+= ${FILESDIR}/stable-patch-src_numbers.c
.endif
post-extract:
@${RM} ${WRKSRC}/test

View File

@ -1,3 +1,3 @@
MD5 (librep-0.16.2.tar.gz) = b0f219f9f3d51bc06ebb1bd1861b6e5c
SHA256 (librep-0.16.2.tar.gz) = 9b394fd043298aa6a8f009b4d8c13a7a5cc475a10fec9d7e01e3bb4c4dc196bf
SIZE (librep-0.16.2.tar.gz) = 911485
MD5 (librep-0.17.tar.gz) = ad4ad851ff9f82a5d61024cd96bc2998
SHA256 (librep-0.17.tar.gz) = 3cc4d923e4eaee00adb696dbeb0144847e7cc03475962bfeb4add4cbbe271a3e
SIZE (librep-0.17.tar.gz) = 1195890

View File

@ -1,20 +1,19 @@
--- configure.orig Mon Oct 29 06:19:47 2001
+++ configure Thu Jan 24 17:54:12 2002
@@ -4659,7 +4659,7 @@
;;
esac
fi
-need_lc=${lt_cv_archive_cmds_need_lc-yes}
+need_lc=no
--- configure.orig Mon Nov 24 22:46:51 2003
+++ configure Sat Jun 30 01:24:06 2007
@@ -6567,6 +6567,7 @@ if test -z "$aix_libpath"; then aix_libp
hardcode_libdir_flag_spec='-R$libdir'
hardcode_direct=yes
hardcode_shlibpath_var=no
+ archive_cmds_need_lc=no
;;
# The second clause should only fire when bootstrapping the
# libtool distribution, otherwise you forgot to ship ltmain.sh
@@ -6136,7 +6136,7 @@
fi
if eval "test \"`echo '$ac_cv_lib_'$ac_lib_var`\" = yes"; then
echo "$ac_t""yes" 1>&6
hpux9*)
@@ -19768,7 +19769,7 @@ fi
echo "$as_me:$LINENO: result: $ac_cv_lib_gdbm_gdbm_open" >&5
echo "${ECHO_T}$ac_cv_lib_gdbm_gdbm_open" >&6
if test $ac_cv_lib_gdbm_gdbm_open = yes; then
- GDBM_LIBS="-lgdbm"
+ GDBM_LIBS="-lgdbm $LIBS"
+ GDBM_LIBS="$LIBS -lgdbm"
else
echo "$ac_t""no" 1>&6
{ echo "configure: error: Cannot find GDBM library" 1>&2; exit 1; }
{ { echo "$as_me:$LINENO: error: Cannot find GDBM library" >&5
echo "$as_me: error: Cannot find GDBM library" >&2;}

View File

@ -1,22 +0,0 @@
--- src/numbers.c.orig Sat May 31 17:50:08 2003
+++ src/numbers.c Sat May 31 18:15:24 2003
@@ -2696,13 +2696,14 @@
#ifdef HAVE_GMP
else
{
- rep_number_q *q;
+ double x, y;
+ rep_number_z *z;
- q = make_number (rep_NUMBER_RATIONAL);
- mpq_init (q->q);
- mpq_set_d (q->q, rep_get_float (arg));
+ rationalize (arg, &x, &y);
+ z = make_number (rep_NUMBER_BIGNUM);
+ mpz_init_set_d (z->z, (x / y));
- return maybe_demote (rep_VAL (q));
+ return maybe_demote (rep_VAL (z));
}
#else
else

View File

@ -4,13 +4,14 @@ bin/rep-remote
bin/rep-xgettext
bin/repdoc
include/rep.h
include/rep_gh.h
include/rep_lisp.h
include/rep_regexp.h
include/rep_subrs.h
lib/librep.la
lib/librep.so
lib/librep.so.12
libexec/rep/%%VERSION%%/%%GNUHOST%%/DOC
lib/librep.so.13
libexec/rep/%%VERSION%%/%%GNUHOST%%/doc-strings
libexec/rep/%%VERSION%%/%%GNUHOST%%/emulate-gnu-tar
libexec/rep/%%VERSION%%/%%GNUHOST%%/gdbm.la
libexec/rep/%%VERSION%%/%%GNUHOST%%/gdbm.so
@ -20,6 +21,8 @@ libexec/rep/%%VERSION%%/%%GNUHOST%%/readline.la
libexec/rep/%%VERSION%%/%%GNUHOST%%/readline.so
libexec/rep/%%VERSION%%/%%GNUHOST%%/rep/data/tables.la
libexec/rep/%%VERSION%%/%%GNUHOST%%/rep/data/tables.so
libexec/rep/%%VERSION%%/%%GNUHOST%%/rep/ffi.la
libexec/rep/%%VERSION%%/%%GNUHOST%%/rep/ffi.so
libexec/rep/%%VERSION%%/%%GNUHOST%%/rep/i18n/gettext.la
libexec/rep/%%VERSION%%/%%GNUHOST%%/rep/i18n/gettext.so
libexec/rep/%%VERSION%%/%%GNUHOST%%/rep/io/db/gdbm.la