- Remove expired port www/mplayer-plugin: Upstream support dropped. Please

consider using www/gecko-mediaplayer instead.
This commit is contained in:
Beat Gaetzi 2010-08-08 08:46:24 +00:00
parent 9ed39ea0ff
commit ab63d821dc
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=258909
9 changed files with 1 additions and 159 deletions

1
MOVED
View File

@ -4470,3 +4470,4 @@ sysutils/zfSnap|sysutils/zfsnap|2010-08-03|Change name to lower case
mail/lightning|deskutils/lightning|2010-08-03|Upstream development discontinued
mail/lightning|deskutils/lightning|2010-08-03|Upstream development discontinued
devel/py_otp_interface|devel/py-interface|2010-08-06|Duplicate py-interface port has better distutils handling
www/mplayer-plugin|www/gecko-mediaplayer|2010-08-08|Upstream support dropped

View File

@ -575,7 +575,6 @@
SUBDIR += mozex
SUBDIR += mozilla
SUBDIR += mozplugger
SUBDIR += mplayer-plugin
SUBDIR += multisort
SUBDIR += mybb
SUBDIR += myfaces

View File

@ -1,70 +0,0 @@
# New ports collection makefile for: mplayerplug-in
# Date Created: 20 February 2003
# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
#
# $FreeBSD$
#
PORTNAME= mplayerplug-in
PORTVERSION= 3.55
PORTREVISION= 7
CATEGORIES= www multimedia
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/v${PORTVERSION}
MAINTAINER= gecko@FreeBSD.org
COMMENT= A Mozilla plugin for the MPlayer media player
RUN_DEPENDS= mplayer:${PORTSDIR}/multimedia/mplayer
DEPRECATED= Upstream support dropped. Please consider using www/gecko-mediaplayer instead
EXPIRATION_DATE=2010-08-01
USE_GETTEXT= yes
USE_GMAKE= yes
USE_GECKO= libxul
USE_WEBPLUGINS= gecko*
WEBPLUGINS_FILES=mplayerplug-in.so mplayerplug-in.xpt mplayerplug-in-wmp.so \
mplayerplug-in-qt.so mplayerplug-in-rm.so \
mplayerplug-in-gmp.so mplayerplug-in-wmp.xpt \
mplayerplug-in-qt.xpt mplayerplug-in-rm.xpt \
mplayerplug-in-gmp.xpt mplayerplug-in-dvx.so \
mplayerplug-in-dvx.xpt
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-gmp
USE_GNOME= gnometarget
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -DBSD" \
LDFLAGS="-L${LOCALBASE}/lib" \
GECKO_XPIDL="${XPIDL}"
USE_XORG= x11 xpm xt
.include <bsd.port.pre.mk>
.include "${PORTSDIR}/www/firefox/Makefile.webplugins"
post-patch:
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|make|${GMAKE}|g' \
${WRKSRC}/Makefile.in
@${REINPLACE_CMD} -e 's|/etc/|${PREFIX}/etc/|g' \
${WRKSRC}/Source/plugin-setup.cpp
do-install:
${MKDIR} ${WEBPLUGINS_DIR}
.for moo in ${WEBPLUGINS_FILES}
${INSTALL_DATA} ${WRKSRC}/${moo} ${WEBPLUGINS_DIR}
.endfor
${INSTALL_DATA} ${WRKSRC}/mplayerplug-in.conf \
${PREFIX}/etc/mplayerplug-in.conf.dist
if [ ! -f ${PREFIX}/etc/mplayerplug-in.conf ]; then \
${INSTALL_DATA} ${WRKSRC}/mplayerplug-in.conf \
${PREFIX}/etc/mplayerplug-in.conf ; \
fi
${INSTALL_DATA} ${WRKSRC}/mplayerplug-in.types \
${PREFIX}/etc/mplayerplug-in.types.dist
if [ ! -f ${PREFIX}/etc/mplayerplug-in.types ]; then \
${INSTALL_DATA} ${WRKSRC}/mplayerplug-in.types \
${PREFIX}/etc/mplayerplug-in.types ;\
fi
cd ${WRKSRC}/po && ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} \
Makefile ${MAKE_ARGS} install
.include <bsd.port.post.mk>

View File

@ -1,3 +0,0 @@
MD5 (mplayerplug-in-3.55.tar.gz) = cb59d32221cfbd04b6a8b3bb55593484
SHA256 (mplayerplug-in-3.55.tar.gz) = ba5affde4c5d5a89c8bf987ae9326daabbf8ea8279fccd589474e5157fc67b7e
SIZE (mplayerplug-in-3.55.tar.gz) = 281845

View File

@ -1,16 +0,0 @@
--- Source/plugin-support.cpp.orig Sat Feb 18 17:05:30 2006
+++ Source/plugin-support.cpp Sat Feb 18 17:05:58 2006
@@ -486,9 +486,13 @@ void killmplayer(nsPluginInstance * inst
if (instance->paused == 1)
sendCommand(instance, "pause\n");
sendCommand(instance, "quit\n");
+#ifndef BSD
pthread_mutex_lock(&(instance->read_mutex));
+#endif
instance->cancelled = 1;
+#ifndef BSD
pthread_mutex_unlock(&(instance->read_mutex));
+#endif
/* count = 0;
while (count < 500) {

View File

@ -1,14 +0,0 @@
--- Source/plugin-threads.cpp.orig 2008-06-12 23:38:37.000000000 -0400
+++ Source/plugin-threads.cpp 2009-10-01 05:04:31.000000000 -0400
@@ -14,8 +14,11 @@
static void sig_child(int signo)
{
- // Not used, so commented out
- // wait(NULL);
+ pid_t pid;
+ int status;
+
+ pid = wait(&status);
+ return;
}

View File

@ -1,11 +0,0 @@
--- configure.orig 2008-06-24 09:15:05.000000000 -0400
+++ configure 2009-04-10 17:04:02.000000000 -0400
@@ -3789,7 +3789,7 @@
if test $succeeded = yes; then
MOZPLUG_CFLAGS="${MOZPLUG_CFLAGS} -I`$PKG_CONFIG --variable=includedir libxul`"
MOZILLA_HOME=`$PKG_CONFIG --variable=libdir libxul`
-GECKO_IDLDIR=`$PKG_CONFIG --variable=idldir libxul`
+GECKO_IDLDIR=`$PKG_CONFIG --variable=idldir libxul`/`$PKG_CONFIG --variable=includetype libxul`
else
{ echo "$as_me:$LINENO: WARNING: libxul not found" >&5

View File

@ -1,3 +0,0 @@
A Mozilla plugin that uses MPlayer to play videos from websites.
WWW: http://mplayerplug-in.sourceforge.net/

View File

@ -1,41 +0,0 @@
@unexec if cmp -s %D/etc/mplayerplug-in.conf %D/etc/mplayerplug-in.conf.dist; then rm -f %D/etc/mplayerplug-in.conf; fi
etc/mplayerplug-in.conf.dist
@unexec if cmp -s %D/etc/mplayerplug-in.types %D/etc/mplayerplug-in.types.dist; then rm -f %D/etc/mplayerplug-in.types; fi
etc/mplayerplug-in.types.dist
%%WEBPLUGINS_DIR%%/mplayerplug-in-dvx.so
%%WEBPLUGINS_DIR%%/mplayerplug-in-dvx.xpt
%%WEBPLUGINS_DIR%%/mplayerplug-in-gmp.so
%%WEBPLUGINS_DIR%%/mplayerplug-in-gmp.xpt
%%WEBPLUGINS_DIR%%/mplayerplug-in-qt.so
%%WEBPLUGINS_DIR%%/mplayerplug-in-qt.xpt
%%WEBPLUGINS_DIR%%/mplayerplug-in-rm.so
%%WEBPLUGINS_DIR%%/mplayerplug-in-rm.xpt
%%WEBPLUGINS_DIR%%/mplayerplug-in-wmp.so
%%WEBPLUGINS_DIR%%/mplayerplug-in-wmp.xpt
%%WEBPLUGINS_DIR%%/mplayerplug-in.so
%%WEBPLUGINS_DIR%%/mplayerplug-in.xpt
share/locale/cs/LC_MESSAGES/mplayerplug-in.mo
share/locale/da/LC_MESSAGES/mplayerplug-in.mo
share/locale/de/LC_MESSAGES/mplayerplug-in.mo
share/locale/en_US/LC_MESSAGES/mplayerplug-in.mo
share/locale/es/LC_MESSAGES/mplayerplug-in.mo
share/locale/fr/LC_MESSAGES/mplayerplug-in.mo
share/locale/hu/LC_MESSAGES/mplayerplug-in.mo
share/locale/it/LC_MESSAGES/mplayerplug-in.mo
share/locale/ja/LC_MESSAGES/mplayerplug-in.mo
share/locale/ko/LC_MESSAGES/mplayerplug-in.mo
share/locale/nb/LC_MESSAGES/mplayerplug-in.mo
share/locale/nl/LC_MESSAGES/mplayerplug-in.mo
share/locale/pl/LC_MESSAGES/mplayerplug-in.mo
share/locale/pt_BR/LC_MESSAGES/mplayerplug-in.mo
share/locale/ru/LC_MESSAGES/mplayerplug-in.mo
share/locale/se/LC_MESSAGES/mplayerplug-in.mo
share/locale/sk/LC_MESSAGES/mplayerplug-in.mo
share/locale/tr/LC_MESSAGES/mplayerplug-in.mo
share/locale/wa/LC_MESSAGES/mplayerplug-in.mo
share/locale/zh_CN/LC_MESSAGES/mplayerplug-in.mo
@dirrmtry %%WEBPLUGINS_DIR%%
@dirrmtry share/locale/se/LC_MESSAGES
@dirrmtry share/locale/se
@dirrmtry share/locale/en_US/LC_MESSAGES
@dirrmtry share/locale/en_US