Update to 2.3c1

This commit is contained in:
Hye-Shik Chang 2003-07-19 07:44:46 +00:00
parent 8f71b02709
commit ab4b78dba6
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=85183
36 changed files with 93 additions and 149 deletions

View File

@ -125,11 +125,11 @@ PYDISTUTILS= ${PYTHON_LIBDIR}/distutils/core.py:${PYTHON_PORTSDIR}
PYNUMERIC= ${PYTHON_SITELIBDIR}/Numeric/Numeric.py:${PORTSDIR}/math/py-numeric
PYXML= ${PYTHON_SITELIBDIR}/_xmlplus/__init__.py:${PORTSDIR}/textproc/py-xml
PYTHON_DISTFILE= Python-2.3b2.tgz
PYTHON_DISTFILE= Python-2.3c1.tgz
PYTHON_PORTSDIR= ${PORTSDIR}/lang/python-devel
PYTHON_REL= 230
PYTHON_SUFFIX= 23
PYTHON_WRKSRC= ${WRKDIR}/Python-2.3b2
PYTHON_WRKSRC= ${WRKDIR}/Python-2.3c1
# Python-2.2
.elif ${PYTHON_VERSION} == "python2.2"

View File

@ -5,11 +5,10 @@
# $FreeBSD$
PORTNAME= python
PORTVERSION= 2.3.b2
PORTREVISION= 1
PORTVERSION= 2.3.c1
CATEGORIES= lang python ipv6
MASTER_SITES= ${MASTER_SITE_PYTHON}
MASTER_SITE_SUBDIR= ftp/python/${PORTVERSION:S/.b2//}
MASTER_SITE_SUBDIR= ftp/python/${PORTVERSION:S/.c1//}
DISTFILES= ${PYTHON_DISTFILE}
MAINTAINER= perky@FreeBSD.org

View File

@ -1 +1 @@
MD5 (python/Python-2.3b2.tgz) = da16309c14caf585353686d5462fe9d7
MD5 (python/Python-2.3c1.tgz) = 167327b762b305d72b1cce3a5d78ccdf

View File

@ -1,6 +1,6 @@
--- configure.orig Sat Jun 28 16:46:31 2003
+++ configure Thu Jul 3 22:29:46 2003
@@ -3278,6 +3278,12 @@
--- configure.orig Sun Jul 13 18:46:13 2003
+++ configure Sat Jul 19 15:21:09 2003
@@ -3288,6 +3288,12 @@
RUNSHARED=LD_LIBRARY_PATH=`pwd`:$LD_LIBRARY_PATH
INSTSONAME="$LDLIBRARY".$SOVERSION
;;
@ -13,12 +13,3 @@
hp*|HP*)
LDLIBRARY='libpython$(VERSION).sl'
BLDLIBRARY='-Wl,+b,$(LIBDIR) -L. -lpython$(VERSION)'
@@ -3907,7 +3913,7 @@
echo $ECHO_N "(cached) $ECHO_C" >&6
else
ac_save_cc="$CC"
-CC="$CC -Kthread"
+CC="/nonexistent/ignore/$CC -Kthread"
if test "$cross_compiling" = yes; then
ac_cv_kthread=no
else

View File

@ -1,15 +1,15 @@
--- setup.py.orig Tue Jun 17 11:51:28 2003
+++ setup.py Fri Jul 4 17:33:05 2003
--- setup.py.orig Thu Jul 10 21:48:39 2003
+++ setup.py Sat Jul 19 16:27:04 2003
@@ -15,7 +15,7 @@
from distutils.command.install_lib import install_lib
# This global variable is used to hold the list of modules to be disabled.
-disabled_module_list = []
+disabled_module_list = ["_tkinter", "gdbm", "mpz", "pyexpat"]
+disabled_module_list = ["_bsddb", "_tkinter", "gdbm", "mpz", "pyexpat"]
def add_dir_to_list(dirlist, dir):
"""Add the directory 'dir' to the list 'dirlist' (at the front) if
@@ -1127,7 +1127,7 @@
@@ -1128,7 +1128,7 @@
ext_modules=[Extension('struct', ['structmodule.c'])],
# Scripts to install

View File

@ -2382,6 +2382,9 @@ lib/%%PYTHON_VERSION%%/test/test_userstring.pyo
lib/%%PYTHON_VERSION%%/test/test_uu.py
lib/%%PYTHON_VERSION%%/test/test_uu.pyc
lib/%%PYTHON_VERSION%%/test/test_uu.pyo
lib/%%PYTHON_VERSION%%/test/test_warnings.py
lib/%%PYTHON_VERSION%%/test/test_warnings.pyc
lib/%%PYTHON_VERSION%%/test/test_warnings.pyo
lib/%%PYTHON_VERSION%%/test/test_wave.py
lib/%%PYTHON_VERSION%%/test/test_wave.pyc
lib/%%PYTHON_VERSION%%/test/test_wave.pyo
@ -2983,7 +2986,6 @@ lib/%%PYTHON_VERSION%%/zipfile.pyo
%%PORTDOCS%%share/%%PYTHON_VERSION%%/Tools/scripts/suff.py
%%PORTDOCS%%share/%%PYTHON_VERSION%%/Tools/scripts/texcheck.py
%%PORTDOCS%%share/%%PYTHON_VERSION%%/Tools/scripts/texi2html.py
%%PORTDOCS%%share/%%PYTHON_VERSION%%/Tools/scripts/trace.py
%%PORTDOCS%%share/%%PYTHON_VERSION%%/Tools/scripts/treesync.py
%%PORTDOCS%%share/%%PYTHON_VERSION%%/Tools/scripts/untabify.py
%%PORTDOCS%%share/%%PYTHON_VERSION%%/Tools/scripts/which.py

View File

@ -5,11 +5,10 @@
# $FreeBSD$
PORTNAME= python
PORTVERSION= 2.3.b2
PORTREVISION= 1
PORTVERSION= 2.3.c1
CATEGORIES= lang python ipv6
MASTER_SITES= ${MASTER_SITE_PYTHON}
MASTER_SITE_SUBDIR= ftp/python/${PORTVERSION:S/.b2//}
MASTER_SITE_SUBDIR= ftp/python/${PORTVERSION:S/.c1//}
DISTFILES= ${PYTHON_DISTFILE}
MAINTAINER= perky@FreeBSD.org

View File

@ -1 +1 @@
MD5 (python/Python-2.3b2.tgz) = da16309c14caf585353686d5462fe9d7
MD5 (python/Python-2.3c1.tgz) = 167327b762b305d72b1cce3a5d78ccdf

View File

@ -1,6 +1,6 @@
--- configure.orig Sat Jun 28 16:46:31 2003
+++ configure Thu Jul 3 22:29:46 2003
@@ -3278,6 +3278,12 @@
--- configure.orig Sun Jul 13 18:46:13 2003
+++ configure Sat Jul 19 15:21:09 2003
@@ -3288,6 +3288,12 @@
RUNSHARED=LD_LIBRARY_PATH=`pwd`:$LD_LIBRARY_PATH
INSTSONAME="$LDLIBRARY".$SOVERSION
;;
@ -13,12 +13,3 @@
hp*|HP*)
LDLIBRARY='libpython$(VERSION).sl'
BLDLIBRARY='-Wl,+b,$(LIBDIR) -L. -lpython$(VERSION)'
@@ -3907,7 +3913,7 @@
echo $ECHO_N "(cached) $ECHO_C" >&6
else
ac_save_cc="$CC"
-CC="$CC -Kthread"
+CC="/nonexistent/ignore/$CC -Kthread"
if test "$cross_compiling" = yes; then
ac_cv_kthread=no
else

View File

@ -1,15 +1,15 @@
--- setup.py.orig Tue Jun 17 11:51:28 2003
+++ setup.py Fri Jul 4 17:33:05 2003
--- setup.py.orig Thu Jul 10 21:48:39 2003
+++ setup.py Sat Jul 19 16:27:04 2003
@@ -15,7 +15,7 @@
from distutils.command.install_lib import install_lib
# This global variable is used to hold the list of modules to be disabled.
-disabled_module_list = []
+disabled_module_list = ["_tkinter", "gdbm", "mpz", "pyexpat"]
+disabled_module_list = ["_bsddb", "_tkinter", "gdbm", "mpz", "pyexpat"]
def add_dir_to_list(dirlist, dir):
"""Add the directory 'dir' to the list 'dirlist' (at the front) if
@@ -1127,7 +1127,7 @@
@@ -1128,7 +1128,7 @@
ext_modules=[Extension('struct', ['structmodule.c'])],
# Scripts to install

View File

@ -2382,6 +2382,9 @@ lib/%%PYTHON_VERSION%%/test/test_userstring.pyo
lib/%%PYTHON_VERSION%%/test/test_uu.py
lib/%%PYTHON_VERSION%%/test/test_uu.pyc
lib/%%PYTHON_VERSION%%/test/test_uu.pyo
lib/%%PYTHON_VERSION%%/test/test_warnings.py
lib/%%PYTHON_VERSION%%/test/test_warnings.pyc
lib/%%PYTHON_VERSION%%/test/test_warnings.pyo
lib/%%PYTHON_VERSION%%/test/test_wave.py
lib/%%PYTHON_VERSION%%/test/test_wave.pyc
lib/%%PYTHON_VERSION%%/test/test_wave.pyo
@ -2983,7 +2986,6 @@ lib/%%PYTHON_VERSION%%/zipfile.pyo
%%PORTDOCS%%share/%%PYTHON_VERSION%%/Tools/scripts/suff.py
%%PORTDOCS%%share/%%PYTHON_VERSION%%/Tools/scripts/texcheck.py
%%PORTDOCS%%share/%%PYTHON_VERSION%%/Tools/scripts/texi2html.py
%%PORTDOCS%%share/%%PYTHON_VERSION%%/Tools/scripts/trace.py
%%PORTDOCS%%share/%%PYTHON_VERSION%%/Tools/scripts/treesync.py
%%PORTDOCS%%share/%%PYTHON_VERSION%%/Tools/scripts/untabify.py
%%PORTDOCS%%share/%%PYTHON_VERSION%%/Tools/scripts/which.py

View File

@ -5,11 +5,10 @@
# $FreeBSD$
PORTNAME= python
PORTVERSION= 2.3.b2
PORTREVISION= 1
PORTVERSION= 2.3.c1
CATEGORIES= lang python ipv6
MASTER_SITES= ${MASTER_SITE_PYTHON}
MASTER_SITE_SUBDIR= ftp/python/${PORTVERSION:S/.b2//}
MASTER_SITE_SUBDIR= ftp/python/${PORTVERSION:S/.c1//}
DISTFILES= ${PYTHON_DISTFILE}
MAINTAINER= perky@FreeBSD.org

View File

@ -1 +1 @@
MD5 (python/Python-2.3b2.tgz) = da16309c14caf585353686d5462fe9d7
MD5 (python/Python-2.3c1.tgz) = 167327b762b305d72b1cce3a5d78ccdf

View File

@ -1,6 +1,6 @@
--- configure.orig Sat Jun 28 16:46:31 2003
+++ configure Thu Jul 3 22:29:46 2003
@@ -3278,6 +3278,12 @@
--- configure.orig Sun Jul 13 18:46:13 2003
+++ configure Sat Jul 19 15:21:09 2003
@@ -3288,6 +3288,12 @@
RUNSHARED=LD_LIBRARY_PATH=`pwd`:$LD_LIBRARY_PATH
INSTSONAME="$LDLIBRARY".$SOVERSION
;;
@ -13,12 +13,3 @@
hp*|HP*)
LDLIBRARY='libpython$(VERSION).sl'
BLDLIBRARY='-Wl,+b,$(LIBDIR) -L. -lpython$(VERSION)'
@@ -3907,7 +3913,7 @@
echo $ECHO_N "(cached) $ECHO_C" >&6
else
ac_save_cc="$CC"
-CC="$CC -Kthread"
+CC="/nonexistent/ignore/$CC -Kthread"
if test "$cross_compiling" = yes; then
ac_cv_kthread=no
else

View File

@ -1,15 +1,15 @@
--- setup.py.orig Tue Jun 17 11:51:28 2003
+++ setup.py Fri Jul 4 17:33:05 2003
--- setup.py.orig Thu Jul 10 21:48:39 2003
+++ setup.py Sat Jul 19 16:27:04 2003
@@ -15,7 +15,7 @@
from distutils.command.install_lib import install_lib
# This global variable is used to hold the list of modules to be disabled.
-disabled_module_list = []
+disabled_module_list = ["_tkinter", "gdbm", "mpz", "pyexpat"]
+disabled_module_list = ["_bsddb", "_tkinter", "gdbm", "mpz", "pyexpat"]
def add_dir_to_list(dirlist, dir):
"""Add the directory 'dir' to the list 'dirlist' (at the front) if
@@ -1127,7 +1127,7 @@
@@ -1128,7 +1128,7 @@
ext_modules=[Extension('struct', ['structmodule.c'])],
# Scripts to install

View File

@ -2382,6 +2382,9 @@ lib/%%PYTHON_VERSION%%/test/test_userstring.pyo
lib/%%PYTHON_VERSION%%/test/test_uu.py
lib/%%PYTHON_VERSION%%/test/test_uu.pyc
lib/%%PYTHON_VERSION%%/test/test_uu.pyo
lib/%%PYTHON_VERSION%%/test/test_warnings.py
lib/%%PYTHON_VERSION%%/test/test_warnings.pyc
lib/%%PYTHON_VERSION%%/test/test_warnings.pyo
lib/%%PYTHON_VERSION%%/test/test_wave.py
lib/%%PYTHON_VERSION%%/test/test_wave.pyc
lib/%%PYTHON_VERSION%%/test/test_wave.pyo
@ -2983,7 +2986,6 @@ lib/%%PYTHON_VERSION%%/zipfile.pyo
%%PORTDOCS%%share/%%PYTHON_VERSION%%/Tools/scripts/suff.py
%%PORTDOCS%%share/%%PYTHON_VERSION%%/Tools/scripts/texcheck.py
%%PORTDOCS%%share/%%PYTHON_VERSION%%/Tools/scripts/texi2html.py
%%PORTDOCS%%share/%%PYTHON_VERSION%%/Tools/scripts/trace.py
%%PORTDOCS%%share/%%PYTHON_VERSION%%/Tools/scripts/treesync.py
%%PORTDOCS%%share/%%PYTHON_VERSION%%/Tools/scripts/untabify.py
%%PORTDOCS%%share/%%PYTHON_VERSION%%/Tools/scripts/which.py

View File

@ -5,11 +5,10 @@
# $FreeBSD$
PORTNAME= python
PORTVERSION= 2.3.b2
PORTREVISION= 1
PORTVERSION= 2.3.c1
CATEGORIES= lang python ipv6
MASTER_SITES= ${MASTER_SITE_PYTHON}
MASTER_SITE_SUBDIR= ftp/python/${PORTVERSION:S/.b2//}
MASTER_SITE_SUBDIR= ftp/python/${PORTVERSION:S/.c1//}
DISTFILES= ${PYTHON_DISTFILE}
MAINTAINER= perky@FreeBSD.org

View File

@ -1 +1 @@
MD5 (python/Python-2.3b2.tgz) = da16309c14caf585353686d5462fe9d7
MD5 (python/Python-2.3c1.tgz) = 167327b762b305d72b1cce3a5d78ccdf

View File

@ -1,6 +1,6 @@
--- configure.orig Sat Jun 28 16:46:31 2003
+++ configure Thu Jul 3 22:29:46 2003
@@ -3278,6 +3278,12 @@
--- configure.orig Sun Jul 13 18:46:13 2003
+++ configure Sat Jul 19 15:21:09 2003
@@ -3288,6 +3288,12 @@
RUNSHARED=LD_LIBRARY_PATH=`pwd`:$LD_LIBRARY_PATH
INSTSONAME="$LDLIBRARY".$SOVERSION
;;
@ -13,12 +13,3 @@
hp*|HP*)
LDLIBRARY='libpython$(VERSION).sl'
BLDLIBRARY='-Wl,+b,$(LIBDIR) -L. -lpython$(VERSION)'
@@ -3907,7 +3913,7 @@
echo $ECHO_N "(cached) $ECHO_C" >&6
else
ac_save_cc="$CC"
-CC="$CC -Kthread"
+CC="/nonexistent/ignore/$CC -Kthread"
if test "$cross_compiling" = yes; then
ac_cv_kthread=no
else

View File

@ -1,15 +1,15 @@
--- setup.py.orig Tue Jun 17 11:51:28 2003
+++ setup.py Fri Jul 4 17:33:05 2003
--- setup.py.orig Thu Jul 10 21:48:39 2003
+++ setup.py Sat Jul 19 16:27:04 2003
@@ -15,7 +15,7 @@
from distutils.command.install_lib import install_lib
# This global variable is used to hold the list of modules to be disabled.
-disabled_module_list = []
+disabled_module_list = ["_tkinter", "gdbm", "mpz", "pyexpat"]
+disabled_module_list = ["_bsddb", "_tkinter", "gdbm", "mpz", "pyexpat"]
def add_dir_to_list(dirlist, dir):
"""Add the directory 'dir' to the list 'dirlist' (at the front) if
@@ -1127,7 +1127,7 @@
@@ -1128,7 +1128,7 @@
ext_modules=[Extension('struct', ['structmodule.c'])],
# Scripts to install

View File

@ -2382,6 +2382,9 @@ lib/%%PYTHON_VERSION%%/test/test_userstring.pyo
lib/%%PYTHON_VERSION%%/test/test_uu.py
lib/%%PYTHON_VERSION%%/test/test_uu.pyc
lib/%%PYTHON_VERSION%%/test/test_uu.pyo
lib/%%PYTHON_VERSION%%/test/test_warnings.py
lib/%%PYTHON_VERSION%%/test/test_warnings.pyc
lib/%%PYTHON_VERSION%%/test/test_warnings.pyo
lib/%%PYTHON_VERSION%%/test/test_wave.py
lib/%%PYTHON_VERSION%%/test/test_wave.pyc
lib/%%PYTHON_VERSION%%/test/test_wave.pyo
@ -2983,7 +2986,6 @@ lib/%%PYTHON_VERSION%%/zipfile.pyo
%%PORTDOCS%%share/%%PYTHON_VERSION%%/Tools/scripts/suff.py
%%PORTDOCS%%share/%%PYTHON_VERSION%%/Tools/scripts/texcheck.py
%%PORTDOCS%%share/%%PYTHON_VERSION%%/Tools/scripts/texi2html.py
%%PORTDOCS%%share/%%PYTHON_VERSION%%/Tools/scripts/trace.py
%%PORTDOCS%%share/%%PYTHON_VERSION%%/Tools/scripts/treesync.py
%%PORTDOCS%%share/%%PYTHON_VERSION%%/Tools/scripts/untabify.py
%%PORTDOCS%%share/%%PYTHON_VERSION%%/Tools/scripts/which.py

View File

@ -5,11 +5,10 @@
# $FreeBSD$
PORTNAME= python
PORTVERSION= 2.3.b2
PORTREVISION= 1
PORTVERSION= 2.3.c1
CATEGORIES= lang python ipv6
MASTER_SITES= ${MASTER_SITE_PYTHON}
MASTER_SITE_SUBDIR= ftp/python/${PORTVERSION:S/.b2//}
MASTER_SITE_SUBDIR= ftp/python/${PORTVERSION:S/.c1//}
DISTFILES= ${PYTHON_DISTFILE}
MAINTAINER= perky@FreeBSD.org

View File

@ -1 +1 @@
MD5 (python/Python-2.3b2.tgz) = da16309c14caf585353686d5462fe9d7
MD5 (python/Python-2.3c1.tgz) = 167327b762b305d72b1cce3a5d78ccdf

View File

@ -1,6 +1,6 @@
--- configure.orig Sat Jun 28 16:46:31 2003
+++ configure Thu Jul 3 22:29:46 2003
@@ -3278,6 +3278,12 @@
--- configure.orig Sun Jul 13 18:46:13 2003
+++ configure Sat Jul 19 15:21:09 2003
@@ -3288,6 +3288,12 @@
RUNSHARED=LD_LIBRARY_PATH=`pwd`:$LD_LIBRARY_PATH
INSTSONAME="$LDLIBRARY".$SOVERSION
;;
@ -13,12 +13,3 @@
hp*|HP*)
LDLIBRARY='libpython$(VERSION).sl'
BLDLIBRARY='-Wl,+b,$(LIBDIR) -L. -lpython$(VERSION)'
@@ -3907,7 +3913,7 @@
echo $ECHO_N "(cached) $ECHO_C" >&6
else
ac_save_cc="$CC"
-CC="$CC -Kthread"
+CC="/nonexistent/ignore/$CC -Kthread"
if test "$cross_compiling" = yes; then
ac_cv_kthread=no
else

View File

@ -1,15 +1,15 @@
--- setup.py.orig Tue Jun 17 11:51:28 2003
+++ setup.py Fri Jul 4 17:33:05 2003
--- setup.py.orig Thu Jul 10 21:48:39 2003
+++ setup.py Sat Jul 19 16:27:04 2003
@@ -15,7 +15,7 @@
from distutils.command.install_lib import install_lib
# This global variable is used to hold the list of modules to be disabled.
-disabled_module_list = []
+disabled_module_list = ["_tkinter", "gdbm", "mpz", "pyexpat"]
+disabled_module_list = ["_bsddb", "_tkinter", "gdbm", "mpz", "pyexpat"]
def add_dir_to_list(dirlist, dir):
"""Add the directory 'dir' to the list 'dirlist' (at the front) if
@@ -1127,7 +1127,7 @@
@@ -1128,7 +1128,7 @@
ext_modules=[Extension('struct', ['structmodule.c'])],
# Scripts to install

View File

@ -2382,6 +2382,9 @@ lib/%%PYTHON_VERSION%%/test/test_userstring.pyo
lib/%%PYTHON_VERSION%%/test/test_uu.py
lib/%%PYTHON_VERSION%%/test/test_uu.pyc
lib/%%PYTHON_VERSION%%/test/test_uu.pyo
lib/%%PYTHON_VERSION%%/test/test_warnings.py
lib/%%PYTHON_VERSION%%/test/test_warnings.pyc
lib/%%PYTHON_VERSION%%/test/test_warnings.pyo
lib/%%PYTHON_VERSION%%/test/test_wave.py
lib/%%PYTHON_VERSION%%/test/test_wave.pyc
lib/%%PYTHON_VERSION%%/test/test_wave.pyo
@ -2983,7 +2986,6 @@ lib/%%PYTHON_VERSION%%/zipfile.pyo
%%PORTDOCS%%share/%%PYTHON_VERSION%%/Tools/scripts/suff.py
%%PORTDOCS%%share/%%PYTHON_VERSION%%/Tools/scripts/texcheck.py
%%PORTDOCS%%share/%%PYTHON_VERSION%%/Tools/scripts/texi2html.py
%%PORTDOCS%%share/%%PYTHON_VERSION%%/Tools/scripts/trace.py
%%PORTDOCS%%share/%%PYTHON_VERSION%%/Tools/scripts/treesync.py
%%PORTDOCS%%share/%%PYTHON_VERSION%%/Tools/scripts/untabify.py
%%PORTDOCS%%share/%%PYTHON_VERSION%%/Tools/scripts/which.py

View File

@ -5,11 +5,10 @@
# $FreeBSD$
PORTNAME= python
PORTVERSION= 2.3.b2
PORTREVISION= 1
PORTVERSION= 2.3.c1
CATEGORIES= lang python ipv6
MASTER_SITES= ${MASTER_SITE_PYTHON}
MASTER_SITE_SUBDIR= ftp/python/${PORTVERSION:S/.b2//}
MASTER_SITE_SUBDIR= ftp/python/${PORTVERSION:S/.c1//}
DISTFILES= ${PYTHON_DISTFILE}
MAINTAINER= perky@FreeBSD.org

View File

@ -1 +1 @@
MD5 (python/Python-2.3b2.tgz) = da16309c14caf585353686d5462fe9d7
MD5 (python/Python-2.3c1.tgz) = 167327b762b305d72b1cce3a5d78ccdf

View File

@ -1,6 +1,6 @@
--- configure.orig Sat Jun 28 16:46:31 2003
+++ configure Thu Jul 3 22:29:46 2003
@@ -3278,6 +3278,12 @@
--- configure.orig Sun Jul 13 18:46:13 2003
+++ configure Sat Jul 19 15:21:09 2003
@@ -3288,6 +3288,12 @@
RUNSHARED=LD_LIBRARY_PATH=`pwd`:$LD_LIBRARY_PATH
INSTSONAME="$LDLIBRARY".$SOVERSION
;;
@ -13,12 +13,3 @@
hp*|HP*)
LDLIBRARY='libpython$(VERSION).sl'
BLDLIBRARY='-Wl,+b,$(LIBDIR) -L. -lpython$(VERSION)'
@@ -3907,7 +3913,7 @@
echo $ECHO_N "(cached) $ECHO_C" >&6
else
ac_save_cc="$CC"
-CC="$CC -Kthread"
+CC="/nonexistent/ignore/$CC -Kthread"
if test "$cross_compiling" = yes; then
ac_cv_kthread=no
else

View File

@ -1,15 +1,15 @@
--- setup.py.orig Tue Jun 17 11:51:28 2003
+++ setup.py Fri Jul 4 17:33:05 2003
--- setup.py.orig Thu Jul 10 21:48:39 2003
+++ setup.py Sat Jul 19 16:27:04 2003
@@ -15,7 +15,7 @@
from distutils.command.install_lib import install_lib
# This global variable is used to hold the list of modules to be disabled.
-disabled_module_list = []
+disabled_module_list = ["_tkinter", "gdbm", "mpz", "pyexpat"]
+disabled_module_list = ["_bsddb", "_tkinter", "gdbm", "mpz", "pyexpat"]
def add_dir_to_list(dirlist, dir):
"""Add the directory 'dir' to the list 'dirlist' (at the front) if
@@ -1127,7 +1127,7 @@
@@ -1128,7 +1128,7 @@
ext_modules=[Extension('struct', ['structmodule.c'])],
# Scripts to install

View File

@ -2382,6 +2382,9 @@ lib/%%PYTHON_VERSION%%/test/test_userstring.pyo
lib/%%PYTHON_VERSION%%/test/test_uu.py
lib/%%PYTHON_VERSION%%/test/test_uu.pyc
lib/%%PYTHON_VERSION%%/test/test_uu.pyo
lib/%%PYTHON_VERSION%%/test/test_warnings.py
lib/%%PYTHON_VERSION%%/test/test_warnings.pyc
lib/%%PYTHON_VERSION%%/test/test_warnings.pyo
lib/%%PYTHON_VERSION%%/test/test_wave.py
lib/%%PYTHON_VERSION%%/test/test_wave.pyc
lib/%%PYTHON_VERSION%%/test/test_wave.pyo
@ -2983,7 +2986,6 @@ lib/%%PYTHON_VERSION%%/zipfile.pyo
%%PORTDOCS%%share/%%PYTHON_VERSION%%/Tools/scripts/suff.py
%%PORTDOCS%%share/%%PYTHON_VERSION%%/Tools/scripts/texcheck.py
%%PORTDOCS%%share/%%PYTHON_VERSION%%/Tools/scripts/texi2html.py
%%PORTDOCS%%share/%%PYTHON_VERSION%%/Tools/scripts/trace.py
%%PORTDOCS%%share/%%PYTHON_VERSION%%/Tools/scripts/treesync.py
%%PORTDOCS%%share/%%PYTHON_VERSION%%/Tools/scripts/untabify.py
%%PORTDOCS%%share/%%PYTHON_VERSION%%/Tools/scripts/which.py

View File

@ -5,11 +5,10 @@
# $FreeBSD$
PORTNAME= python
PORTVERSION= 2.3.b2
PORTREVISION= 1
PORTVERSION= 2.3.c1
CATEGORIES= lang python ipv6
MASTER_SITES= ${MASTER_SITE_PYTHON}
MASTER_SITE_SUBDIR= ftp/python/${PORTVERSION:S/.b2//}
MASTER_SITE_SUBDIR= ftp/python/${PORTVERSION:S/.c1//}
DISTFILES= ${PYTHON_DISTFILE}
MAINTAINER= perky@FreeBSD.org

View File

@ -1 +1 @@
MD5 (python/Python-2.3b2.tgz) = da16309c14caf585353686d5462fe9d7
MD5 (python/Python-2.3c1.tgz) = 167327b762b305d72b1cce3a5d78ccdf

View File

@ -1,6 +1,6 @@
--- configure.orig Sat Jun 28 16:46:31 2003
+++ configure Thu Jul 3 22:29:46 2003
@@ -3278,6 +3278,12 @@
--- configure.orig Sun Jul 13 18:46:13 2003
+++ configure Sat Jul 19 15:21:09 2003
@@ -3288,6 +3288,12 @@
RUNSHARED=LD_LIBRARY_PATH=`pwd`:$LD_LIBRARY_PATH
INSTSONAME="$LDLIBRARY".$SOVERSION
;;
@ -13,12 +13,3 @@
hp*|HP*)
LDLIBRARY='libpython$(VERSION).sl'
BLDLIBRARY='-Wl,+b,$(LIBDIR) -L. -lpython$(VERSION)'
@@ -3907,7 +3913,7 @@
echo $ECHO_N "(cached) $ECHO_C" >&6
else
ac_save_cc="$CC"
-CC="$CC -Kthread"
+CC="/nonexistent/ignore/$CC -Kthread"
if test "$cross_compiling" = yes; then
ac_cv_kthread=no
else

View File

@ -1,15 +1,15 @@
--- setup.py.orig Tue Jun 17 11:51:28 2003
+++ setup.py Fri Jul 4 17:33:05 2003
--- setup.py.orig Thu Jul 10 21:48:39 2003
+++ setup.py Sat Jul 19 16:27:04 2003
@@ -15,7 +15,7 @@
from distutils.command.install_lib import install_lib
# This global variable is used to hold the list of modules to be disabled.
-disabled_module_list = []
+disabled_module_list = ["_tkinter", "gdbm", "mpz", "pyexpat"]
+disabled_module_list = ["_bsddb", "_tkinter", "gdbm", "mpz", "pyexpat"]
def add_dir_to_list(dirlist, dir):
"""Add the directory 'dir' to the list 'dirlist' (at the front) if
@@ -1127,7 +1127,7 @@
@@ -1128,7 +1128,7 @@
ext_modules=[Extension('struct', ['structmodule.c'])],
# Scripts to install

View File

@ -2382,6 +2382,9 @@ lib/%%PYTHON_VERSION%%/test/test_userstring.pyo
lib/%%PYTHON_VERSION%%/test/test_uu.py
lib/%%PYTHON_VERSION%%/test/test_uu.pyc
lib/%%PYTHON_VERSION%%/test/test_uu.pyo
lib/%%PYTHON_VERSION%%/test/test_warnings.py
lib/%%PYTHON_VERSION%%/test/test_warnings.pyc
lib/%%PYTHON_VERSION%%/test/test_warnings.pyo
lib/%%PYTHON_VERSION%%/test/test_wave.py
lib/%%PYTHON_VERSION%%/test/test_wave.pyc
lib/%%PYTHON_VERSION%%/test/test_wave.pyo
@ -2983,7 +2986,6 @@ lib/%%PYTHON_VERSION%%/zipfile.pyo
%%PORTDOCS%%share/%%PYTHON_VERSION%%/Tools/scripts/suff.py
%%PORTDOCS%%share/%%PYTHON_VERSION%%/Tools/scripts/texcheck.py
%%PORTDOCS%%share/%%PYTHON_VERSION%%/Tools/scripts/texi2html.py
%%PORTDOCS%%share/%%PYTHON_VERSION%%/Tools/scripts/trace.py
%%PORTDOCS%%share/%%PYTHON_VERSION%%/Tools/scripts/treesync.py
%%PORTDOCS%%share/%%PYTHON_VERSION%%/Tools/scripts/untabify.py
%%PORTDOCS%%share/%%PYTHON_VERSION%%/Tools/scripts/which.py