Add gnome-music-quiz, a small quiz game that plays songs from your Rhythmbox

music library and let you guess artist, album or track name.

PR:		ports/68156
Submitted by:	Jean-Yves Lefort <jylefort@brutele.be>
This commit is contained in:
Pav Lucistnik 2004-06-21 20:40:02 +00:00
parent c586aa0073
commit aae559edd7
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=111953
6 changed files with 90 additions and 0 deletions

View File

@ -157,6 +157,7 @@
SUBDIR += gnmm
SUBDIR += gno3dtet
SUBDIR += gnocatan
SUBDIR += gnome-music-quiz
SUBDIR += gnomeattacks
SUBDIR += gnomebreakout
SUBDIR += gnomechess

View File

@ -0,0 +1,34 @@
# New ports collection makefile for: GNOME Music Quiz
# Date created: 20 Jun 2004
# Whom: Jean-Yves Lefort <jylefort@brutele.be>
#
# $FreeBSD$
#
PORTNAME= gnome-music-quiz
PORTVERSION= 0.1
CATEGORIES= games audio
MASTER_SITES= http://ishamael.tunkeymicket.com/tarballs/
DISTNAME= mq-${PORTVERSION}
MAINTAINER= jylefort@brutele.be
COMMENT= A game similar to the television show 'Name That Tune'
RUN_DEPENDS= rhythmbox:${PORTSDIR}/audio/rhythmbox
USE_X_PREFIX= yes
USE_GNOME= gnomeprefix libgnomeui gstreamerplugins
USE_LIBTOOL_VER= 15
post-extract:
@${RM} -f \
${WRKSRC}/intltool-extract.in \
${WRKSRC}/intltool-merge.in \
${WRKSRC}/intltool-update.in
@${CP} -f \
${LOCALBASE}/share/intltool/intltool-extract.in \
${LOCALBASE}/share/intltool/intltool-merge.in \
${LOCALBASE}/share/intltool/intltool-update.in \
${WRKSRC}
.include <bsd.port.mk>

View File

@ -0,0 +1,2 @@
MD5 (mq-0.1.tar.gz) = 8f2051612c0a1dcecbd6cd0b2f30d397
SIZE (mq-0.1.tar.gz) = 817333

View File

@ -0,0 +1,40 @@
--- src/mq.c.orig Sun Jun 20 20:21:26 2004
+++ src/mq.c Sun Jun 20 21:58:03 2004
@@ -440,15 +440,30 @@
static gboolean round_entries_desensitize_timeout(gpointer data)
{
- gint32 i = 0;
+ int i;
+ int entries_left = 0;
+ int n;
+ int j = 0;
- do {
- i = g_random_int_range(0,5);
- } while (round_entries_sensitive[i] == FALSE || i == round_answer);
-
- round_entries_sensitive[i] = FALSE;
- gtk_widget_set_sensitive(GTK_WIDGET(game_buttons[i]),FALSE);
+ for (i = 0; i < 5; i++)
+ if (round_entries_sensitive[i] && i != round_answer)
+ entries_left++;
+ if (entries_left == 0) {
+ round_entries_desensitize_timeout_id = -1;
+ return FALSE;
+ }
+
+ n = g_random_int_range(0, entries_left);
+ for (i = 0; i < 5; i++)
+ if (round_entries_sensitive[i] && i != round_answer) {
+ if (j++ == n) {
+ round_entries_sensitive[i] = FALSE;
+ gtk_widget_set_sensitive(GTK_WIDGET(game_buttons[i]), FALSE);
+ break;
+ }
+ }
+
return TRUE;
}

View File

@ -0,0 +1,10 @@
GNOME Music Quiz is a game similar to the television show 'Name That
Tune'. Players are quizzed on songs from their Rhythmbox music
library. The faster a player identifies a song the more points he or
she receives. Great for parties or to learn your music and impress
your friends.
WWW: http://ishamael.tunkeymicket.com/mq.php
- Jean-Yves Lefort
jylefort@brutele.be

View File

@ -0,0 +1,3 @@
bin/mq
share/gnome/applications/mq.desktop
share/gnome/pixmaps/gnome-mq.png