PR: ports/8959

Submitted by:	andy@icc.surw.chel.su
Initial Import antipolix.
This game is played in a parallelepipede containing PxNxN little cubes.
This commit is contained in:
Seiichirou Hiraoka 1998-12-05 17:08:12 +00:00
parent 88d4021463
commit aadf6ff1df
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=15135
10 changed files with 126 additions and 0 deletions

36
games/antipolix/Makefile Normal file
View File

@ -0,0 +1,36 @@
# New ports collection makefile for: antipolix
# Version required: 2.1
# Date created: 2 December 1998
# Whom: Andrey Zakhvatov
#
# $Id$
#
DISTNAME= AntipoliX_2.1
PKGNAME= antipolix-2.1
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_XCONTRIB}
MASTER_SITE_SUBDIR= games/multiplayer
MAINTAINER= andy@icc.surw.chel.su
WRKSRC= ${WRKDIR}
USE_IMAKE= yes
do-install:
@ ${INSTALL_PROGRAM} ${WRKSRC}/client ${PREFIX}/bin/antipolix-client
@ ${INSTALL_PROGRAM} ${WRKSRC}/server ${PREFIX}/bin/antipolix-server
@ ${MKDIR} ${PREFIX}/share/examples/antipolix
@ ${INSTALL_DATA} ${WRKSRC}/.motd ${PREFIX}/share/examples/antipolix/dot.motd.sample
@ ${INSTALL_DATA} ${WRKSRC}/.players ${PREFIX}/share/examples/antipolix/dot.players.sample
@ ${INSTALL_DATA} ${WRKSRC}/.server_defaults ${PREFIX}/share/examples/antipolix/dot.server_defaults.sample
post-install:
.if !defined(NOPORTDOCS)
@ ${MKDIR} ${PREFIX}/share/doc/antipolix
.for file in ANTIPOLIX_RULES CLIENT_USE COPYRIGHT SERVER_USE
@ ${INSTALL_DATA} ${WRKSRC}/${file} ${PREFIX}/share/doc/antipolix
.endfor
.endif
.include <bsd.port.mk>

1
games/antipolix/distinfo Normal file
View File

@ -0,0 +1 @@
MD5 (AntipoliX_2.1.tar.gz) = 559dac2489422a7e5cd944f399ec2615

View File

@ -0,0 +1,12 @@
--- Imakefile Thu Aug 3 22:29:38 1995
+++ /home/andy/tmp/wrk/Imakefile Wed Dec 2 21:01:22 1998
@@ -1,6 +1,6 @@
-EXTRA_LIBRARIES=-lX11 -lm -lsocket
-CC=gcc
-CDEBUGFLAGS = -g
+EXTRA_LIBRARIES=-lX11 -lm
+CC?=cc
+CDEBUGFLAGS = -I${X11BASE}/include
PROGRAMS = client server

View File

@ -0,0 +1,14 @@
--- client.c Thu Aug 3 22:29:37 1995
+++ /home/andy/tmp/wrk/client.c Wed Dec 2 21:05:02 1998
@@ -5,7 +5,11 @@
#include <stdlib.h>
#include <netdb.h>
#include <stdio.h>
+#ifdef __FreeBSD__
+#include <stdlib.h>
+#else
#include <malloc.h>
+#endif
#include <string.h>
#include <unistd.h>
#include <signal.h>

View File

@ -0,0 +1,14 @@
--- creation.c Thu Aug 3 22:29:37 1995
+++ /home/andy/tmp/wrk/creation.c Wed Dec 2 21:02:24 1998
@@ -1,7 +1,11 @@
#include "creation.h"
#include "game.h"
+#ifdef __FreeBSD__
+#include <stdlib.h>
+#else
#include <malloc.h>
+#endif
void CreateUniverse(Univers *U, int NbNiveaux, int Taille)
{

View File

@ -0,0 +1,14 @@
--- messages.c Thu Aug 3 22:29:37 1995
+++ /home/andy/tmp/wrk/messages.c Wed Dec 2 21:03:17 1998
@@ -3,7 +3,11 @@
#include <sys/time.h>
#include <sys/resource.h>
#include <string.h>
+#ifdef __FreeBSD__
+#include <stdlib.h>
+#else
#include <malloc.h>
+#endif
#include <memory.h>
#include <sys/types.h>
#include <netinet/in.h>

View File

@ -0,0 +1,14 @@
--- server.c Thu Aug 3 22:29:37 1995
+++ /home/andy/tmp/wrk/server.c Wed Dec 2 21:04:18 1998
@@ -9,7 +9,11 @@
#include <math.h>
#include <memory.h>
#include <signal.h>
+#ifdef __FreeBSD__
+#include <limits.h>
+#else
#include <values.h>
+#endif
#include "messages.h"
#include "creation.h"

View File

@ -0,0 +1 @@
Simple multiplayer game for X Window System.

View File

@ -0,0 +1,9 @@
This game is played in a parallelepipede containing PxNxN little
cubes. You can first consider this 3D board as P 2D checkerboards of
NxN squares. From 2 up to 10 players can confront each other.
Each player begins with a certain number of pieces (or armies) that
he has to move and make attack. One of his pieces represents him-self
(or the chief, or the king, or anything you want). If this piece die,
the player is eliminated. The last player staying alive wins.
Messages can be sent to the other players , so that alliances can be
implemented. A special timer assures that the game remains dynamic.

11
games/antipolix/pkg-plist Normal file
View File

@ -0,0 +1,11 @@
bin/antipolix-client
bin/antipolix-server
share/doc/antipolix/ANTIPOLIX_RULES
share/doc/antipolix/CLIENT_USE
share/doc/antipolix/COPYRIGHT
share/doc/antipolix/SERVER_USE
share/examples/antipolix/dot.motd.sample
share/examples/antipolix/dot.players.sample
share/examples/antipolix/dot.server_defaults.sample
@dirrm share/doc/antipolix
@dirrm share/examples/antipolix