New Port: devel/as80

As80 is a lightweight 8080/8085 assembler for UN*X systems.

PR:		24235
Submitted by:	George Reid <greid@ukug.uk.freebsd.org>
This commit is contained in:
James E. Housley 2001-02-17 16:11:46 +00:00
parent a1bac9cb05
commit aad79f3e3f
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=38433
8 changed files with 71 additions and 0 deletions

View File

@ -16,6 +16,7 @@
SUBDIR += arm-aout-gcc295
SUBDIR += arm-elf-binutils
SUBDIR += arm-elf-gcc295
SUBDIR += as80
SUBDIR += asis
SUBDIR += asl
SUBDIR += astyle

26
devel/as80/Makefile Normal file
View File

@ -0,0 +1,26 @@
# New ports collection makefile for: as80
# Date created: 02 January 2001
# Whom: George Reid <greid@ukug.uk.freebsd.org>
#
# $FreeBSD$
#
PORTNAME= as80
PORTVERSION= 0.6.2
CATEGORIES= devel
MASTER_SITES= http://home.t-online.de/home/thomas.strathmann/files/
MAINTAINER= greid@ukug.uk.freebsd.org
WRKSRC= ${WRKDIR}/${PORTNAME}
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/as80 ${PREFIX}/bin
${INSTALL_PROGRAM} ${WRKSRC}/asm80 ${PREFIX}/bin
.if !defined(NOPORTDOCS)
${MKDIR} ${PREFIX}/share/doc/as80
${INSTALL_DATA} ${WRKSRC}/Manual.txt ${PREFIX}/share/doc/as80
${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/as80
.endif
.include <bsd.port.mk>

1
devel/as80/distinfo Normal file
View File

@ -0,0 +1 @@
MD5 (as80-0.6.2.tar.gz) = cc871391e460758806fd368948fa3158

11
devel/as80/files/patch-aa Normal file
View File

@ -0,0 +1,11 @@
--- Makefile.orig Thu Feb 15 10:54:44 2001
+++ Makefile Thu Feb 15 10:55:00 2001
@@ -1,6 +1,5 @@
-CC = gcc
-CFLAGS = -Wall -pedantic -ansi -O3 -fomit-frame-pointer
-PREFIX = /usr/local
+CC? = gcc
+CFLAGS += -Wall -pedantic -ansi
all: asm80 Manual.txt

View File

@ -0,0 +1,9 @@
--- asm80.c.orig Sun Jan 14 14:08:12 2001
+++ asm80.c Thu Feb 15 10:55:50 2001
@@ -23,7 +23,6 @@
#include <stdio.h>
#include <string.h>
#include <stdlib.h>
-#include <malloc.h>
#include "asm80.h"

1
devel/as80/pkg-comment Normal file
View File

@ -0,0 +1 @@
A lightweight 8080/8085 assembler for UN*X systems

17
devel/as80/pkg-descr Normal file
View File

@ -0,0 +1,17 @@
As80 is a lightweight 8080/8085 assembler for UN*X systems. It was
developed on a Debian GNU/Linux System and should well work on other
UN*Xes. As80 is not invoked directly but through a wrapper shell
script (asm) that handles some basic conversion (upper to lower etc.). So
be sure to use this instead of directly running as80 and getting lots of
(if you are lucky, meaningful) error messages.
Although As80 is still in a somewhat early phase of development, it
won't take much to come to one level with professional assemblers. The
use of the C preprocessor instead of implementing some of the
functionality (.EQU comes to mind) makes it easy to write assembler
source programs in a more flexible way. At least, that's what I think.
You are of course welcome to improve and/or add as you like, but be
sure to always obey the license terms.
- George Reid
greid@ukug.uk.freebsd.org

5
devel/as80/pkg-plist Normal file
View File

@ -0,0 +1,5 @@
bin/as80
bin/asm80
share/doc/as80/Manual.txt
share/doc/as80/README
@dirrm share/doc/as80