Removed some expired ports:

2014-05-12 archivers/star: Depends on deprecated smake
2014-05-12 editors/ved: Depends on deprecated smake
2014-04-12 japanese/chasen: Unmaintained since 2001
This commit is contained in:
Renato Botelho 2014-05-15 16:05:40 +00:00
parent 36d576ba9a
commit aac4808550
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=354150
19 changed files with 3 additions and 305 deletions

3
MOVED
View File

@ -6100,3 +6100,6 @@ java/linux-sun-jdk16||2014-05-11|Has expired: Unsupported and known for multiple
ports-mgmt/pver||2014-05-11|Has expired: does not support pkgng
databases/firebird20-client|databases/firebird25-client|2014-05-11|Firebird 2.0 is EOLed
databases/firebird20-server|databases/firebird25-server|2014-05-11|Firebird 2.0 is EOLed
archivers/star||2014-05-15|Has expired: Depends on deprecated smake
editors/ved||2014-05-15|Has expired: Depends on deprecated smake
japanese/chasen||2014-05-15|Has expired: Unmaintained since 2001

View File

@ -182,7 +182,6 @@
SUBDIR += snappy-java
SUBDIR += squeeze
SUBDIR += squsq
SUBDIR += star
SUBDIR += stuffit
SUBDIR += szip
SUBDIR += tardy

View File

@ -1,76 +0,0 @@
# Created by: Andreas Klemm <andreas@klemm.gtn.com>
# $FreeBSD$
PORTNAME= star
DISTVERSION= 1.5.2
CATEGORIES= archivers
MASTER_SITES= ftp://ftp.berlios.de/pub/star/
MAINTAINER= ports@FreeBSD.org
COMMENT= Unique standard tape archiver with many enhancements
DEPRECATED= Depends on deprecated smake
EXPIRATION_DATE= 2014-05-12
BUILD_DEPENDS= smake:${PORTSDIR}/devel/smake
NO_STAGE= yes
USE_BZIP2= yes
USES= gettext iconv
.if !defined(NO_INSTALL_MANPAGES)
MAN1= scpio.1 spax.1 srmt.1 star.1 suntar.1 tartest.1
MAN5= star.5
MLINKS= star.1 ustar.1 star.5 ustar.5
.else
XMKFLAGS= XMK_FILE=""
.endif
MAKEFLAGS+= MANBASE=
MAKE_ENV+= MAKEFLAGS=${MAKEFLAGS}
PORTDOCS= README README.crash README.mtio README.pattern STARvsGNUTAR \
README.ACL README.largefiles README.otherbugs \
README.posix-2001
OPTIONS_DEFINE= DOCS
.include <bsd.port.options.mk>
post-patch:
@${FIND} ${WRKSRC} -type f -print \
| ${XARGS} ${REINPLACE_CMD} -e "s@/etc/default@${PREFIX}/etc@g"
@${MV} ${WRKSRC}/rmt/rmt.1 ${WRKSRC}/rmt/srmt.1
do-build:
cd ${WRKSRC} && ${MAKE_ENV} smake
cd ${WRKSRC}/star && ${MAKE_ENV} smake -f Makefile.doc
do-install:
cd ${WRKSRC}/star && ${MAKE_ENV} smake \
${INSTALL_TARGET} INS_BASE=${PREFIX} ${XMKFLAGS}
cd ${WRKSRC}/rmt && ${MAKE_ENV} smake \
${INSTALL_TARGET} INS_BASE=${PREFIX} ${XMKFLAGS}
cd ${WRKSRC}/tartest && ${MAKE_ENV} smake \
${INSTALL_TARGET} INS_BASE=${PREFIX} ${XMKFLAGS}
@${STRIP_CMD} ${PREFIX}/bin/star
@${STRIP_CMD} ${PREFIX}/sbin/srmt
@${STRIP_CMD} ${PREFIX}/bin/tartest
@${INSTALL_DATA} ${WRKSRC}/star/star.dfl ${PREFIX}/etc/star.sample
@if [ ! -f ${PREFIX}/etc/star ]; then \
${CP} -p ${PREFIX}/etc/star.sample ${PREFIX}/etc/star; \
fi
@${INSTALL_DATA} ${WRKSRC}/rmt/rmt.dfl ${PREFIX}/etc/rmt.sample
@if [ ! -f ${PREFIX}/etc/rmt ]; then \
${CP} -p ${PREFIX}/etc/rmt.sample ${PREFIX}/etc/rmt; \
fi
post-install:
.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
.for FILE in ${PORTDOCS}
@${INSTALL_DATA} ${WRKSRC}/star/${FILE} ${DOCSDIR}/${FILE}
.endfor
.endif
.include <bsd.port.mk>

View File

@ -1,2 +0,0 @@
SHA256 (star-1.5.2.tar.bz2) = 762645b98af13bb9b0512812814ec8e90635d1400c94eb5911e9774daed2addf
SIZE (star-1.5.2.tar.bz2) = 874558

View File

@ -1,21 +0,0 @@
$FreeBSD$
--- rmt/Makefile.orig
+++ rmt/Makefile
@@ -6,13 +6,13 @@
###########################################################################
INSDIR= sbin
-TARGET= rmt
+TARGET= srmt
CPPOPTS += -DUSE_REMOTE
CPPOPTS += -DUSE_LARGEFILES
CFILES= rmt.c
#HFILES=
LIBS= -ldeflt -lschily $(LIB_SOCKET)
-XMK_FILE= Makefile.man Makefile.dfl Makefile.doc
+XMK_FILE= Makefile.man
###########################################################################
include $(SRCROOT)/$(RULESDIR)/rules.cmd

View File

@ -1,18 +0,0 @@
$FreeBSD$
--- rmt/Makefile.man.orig
+++ rmt/Makefile.man
@@ -8,10 +8,10 @@
###########################################################################
MANDIR= man
-TARGETMAN= rmt
+TARGETMAN= srmt
MANSECT= $(MANSECT_CMD)
MANSUFFIX= $(MANSUFF_CMD)
-MANFILE= rmt.1
+MANFILE= srmt.1
###########################################################################
include $(SRCROOT)/$(RULESDIR)/rules.man

View File

@ -1,22 +0,0 @@
--- star/Makefile.orig 2010-05-13 13:47:27.000000000 -0600
+++ star/Makefile 2013-01-22 08:50:22.000000000 -0700
@@ -15,7 +15,7 @@
INSDIR= bin
TARGET= star
#SYMLINKS= ustar tar
-SYMLINKS= ustar tar gnutar suntar scpio spax
+SYMLINKS= ustar suntar scpio spax
CPPOPTS += -D__STAR__
CPPOPTS += -DSET_CTIME -DFIFO -DUSE_MMAP -DUSE_REMOTE -DUSE_RCMD_RSH
#CPPOPTS += -DSET_CTIME -DFIFO -DUSE_MMAP
@@ -52,8 +52,8 @@
#
# Wenn -lfind, dann auch $(LIB_INTL)
#
-XMK_FILE= Makefile.man ustarman.mk starformatman.mk scpioman.mk gnutarman.mk \
- spaxman.mk suntarman.mk Makefile.dfl Makefile.doc
+XMK_FILE= Makefile.man starformatman.mk scpioman.mk \
+ spaxman.mk suntarman.mk
star_fat.c: star.c
$(RM) $(RM_FORCE) $@; cp star.c $@

View File

@ -1,17 +0,0 @@
--- star/star.1.orig Thu Nov 24 21:05:10 2005
+++ star/star.1 Thu Nov 24 21:06:26 2005
@@ -32,14 +32,6 @@
.I file1 .\|.\|. filen
[\fIfind_expr\fP]
.br
-.ie n .B "tar\ \ "
-.el .B "tar\ \ \ "
-.I command
-[\fIoptions\fP]
-.ie n .B "\ \ \ \ \ \ \ "
-.el .B "\ \ \ \ \ \ \ \ \ "
-.I file1 .\|.\|. filen
-.br
.B "star\ "
.ie n .B "\-copy\ \ "
.el .B "\-copy\ \ \ \ "

View File

@ -1,19 +0,0 @@
Star is the fastest known implementation of a tar archiver.
Main advantages over other tar implementations:
fifo - Keeps the tape streaming.
pattern matcher - For a convenient user interface.
sophisticated diff - User tailorable interface for comparing tar
archives against file trees.
no namelen limitation - Pathnames up to 1024 Bytes may be archived.
deals with all 3 times - Stores/restores all 3 times of a file.
does not clobber files - More recent copies on disk will not be
clobbered from tape.
automatic byte swap - star automatically detects swapped archives.
automatic format detect - Automatically detects archive formats:
old tar, gnu tar, ansi tar, star.
fully ansi compatible - star is fully ANSI/Posix 1003.1 compatible.
Please mail bugs and suggestions to:
Author: Joerg Schilling <js@cs.tu-berlin.de>
WWW: http://cdrecord.berlios.de/old/private/star.html

View File

@ -1,13 +0,0 @@
bin/scpio
bin/spax
bin/star
bin/suntar
bin/tartest
bin/ustar
sbin/srmt
@unexec if cmp -s %D/etc/rmt %D/etc/rmt.sample; then rm -f %D/etc/rmt; fi
etc/rmt.sample
@exec [ -f %B/rmt ] || cp %B/%f %B/rmt
@unexec if cmp -s %D/etc/star %D/etc/star.sample; then rm -f %D/etc/star; fi
etc/star.sample
@exec [ -f %B/star ] || cp %B/%f %B/star

View File

@ -271,7 +271,6 @@
SUBDIR += tweak
SUBDIR += uemacs
SUBDIR += uzap
SUBDIR += ved
SUBDIR += vigor
SUBDIR += vile
SUBDIR += vim

View File

@ -1,53 +0,0 @@
# Created by: George Reid <greid@ukug.uk.freebsd.org>
# $FreeBSD$
PORTNAME= ved
PORTVERSION= 1.7
PORTREVISION= 1
CATEGORIES= editors
MASTER_SITES= ftp://ftp.berlios.de/pub/ved/
MAINTAINER= ports@FreeBSD.org
COMMENT= A small and fast screen-oriented editor
DEPRECATED= Depends on deprecated smake
EXPIRATION_DATE= 2014-05-12
BUILD_DEPENDS= smake:${PORTSDIR}/devel/smake
MAN1= ved.1
PLIST_FILES= bin/ved %%DATADIR%%/ved.help
PLIST_DIRS= %%DATADIR%%
NO_STAGE= yes
.include <bsd.port.pre.mk>
.if ${ARCH} == "ia64" || ${ARCH} == "powerpc" || ${ARCH} == "sparc64"
BROKEN= Does not compile on ia64, powerpc, or sparc64
.endif
post-patch:
${REINPLACE_CMD} -e 's|^COPTOPT=.*$$|COPTOPT= ${CFLAGS}|g ; \
s| gcc| ${CC}|g' ${WRKSRC}/RULES/i386-freebsd-cc.rul
${REINPLACE_CMD} -e 's|fexecve|fexecve_ved|g' ${WRKSRC}/include/schily.h
${REINPLACE_CMD} -e 's|fexecve|fexecve_ved|g' ${WRKSRC}/libschily/fexec.c
.for file in ved.h ved.1
${REINPLACE_CMD} -e 's|%%DATADIR%%|${DATADIR}|g' ${WRKSRC}/ved/${file}
.endfor
.for arch in alpha amd64 ia64 sparc64
cd ${WRKSRC}/RULES \
&& ${LN} -sf i386-freebsd-cc.rul ${arch}-freebsd-cc.rul
.endfor
do-build:
(cd ${WRKSRC} && smake)
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/ved/OBJ/${ARCH}-freebsd-cc/ved \
${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/ved/ved.1 ${MANPREFIX}/man/man1
@${MKDIR} ${DATADIR}
${INSTALL_DATA} ${WRKSRC}/ved/ved.help ${DATADIR}
.include <bsd.port.post.mk>

View File

@ -1,2 +0,0 @@
SHA256 (ved-1.7.tar.gz) = ed1a5722bf788d5bd0e77a5a82f1d36d73c06384e954a5028e92591fefc378c9
SIZE (ved-1.7.tar.gz) = 512815

View File

@ -1,11 +0,0 @@
--- ved/ved.h.orig Sat Mar 13 06:33:40 2004
+++ ved/ved.h Wed Dec 15 02:17:42 2004
@@ -134,7 +134,7 @@
# define HELPFILE UC "/doc/cmds/ved.help"
#else
# define DEFSHELL "/bin/sh"
-# define HELPFILE UC "/opt/schily/man/help/ved.help"
+# define HELPFILE UC "%%DATADIR%%/ved.help"
#endif
/*

View File

@ -1,20 +0,0 @@
--- ved/ved.1.orig Sun Dec 31 18:53:00 2000
+++ ved/ved.1 Sun Dec 31 18:54:13 2000
@@ -2614,15 +2614,8 @@
.B ved
shell command execute buffer.
.TP
-.B .../man/help/ved.help
-The on-line help file is assumed to be in the same
-directory tree as the
-.B ved
-binary.
-
-.SH "SEE ALSO"
-.BR change "(1),"
-.BR match "(1)."
+.B %%DATADIR%%/ved.help
+The on-line help file is installed in %%DATADIR%%
.SH NOTES
To edit files greater than 2 GB, you need to compile
.B ved

View File

@ -1,4 +0,0 @@
Ved (visual editor) is a small and very fast screen-oriented editor
that implements a user interface somewhere between vi and Emacs. It is
powerful and easy to learn, and has no limitations on line length,
file size, or the types of characters that may appear in a file.

View File

@ -32,7 +32,6 @@
SUBDIR += cannadic
SUBDIR += cdrom2
SUBDIR += celrw
SUBDIR += chasen
SUBDIR += chasen-base
SUBDIR += cmigemo
SUBDIR += cmigemo-dict

View File

@ -1,23 +0,0 @@
# Created by: kuriyama
# $FreeBSD$
PORTNAME= chasen
PORTVERSION= 2.4.5
CATEGORIES= japanese textproc
MASTER_SITES= # empty
DISTFILES= # empty
EXTRACT_ONLY= # empty
MAINTAINER= ports@FreeBSD.org
COMMENT= Japanese Morphological Analysis System
RUN_DEPENDS= chasen:${PORTSDIR}/japanese/chasen-base \
${LOCALBASE}/share/chasen/dic/ipadic/cforms.cha:${PORTSDIR}/japanese/ipadic
DEPRECATED= Unmaintained since 2001
EXPIRATION_DATE= 2014-04-12
NO_BUILD= YES
do-install:
.include <bsd.port.mk>

View File

@ -1 +0,0 @@
Japanese Morphological Analysis System