lang/quickjs: fix build on GCC architectures

Don't use Clang if we need to use GCC

PR:		251030
Approved by:	yuri (maintainer timeout)
MFH:		2020Q4 (fix build blanket)
This commit is contained in:
Piotr Kubaj 2020-11-25 17:49:35 +00:00
parent 16f2119df1
commit aa99f2904c
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=556299
3 changed files with 48 additions and 2 deletions

View File

@ -11,6 +11,16 @@ COMMENT= Embeddable Javascript interpreter in C
LICENSE= MIT
USES= gmake tar:xz
USES= compiler:c11 gmake tar:xz
.include <bsd.port.mk>
EXTRA_PATCHES= ${FILESDIR}/extra-${CHOSEN_COMPILER_TYPE}-patch-Makefile
.include <bsd.port.pre.mk>
.if ${CHOSEN_COMPILER_TYPE} == gcc
post-patch:
@${REINPLACE_CMD} -e 's/%%GCC_DEFAULT%%/${GCC_DEFAULT}/' \
${WRKSRC}/Makefile
.endif
.include <bsd.port.post.mk>

View File

@ -0,0 +1,36 @@
--- Makefile.orig 2020-09-06 09:31:51 UTC
+++ Makefile
@@ -25,6 +25,9 @@
ifeq ($(shell uname -s),Darwin)
CONFIG_DARWIN=y
endif
+ifeq ($(shell uname -s),FreeBSD)
+CONFIG_FREEBSD=y
+endif
# Windows cross compilation from Linux
#CONFIG_WIN32=y
# use link time optimization (smaller and faster executables but slower build)
@@ -39,6 +42,12 @@ ifdef CONFIG_DARWIN
CONFIG_CLANG=y
CONFIG_DEFAULT_AR=y
endif
+ifdef CONFIG_FREEBSD
+# use clang instead of gcc
+CONFIG_CLANG=
+CONFIG_DEFAULT_AR=y
+CONFIG_LTO=
+endif
# installation directory
prefix=/usr/local
@@ -81,8 +90,8 @@ ifdef CONFIG_CLANG
endif
endif
else
- HOST_CC=gcc
- CC=$(CROSS_PREFIX)gcc
+ HOST_CC=gcc%%GCC_DEFAULT%%
+ CC=$(CROSS_PREFIX)gcc%%GCC_DEFAULT%%
CFLAGS=-g -Wall -MMD -MF $(OBJDIR)/$(@F).d
CFLAGS += -Wno-array-bounds -Wno-format-truncation
ifdef CONFIG_LTO