Separate 2.0 version of haproxy into it's own port,
haproxy will track 2.1 branch now.
This commit is contained in:
parent
37a49a023d
commit
aa98590043
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=543441
@ -234,6 +234,7 @@
|
||||
SUBDIR += haproxy17
|
||||
SUBDIR += haproxy18
|
||||
SUBDIR += haproxy19
|
||||
SUBDIR += haproxy20
|
||||
SUBDIR += haproxy21
|
||||
SUBDIR += hblock
|
||||
SUBDIR += hexinject
|
||||
|
64
net/haproxy20/Makefile
Normal file
64
net/haproxy20/Makefile
Normal file
@ -0,0 +1,64 @@
|
||||
# Created by: Hugo Saro <hugo@barafranca.com>
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= haproxy
|
||||
DISTVERSION= 2.0.14
|
||||
CATEGORIES= net www
|
||||
PKGNAMESUFFIX= 20
|
||||
MASTER_SITES= http://www.haproxy.org/download/2.0/src/
|
||||
|
||||
MAINTAINER= demon@FreeBSD.org
|
||||
COMMENT= Reliable, high performance TCP/HTTP load balancer
|
||||
|
||||
LICENSE= GPLv2 LGPL21
|
||||
LICENSE_COMB= multi
|
||||
|
||||
CONFLICTS_INSTALL= haproxy-devel-[0-9]* haproxy17-[0-9]* haproxy18-[0-9]* haproxy19-[0-9]* haproxy21-[0-9]*
|
||||
|
||||
USES= compiler:c++11-lang cpe gmake
|
||||
USE_RC_SUBR= haproxy
|
||||
|
||||
MAKE_ARGS= TARGET=freebsd DEFINE=-DFREEBSD_PORTS USE_GETADDRINFO=1 \
|
||||
USE_ZLIB=1 USE_CPU_AFFINITY=1 USE_ACCEPT4=1 \
|
||||
CC="${CC}" DEBUG_CFLAGS="" CPU_CFLAGS="${CFLAGS}"
|
||||
|
||||
OPTIONS_DEFINE= DOCS EXAMPLES LUA OPENSSL DEVICEATLAS PROMEX
|
||||
OPTIONS_RADIO= PCRE
|
||||
OPTIONS_RADIO_PCRE= DPCRE SPCRE
|
||||
DPCRE_DESC= Link dynamically
|
||||
SPCRE_DESC= Link statically
|
||||
DEVICEATLAS_DESC= DeviceAtlas Device Detection support
|
||||
PROMEX_DESC= Enable Prometheus exporter
|
||||
OPTIONS_DEFAULT= SPCRE OPENSSL
|
||||
|
||||
DPCRE_LIB_DEPENDS= libpcre.so:devel/pcre
|
||||
DPCRE_MAKE_ARGS= USE_PCRE=1 USE_PCRE_JIT=1
|
||||
SPCRE_LIB_DEPENDS= libpcre.so:devel/pcre
|
||||
SPCRE_MAKE_ARGS= USE_PCRE=1 USE_STATIC_PCRE=1 USE_PCRE_JIT=1
|
||||
DEVICEATLAS_LIB_DEPENDS= libda.so:net/deviceatlas-enterprise-c
|
||||
DEVICEATLAS_MAKE_ARGS= USE_DEVICEATLAS=1 DEVICEATLAS_LIB=${LOCALBASE}/lib DEVICEATLAS_INC=${LOCALBASE}/include
|
||||
PROMEX_MAKE_ARGS= EXTRA_OBJS="contrib/prometheus-exporter/service-prometheus.o"
|
||||
OPENSSL_USES= ssl
|
||||
OPENSSL_MAKE_ARGS= USE_OPENSSL=1 SSL_LIB=${OPENSSLLIB} SSL_INC=${OPENSSLINC}
|
||||
LUA_USES= lua:53
|
||||
LUA_MAKE_ARGS= USE_LUA=1 LUA_INC=${LUA_INCDIR} LUA_LIB=${LUA_LIBDIR} LUA_LIB_NAME=lua-${LUA_VER}
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${ARCH} == "amd64" || ${ARCH} == "i386"
|
||||
MAKE_ARGS+= USE_REGPARM=1
|
||||
.endif
|
||||
|
||||
post-build:
|
||||
cd ${WRKSRC}/contrib/halog && ${MAKE_CMD} ${MAKE_ENV}
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/haproxy ${STAGEDIR}${PREFIX}/sbin/
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/contrib/halog/halog ${STAGEDIR}${PREFIX}/sbin/
|
||||
${INSTALL_MAN} ${WRKSRC}/doc/haproxy.1 ${STAGEDIR}${MAN1PREFIX}/man/man1
|
||||
${MKDIR} ${STAGEDIR}${DOCSDIR}
|
||||
(cd ${WRKSRC}/doc/ && ${COPYTREE_SHARE} \* ${STAGEDIR}${DOCSDIR})
|
||||
${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
|
||||
(cd ${WRKSRC}/examples/ && ${COPYTREE_SHARE} \* ${STAGEDIR}${EXAMPLESDIR})
|
||||
|
||||
.include <bsd.port.post.mk>
|
3
net/haproxy20/distinfo
Normal file
3
net/haproxy20/distinfo
Normal file
@ -0,0 +1,3 @@
|
||||
TIMESTAMP = 1585832617
|
||||
SHA256 (haproxy-2.0.14.tar.gz) = 552a708b8b6efd0f241f5d9fd7ad4168d37ce17cdb6dcb6239c2e519f0a63c75
|
||||
SIZE (haproxy-2.0.14.tar.gz) = 2651320
|
133
net/haproxy20/files/haproxy.in
Normal file
133
net/haproxy20/files/haproxy.in
Normal file
@ -0,0 +1,133 @@
|
||||
#!/bin/sh
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
# PROVIDE: haproxy
|
||||
# REQUIRE: DAEMON LOGIN
|
||||
# KEYWORD: shutdown
|
||||
|
||||
#
|
||||
# Add the following lines to /etc/rc.conf to enable haproxy:
|
||||
#
|
||||
# haproxy_enable (bool): default: "NO"
|
||||
# Set to "YES" to enable haproxy
|
||||
# haproxy_pidfile (str): default: /var/run/haproxy.pid
|
||||
# Set to the full path of the pid file
|
||||
# haproxy_config (str): default: %%PREFIX%%/etc/haproxy.conf
|
||||
# Set to the full path of the config file
|
||||
# haproxy_flags (str): default: Autogenerated using pidfile and config options
|
||||
# Set to override with your own options
|
||||
# haproxy_profiles (str): default: empty
|
||||
# Set to space-separated list of profiles: for each profile separate haproxy
|
||||
# process will be spawned, with haproxy-${profile}.conf config file.
|
||||
# You can override default pidfile and config file for each profile with
|
||||
# haproxy_${profile}_config and haproxy_${profile}_pidfile.
|
||||
|
||||
. /etc/rc.subr
|
||||
|
||||
name="haproxy"
|
||||
rcvar=haproxy_enable
|
||||
command="%%PREFIX%%/sbin/haproxy"
|
||||
extra_commands="reload configtest hardstop hardreload softreload"
|
||||
reload_cmd="haproxy_reload"
|
||||
hardreload_cmd="haproxy_reload"
|
||||
hardreload_precmd="def_hardreload_option"
|
||||
softreload_cmd="haproxy_reload"
|
||||
softreload_precmd="def_softreload_option"
|
||||
stop_cmd="haproxy_stop"
|
||||
hardstop_cmd="haproxy_stop"
|
||||
hardstop_precmd="def_hardstop_signal"
|
||||
|
||||
: ${haproxy_enable:="NO"}
|
||||
: ${haproxy_config:="%%PREFIX%%/etc/${name}.conf"}
|
||||
: ${haproxy_socket:="/var/run/${name}/socket"}
|
||||
pidfile=${haproxy_pidfile:-"/var/run/haproxy.pid"}
|
||||
|
||||
def_hardreload_option()
|
||||
{
|
||||
reload_opt="-st"
|
||||
}
|
||||
|
||||
def_softreload_option()
|
||||
{
|
||||
reload_opt="-x ${haproxy_socket} -sf"
|
||||
}
|
||||
|
||||
def_hardstop_signal()
|
||||
{
|
||||
sig_stop="TERM"
|
||||
}
|
||||
|
||||
load_rc_config $name
|
||||
|
||||
is_valid_profile() {
|
||||
local profile
|
||||
for profile in $haproxy_profiles; do
|
||||
if [ "$profile" = "$1" ]; then
|
||||
return 0
|
||||
fi
|
||||
done
|
||||
return 1
|
||||
}
|
||||
|
||||
if [ -n "$2" ]; then
|
||||
profile=$2
|
||||
if ! is_valid_profile $profile; then
|
||||
echo "$0: no such profile ($profile) defined in ${name}_profiles."
|
||||
exit 1
|
||||
fi
|
||||
eval haproxy_config="\${haproxy_${profile}_config:-%%PREFIX%%/etc/haproxy-${profile}.conf}"
|
||||
eval pidfile="\${haproxy_${profile}_pidfile:-/var/run/haproxy-${profile}.pid}"
|
||||
else
|
||||
if [ "x${haproxy_profiles}" != "x" -a "x$1" != "x" ]; then
|
||||
for profile in ${haproxy_profiles}; do
|
||||
echo "===> ${name} profile: ${profile}"
|
||||
%%PREFIX%%/etc/rc.d/haproxy $1 ${profile}
|
||||
retcode="$?"
|
||||
if [ ${retcode} -ne 0 ]; then
|
||||
failed="${profile} (${retcode}) ${failed:-}"
|
||||
else
|
||||
success="${profile} ${success:-}"
|
||||
fi
|
||||
done
|
||||
exit 0
|
||||
fi
|
||||
fi
|
||||
|
||||
: ${haproxy_flags:="-q -f ${haproxy_config} -p ${pidfile}"}
|
||||
configtest_cmd="$command -c -f $haproxy_config"
|
||||
start_precmd="$command -q -c -f $haproxy_config"
|
||||
required_files=$haproxy_config
|
||||
sig_stop=SIGUSR1
|
||||
reload_opt="-sf"
|
||||
|
||||
haproxy_reload()
|
||||
{
|
||||
${command} -q -c -f ${haproxy_config}
|
||||
if [ $? -ne 0 ]; then
|
||||
err 1 "Error found in ${haproxy_config} - not reloading current process!"
|
||||
fi
|
||||
rc_pid=$(check_pidfile ${pidfile} ${command})
|
||||
if [ $rc_pid ]; then
|
||||
${command} ${haproxy_flags} $reload_opt $(cat ${pidfile})
|
||||
else
|
||||
_run_rc_notrunning
|
||||
return 1
|
||||
fi
|
||||
}
|
||||
|
||||
haproxy_stop()
|
||||
{
|
||||
rc_pid=$(check_pidfile ${pidfile} ${command})
|
||||
if [ $rc_pid ]; then
|
||||
rc_pid=$(cat ${pidfile})
|
||||
kill -$sig_stop $rc_pid
|
||||
wait_for_pids $rc_pid
|
||||
else
|
||||
_run_rc_notrunning
|
||||
return 1
|
||||
fi
|
||||
}
|
||||
|
||||
run_rc_command "$1"
|
11
net/haproxy20/files/patch-include-common-hathreads.h
Normal file
11
net/haproxy20/files/patch-include-common-hathreads.h
Normal file
@ -0,0 +1,11 @@
|
||||
--- include/common/hathreads.h.orig 2018-02-17 18:17:22.219400000 +0000
|
||||
+++ include/common/hathreads.h 2018-02-17 18:18:44.598422000 +0000
|
||||
@@ -104,7 +104,7 @@ extern THREAD_LOCAL unsigned long tid_bit; /* The bit
|
||||
/* TODO: thread: For now, we rely on GCC builtins but it could be a good idea to
|
||||
* have a header file regrouping all functions dealing with threads. */
|
||||
|
||||
-#if defined(__GNUC__) && (__GNUC__ < 4 || __GNUC__ == 4 && __GNUC_MINOR__ < 7) && !defined(__clang__)
|
||||
+#if (defined(__GNUC__) && (__GNUC__ < 4 || __GNUC__ == 4 && __GNUC_MINOR__ < 7) && !defined(__clang__)) || (defined(__clang__) && defined(__i386__))
|
||||
/* gcc < 4.7 */
|
||||
|
||||
#define HA_ATOMIC_ADD(val, i) __sync_add_and_fetch(val, i)
|
6
net/haproxy20/pkg-descr
Normal file
6
net/haproxy20/pkg-descr
Normal file
@ -0,0 +1,6 @@
|
||||
HAProxy is a free, very fast and reliable solution offering high
|
||||
availability, load balancing, and proxying for TCP and HTTP-based
|
||||
applications. It is particularly suited for web sites crawling under
|
||||
very high loads while needing persistence or Layer7 processing.
|
||||
|
||||
WWW: http://www.haproxy.org
|
95
net/haproxy20/pkg-plist
Normal file
95
net/haproxy20/pkg-plist
Normal file
@ -0,0 +1,95 @@
|
||||
man/man1/haproxy.1.gz
|
||||
sbin/halog
|
||||
sbin/haproxy
|
||||
%%PORTDOCS%%%%DOCSDIR%%/51Degrees-device-detection.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/DeviceAtlas-device-detection.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/SOCKS4.protocol.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/SPOE.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/WURFL-device-detection.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/acl.fig
|
||||
%%PORTDOCS%%%%DOCSDIR%%/architecture.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/close-options.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/coding-style.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/configuration.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/cookie-options.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/design-thoughts/backends-v0.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/design-thoughts/backends.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/design-thoughts/be-fe-changes.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/design-thoughts/binding-possibilities.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/design-thoughts/config-language.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/design-thoughts/connection-reuse.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/design-thoughts/connection-sharing.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/design-thoughts/dynamic-buffers.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/design-thoughts/entities-v2.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/design-thoughts/how-it-works.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/design-thoughts/http2.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/design-thoughts/http_load_time.url
|
||||
%%PORTDOCS%%%%DOCSDIR%%/design-thoughts/rate-shaping.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/design-thoughts/sess_par_sec.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/gpl.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/haproxy.1
|
||||
%%PORTDOCS%%%%DOCSDIR%%/internals/acl.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/internals/body-parsing.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/internals/buffer-api.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/internals/connect-status.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/internals/connection-header.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/internals/connection-scale.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/internals/entities-v2.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/internals/entities.fig
|
||||
%%PORTDOCS%%%%DOCSDIR%%/internals/entities.pdf
|
||||
%%PORTDOCS%%%%DOCSDIR%%/internals/entities.svg
|
||||
%%PORTDOCS%%%%DOCSDIR%%/internals/entities.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/internals/filters.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/internals/hashing.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/internals/header-parser-speed.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/internals/header-tree.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/internals/http-cookies.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/internals/http-docs.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/internals/http-parsing.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/internals/list.fig
|
||||
%%PORTDOCS%%%%DOCSDIR%%/internals/listener-states.fig
|
||||
%%PORTDOCS%%%%DOCSDIR%%/internals/listener-states.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/internals/lua_socket.fig
|
||||
%%PORTDOCS%%%%DOCSDIR%%/internals/lua_socket.pdf
|
||||
%%PORTDOCS%%%%DOCSDIR%%/internals/naming.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/internals/notes-layers.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/internals/pattern.dia
|
||||
%%PORTDOCS%%%%DOCSDIR%%/internals/pattern.pdf
|
||||
%%PORTDOCS%%%%DOCSDIR%%/internals/polling-states.fig
|
||||
%%PORTDOCS%%%%DOCSDIR%%/internals/repartition-be-fe-fi.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/internals/sequence.fig
|
||||
%%PORTDOCS%%%%DOCSDIR%%/internals/stats-v2.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/internals/stream-sock-states.fig
|
||||
%%PORTDOCS%%%%DOCSDIR%%/intro.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/lgpl.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/linux-syn-cookies.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/lua-api/Makefile
|
||||
%%PORTDOCS%%%%DOCSDIR%%/lua-api/_static/channel.fig
|
||||
%%PORTDOCS%%%%DOCSDIR%%/lua-api/_static/channel.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/lua-api/conf.py
|
||||
%%PORTDOCS%%%%DOCSDIR%%/lua-api/index.rst
|
||||
%%PORTDOCS%%%%DOCSDIR%%/lua.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/management.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/netscaler-client-ip-insertion-protocol.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/network-namespaces.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/peers.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/peers-v2.0.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/proxy-protocol.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/queuing.fig
|
||||
%%PORTDOCS%%%%DOCSDIR%%/regression-testing.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/seamless_reload.txt
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/acl-content-sw.cfg
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/content-sw-sample.cfg
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/errorfiles/400.http
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/errorfiles/403.http
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/errorfiles/408.http
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/errorfiles/500.http
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/errorfiles/502.http
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/errorfiles/503.http
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/errorfiles/504.http
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/errorfiles/README
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/haproxy.init
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/option-http_proxy.cfg
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/socks4.cfg
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/transparent_proxy.cfg
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/wurfl-example.cfg
|
Loading…
Reference in New Issue
Block a user