Remove patches that added an autotools based build system and instead use

do-build and do-install targets
This commit is contained in:
Tijl Coosemans 2014-09-25 14:26:52 +00:00
parent 91294e8e77
commit aa665fcc57
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=369258
8 changed files with 17 additions and 73 deletions

View File

@ -3,7 +3,7 @@
PORTNAME= dico
PORTVERSION= 1.1
PORTREVISION= 7
PORTREVISION= 8
CATEGORIES= french
MASTER_SITES= ftp://ftp.supelec.fr/lsi/pub/security/
DISTNAME= le_dico
@ -13,30 +13,27 @@ COMMENT= Interactive dictionary in french
BROKEN_WWW= http://www.montefiore.ulg.ac.be/cgi-bin-ulg/DICO.html
# Global variables
#
WRKSRC= ${WRKDIR}/${PORTNAME}
USE_AUTOTOOLS= automake14 autoconf
CONFIGURE_ARGS= --mandir=${PREFIX}/man
USES= gmake
AUTOMAKE_ARGS= --add-missing --foreign --include-deps
MAKE_ARGS= prefix=${PREFIX}
REINPLACE_SUB= PREFIX=${PREFIX}
# Post-patch
#
OPTIONS_DEFINE= DOCS
do-build:
(cd ${WRKSRC}/sources && ${CC} ${CFLAGS} ${LDFLAGS} -o dico dico.c)
do-install:
${MKDIR} ${STAGEDIR}${PREFIX}/bin
${INSTALL_PROGRAM} ${WRKSRC}/sources/dico ${STAGEDIR}${PREFIX}/bin
${MKDIR} ${STAGEDIR}${DATADIR}
${INSTALL_DATA} ${WRKSRC}/lexique/*.dic ${STAGEDIR}${DATADIR}
${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README.TXT ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/manuel/copying.doc ${STAGEDIR}${DOCSDIR}
${MKDIR} ${STAGEDIR}${MAN1PREFIX}/man/man1
${INSTALL_MAN} ${WRKSRC}/manuel/dico.1 ${STAGEDIR}${MAN1PREFIX}/man/man1
post-patch:
@${REINPLACE_CMD} ${REINPLACE_SUB:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} \
@${REINPLACE_CMD} 's,/usr/local,${PREFIX},' \
${WRKSRC}/README.TXT ${WRKSRC}/manuel/dico.1 \
${WRKSRC}/sources/dico.c
# Pre-configure
#
pre-configure:
@cd ${WRKSRC} && ${ACLOCAL}
.include <bsd.port.mk>

View File

@ -1,7 +0,0 @@
--- /dev/null Thu Jan 1 01:00:00 1970
+++ Makefile.am Wed Oct 11 03:49:06 2000
@@ -0,0 +1,4 @@
+docdir = $(datadir)/doc/dico
+doc_DATA = README.TXT
+
+SUBDIRS = sources lexique manuel

View File

@ -1,7 +0,0 @@
--- /dev/null Thu Jan 1 01:00:00 1970
+++ configure.in Wed Oct 11 04:19:05 2000
@@ -0,0 +1,4 @@
+AC_INIT(sources/dico.c)
+AM_INIT_AUTOMAKE(dico, 1.1)
+AC_PROG_CC
+AC_OUTPUT([Makefile sources/Makefile lexique/Makefile manuel/Makefile])

View File

@ -1,7 +0,0 @@
--- /dev/null Thu Jan 1 01:00:00 1970
+++ lexique/Makefile.am Wed Oct 11 04:40:58 2000
@@ -0,0 +1,4 @@
+pkgdata_DATA = a.dic b.dic c.dic d.dic e.dic f.dic g.dic h.dic \
+ i.dic j.dic k.dic l.dic m.dic n.dic o.dic p.dic \
+ q.dic r.dic s.dic t.dic u.dic v.dic w.dic x.dic \
+ y.dic z.dic version.dic

View File

@ -1,9 +0,0 @@
--- old/lexique/version.dic Thu Jan 1 01:00:00 1970
+++ new/lexique/version.dic Wed Oct 11 04:40:35 2000
@@ -0,0 +1,6 @@
+Derniere mise a jour: 21 Octobre 1992
+Realisee par : Rene Cougnenc
+Jeu de caracteres : ISO 8859-1 ( 8 bits Latin-1)
+
+ 94836 mots
++ 39072 communes de France

View File

@ -1,10 +0,0 @@
--- /dev/null Thu Jan 1 01:00:00 1970
+++ manuel/Makefile.am Wed Oct 11 03:46:58 2000
@@ -0,0 +1,7 @@
+docdir = $(datadir)/doc/dico
+doc_DATA = copying.doc
+
+man_MANS = dico.1
+
+EXTRA_DISTS = install.doc.msdos manuel.txt msdos.doc readme.txt.msdos \
+ unix.doc

View File

@ -1,4 +0,0 @@
--- /dev/null Thu Jan 1 01:00:00 1970
+++ sources/Makefile.am Wed Oct 11 03:35:13 2000
@@ -0,0 +1 @@
+bin_PROGRAMS = dico

View File

@ -29,15 +29,6 @@
#ifdef MSDOS /* Systeme d'operation de disque */
#define MYOS "MSDOS" /* Microsoft :-) */
#endif
@@ -49,7 +57,7 @@
#define ISO_TERM 3
#define COMMENT_CHAR 35 /* '#' ligne de commentaire */
-#define DICT_PATH "/usr/local/lib/dico" /* path par defaut unix/dos */
+#define DICT_PATH "%%PREFIX%%/share/dico" /* path par defaut unix/dos */
#define DOS_PATH "lexique" /* path par defaut Dos uniquement */
#define DICT_EXT ".dic" /* extension des fichiers dicos */
#define VERSION_FILE "version.dic" /* fichier texte version dico */
@@ -58,11 +66,13 @@
#define OK 0
#define MYVBUF 10240 /* pour setvbuf() eventuel */