Import of METIS, a package for unstructured graph partitioning.
At least, that's what the COMMENT says it does... PR: 4920 Submitted by: Pedro Giffuni <giffunip@asme.org>
This commit is contained in:
parent
33cc2be5ff
commit
aa396234bd
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=10682
33
math/metis/Makefile
Normal file
33
math/metis/Makefile
Normal file
@ -0,0 +1,33 @@
|
||||
# New ports collection makefile for: METIS
|
||||
# Version required: 3.0
|
||||
# Date created: 26 Oct 97
|
||||
# Whom: Pedro Giffuni <giffunip@asme.org>
|
||||
#
|
||||
# $Id$
|
||||
#
|
||||
|
||||
DISTNAME= metis-3.0
|
||||
CATEGORIES= math
|
||||
MASTER_SITES= http://www.cs.umn.edu/~karypis/metis/metis/files/
|
||||
|
||||
MAINTAINER= giffunip@asme.org
|
||||
|
||||
ALL_TARGET=
|
||||
|
||||
do-install:
|
||||
$(INSTALL_PROGRAM) $(WRKSRC)/pmetis $(PREFIX)/bin
|
||||
$(INSTALL_PROGRAM) $(WRKSRC)/kmetis $(PREFIX)/bin
|
||||
$(INSTALL_PROGRAM) $(WRKSRC)/oemetis $(PREFIX)/bin
|
||||
$(INSTALL_PROGRAM) $(WRKSRC)/onmetis $(PREFIX)/bin
|
||||
$(INSTALL_PROGRAM) $(WRKSRC)/partnmesh $(PREFIX)/bin
|
||||
$(INSTALL_PROGRAM) $(WRKSRC)/partdmesh $(PREFIX)/bin
|
||||
$(INSTALL_PROGRAM) $(WRKSRC)/mesh2nodal $(PREFIX)/bin
|
||||
$(INSTALL_PROGRAM) $(WRKSRC)/mesh2dual $(PREFIX)/bin
|
||||
$(INSTALL_PROGRAM) $(WRKSRC)/graphchk $(PREFIX)/bin
|
||||
$(INSTALL_DATA) $(WRKSRC)/libmetis.a $(PREFIX)/lib
|
||||
.if !defined(NOPORTDOCS)
|
||||
${MKDIR} $(PREFIX)/share/doc/METIS
|
||||
$(INSTALL_DATA) ${WRKSRC}/Doc/manual.ps $(PREFIX)/share/doc/METIS
|
||||
.endif
|
||||
|
||||
.include <bsd.port.mk>
|
1
math/metis/distinfo
Normal file
1
math/metis/distinfo
Normal file
@ -0,0 +1 @@
|
||||
MD5 (metis-3.0.tar.gz) = f547a7e503f497de29e1e54c1c13e91e
|
27
math/metis/files/patch-aa
Normal file
27
math/metis/files/patch-aa
Normal file
@ -0,0 +1,27 @@
|
||||
--- Makefile.in.orig Sat Apr 25 23:41:58 1998
|
||||
+++ Makefile.in Sat Apr 25 23:43:23 1998
|
||||
@@ -1,9 +1,9 @@
|
||||
|
||||
# Which compiler to use
|
||||
-CC = cc
|
||||
+# CC = cc
|
||||
|
||||
# What optimization level to use
|
||||
-OPTFLAGS = -O2
|
||||
+# OPTFLAGS = -O2
|
||||
|
||||
# What options to be used by the compiler
|
||||
COPTIONS =
|
||||
@@ -12,10 +12,10 @@
|
||||
LDOPTIONS =
|
||||
|
||||
# What archiving to use
|
||||
-AR = ar rv
|
||||
+# AR = ar rv
|
||||
|
||||
# What to use for indexing the archive
|
||||
-RANLIB = ranlib
|
||||
+# RANLIB = ranlib
|
||||
# RANLIB = ar -ts
|
||||
# RANLIB =
|
||||
|
20
math/metis/files/patch-ab
Normal file
20
math/metis/files/patch-ab
Normal file
@ -0,0 +1,20 @@
|
||||
--- Lib/Makefile.orig Sat Apr 25 23:43:54 1998
|
||||
+++ Lib/Makefile Sat Apr 25 23:44:31 1998
|
||||
@@ -2,7 +2,7 @@
|
||||
|
||||
INCLUDES = -I./
|
||||
|
||||
-CFLAGS = $(COPTIONS) $(OPTFLAGS) $(INCLUDES)
|
||||
+CFLAGS += $(COPTIONS) $(OPTFLAGS) $(INCLUDES)
|
||||
LD = $(CC) -L./
|
||||
|
||||
|
||||
@@ -17,7 +17,7 @@
|
||||
$(CC) $(CFLAGS) -c $*.c
|
||||
|
||||
../libmetis.a: $(OBJS)
|
||||
- $(AR) $@ $(OBJS)
|
||||
+ $(AR) $(ARFLAGS) $@ $(OBJS)
|
||||
$(RANLIB) $@
|
||||
|
||||
checkin:
|
11
math/metis/files/patch-ac
Normal file
11
math/metis/files/patch-ac
Normal file
@ -0,0 +1,11 @@
|
||||
--- Programs/Makefile.orig Sat Apr 25 23:44:50 1998
|
||||
+++ Programs/Makefile Sat Apr 25 23:46:35 1998
|
||||
@@ -3,7 +3,7 @@
|
||||
BINDIR = ..
|
||||
|
||||
INCLUDES = -I../Lib
|
||||
-CFLAGS = $(COPTIONS) $(OPTFLAGS) $(INCLUDES)
|
||||
+CFLAGS += $(COPTIONS) $(OPTFLAGS) $(INCLUDES)
|
||||
|
||||
LIBS = -lmetis -lm
|
||||
LD = $(CC) $(LDOPTIONS) -L./ -L../
|
11
math/metis/files/patch-ad
Normal file
11
math/metis/files/patch-ad
Normal file
@ -0,0 +1,11 @@
|
||||
--- Test/Makefile.orig Sat Apr 25 23:46:45 1998
|
||||
+++ Test/Makefile Sat Apr 25 23:46:53 1998
|
||||
@@ -3,7 +3,7 @@
|
||||
BINDIR = ./
|
||||
|
||||
INCLUDES = -I../Lib
|
||||
-CFLAGS = $(COPTIONS) $(OPTFLAGS) $(INCLUDES)
|
||||
+CFLAGS += $(COPTIONS) $(OPTFLAGS) $(INCLUDES)
|
||||
|
||||
LIBS = -lmetis -lm
|
||||
LD = $(CC) $(LDOPTIONS) -L../
|
1
math/metis/pkg-comment
Normal file
1
math/metis/pkg-comment
Normal file
@ -0,0 +1 @@
|
||||
A package for unstructured graph partitioning.
|
7
math/metis/pkg-descr
Normal file
7
math/metis/pkg-descr
Normal file
@ -0,0 +1,7 @@
|
||||
METIS is a set of programs for partitioning graphs and for producing fill
|
||||
reducing orderings for sparse matrices. The algorithms implemented by METIS
|
||||
are based on the multilevel graph partitioning scheme described in [KK95a]
|
||||
and [KK95e].
|
||||
|
||||
METIS provides high quality partitions, is extremely fast, and produces
|
||||
low fill orderings.
|
11
math/metis/pkg-plist
Normal file
11
math/metis/pkg-plist
Normal file
@ -0,0 +1,11 @@
|
||||
bin/pmetis
|
||||
bin/kmetis
|
||||
bin/oemetis
|
||||
bin/onmetis
|
||||
bin/partnmesh
|
||||
bin/partdmesh
|
||||
bin/mesh2nodal
|
||||
bin/mesh2dual
|
||||
bin/graphchk
|
||||
lib/libmetis.a
|
||||
share/doc/METIS/manual.ps
|
33
math/metis4/Makefile
Normal file
33
math/metis4/Makefile
Normal file
@ -0,0 +1,33 @@
|
||||
# New ports collection makefile for: METIS
|
||||
# Version required: 3.0
|
||||
# Date created: 26 Oct 97
|
||||
# Whom: Pedro Giffuni <giffunip@asme.org>
|
||||
#
|
||||
# $Id$
|
||||
#
|
||||
|
||||
DISTNAME= metis-3.0
|
||||
CATEGORIES= math
|
||||
MASTER_SITES= http://www.cs.umn.edu/~karypis/metis/metis/files/
|
||||
|
||||
MAINTAINER= giffunip@asme.org
|
||||
|
||||
ALL_TARGET=
|
||||
|
||||
do-install:
|
||||
$(INSTALL_PROGRAM) $(WRKSRC)/pmetis $(PREFIX)/bin
|
||||
$(INSTALL_PROGRAM) $(WRKSRC)/kmetis $(PREFIX)/bin
|
||||
$(INSTALL_PROGRAM) $(WRKSRC)/oemetis $(PREFIX)/bin
|
||||
$(INSTALL_PROGRAM) $(WRKSRC)/onmetis $(PREFIX)/bin
|
||||
$(INSTALL_PROGRAM) $(WRKSRC)/partnmesh $(PREFIX)/bin
|
||||
$(INSTALL_PROGRAM) $(WRKSRC)/partdmesh $(PREFIX)/bin
|
||||
$(INSTALL_PROGRAM) $(WRKSRC)/mesh2nodal $(PREFIX)/bin
|
||||
$(INSTALL_PROGRAM) $(WRKSRC)/mesh2dual $(PREFIX)/bin
|
||||
$(INSTALL_PROGRAM) $(WRKSRC)/graphchk $(PREFIX)/bin
|
||||
$(INSTALL_DATA) $(WRKSRC)/libmetis.a $(PREFIX)/lib
|
||||
.if !defined(NOPORTDOCS)
|
||||
${MKDIR} $(PREFIX)/share/doc/METIS
|
||||
$(INSTALL_DATA) ${WRKSRC}/Doc/manual.ps $(PREFIX)/share/doc/METIS
|
||||
.endif
|
||||
|
||||
.include <bsd.port.mk>
|
1
math/metis4/distinfo
Normal file
1
math/metis4/distinfo
Normal file
@ -0,0 +1 @@
|
||||
MD5 (metis-3.0.tar.gz) = f547a7e503f497de29e1e54c1c13e91e
|
27
math/metis4/files/patch-aa
Normal file
27
math/metis4/files/patch-aa
Normal file
@ -0,0 +1,27 @@
|
||||
--- Makefile.in.orig Sat Apr 25 23:41:58 1998
|
||||
+++ Makefile.in Sat Apr 25 23:43:23 1998
|
||||
@@ -1,9 +1,9 @@
|
||||
|
||||
# Which compiler to use
|
||||
-CC = cc
|
||||
+# CC = cc
|
||||
|
||||
# What optimization level to use
|
||||
-OPTFLAGS = -O2
|
||||
+# OPTFLAGS = -O2
|
||||
|
||||
# What options to be used by the compiler
|
||||
COPTIONS =
|
||||
@@ -12,10 +12,10 @@
|
||||
LDOPTIONS =
|
||||
|
||||
# What archiving to use
|
||||
-AR = ar rv
|
||||
+# AR = ar rv
|
||||
|
||||
# What to use for indexing the archive
|
||||
-RANLIB = ranlib
|
||||
+# RANLIB = ranlib
|
||||
# RANLIB = ar -ts
|
||||
# RANLIB =
|
||||
|
20
math/metis4/files/patch-ab
Normal file
20
math/metis4/files/patch-ab
Normal file
@ -0,0 +1,20 @@
|
||||
--- Lib/Makefile.orig Sat Apr 25 23:43:54 1998
|
||||
+++ Lib/Makefile Sat Apr 25 23:44:31 1998
|
||||
@@ -2,7 +2,7 @@
|
||||
|
||||
INCLUDES = -I./
|
||||
|
||||
-CFLAGS = $(COPTIONS) $(OPTFLAGS) $(INCLUDES)
|
||||
+CFLAGS += $(COPTIONS) $(OPTFLAGS) $(INCLUDES)
|
||||
LD = $(CC) -L./
|
||||
|
||||
|
||||
@@ -17,7 +17,7 @@
|
||||
$(CC) $(CFLAGS) -c $*.c
|
||||
|
||||
../libmetis.a: $(OBJS)
|
||||
- $(AR) $@ $(OBJS)
|
||||
+ $(AR) $(ARFLAGS) $@ $(OBJS)
|
||||
$(RANLIB) $@
|
||||
|
||||
checkin:
|
11
math/metis4/files/patch-ac
Normal file
11
math/metis4/files/patch-ac
Normal file
@ -0,0 +1,11 @@
|
||||
--- Programs/Makefile.orig Sat Apr 25 23:44:50 1998
|
||||
+++ Programs/Makefile Sat Apr 25 23:46:35 1998
|
||||
@@ -3,7 +3,7 @@
|
||||
BINDIR = ..
|
||||
|
||||
INCLUDES = -I../Lib
|
||||
-CFLAGS = $(COPTIONS) $(OPTFLAGS) $(INCLUDES)
|
||||
+CFLAGS += $(COPTIONS) $(OPTFLAGS) $(INCLUDES)
|
||||
|
||||
LIBS = -lmetis -lm
|
||||
LD = $(CC) $(LDOPTIONS) -L./ -L../
|
11
math/metis4/files/patch-ad
Normal file
11
math/metis4/files/patch-ad
Normal file
@ -0,0 +1,11 @@
|
||||
--- Test/Makefile.orig Sat Apr 25 23:46:45 1998
|
||||
+++ Test/Makefile Sat Apr 25 23:46:53 1998
|
||||
@@ -3,7 +3,7 @@
|
||||
BINDIR = ./
|
||||
|
||||
INCLUDES = -I../Lib
|
||||
-CFLAGS = $(COPTIONS) $(OPTFLAGS) $(INCLUDES)
|
||||
+CFLAGS += $(COPTIONS) $(OPTFLAGS) $(INCLUDES)
|
||||
|
||||
LIBS = -lmetis -lm
|
||||
LD = $(CC) $(LDOPTIONS) -L../
|
1
math/metis4/pkg-comment
Normal file
1
math/metis4/pkg-comment
Normal file
@ -0,0 +1 @@
|
||||
A package for unstructured graph partitioning.
|
7
math/metis4/pkg-descr
Normal file
7
math/metis4/pkg-descr
Normal file
@ -0,0 +1,7 @@
|
||||
METIS is a set of programs for partitioning graphs and for producing fill
|
||||
reducing orderings for sparse matrices. The algorithms implemented by METIS
|
||||
are based on the multilevel graph partitioning scheme described in [KK95a]
|
||||
and [KK95e].
|
||||
|
||||
METIS provides high quality partitions, is extremely fast, and produces
|
||||
low fill orderings.
|
11
math/metis4/pkg-plist
Normal file
11
math/metis4/pkg-plist
Normal file
@ -0,0 +1,11 @@
|
||||
bin/pmetis
|
||||
bin/kmetis
|
||||
bin/oemetis
|
||||
bin/onmetis
|
||||
bin/partnmesh
|
||||
bin/partdmesh
|
||||
bin/mesh2nodal
|
||||
bin/mesh2dual
|
||||
bin/graphchk
|
||||
lib/libmetis.a
|
||||
share/doc/METIS/manual.ps
|
Loading…
Reference in New Issue
Block a user