Update to 0.9beta1.

This version is now GNU configure driven.

A word of warning for future committers so that you don't fall into
the same trap as I did: The source has an printf-style funtion
"print". This doesn't understand "%u", so the usual print-casting
stuff for long long ints isn't
  printf("%u", (unsigned int)foo);
but
  print("%d", (int)foo);
which obviously looses in some cases, but I didn't take the effort to
extend this function to take 64 bit value (just unsigned is limited as
well).

In this case, it isn't that bad, since it is used to print limits, but
memory limits are internally stored as "mega" or "kilo" anyway.
This commit is contained in:
Martin Cracauer 1998-06-08 13:59:35 +00:00
parent 116a2abbae
commit aa2af247b4
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=11355
4 changed files with 42 additions and 93 deletions

View File

@ -3,14 +3,19 @@
# Date created: Sun Aug 13 12:36:14 CDT 1995
# Whom: erich@rrnet.com
#
# $Id: Makefile,v 1.3 1996/07/30 04:17:03 asami Exp $
# $Id: Makefile,v 1.4 1996/11/18 11:39:46 asami Exp $
#
DISTNAME= es-0.9-alpha1
PKGNAME= es-0.9a1
DISTNAME= es-0.9-beta1
PKGNAME= es-0.9b1
CATEGORIES= shells
MASTER_SITES= ftp://ftp.sys.toronto.edu/pub/es/
MAINTAINER= erich@FreeBSD.org
GNU_CONFIGURE= yes
ALL_TARGET= es
MAN1= es.1
.include <bsd.port.mk>

View File

@ -1 +1 @@
MD5 (es-0.9-alpha1.tar.gz) = 2e7372fc4c8eaeb00571e721730b6108
MD5 (es-0.9-beta1.tar.gz) = 1d0f771d94d9d8f958f264f1757b8620

View File

@ -1,93 +1,38 @@
*** Makefile.orig Tue May 30 06:14:14 1995
--- Makefile Fri Aug 11 16:02:11 1995
*** prim-sys.c.original Mon Jun 8 14:55:11 1998
--- prim-sys.c Mon Jun 8 14:51:15 1998
***************
*** 33,40 ****
SHELL = /bin/sh
CC = cc
#CC = gcc
! CFLAGS = -g
! #CFLAGS = -g -O -Wall
LDFLAGS =
LIBS =
*** 213,219 ****
lim /= suf->amount;
break;
}
! print("%-8s\t%d%s\n", limit->name, lim, (suf == NULL || lim == 0) ? "" : suf->name);
}
}
--- 33,40 ----
SHELL = /bin/sh
CC = cc
#CC = gcc
! #CFLAGS = -g
! CFLAGS = -O2
LDFLAGS =
LIBS =
--- 213,219 ----
lim /= suf->amount;
break;
}
! print("%-8s\t%d%s\n", limit->name, (int)lim, (suf == NULL || lim == 0) ? "" : suf->name);
}
}
*** configure.orig Mon Jun 8 15:02:05 1998
--- configure Mon Jun 8 15:02:37 1998
***************
*** 52,57 ****
--- 52,66 ----
tree.o util.o var.o vec.o version.o y.tab.o
OTHER = Makefile parse.y mksignal
GEN = esdump y.tab.c y.tab.h y.output token.h sigmsgs.c initial.c
+
+ all: es
+
+ install:
+ $(INSTALL) -c es $(PREFIX)/bin
+ $(INSTALL) -c esdebug $(PREFIX)/bin/esdebug
+ $(INSTALL) -c es.1 $(PREFIX)/man/man1
+ strip $(PREFIX)/bin/es
+ gzip -9nf $(PREFIX)/man/man1/es.1
*** 2344,2350 ****
cat >> confdefs.h <<EOF
! #define LIMIT_T $es_cv_rlimit_t
EOF
--- 2344,2350 ----
cat >> confdefs.h <<EOF
! #define LIMIT_T u_quad_t
EOF
es : ${OFILES} initial.o
${CC} -o es ${LDFLAGS} ${OFILES} initial.o ${LIBS}
--- prim-sys.c.orig Tue May 30 06:13:51 1995
+++ prim-sys.c Thu Apr 10 10:15:40 1997
@@ -194,7 +194,7 @@
static void printlimit(const Limit *limit, Boolean hard) {
struct rlimit rlim;
- long lim;
+ u_quad_t lim;
getrlimit(limit->flag, &rlim);
if (hard)
lim = rlim.rlim_max;
@@ -209,11 +209,11 @@
lim /= suf->amount;
break;
}
- print("%-8s\t%d%s\n", limit->name, lim, (suf == NULL || lim == 0) ? "" : suf->name);
+ print("%-8s\t%ud%s\n", limit->name, (unsigned int)lim, (suf == NULL || lim == 0) ? "" : suf->name);
}
}
-static long parselimit(const Limit *limit, char *s) {
+static u_quad_t parselimit(const Limit *limit, char *s) {
long lim;
char *t;
const Suffix *suf = limit->suffix;
--- main.c~ Tue May 30 06:13:50 1995
+++ main.c Thu Apr 10 09:20:49 1997
@@ -9,7 +9,7 @@
Boolean gcinfo = FALSE; /* -I */
#endif
-#if !HPUX && !defined(linux)
+#if !HPUX && !defined(linux) && !defined(__FreeBSD__) && !defined(__NetBSD__) && !defined(__OpenBSD__)
extern int getopt (int argc, char **argv, const char *optstring);
#endif
extern int optind;
--- stdenv.h~ Tue May 30 06:13:53 1995
+++ stdenv.h Thu Apr 10 09:32:22 1997
@@ -283,6 +283,7 @@
/* stdlib */
+#if !defined(__FreeBSD__) && !defined(__NetBSD__) && !defined(__OpenBSD__)
extern noreturn exit(int);
extern noreturn abort(void);
extern long strtol(const char *num, char **end, int base);
@@ -290,6 +291,7 @@
void *base, size_t nmemb, size_t size,
int (*compar)(const void *, const void *)
);
+#endif
/* setjmp */

View File

@ -1,3 +1,2 @@
bin/es
bin/esdebug
man/man1/es.1.gz