Update to 3.5.1.

Changelog is here:
http://doc.powerdns.com/html/changelog.html#changelog-recursor-3.5.1

Also pet the Makefile:
- Change ${LOCALBASE} to ${PREFIX} where applicable
- Fix overwrite of recursor.conf by changing to bsd.port.pre/post.mk (and
  thus fixing ${PREFIX})

PR:		ports/178340
Submitted by:	Ralf van der Enden <tremere@cainites.net>
Approved by:	Sten Spans <sten@blinkenlights.nl> (maintainer)
This commit is contained in:
Raphael Kubo da Costa 2013-05-19 14:27:56 +00:00
parent cb96184034
commit aa1eb6b705
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=318527
4 changed files with 49 additions and 47 deletions

View File

@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= powerdns-recursor
PORTVERSION= 3.3
PORTVERSION= 3.5.1
CATEGORIES= dns ipv6
MASTER_SITES= http://downloads.powerdns.com/releases/ \
http://mirrors.evolva.ro/powerdns.com/releases/
@ -22,14 +22,16 @@ OPTIONS_DEFAULT= SETUID
SETUID_DESC= Run as pdns_recursor user
STATIC_DESC= Build static binaries
CXXFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
CXXFLAGS+= -I${PREFIX}/include
LDFLAGS+= -L${PREFIX}/lib
MAN8= rec_control.8 pdns_recursor.8
SUB_FILES= pkg-message
.include <bsd.port.options.mk>
.include <bsd.port.pre.mk>
.if ${ARCH} == "sparc64"
BROKEN= Does not compile on sparc64
.endif
@ -46,8 +48,8 @@ GROUPS= pdns
USE_LUA=5.1
LUA_COMPS=lua
MAKE_ENV+=LUA=1
MAKE_ENV+=LUA_CPPFLAGS_CONFIG=-I${LOCALBASE}/include/lua51
MAKE_ENV+="LUA_LIBS_CONFIG=-L${LOCALBASE}/lib/lua51/ -llua"
MAKE_ENV+=LUA_CPPFLAGS_CONFIG=-I${PREFIX}/include/lua51
MAKE_ENV+="LUA_LIBS_CONFIG=-L${PREFIX}/lib/lua51/ -llua"
.endif
.if ${PORT_OPTIONS:MSTATIC}
@ -78,4 +80,4 @@ post-install:
@${INSTALL_MAN} ${WRKSRC}/*.8 ${PREFIX}/man/man8/
@${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>
.include <bsd.port.post.mk>

View File

@ -1,2 +1,2 @@
SHA256 (pdns-recursor-3.3.tar.bz2) = 7b62d97f2bb02bb0ba366dabb5e504338b949a572b9062ec2198012fc3b525bc
SIZE (pdns-recursor-3.3.tar.bz2) = 145785
SHA256 (pdns-recursor-3.5.1.tar.bz2) = 30655996d1963e259d4fc8648184031bf9cb83f64510d0b00539d3ce698b2824
SIZE (pdns-recursor-3.5.1.tar.bz2) = 176413

View File

@ -27,8 +27,8 @@
$(DESTDIR)/$(SBINDIR)/pdns_recursor --config > $(DESTDIR)/$(CONFIGDIR)/recursor.conf-dist
- -mkdir -p $(DESTDIR)/usr/share/man/man1
- cp pdns_recursor.1 rec_control.1 $(DESTDIR)/usr/share/man/man1
+ mv pdns_recursor.1 pdns_recursor.8
+ mv rec_control.1 rec_control.8
+ cp pdns_recursor.1 pdns_recursor.8
+ cp rec_control.1 rec_control.8
$(OS_SPECIFIC_INSTALL)
clean: binclean

View File

@ -1,44 +1,15 @@
--- pdns_recursor.1.orig 2010-09-21 18:22:09.000000000 +0200
+++ pdns_recursor.1 2010-09-27 09:24:15.000000000 +0200
--- rec_control.1.orig 2013-04-15 09:40:40.000000000 +0200
+++ rec_control.1 2013-04-16 20:20:23.142475518 +0200
@@ -7,7 +7,7 @@
.\" Source: [FIXME: source]
.\" Source: \ \& 3.0
.\" Language: English
.\"
-.TH "PDNS_RECURSOR" "1" "02/10/2010" "[FIXME: source]" "[FIXME: manual]"
+.TH "PDNS_RECURSOR" "8" "02/10/2010" "[FIXME: source]" "[FIXME: manual]"
-.TH "REC_CONTROL" "1" "05/03/2013" "\ \& 3\&.0" "\ \&"
+.TH "REC_CONTROL" "8" "05/03/2013" "\ \& 3\&.0" "\ \&"
.\" -----------------------------------------------------------------
.\" * set default formatting
.\" * Define some portability stuff
.\" -----------------------------------------------------------------
@@ -25,7 +25,7 @@
\fIpdns_recursor\fR [\-\-daemon] [\-\-local\-address] [\-\-help, \-h] [\-\-allow\-from]
.SH "DESCRIPTION"
.sp
-pdns_recursor(1) is a high performance, simple and secure recursing nameserver\&. It currently powers over two million internet connections\&.
+pdns_recursor(8) is a high performance, simple and secure recursing nameserver\&. It currently powers over two million internet connections\&.
.sp
The recursor is configured via a configuration file, but each item in that file can be overridden on the command line\&.
.sp
@@ -264,7 +264,7 @@
Website: \m[blue]\fBhttp://wiki\&.powerdns\&.com\fR\m[], \m[blue]\fBhttp://www\&.powerdns\&.com\fR\m[]
.SH "SEE ALSO"
.sp
-rec_control(1)
+rec_control(8)
.SH "COPYING"
.sp
Copyright \(co 2006 PowerDNS\&.COM BV\&. Free use of this software is granted under the terms of the GNU General Public License (GPL) version 2\&.
--- rec_control.1.orig 2010-09-21 18:22:09.000000000 +0200
+++ rec_control.1 2010-09-27 09:22:54.000000000 +0200
@@ -7,7 +7,7 @@
.\" Source: [FIXME: source]
.\" Language: English
.\"
-.TH "REC_CONTROL" "1" "08/30/2010" "[FIXME: source]" "[FIXME: manual]"
+.TH "REC_CONTROL" "8" "08/30/2010" "[FIXME: source]" "[FIXME: manual]"
.\" -----------------------------------------------------------------
.\" * set default formatting
.\" -----------------------------------------------------------------
@@ -25,7 +25,7 @@
@@ -34,7 +34,7 @@
\fIrec_control\fR [\-\-help] [\-\-socket\-dir] [\-\-socket\-pid] command \&.\&.
.SH "DESCRIPTION"
.sp
@ -47,7 +18,7 @@
.sp
The commands that can be passed to the recursor are described on \m[blue]\fBhttp://doc\&.powerdns\&.com/rec\-control\&.html\fR\m[]
.SH "EXAMPLES"
@@ -133,7 +133,7 @@
@@ -142,7 +142,7 @@
Website: \m[blue]\fBhttp://wiki\&.powerdns\&.com\fR\m[], \m[blue]\fBhttp://www\&.powerdns\&.com\fR\m[]
.SH "SEE ALSO"
.sp
@ -56,3 +27,32 @@
.SH "COPYING"
.sp
Copyright \(co 2006 PowerDNS\&.COM BV\&. Free use of this software is granted under the terms of the GNU General Public License (GPL) version 2\&.
--- pdns_recursor.1.orig 2013-05-03 10:17:59.000000000 +0200
+++ pdns_recursor.1 2013-05-03 18:41:34.355622682 +0200
@@ -7,7 +7,7 @@
.\" Source: \ \& 3.0
.\" Language: English
.\"
-.TH "PDNS_RECURSOR" "1" "05/03/2013" "\ \& 3\&.0" "\ \&"
+.TH "PDNS_RECURSOR" "8" "05/03/2013" "\ \& 3\&.0" "\ \&"
.\" -----------------------------------------------------------------
.\" * Define some portability stuff
.\" -----------------------------------------------------------------
@@ -34,7 +34,7 @@
\fIpdns_recursor\fR [\-\-daemon] [\-\-local\-address] [\-\-help, \-h] [\-\-allow\-from]
.SH "DESCRIPTION"
.sp
-pdns_recursor(1) is a high performance, simple and secure recursing nameserver\&. It currently powers over two million internet connections\&.
+pdns_recursor(8) is a high performance, simple and secure recursing nameserver\&. It currently powers over two million internet connections\&.
.sp
The recursor is configured via a configuration file, but each item in that file can be overridden on the command line\&.
.sp
@@ -273,7 +273,7 @@
Website: \m[blue]\fBhttp://wiki\&.powerdns\&.com\fR\m[], \m[blue]\fBhttp://www\&.powerdns\&.com\fR\m[]
.SH "SEE ALSO"
.sp
-rec_control(1)
+rec_control(8)
.SH "COPYING"
.sp
Copyright \(co 2006 PowerDNS\&.COM BV\&. Free use of this software is granted under the terms of the GNU General Public License (GPL) version 2\&.