Mission: Move ports/comms/atp into ports/news/atp.
Phase IV: easy-import atp. MISSION UPDATE FROM I.M.F. HQ: I have been saying "ports/mail/atp" up till now. I just changed my mind -- I'm puttin' this sucker in "ports/news/atp" I base this on what little precedent we have in the ports tree -- our only other port that deals with this is plor, a SOUP/QWK packet reader, and it's in news/. This is really kind of a tough call, though, as neither mail/ nor news/ is really 100% appropriate.
This commit is contained in:
parent
2d1ba4c0c6
commit
aa1a7ae776
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=11391
33
news/atp/Makefile
Normal file
33
news/atp/Makefile
Normal file
@ -0,0 +1,33 @@
|
||||
# New ports collection makefile for: atp
|
||||
# Version required: 1.50
|
||||
# Date created: 9 Nov 1997
|
||||
# Whom: Donald Burr <dburr@FreeBSD.ORG>
|
||||
#
|
||||
# $Id$
|
||||
#
|
||||
|
||||
DISTNAME= atp-1.50-src
|
||||
PKGNAME= atp-1.50
|
||||
CATEGORIES= news
|
||||
MASTER_SITES= ${MASTER_SITE_SUNSITE}
|
||||
MASTER_SITE_SUBDIR= system/bbs/mail
|
||||
|
||||
MAINTAINER= dburr@FreeBSD.ORG
|
||||
|
||||
RUN_DEPENDS= zip:${PORTSDIR}/archivers/zip \
|
||||
unzip:${PORTSDIR}/archivers/unzip
|
||||
|
||||
WRKSRC= ${WRKDIR}/${PKGNAME}
|
||||
|
||||
USE_GMAKE= YES
|
||||
GNU_CONFIGURE= YES
|
||||
|
||||
MAN1= atp.1 \
|
||||
atpdiag.1 \
|
||||
rot13.1
|
||||
MAN3= editline.3
|
||||
|
||||
post-install:
|
||||
@${CAT} ${PKGDIR}/MESSAGE
|
||||
|
||||
.include <bsd.port.mk>
|
1
news/atp/distinfo
Normal file
1
news/atp/distinfo
Normal file
@ -0,0 +1 @@
|
||||
MD5 (atp-1.50-src.tar.gz) = dfaa7d9b883e766bde296a0a62b2355f
|
42
news/atp/files/patch-aa
Normal file
42
news/atp/files/patch-aa
Normal file
@ -0,0 +1,42 @@
|
||||
--- Makefile.in.old Fri May 15 16:34:21 1998
|
||||
+++ Makefile.in Fri May 15 16:35:02 1998
|
||||
@@ -20,7 +20,7 @@
|
||||
mandir = $(prefix)/man
|
||||
|
||||
# path where your ATP data and configuration files will reside:
|
||||
-atphome = @ATPHOME@
|
||||
+atphome = $(prefix)/share/atp
|
||||
|
||||
# permissions and ownership
|
||||
bin_prm = 755
|
||||
@@ -78,7 +78,7 @@
|
||||
# phony targets (a.k.a "forced" targets)
|
||||
clean_targ = clean distclean clobber spotless mostlyclean unconvert
|
||||
devel_targ = callmap check depend extract lint tags
|
||||
-instl_targ = install uninstall in_cfg in_man in_wrap
|
||||
+instl_targ = install uninstall in_cfg in_man
|
||||
misc_targ = debug dvi info eline elinedb manifest
|
||||
.PHONY : $(clean_targ) $(devel_targ) $(instl_targ) $(misc_targ)
|
||||
|
||||
@@ -109,7 +109,7 @@
|
||||
utils/rot13:
|
||||
cd utils ; $(MAKE) rot13
|
||||
|
||||
-install: in_bin in_man in_cfg in_wrap
|
||||
+install: in_bin in_man in_cfg
|
||||
|
||||
in_cfg:
|
||||
@echo " "
|
||||
@@ -136,12 +136,6 @@
|
||||
$(INSTALL) -m $(bin_prm) -o $(bin_own) -g $(bin_grp) ./atp $(bindir)/atp
|
||||
$(INSTALL) -m $(bin_prm) -o $(bin_own) -g $(bin_grp) ./utils/atpdiag $(bindir)/atpdiag
|
||||
$(INSTALL) -m $(bin_prm) -o $(bin_own) -g $(bin_grp) ./utils/rot13 $(bindir)/rot13
|
||||
-
|
||||
-in_wrap:
|
||||
- @echo " "
|
||||
- @echo "Now it's YOUR turn, please do this:"
|
||||
- @echo "Set and export the environment variable: ATP=$(atphome)"
|
||||
- @echo "Edit your $(atphome)/atprc and then read the docs!"
|
||||
|
||||
in_man:
|
||||
@echo " "
|
1
news/atp/pkg-comment
Normal file
1
news/atp/pkg-comment
Normal file
@ -0,0 +1 @@
|
||||
A QWK message packet reader and composer for FreeBSD
|
8
news/atp/pkg-descr
Normal file
8
news/atp/pkg-descr
Normal file
@ -0,0 +1,8 @@
|
||||
ATP allows you to read and compose mail packets of the QWK format,
|
||||
commonly used on PC-based BBS systems. With this program, you can
|
||||
download all of your new e-mail and board messages as a QWK packet,
|
||||
read them offline, compose replies to selected messages off-line,
|
||||
then upload all of your replies as one QWK reply packet the next
|
||||
time you call the BBS.
|
||||
|
||||
[ This port is maintained by Donald Burr <dburr@FreeBSD.ORG>. ]
|
20
news/atp/pkg-message
Normal file
20
news/atp/pkg-message
Normal file
@ -0,0 +1,20 @@
|
||||
Each user who wishes to use ATP must do the following:
|
||||
|
||||
1. set environment variable ATP to the location where s/he
|
||||
wishes configuration files located (e.g. ${HOME}/.qwk')
|
||||
|
||||
2. create the directory named above
|
||||
|
||||
3. copy the files in ${PREFIX}/share/atp into it
|
||||
|
||||
4. edit the atprc and taglines.atp file to contain whatever
|
||||
data you want.
|
||||
|
||||
5. If you want atp to look good in xterms, you should get and install the
|
||||
VGA font, available in the port "emulators/pcemu". Then run ATP like
|
||||
this: "xterm -fn vga -e atp". Be sure to set "ansi = on", "color = on",
|
||||
"charset = msdos", and "graphics = off" in your atprc file! (You can
|
||||
use atp in an xterm even without doing these steps, but you won't get
|
||||
the pretty PC ANSI-style graphics characters!)
|
||||
|
||||
see the atp(1) man page for more details.
|
10
news/atp/pkg-plist
Normal file
10
news/atp/pkg-plist
Normal file
@ -0,0 +1,10 @@
|
||||
bin/atp
|
||||
bin/atpdiag
|
||||
bin/rot13
|
||||
man/man1/atp.1.gz
|
||||
man/man1/atpdiag.1.gz
|
||||
man/man1/rot13.1.gz
|
||||
man/man3/editline.3.gz
|
||||
share/atp/atprc
|
||||
share/atp/taglines.atp
|
||||
@dirrm share/atp
|
Loading…
Reference in New Issue
Block a user