sysutils/u-boot-rpi-arm64: Add new port

This u-boot is intended to boot on all 64bits variants of the RPI boards
like the RPI2v1.1, RPI3* and RPI*

Suggested by: karels
This commit is contained in:
Emmanuel Vadot 2020-12-15 15:02:39 +00:00
parent 413fa9d85e
commit aa1634ec21
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=558161
5 changed files with 40 additions and 0 deletions

View File

@ -1404,6 +1404,7 @@
SUBDIR += u-boot-rpi3
SUBDIR += u-boot-rpi3-32
SUBDIR += u-boot-rpi4
SUBDIR += u-boot-rpi-arm64
SUBDIR += u-boot-sinovoip-bpi-m3
SUBDIR += u-boot-sopine
SUBDIR += u-boot-sopine-spi

View File

@ -0,0 +1,18 @@
# $FreeBSD$
MASTERDIR= ${.CURDIR}/../u-boot-master
EXTRA_PATCHES= ${.CURDIR}/files/
PATCHFILES+= 939129/raw
MODEL= rpi-arm64
BOARD_CONFIG= rpi_arm64_defconfig
FAMILY= rpi
UBOOT_ARCH= aarch64
DEPENDS= ${LOCALBASE}/share/rpi-firmware/bootcode.bin:sysutils/rpi-firmware
CONFIG_FRAGMENT= ${.CURDIR}/files/rpi_arm64_fragment
FRAGMENT_NAME= rpi_arm64_fragment
.include "${MASTERDIR}/Makefile"

View File

@ -0,0 +1,13 @@
--- lib/efi_loader/efi_console.c.orig 2018-03-13 12:02:19 UTC
+++ lib/efi_loader/efi_console.c
@@ -547,8 +547,8 @@ int efi_console_register(void)
printf("ERROR: Failed to register console event\n");
return r;
}
- /* 5000 ns cycle is sufficient for 2 MBaud */
- r = efi_set_timer(console_timer_event, EFI_TIMER_PERIODIC, 50);
+ /* 100 ms */
+ r = efi_set_timer(console_timer_event, EFI_TIMER_PERIODIC, 100*1000*10);
if (r != EFI_SUCCESS)
printf("ERROR: Failed to set console timer\n");
return r;

View File

@ -0,0 +1,2 @@
CONFIG_ENV_FAT_DEVICE_AND_PART="1:1"
CONFIG_RPI_EFI_NR_SPIN_PAGES=2

View File

@ -0,0 +1,6 @@
U-Boot loader and related files for the 64 bit variants of the RPI
This u-boot config is made to be bootable on any 64bits RPI like the RPI2v1.1
RPI3 and RPI4.
For general information about U-Boot see WWW: https://www.denx.de/wiki/U-Boot