Upgrade to version 10.4.1.

This commit is contained in:
Jimmy Olgeni 2010-08-13 16:10:19 +00:00
parent ac206b0bbd
commit a9c0a74c90
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=259187
5 changed files with 57 additions and 134 deletions

View File

@ -6,31 +6,31 @@
#
PORTNAME= ecl
PORTVERSION= 0.9l
PORTREVISION= 3
PORTVERSION= 10.4.1
CATEGORIES= lang lisp
MASTER_SITES= SF/${PORTNAME}s/${PORTNAME}s/${PORTVERSION}
EXTRACT_SUFX= .tgz
MASTER_SITES= SF/${PORTNAME}s/${PORTNAME}s/10.4/
MAINTAINER= olgeni@FreeBSD.org
COMMENT= An ANSI Common Lisp implementation
LIB_DEPENDS= gmp.10:${PORTSDIR}/math/gmp gc.1:${PORTSDIR}/devel/boehm-gc
LIB_DEPENDS= gmp.10:${PORTSDIR}/math/gmp
USE_GMAKE= yes
USE_PERL5_BUILD=yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-system-gmp --enable-boehm=system
CONFIGURE_ENV= CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
CFLAGS= -I${LOCALBASE}/include
CONFIGURE_ENV+= CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
CFLAGS= -I${LOCALBASE}/include
LDFLAGS= -L${LOCALBASE}/lib
USE_LDCONFIG= yes
OPTIONS= ASDF "Enable ASDF building facility" on \
CLOS_STREAMS "Enable user defined stream objects" on \
CLX "Enable X11 interface" off \
SOCKETS "Enable socket interface" on \
THREADS "Enable threading support" off
MAN1= ecl.1
.include <bsd.port.pre.mk>
.if ${ARCH} == "ia64" || ${ARCH} == "sparc64"
@ -45,14 +45,6 @@ CONFIGURE_ARGS+=--with-asdf=no
PLIST_SUB+= ASDF="@comment "
.endif
.if !defined(WITHOUT_CLOS_STREAMS)
CONFIGURE_ARGS+=--with-clos-streams=yes
PLIST_SUB+= CLOS_STREAMS=""
.else
CONFIGURE_ARGS+=--with-clos-streams=no
PLIST_SUB+= CLOS_STREAMS="@comment "
.endif
.if defined(WITH_CLX)
USE_XORG= x11
CONFIGURE_ARGS+=--with-clx=yes
@ -74,14 +66,18 @@ PLIST_SUB+= SOCKETS="@comment "
.if defined(WITH_THREADS)
CONFIGURE_ARGS+=--enable-threads=yes
LDFLAGS+= ${PTHREAD_LIBS}
LIB_DEPENDS+= gc-threaded.1:${PORTSDIR}/devel/boehm-gc-threaded
.else
CONFIGURE_ARGS+=--enable-threads=no
LIB_DEPENDS+= gc.1:${PORTSDIR}/devel/boehm-gc
.endif
.if defined(WITH_THREADS)
post-patch:
@${REINPLACE_CMD} -e 's|_NP[[:>:]]||' \
${WRKSRC}/src/c/package.d ${WRKSRC}/src/c/threads.d
@${REINPLACE_CMD} -e 's|-lgc|-lgc-threaded|' \
-e 's|-lpthread|${PTHREAD_LIBS}|' ${WRKSRC}/src/configure
.endif
.include <bsd.port.post.mk>

View File

@ -1,3 +1,3 @@
MD5 (ecl-0.9l.tgz) = a2bff84ccd3a4aa76d14ee3a277038df
SHA256 (ecl-0.9l.tgz) = a50a3289baeb2e1395e3d7f1e563da06c20e2a22ee174516ff4313122f2e7411
SIZE (ecl-0.9l.tgz) = 4989464
MD5 (ecl-10.4.1.tar.gz) = be53f5e55a3f07c7cfb5fb5cd9a2a3f0
SHA256 (ecl-10.4.1.tar.gz) = 505dcfe8f26aca352271225ad5a7f117b9bef0f6e7f7a7abaf7b7f11f7c63c6c
SIZE (ecl-10.4.1.tar.gz) = 5835953

View File

@ -1,23 +0,0 @@
--- ./src/doc/Makefile.in.orig Fri Aug 12 13:26:42 2005
+++ ./src/doc/Makefile.in Sat Jun 24 22:59:42 2006
@@ -51,10 +51,6 @@
$(INSTALL_INFO) --info-dir=$(DESTDIR)$(infodir) $$k; \
fi; \
done
- $(mkinstalldirs) $(DESTDIR)$(docdir)
- for i in Copyright LGPL; do \
- $(INSTALL_DATA) $(top_srcdir)/../$$i $(DESTDIR)$(docdir); \
- done
$(mkinstalldirs) $(DESTDIR)$(mandir)/man$(manext)
$(INSTALL_DATA) ecl.man $(DESTDIR)$(mandir)/man$(manext)/ecl.$(manext)
flatinstall: all $(HTML_FILES)
@@ -72,9 +68,6 @@
$(mkinstalldirs) $(DESTDIR)$(docdir)/ecldev; \
for i in ecldev/*; do $(INSTALL_DATA) $$i $(DESTDIR)$(docdir)/ecldev/; done; \
fi
- for i in Copyright LGPL; do \
- $(INSTALL_DATA) $(top_srcdir)/../$$i $(DESTDIR)$(docdir); \
- done
for i in *.html; do $(INSTALL_DATA) $$i $(DESTDIR)$(docdir)/; done
uninstall:

View File

@ -1,76 +0,0 @@
--- src/gc/include/private/gcconfig.h.orig 2007-03-28 09:59:40.000000000 +0200
+++ src/gc/include/private/gcconfig.h 2008-08-27 16:27:54.000000000 +0200
@@ -330,10 +330,6 @@
# define OPENBSD
# define mach_type_known
# endif
-# if defined(FREEBSD) && (defined(i386) || defined(__i386__))
-# define I386
-# define mach_type_known
-# endif
# if defined(__NetBSD__) && (defined(i386) || defined(__i386__))
# define I386
# define mach_type_known
@@ -342,10 +338,24 @@
# define X86_64
# define mach_type_known
# endif
-# if defined(FREEBSD) && defined(__sparc__)
-# define SPARC
-# define mach_type_known
-#endif
+# if defined(FREEBSD)
+# ifdef __i386__
+# define I386
+# define mach_type_known
+# endif
+# ifdef __amd64__
+# define X86_64
+# define mach_type_known
+# endif
+# ifdef __sparc64__
+# define SPARC
+# define mach_type_known
+# endif
+# ifdef __ia64__
+# define IA64
+# define mach_type_known
+# endif
+# endif
# if defined(bsdi) && (defined(i386) || defined(__i386__))
# define I386
# define BSDI
@@ -1017,6 +1027,9 @@
# ifdef __ELF__
# define DYNAMIC_LOADING
# endif
+# ifndef GC_FREEBSD_THREADS
+# define MPROTECT_VDB
+# endif
extern char etext[];
extern char edata[];
extern char end[];
@@ -2009,6 +2022,23 @@
# endif
# ifdef FREEBSD
# define OS_TYPE "FREEBSD"
+# define SIG_SUSPEND SIGUSR1
+# define SIG_THR_RESTART SIGUSR2
+# define FREEBSD_STACKBOTTOM
+# ifdef __ELF__
+# define DYNAMIC_LOADING
+# endif
+ extern char etext[];
+ extern char edata[];
+ extern char end[];
+# define NEED_FIND_LIMIT
+# define DATASTART ((ptr_t)(&etext))
+# define DATAEND (GC_find_limit (DATASTART, TRUE))
+# define DATASTART2 ((ptr_t)(&edata))
+# define DATAEND2 ((ptr_t)(&end))
+# endif
+# ifdef FREEBSD
+# define OS_TYPE "FREEBSD"
# ifndef GC_FREEBSD_THREADS
# define MPROTECT_VDB
# endif

View File

@ -15,19 +15,45 @@ include/ecl/object.h
include/ecl/page.h
include/ecl/stacks.h
include/ecl/unify.h
lib/ecl/BUILD-STAMP
%%ASDF%%lib/ecl/asdf.fas
%%CLX%%lib/ecl/clx.fas
%%CLOS_STREAMS%%lib/ecl/cmp.fas
lib/ecl/defsystem.fas
lib/ecl/dpp
lib/ecl/ecl_min
lib/ecl/help.doc
lib/ecl/profile.fas
lib/ecl/rt.fas
lib/ecl/serve-event.fas
%%SOCKETS%%lib/ecl/sockets.fas
lib/ecl/sysfun.lsp
lib/libecl.so
@dirrm include/ecl
@dirrm lib/ecl
%%LIB32DIR%%/Copyright
%%LIB32DIR%%/LGPL
%%LIB32DIR%%/ecl-10.4.1/BUILD-STAMP
%%LIB32DIR%%/ecl-10.4.1/TAGS
%%ASDF%%%%LIB32DIR%%/ecl-10.4.1/asdf.fas
%%LIB32DIR%%/ecl-10.4.1/bytecmp.asd
%%LIB32DIR%%/ecl-10.4.1/bytecmp.fas
%%CLX%%%%LIB32DIR%%/ecl-10.4.1/clx.asd
%%CLX%%%%LIB32DIR%%/ecl-10.4.1/clx.fas
%%LIB32DIR%%/ecl-10.4.1/cmp.asd
%%LIB32DIR%%/ecl-10.4.1/cmp.fas
%%LIB32DIR%%/ecl-10.4.1/defsystem.asd
%%LIB32DIR%%/ecl-10.4.1/defsystem.fas
%%LIB32DIR%%/ecl-10.4.1/dpp
%%LIB32DIR%%/ecl-10.4.1/ecl_min
%%LIB32DIR%%/ecl-10.4.1/help.doc
%%ASDF%%%%LIB32DIR%%/ecl-10.4.1/libasdf.a
%%LIB32DIR%%/ecl-10.4.1/libbytecmp.a
%%CLX%%%%LIB32DIR%%/ecl-10.4.1/libclx.a
%%LIB32DIR%%/ecl-10.4.1/libcmp.a
%%LIB32DIR%%/ecl-10.4.1/libdefsystem.a
%%LIB32DIR%%/ecl-10.4.1/libprofile.a
%%LIB32DIR%%/ecl-10.4.1/librt.a
%%SOCKETS%%%%LIB32DIR%%/ecl-10.4.1/libsb-bsd-sockets.a
%%LIB32DIR%%/ecl-10.4.1/libserve-event.a
%%SOCKETS%%%%LIB32DIR%%/ecl-10.4.1/libsockets.a
%%LIB32DIR%%/ecl-10.4.1/profile.asd
%%LIB32DIR%%/ecl-10.4.1/profile.fas
%%LIB32DIR%%/ecl-10.4.1/rt.asd
%%LIB32DIR%%/ecl-10.4.1/rt.fas
%%SOCKETS%%%%LIB32DIR%%/ecl-10.4.1/sb-bsd-sockets.asd
%%SOCKETS%%%%LIB32DIR%%/ecl-10.4.1/sb-bsd-sockets.fas
%%LIB32DIR%%/ecl-10.4.1/serve-event.asd
%%LIB32DIR%%/ecl-10.4.1/serve-event.fas
%%SOCKETS%%%%LIB32DIR%%/ecl-10.4.1/sockets.asd
%%SOCKETS%%%%LIB32DIR%%/ecl-10.4.1/sockets.fas
%%LIB32DIR%%/ecl-10.4.1/sysfun.lsp
%%LIB32DIR%%/ecl-10.4.1/ucd.dat
%%LIB32DIR%%/libecl.so
%%LIB32DIR%%/libecl.so.10
%%LIB32DIR%%/libecl.so.10.4
%%LIB32DIR%%/libecl.so.10.4.1