Update to version 0.30
PR: ports/74245 Submitted by: Ports Fury
This commit is contained in:
parent
40797d26e7
commit
a974bbd8dd
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=122237
@ -7,8 +7,7 @@
|
||||
#
|
||||
|
||||
PORTNAME= open-cobol
|
||||
PORTVERSION= 0.23
|
||||
PORTREVISION= 1
|
||||
PORTVERSION= 0.30
|
||||
CATEGORIES= lang
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= ${PORTNAME}
|
||||
@ -20,10 +19,10 @@ LIB_DEPENDS= gmp.6:${PORTSDIR}/math/libgmp4
|
||||
|
||||
USE_LIBLTDL= yes
|
||||
USE_GETOPT_LONG= yes
|
||||
GNU_CONFIGURE= yes
|
||||
USE_REINPLACE= yes
|
||||
USE_LIBTOOL_VER= 15
|
||||
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
|
||||
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
|
||||
CONFIGURE_ARGS= --with-readline
|
||||
INSTALLS_SHLIB= yes
|
||||
|
||||
INFO= open-cobol
|
||||
@ -36,8 +35,13 @@ CONFIGURE_ARGS+= --disable-nls
|
||||
PLIST_SUB+= NLS="@comment "
|
||||
.else
|
||||
USE_GETTEXT= yes
|
||||
LDFLAGS+= -lintl
|
||||
PLIST_SUB+= NLS=""
|
||||
.endif
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's|^SUBDIRS = lib |SUBDIRS = |g' \
|
||||
${WRKSRC}/Makefile.in
|
||||
@${REINPLACE_CMD} -e 's|$$(top_builddir)/lib/libsupport\.a||g' \
|
||||
${WRKSRC}/cobc/Makefile.in
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
@ -1,2 +1,2 @@
|
||||
MD5 (open-cobol-0.23.tar.gz) = a253ca8965dd071c517d3860e9730137
|
||||
SIZE (open-cobol-0.23.tar.gz) = 658911
|
||||
MD5 (open-cobol-0.30.tar.gz) = 8945775abca6703bba0a25a3293f78ac
|
||||
SIZE (open-cobol-0.30.tar.gz) = 738437
|
||||
|
@ -1,15 +0,0 @@
|
||||
--- config/ltmain.sh.orig Fri Nov 22 17:03:54 2002
|
||||
+++ config/ltmain.sh Thu Dec 12 20:35:02 2002
|
||||
@@ -4280,10 +4280,12 @@
|
||||
fi
|
||||
|
||||
# Install the pseudo-library for information purposes.
|
||||
+ if /usr/bin/false; then
|
||||
name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
|
||||
instname="$dir/$name"i
|
||||
$show "$install_prog $instname $destdir/$name"
|
||||
$run eval "$install_prog $instname $destdir/$name" || exit $?
|
||||
+ fi
|
||||
|
||||
# Maybe install the static library, too.
|
||||
test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
|
@ -1,20 +0,0 @@
|
||||
--- lib/Makefile.in.orig Thu Jun 12 05:13:50 2003
|
||||
+++ lib/Makefile.in Sun Apr 4 00:28:58 2004
|
||||
@@ -175,7 +175,7 @@
|
||||
DEFAULT_INCLUDES = -I. -I$(srcdir) -I$(top_builddir)
|
||||
depcomp = $(SHELL) $(top_srcdir)/config/depcomp
|
||||
am__depfiles_maybe = depfiles
|
||||
-@AMDEP_TRUE@DEP_FILES = $(DEPDIR)/getopt.Po $(DEPDIR)/getopt1.Po \
|
||||
+@AMDEP_TRUE@DEP_FILES = \
|
||||
@AMDEP_TRUE@ $(DEPDIR)/malloc.Po $(DEPDIR)/memcmp.Po \
|
||||
@AMDEP_TRUE@ $(DEPDIR)/realloc.Po
|
||||
COMPILE = $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) \
|
||||
@@ -215,8 +215,6 @@
|
||||
distclean-compile:
|
||||
-rm -f *.tab.c
|
||||
|
||||
-@AMDEP_TRUE@@am__include@ @am__quote@$(DEPDIR)/getopt.Po@am__quote@
|
||||
-@AMDEP_TRUE@@am__include@ @am__quote@$(DEPDIR)/getopt1.Po@am__quote@
|
||||
@AMDEP_TRUE@@am__include@ @am__quote@$(DEPDIR)/malloc.Po@am__quote@
|
||||
@AMDEP_TRUE@@am__include@ @am__quote@$(DEPDIR)/memcmp.Po@am__quote@
|
||||
@AMDEP_TRUE@@am__include@ @am__quote@$(DEPDIR)/realloc.Po@am__quote@
|
@ -1,20 +0,0 @@
|
||||
--- libcob/fileio.c.orig Wed Jun 11 15:40:20 2003
|
||||
+++ libcob/fileio.c Wed Aug 27 09:57:31 2003
|
||||
@@ -202,13 +202,10 @@
|
||||
else
|
||||
{
|
||||
/* discard input until the next newline */
|
||||
- int c = getc (f->file);
|
||||
- while (c != '\r' && c != '\n' && c != EOF)
|
||||
- c = getc (f->file);
|
||||
- if (c == '\r')
|
||||
- c = getc (f->file);
|
||||
- if (c != '\n' && c != EOF)
|
||||
- ungetc (c, f->file);
|
||||
+ char buff[BUFSIZ];
|
||||
+ while (fgets (buff, BUFSIZ, f->file) !=NULL)
|
||||
+ if (strchr (buff, '\n') != NULL)
|
||||
+ break;
|
||||
}
|
||||
|
||||
memcpy (f->record->data, buff, f->record->size);
|
@ -1,10 +1,10 @@
|
||||
--- libcob/screenio.c.orig Thu Apr 3 06:02:51 2003
|
||||
+++ libcob/screenio.c Tue Apr 29 04:09:44 2003
|
||||
--- libcob/screenio.c.orig Fri Mar 12 13:41:58 2004
|
||||
+++ libcob/screenio.c Wed Nov 24 02:43:30 2004
|
||||
@@ -19,6 +19,7 @@
|
||||
|
||||
#include "config.h"
|
||||
|
||||
+#include <sys/types.h>
|
||||
+#include <stdio.h>
|
||||
#include <string.h>
|
||||
#if HAVE_CURSES_H
|
||||
#include <curses.h>
|
||||
|
||||
#if HAVE_NCURSES_H
|
||||
|
@ -1,7 +1,7 @@
|
||||
bin/cob-config
|
||||
bin/cobc
|
||||
etc/libcob.conf
|
||||
include/libcob.h
|
||||
include/libcob/byteswap.h
|
||||
include/libcob/call.h
|
||||
include/libcob/common.h
|
||||
include/libcob/exception.def
|
||||
@ -15,4 +15,13 @@ lib/libcob.a
|
||||
lib/libcob.so
|
||||
lib/libcob.so.1
|
||||
%%NLS%%share/locale/ja/LC_MESSAGES/open-cobol.mo
|
||||
%%DATADIR%%/config/cobol2002.conf
|
||||
%%DATADIR%%/config/cobol85.conf
|
||||
%%DATADIR%%/config/default.conf
|
||||
%%DATADIR%%/config/ibm.conf
|
||||
%%DATADIR%%/config/mf.conf
|
||||
%%DATADIR%%/config/mvs.conf
|
||||
%%DATADIR%%/config/v023.conf
|
||||
@dirrm %%DATADIR%%/config
|
||||
@dirrm %%DATADIR%%
|
||||
@dirrm include/libcob
|
||||
|
@ -7,8 +7,7 @@
|
||||
#
|
||||
|
||||
PORTNAME= open-cobol
|
||||
PORTVERSION= 0.23
|
||||
PORTREVISION= 1
|
||||
PORTVERSION= 0.30
|
||||
CATEGORIES= lang
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= ${PORTNAME}
|
||||
@ -20,10 +19,10 @@ LIB_DEPENDS= gmp.6:${PORTSDIR}/math/libgmp4
|
||||
|
||||
USE_LIBLTDL= yes
|
||||
USE_GETOPT_LONG= yes
|
||||
GNU_CONFIGURE= yes
|
||||
USE_REINPLACE= yes
|
||||
USE_LIBTOOL_VER= 15
|
||||
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
|
||||
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
|
||||
CONFIGURE_ARGS= --with-readline
|
||||
INSTALLS_SHLIB= yes
|
||||
|
||||
INFO= open-cobol
|
||||
@ -36,8 +35,13 @@ CONFIGURE_ARGS+= --disable-nls
|
||||
PLIST_SUB+= NLS="@comment "
|
||||
.else
|
||||
USE_GETTEXT= yes
|
||||
LDFLAGS+= -lintl
|
||||
PLIST_SUB+= NLS=""
|
||||
.endif
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's|^SUBDIRS = lib |SUBDIRS = |g' \
|
||||
${WRKSRC}/Makefile.in
|
||||
@${REINPLACE_CMD} -e 's|$$(top_builddir)/lib/libsupport\.a||g' \
|
||||
${WRKSRC}/cobc/Makefile.in
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
@ -1,2 +1,2 @@
|
||||
MD5 (open-cobol-0.23.tar.gz) = a253ca8965dd071c517d3860e9730137
|
||||
SIZE (open-cobol-0.23.tar.gz) = 658911
|
||||
MD5 (open-cobol-0.30.tar.gz) = 8945775abca6703bba0a25a3293f78ac
|
||||
SIZE (open-cobol-0.30.tar.gz) = 738437
|
||||
|
@ -1,15 +0,0 @@
|
||||
--- config/ltmain.sh.orig Fri Nov 22 17:03:54 2002
|
||||
+++ config/ltmain.sh Thu Dec 12 20:35:02 2002
|
||||
@@ -4280,10 +4280,12 @@
|
||||
fi
|
||||
|
||||
# Install the pseudo-library for information purposes.
|
||||
+ if /usr/bin/false; then
|
||||
name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
|
||||
instname="$dir/$name"i
|
||||
$show "$install_prog $instname $destdir/$name"
|
||||
$run eval "$install_prog $instname $destdir/$name" || exit $?
|
||||
+ fi
|
||||
|
||||
# Maybe install the static library, too.
|
||||
test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
|
@ -1,20 +0,0 @@
|
||||
--- lib/Makefile.in.orig Thu Jun 12 05:13:50 2003
|
||||
+++ lib/Makefile.in Sun Apr 4 00:28:58 2004
|
||||
@@ -175,7 +175,7 @@
|
||||
DEFAULT_INCLUDES = -I. -I$(srcdir) -I$(top_builddir)
|
||||
depcomp = $(SHELL) $(top_srcdir)/config/depcomp
|
||||
am__depfiles_maybe = depfiles
|
||||
-@AMDEP_TRUE@DEP_FILES = $(DEPDIR)/getopt.Po $(DEPDIR)/getopt1.Po \
|
||||
+@AMDEP_TRUE@DEP_FILES = \
|
||||
@AMDEP_TRUE@ $(DEPDIR)/malloc.Po $(DEPDIR)/memcmp.Po \
|
||||
@AMDEP_TRUE@ $(DEPDIR)/realloc.Po
|
||||
COMPILE = $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) \
|
||||
@@ -215,8 +215,6 @@
|
||||
distclean-compile:
|
||||
-rm -f *.tab.c
|
||||
|
||||
-@AMDEP_TRUE@@am__include@ @am__quote@$(DEPDIR)/getopt.Po@am__quote@
|
||||
-@AMDEP_TRUE@@am__include@ @am__quote@$(DEPDIR)/getopt1.Po@am__quote@
|
||||
@AMDEP_TRUE@@am__include@ @am__quote@$(DEPDIR)/malloc.Po@am__quote@
|
||||
@AMDEP_TRUE@@am__include@ @am__quote@$(DEPDIR)/memcmp.Po@am__quote@
|
||||
@AMDEP_TRUE@@am__include@ @am__quote@$(DEPDIR)/realloc.Po@am__quote@
|
@ -1,20 +0,0 @@
|
||||
--- libcob/fileio.c.orig Wed Jun 11 15:40:20 2003
|
||||
+++ libcob/fileio.c Wed Aug 27 09:57:31 2003
|
||||
@@ -202,13 +202,10 @@
|
||||
else
|
||||
{
|
||||
/* discard input until the next newline */
|
||||
- int c = getc (f->file);
|
||||
- while (c != '\r' && c != '\n' && c != EOF)
|
||||
- c = getc (f->file);
|
||||
- if (c == '\r')
|
||||
- c = getc (f->file);
|
||||
- if (c != '\n' && c != EOF)
|
||||
- ungetc (c, f->file);
|
||||
+ char buff[BUFSIZ];
|
||||
+ while (fgets (buff, BUFSIZ, f->file) !=NULL)
|
||||
+ if (strchr (buff, '\n') != NULL)
|
||||
+ break;
|
||||
}
|
||||
|
||||
memcpy (f->record->data, buff, f->record->size);
|
@ -1,10 +1,10 @@
|
||||
--- libcob/screenio.c.orig Thu Apr 3 06:02:51 2003
|
||||
+++ libcob/screenio.c Tue Apr 29 04:09:44 2003
|
||||
--- libcob/screenio.c.orig Fri Mar 12 13:41:58 2004
|
||||
+++ libcob/screenio.c Wed Nov 24 02:43:30 2004
|
||||
@@ -19,6 +19,7 @@
|
||||
|
||||
#include "config.h"
|
||||
|
||||
+#include <sys/types.h>
|
||||
+#include <stdio.h>
|
||||
#include <string.h>
|
||||
#if HAVE_CURSES_H
|
||||
#include <curses.h>
|
||||
|
||||
#if HAVE_NCURSES_H
|
||||
|
@ -1,7 +1,7 @@
|
||||
bin/cob-config
|
||||
bin/cobc
|
||||
etc/libcob.conf
|
||||
include/libcob.h
|
||||
include/libcob/byteswap.h
|
||||
include/libcob/call.h
|
||||
include/libcob/common.h
|
||||
include/libcob/exception.def
|
||||
@ -15,4 +15,13 @@ lib/libcob.a
|
||||
lib/libcob.so
|
||||
lib/libcob.so.1
|
||||
%%NLS%%share/locale/ja/LC_MESSAGES/open-cobol.mo
|
||||
%%DATADIR%%/config/cobol2002.conf
|
||||
%%DATADIR%%/config/cobol85.conf
|
||||
%%DATADIR%%/config/default.conf
|
||||
%%DATADIR%%/config/ibm.conf
|
||||
%%DATADIR%%/config/mf.conf
|
||||
%%DATADIR%%/config/mvs.conf
|
||||
%%DATADIR%%/config/v023.conf
|
||||
@dirrm %%DATADIR%%/config
|
||||
@dirrm %%DATADIR%%
|
||||
@dirrm include/libcob
|
||||
|
Loading…
Reference in New Issue
Block a user