update to 0.5.6

mark MAKE_JOBS_SAFE= yes
This commit is contained in:
Oliver Lehmann 2009-05-12 04:51:37 +00:00
parent c335897ffd
commit a92700b2d8
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=233743
5 changed files with 1460 additions and 1385 deletions

View File

@ -6,7 +6,7 @@
#
PORTNAME= ember
PORTVERSION= 0.5.5
PORTVERSION= 0.5.6
CATEGORIES= games
MASTER_SITES= SF \
http://amber.worldforge.org/ember/releases/stable/
@ -37,6 +37,7 @@ USE_LUA= 5.1
USE_GNOME= gnomehack
USE_BZIP2= YES
CPPFLAGS= -DBR_NO_MACROS
MAKE_JOBS_SAFE= yes
post-patch:
@${REINPLACE_CMD} -e '\
@ -60,7 +61,7 @@ post-patch:
${WRKSRC}/src/components/ogre/Makefile.in
post-install:
(cd ${WRKDIR}/${PORTNAME}-media-${PORTVERSION} && ${FIND} . -type f -print | \
(cd ${WRKDIR}/media-${PORTVERSION} && ${FIND} . -type f -print | \
${CPIO} -pdmu -R${SHAREOWN}:${SHAREGRP} ${DATADIR}/media)
${FIND} ${DATADIR} -type d -print0 | ${XARGS} -0 ${CHMOD} 0755
${FIND} ${DATADIR} -type f -print0 | ${XARGS} -0 ${CHMOD} 0644

View File

@ -1,6 +1,6 @@
MD5 (ember-0.5.5.tar.bz2) = 2de7d28a45c4e57112f6da57034f4306
SHA256 (ember-0.5.5.tar.bz2) = 0742b482d9220cad0da4f58dff0f1769e0660cbd13ed2cee3582cb4c981efbea
SIZE (ember-0.5.5.tar.bz2) = 1879882
MD5 (ember-media-0.5.5.tar.bz2) = 3d0ed1261f9b876f8556d78c99e10bee
SHA256 (ember-media-0.5.5.tar.bz2) = 9ee6ceaaa4a4bd4e7bd02b80c6fc09ec446acca9ac1105d1a866509e1d33445f
SIZE (ember-media-0.5.5.tar.bz2) = 197593995
MD5 (ember-0.5.6.tar.bz2) = 9cbfe1138ac688a88c79fc28fd69e212
SHA256 (ember-0.5.6.tar.bz2) = e81c8fe5819566ff101f9d12c079fa7c7919ba048cfc223a45656bc0ba711c8a
SIZE (ember-0.5.6.tar.bz2) = 1966772
MD5 (ember-media-0.5.6.tar.bz2) = b6100ce3c456e06a15a4e94f87ccf8b1
SHA256 (ember-media-0.5.6.tar.bz2) = ce706d9814bb05ce613a9695741b718128f4bd5dce0a857ff36810e42a86714c
SIZE (ember-media-0.5.6.tar.bz2) = 209313052

View File

@ -1,10 +0,0 @@
--- src/components/ogre/widgets/InspectWidget.h.orig 2009-04-05 19:03:20.000000000 +0200
+++ src/components/ogre/widgets/InspectWidget.h 2009-04-05 19:03:25.000000000 +0200
@@ -23,6 +23,7 @@
#ifndef EMBEROGREINSPECTWIDGET_H
#define EMBEROGREINSPECTWIDGET_H
+#include <Atlas/Objects/Operation.h>
#include <Eris/Entity.h>
#include "Widget.h"

View File

@ -18,20 +18,4 @@
#if [ "$fullpath" = "" ]; then
if [ "$test" = "." ]; then
path=${PWD}
@@ -95,7 +96,7 @@
if [ ! -d $media_dir ] ; then
echo "Copying dynamic data to user directory"
- cp -dpR $media_user_dir $media_dir
+ cp -pR $media_user_dir $media_dir
fi
#Let's write the version number so that we can do some useful thing with it in the future. (Like remove old media dirs.)
@@ -104,4 +105,6 @@
# Execute real ember binary
echo "Starting Ember...."
#we have to do the LD_PRELOAD thing, because else at least I get an error: libnvidia-tls.so.1: cannot handle TLS data /ehj
-LD_PRELOAD=libGL.so.1 $bindir/ember.bin --home $homedata
+[ ! -f $homedata/plugins.cfg ] && cp $etcdir/plugins.cfg $homedata/
+[ ! -f $homedata/resources.cfg ] && cp $etcdir/resources.cfg $homedata/
++LD_PRELOAD=libGL.so.1 $bindir/ember.bin

File diff suppressed because it is too large Load Diff