flash plugin for mozilla firefox browser

PR:		ports/69126
Submitted by:	Roman Y. Bogdanov <sam@brj.pp.ru>
Approved by:	krion (mentor) (implicitly)
This commit is contained in:
Sergey Matveychuk 2004-07-21 05:57:34 +00:00
parent 8552b10d81
commit a910bdc6d6
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=114326
7 changed files with 84 additions and 0 deletions

View File

@ -103,6 +103,7 @@
SUBDIR += firefox
SUBDIR += firefox-remote
SUBDIR += flashplugin
SUBDIR += flashplugin-firefox
SUBDIR += flashplugin-mozilla
SUBDIR += flashplugin-mozilla-devel
SUBDIR += flashpluginwrapper

View File

@ -0,0 +1,32 @@
# New ports collection makefile for: flashplugin-firefox
# Date created: 16.07.2004
# Whom: Roman Y. Bogdanov <sam@brj.pp.ru>
#
# $FreeBSD$
#
PORTNAME= flashplugin-firefox
PORTVERSION= 0.4.10
PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= http://www.swift-tools.net/Flash/
DISTNAME= flash-${PORTVERSION}
EXTRACT_SUFX= .tgz
MAINTAINER= sam@brj.pp.ru
COMMENT= A GPL standalone Flash (TM) plugin for FireFox web browser
LIB_DEPENDS= flash.0:${PORTSDIR}/graphics/libflash
RUN_DEPENDS?= firefox:${PORTSDIR}/www/firefox
USE_X_PREFIX= yes
WRKSRC= ${WRKDIR}/${DISTNAME}/Plugin
PLUGIN_DIR?= lib/firefox/lib/firefox-0.9.1/plugins
PLIST_SUB+= PLUGIN_DIR=${PLUGIN_DIR}
do-install:
@${MKDIR} ${PREFIX}/${PLUGIN_DIR}
@${INSTALL_PROGRAM} ${WRKSRC}/npflash.so ${PREFIX}/${PLUGIN_DIR}
.include <bsd.port.mk>

View File

@ -0,0 +1,2 @@
MD5 (flash-0.4.10.tgz) = 1473f085c599d8076fa866cd91e11598
SIZE (flash-0.4.10.tgz) = 358995

View File

@ -0,0 +1,22 @@
--- Makefile.orig Tue Sep 28 05:13:38 1999
+++ Makefile Sat Mar 13 20:06:26 2004
@@ -35,8 +35,8 @@
# Linux
SHARED=-shared
-CFLAGS= $(OPTIMIZER) $(PLUGIN_DEFINES) -I$(FLASH) -I/usr/X11R6/include
-LDFLAGS= $(FLASH)/libflash.a $(LIBCXX) ../Jpeg/libjpeg.a ../Zlib/libz.a
+CFLAGS+= $(OPTIMIZER) $(PLUGIN_DEFINES) -I$(FLASH) -I/usr/X11R6/include -fPIC
+LDFLAGS= -L${LOCALBASE}/lib -lflash -ljpeg -lz -L$(X11BASE)/lib -lXt
SRC= plugin.c npunix.c
OBJ= plugin.o npunix.o
@@ -45,7 +45,7 @@
default all: $(SHAREDTARGET)
-$(SHAREDTARGET): $(OBJ) $(FLASH)/libflash.a
+$(SHAREDTARGET): $(OBJ)
$(LD) $(SHARED) -o $(SHAREDTARGET) $(OBJ) $(LDFLAGS)
plugin.o: $(FLASH)/flash.h

View File

@ -0,0 +1,20 @@
*** plugin.c.old Mon Jun 12 10:24:09 2000
--- plugin.c Mon Sep 30 00:48:40 2002
***************
*** 193,198 ****
--- 193,207 ----
XSync(This->dpy,False);
XFreePixmap(This->dpy, This->canvas);
shmdt(This->segInfo.shmaddr);
+ #ifndef linux
+ {
+ struct shmid_ds buf;
+
+ if (shmctl(This->segInfo.shmid, IPC_RMID, &buf) < 0) {
+ perror("shmctl");
+ }
+ }
+ #endif
FlashClose(This->fh);
This->fh = 0;

View File

@ -0,0 +1,5 @@
This is GPL standalone Flash (TM) Plugin, that comes with FlashLib
(libflash) distribution.
Author: Olivier Debon <olivier@debon.net>
WWW: http://www.swift-tools.net/Flash/

View File

@ -0,0 +1,2 @@
%%PLUGIN_DIR%%/npflash.so
@unexec rmdir %%PLUGIN_DIR%% 2>/dev/null || true