Remove expired port:

2015-11-12 deskutils/steadyflow: No new releases for years, consider using net/uget
This commit is contained in:
Rene Ladan 2015-11-13 06:55:48 +00:00
parent 1489c98da6
commit a9108b5e21
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=401480
12 changed files with 1 additions and 235 deletions

1
MOVED
View File

@ -7934,3 +7934,4 @@ databases/mysql51-scripts||2015-11-10|Has expired: EOL upstream, use mysql55 or
databases/mysql51-server||2015-11-10|Has expired: EOL upstream, use mysql55 or mysql56 instead
databases/p5-DBD-mysql51|databases/p5-DBD-mysql|2015-11-10|Has expired: EOL upstream, use databases/p5-DBD-mysql instead
databases/py-MySQLdb51||2015-11-10|Has expired: EOL upstream, use databases/py-MySQLdb instead
deskutils/steadyflow||2015-11-13|Has expired: No new releases for years, consider using net/uget

View File

@ -225,7 +225,6 @@
SUBDIR += simplegroupware
SUBDIR += sliderule
SUBDIR += spice-gtk
SUBDIR += steadyflow
SUBDIR += strigi
SUBDIR += strigiclient
SUBDIR += strigidaemon

View File

@ -1,32 +0,0 @@
# $FreeBSD$
PORTNAME= steadyflow
PORTVERSION= 0.2.0
PORTREVISION= 2
CATEGORIES= deskutils
MASTER_SITES= https://launchpadlibrarian.net/109019071/ \
https://launchpad.net/${PORTNAME}/trunk/${PORTVERSION}/+download/ \
LOCAL/olivierd
MAINTAINER= olivierd@FreeBSD.org
COMMENT= Simple download manager
LICENSE= GPLv3
DEPRECATED= No new releases for years, consider using net/uget
EXPIRATION_DATE= 2015-11-12
LIB_DEPENDS= libdbus-glib-1.so:${PORTSDIR}/devel/dbus-glib \
libgee-0.8.so:${PORTSDIR}/devel/libgee \
libnotify.so:${PORTSDIR}/devel/libnotify
BUILD_DEPENDS= valac:${PORTSDIR}/lang/vala
USES= cmake gettext pkgconfig shebangfix tar:xz
SHEBANG_FILES= cmake/intltool-merge.pl
GLIB_SCHEMAS= net.launchpad.steadyflow.gschema.xml
USE_GNOME= glib20 gtk30 intltool
INSTALLS_ICONS= yes
CMAKE_ARGS= -DCOMPILE_GSETTINGS_ON_INSTALL:BOOL=ON \
-DWANT_AYATANA:BOOL=OFF
.include <bsd.port.mk>

View File

@ -1,2 +0,0 @@
SHA256 (steadyflow-0.2.0.tar.xz) = ab1f23d52be78c952979ee0bb1778b8bf4664145c6fb28db219d516aae7dddb6
SIZE (steadyflow-0.2.0.tar.xz) = 132744

View File

@ -1,11 +0,0 @@
--- ./CMakeLists.txt.orig 2012-06-30 12:39:35.000000000 +0000
+++ ./CMakeLists.txt 2013-09-25 11:46:49.000000000 +0000
@@ -48,7 +48,7 @@
)
set(VALA_PACKAGES
- gee-1.0
+ ${GEE_PACKAGE}
gio-2.0
glib-2.0
gtk+-3.0

View File

@ -1,14 +0,0 @@
Fix the compile with vala 0.24. Patch from upstream
--- Steadyflow/Services.vala.orig 2014-10-01 16:34:37.909464669 +0200
+++ Steadyflow/Services.vala 2014-10-01 16:34:55.297464318 +0200
@@ -61,7 +61,7 @@
"information to the developer:\n\nError Code %d:\n\n%s").printf (e.code, message));
md.run ();
- exit(1);
+ GLib.Process.exit(1);
}
}

View File

@ -1,40 +0,0 @@
--- ./cmake/FindExtraDeps.cmake.orig 2012-06-30 12:39:35.000000000 +0000
+++ ./cmake/FindExtraDeps.cmake 2013-09-25 12:11:22.000000000 +0000
@@ -1,13 +1,31 @@
message("-- Checking for libgee...")
-pkg_check_modules(GEE gee-1.0)
+# libgee <= 0.6.x
+pkg_check_modules(GEE_10 gee-1.0)
+if(GEE_10_FOUND)
+ set(GEE_PACKAGE gee-1.0)
+
+ set(EXTRA_DEP_INCLUDES ${EXTRA_DEP_INCLUDES} ${GEE_10_INCLUDE_DIRS})
+ set(EXTRA_DEP_CFLAGS ${EXTRA_DEP_CFLAGS} ${GEE_10_CFLAGS_OTHER})
+ set(EXTRA_DEP_LIBS ${EXTRA_DEP_LIBS} ${GEE_10_LDFLAGS})
+
+ set(GEE_FOUND true)
+else()
+ # libgee >= 0.8.x
+ pkg_check_modules(GEE_08 gee-0.8)
+ if(GEE_08_FOUND)
+ set(GEE_PACKAGE gee-0.8)
+
+ set(EXTRA_DEP_INCLUDES ${EXTRA_DEP_INCLUDES} ${GEE_08_INCLUDE_DIRS})
+ set(EXTRA_DEP_CFLAGS ${EXTRA_DEP_CFLAGS} ${GEE_08_CFLAGS_OTHER})
+ set(EXTRA_DEP_LIBS ${EXTRA_DEP_LIBS} ${GEE_08_LDFLAGS})
+
+ set(GEE_FOUND true)
+ endif()
+endif()
message("-- Checking for libnotify >= 0.7...")
pkg_check_modules(LIBNOTIFY libnotify>=0.7)
-if(GEE_FOUND)
- set(EXTRA_DEP_INCLUDES ${EXTRA_DEP_INCLUDES} ${GEE_INCLUDE_DIRS})
- set(EXTRA_DEP_CFLAGS ${EXTRA_DEP_CFLAGS} ${GEE_CFLAGS_OTHER})
- set(EXTRA_DEP_LIBS ${EXTRA_DEP_LIBS} ${GEE_LDFLAGS})
-else()
+if(NOT GEE_FOUND)
message(FATAL_ERROR "libgee not found")
endif()

View File

@ -1,11 +0,0 @@
--- ./data/net.launchpad.steadyflow.gschema.xml.orig 2011-05-22 09:29:17.000000000 +0000
+++ ./data/net.launchpad.steadyflow.gschema.xml 2012-09-01 11:09:47.000000000 +0000
@@ -35,7 +35,7 @@
<description>Show notification popups.</description>
</key>
<key name="start-minimized" type="b">
- <default>true</default>
+ <default>false</default>
<description>Hide the main window when the application starts.</description>
</key>
<key name="default-post-download-action" enum="finish-action">

View File

@ -1,12 +0,0 @@
--- install.cmake.orig 2011-07-26 21:54:45.000000000 +0200
+++ install.cmake 2011-07-26 21:59:45.000000000 +0200
@@ -5,8 +5,7 @@
install(FILES ${CMAKE_SOURCE_DIR}/data/net.launchpad.steadyflow.gschema.xml
DESTINATION ${COMMON_DATA_DIR}/glib-2.0/schemas)
-install(FILES ${CMAKE_SOURCE_DIR}/data/steadyflow.1 DESTINATION ${COMMON_DATA_DIR}/man/man1)
-install(CODE "execute_process(COMMAND gzip ${COMMON_DATA_DIR}/man/man1/steadyflow.1)")
+install(FILES ${CMAKE_SOURCE_DIR}/data/steadyflow.1 DESTINATION ${CMAKE_INSTALL_PREFIX}/man/man1)
if(COMPILE_GSETTINGS_ON_INSTALL)
add_gsettings_install_hook()

View File

@ -1,38 +0,0 @@
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=787875
>From 8a69e5adedc64aaf8c16ffb7c8e8cf23b416c5a8 Mon Sep 17 00:00:00 2001
From: Rodolphe PELLOUX-PRAYER <rodolphe@damsy.net>
Date: Sun, 7 Jun 2015 16:33:27 +0200
Subject: [PATCH] Fix ambiguous references between GLib.ListStore and
Gtk.ListStore GLib.ListStore is a new class in GIO and creates a conflict in
Vala 0.28.
Closes: #787875
---
...us-references-between-GLib.ListStore-and-.patch | 33 ++++++++++++++++++++++
debian/patches/series | 1 +
2 files changed, 34 insertions(+)
create mode 100644 debian/patches/0002-Fix-ambiguous-references-between-GLib.ListStore-and-.patch
diff --git a/Steadyflow/FileListController.vala b/Steadyflow/FileListController.vala
index 43a65c4..ae71222 100644
--- Steadyflow/FileListController.vala
+++ Steadyflow/FileListController.vala
@@ -27,7 +27,7 @@ public class FileListController : GLib.Object {
private static const double REDRAW_SEC = 0.2;
private TreeView tree;
- private ListStore model;
+ private Gtk.ListStore model;
private string filter = "";
private Timer redraw_timer;
@@ -46,7 +46,7 @@ public class FileListController : GLib.Object {
column.pack_start (renderer, true);
column.set_cell_data_func (renderer, set_cell_data);
- model = new ListStore.newv ({ typeof (IDownloadFile) });
+ model = new Gtk.ListStore.newv ({ typeof (IDownloadFile) });
tree.set_model (model);
tree.append_column (column);

View File

@ -1,5 +0,0 @@
Steadyflow is a GTK+ based download manager that aims for minimalism, and
ease of use. It should be easy to control, whether from the GUI, command
line, or D-Bus.
WWW: https://launchpad.net/steadyflow

View File

@ -1,69 +0,0 @@
bin/steadyflow
man/man1/steadyflow.1.gz
share/applications/steadyflow.desktop
share/icons/hicolor/16x16/apps/steadyflow.svg
share/icons/hicolor/22x22/apps/steadyflow.svg
share/icons/hicolor/24x24/apps/steadyflow.svg
share/icons/hicolor/32x32/apps/steadyflow.svg
share/icons/hicolor/48x48/apps/steadyflow.svg
share/icons/hicolor/64x64/apps/steadyflow.svg
share/icons/hicolor/scalable/apps/steadyflow.svg
share/locale/ar/LC_MESSAGES/steadyflow.mo
share/locale/ast/LC_MESSAGES/steadyflow.mo
share/locale/be/LC_MESSAGES/steadyflow.mo
share/locale/bg/LC_MESSAGES/steadyflow.mo
share/locale/bn/LC_MESSAGES/steadyflow.mo
share/locale/bs/LC_MESSAGES/steadyflow.mo
share/locale/ca/LC_MESSAGES/steadyflow.mo
share/locale/cs/LC_MESSAGES/steadyflow.mo
share/locale/da/LC_MESSAGES/steadyflow.mo
share/locale/de/LC_MESSAGES/steadyflow.mo
share/locale/el/LC_MESSAGES/steadyflow.mo
share/locale/en_AU/LC_MESSAGES/steadyflow.mo
share/locale/en_CA/LC_MESSAGES/steadyflow.mo
share/locale/en_GB/LC_MESSAGES/steadyflow.mo
share/locale/eo/LC_MESSAGES/steadyflow.mo
share/locale/es/LC_MESSAGES/steadyflow.mo
share/locale/et/LC_MESSAGES/steadyflow.mo
share/locale/eu/LC_MESSAGES/steadyflow.mo
share/locale/fa/LC_MESSAGES/steadyflow.mo
share/locale/fi/LC_MESSAGES/steadyflow.mo
share/locale/fo/LC_MESSAGES/steadyflow.mo
share/locale/fr/LC_MESSAGES/steadyflow.mo
share/locale/gl/LC_MESSAGES/steadyflow.mo
share/locale/gu/LC_MESSAGES/steadyflow.mo
share/locale/he/LC_MESSAGES/steadyflow.mo
share/locale/hi/LC_MESSAGES/steadyflow.mo
share/locale/hr/LC_MESSAGES/steadyflow.mo
share/locale/hu/LC_MESSAGES/steadyflow.mo
share/locale/id/LC_MESSAGES/steadyflow.mo
share/locale/it/LC_MESSAGES/steadyflow.mo
share/locale/ja/LC_MESSAGES/steadyflow.mo
share/locale/ka/LC_MESSAGES/steadyflow.mo
share/locale/ko/LC_MESSAGES/steadyflow.mo
share/locale/lt/LC_MESSAGES/steadyflow.mo
share/locale/ml/LC_MESSAGES/steadyflow.mo
share/locale/ms/LC_MESSAGES/steadyflow.mo
share/locale/my/LC_MESSAGES/steadyflow.mo
share/locale/nb/LC_MESSAGES/steadyflow.mo
share/locale/nl/LC_MESSAGES/steadyflow.mo
share/locale/nn/LC_MESSAGES/steadyflow.mo
share/locale/pl/LC_MESSAGES/steadyflow.mo
share/locale/pt/LC_MESSAGES/steadyflow.mo
share/locale/pt_BR/LC_MESSAGES/steadyflow.mo
share/locale/ro/LC_MESSAGES/steadyflow.mo
share/locale/ru/LC_MESSAGES/steadyflow.mo
share/locale/si/LC_MESSAGES/steadyflow.mo
share/locale/sk/LC_MESSAGES/steadyflow.mo
share/locale/sl/LC_MESSAGES/steadyflow.mo
share/locale/sr/LC_MESSAGES/steadyflow.mo
share/locale/sv/LC_MESSAGES/steadyflow.mo
share/locale/te/LC_MESSAGES/steadyflow.mo
share/locale/tr/LC_MESSAGES/steadyflow.mo
share/locale/uk/LC_MESSAGES/steadyflow.mo
share/locale/vi/LC_MESSAGES/steadyflow.mo
share/locale/zh_CN/LC_MESSAGES/steadyflow.mo
share/locale/zh_TW/LC_MESSAGES/steadyflow.mo
%%DATADIR%%/ui/AddFileDialog.ui
%%DATADIR%%/ui/MainWindow.ui
%%DATADIR%%/ui/PreferencesDialog.ui