Fix build with gcc 3.4
This commit is contained in:
parent
bfd65f6466
commit
a8e8e15d33
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=115385
@ -26,4 +26,8 @@ USE_INC_LIBTOOL_VER=13
|
||||
INSTALLS_SHLIB= yes
|
||||
CONFIGURE_ARGS= --enable-static
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e '/^SUBDIRS =/s/examples//' \
|
||||
${WRKSRC}/Makefile.in
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
@ -0,0 +1,11 @@
|
||||
--- libgnomecanvas/libgnomecanvasmm/line.h.orig Wed Aug 4 13:38:03 2004
|
||||
+++ libgnomecanvas/libgnomecanvasmm/line.h Wed Aug 4 13:38:23 2004
|
||||
@@ -286,7 +286,7 @@
|
||||
{
|
||||
|
||||
template <>
|
||||
-class Glib::Value<Gnome::Canvas::Points> : public Glib::Value_Boxed<Gnome::Canvas::Points>
|
||||
+class Value<Gnome::Canvas::Points> : public Glib::Value_Boxed<Gnome::Canvas::Points>
|
||||
{
|
||||
public:
|
||||
static GType value_type() G_GNUC_CONST;
|
Loading…
Reference in New Issue
Block a user