All qbittorrent development has moved to the 2.8 branch, so introduce

version 2.8.1, and remove the older versions. The 2.8 branch has support
for uTP when combined with the upcoming libtorrent-rasterbar 0.16 release.

Additional new features:
Proxy can be disabled for peer connections
Added support for secure SMTP connection (SSL)
Added support for SMTP authentication
Added UPnP/NAT-PMP port forward for the Web UI port
qBittorrent can update dynamic DNS services (DynDNS, no-ip)
Display peer connection type in peer list (BT, uTP, Web)
Added full regex support to RSS downloader
Added regex help and validation in RSS downloader
Added HTTPS support to Web UI (Ishan Arora)

Bug fixes:
Change systray icon on the fly (no restart needed)
Remember peer-level rate limits (requires libtorrent v0.16)
Stop announcing to trackers an all tiers (more respectful)
Stop sharing private trackers with other peers
Tracker exchange extension can be disabled
Cleaner program exit on system log out
Fix possible magnet link parsing problems
Fix possible RSS URL parsing problems

COSMETIC: Added monochrome icon for light themes
This commit is contained in:
Doug Barton 2011-06-06 07:29:26 +00:00
parent 76a74143ab
commit a8d76a0936
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=275118
19 changed files with 26 additions and 408 deletions

20
MOVED
View File

@ -2194,19 +2194,7 @@ textproc/scim-kmfl-sil-yi|textproc/kmfl-sil-yi|2011-05-29|KMFL keyboard ports ar
textproc/scim-kmfl-varamozhi-malayalam|textproc/kmfl-varamozhi-malayalam|2011-05-29|KMFL keyboard ports are now platform-independent
dns/bind94||2011-05-31|EOL - Update to dns/bind97 or dns/bind96
dns/bind94-geoip||2011-05-31|BIND 9.4.x is EOL
german/citrix_xenapp||2011-06-01|Has expired: "crashes with f10"
japanese/citrix_xenapp||2011-06-01|Has expired: "crashes with f10"
net/citrix_xenapp||2011-06-01|Has expired: "crashes with f10"
comms/gammu-python||2011-06-01|Has expired: since version 1.29.0 comms/gammu uses python by default
java/gj||2011-06-01|Has expired: Upstream disapear and distfile is no more available
net/ipv6socket_scrub||2011-06-01|Has expired: Upstream disapear and distfile is no more available
graphics/lodju||2011-06-01|Has expired: depends on rep-gtk, which doesn't build anymore.
www/mod_pubcookie||2011-06-01|Has expired: will be unsupported by ASF when 2.4.0 is release, migrate to 2.2.x+ now
ftp/prozilla||2011-06-01|Has expired: Upstream disapear and distfile is no more available
www/py-django11||2011-06-01|Has expired: Unsupported (no longer receive security updates or bugfixes)
x11-toolkits/rep-gtk||2011-06-01|Has expired: missing rep-config from librep port broke the build.
games/tnl||2011-06-01|Has expired: Upstream development has ceased, it doesn't work with newer CEGUI and is generally broken
net/vnc2swf|deskutils/vnc2flv|2011-06-01|Has expired: Development is now superseded by deskutils/vnc2flv
lang/libobjc2||2011-06-02|Redundant with lang/gnustep-libobjc
mail/postfix24||2011-06-03|Has expired: no further upstream development; please consider upgrading
www/mod_roaming2||2011-06-04|Has expired: no supported browser and no further upstream development; see PR 73383
net-p2p/qbittorrent26|net-p2p/qbittorrent28|2011-06-05|Old version no longer updated
net-p2p/qbittorrent26-nox11|net-p2p/qbittorrent28-nox11|2011-06-05|Old version no longer updated
net-p2p/qbittorrent27|net-p2p/qbittorrent28|2011-06-05|Old version no longer updated
net-p2p/qbittorrent27-nox11|net-p2p/qbittorrent28-nox11|2011-06-05|Old version no longer updated

View File

@ -96,10 +96,8 @@
SUBDIR += py-py2play
SUBDIR += py-transmissionrpc
SUBDIR += py-vertex
SUBDIR += qbittorrent-26
SUBDIR += qbittorrent-26-nox11
SUBDIR += qbittorrent-27
SUBDIR += qbittorrent-27-nox11
SUBDIR += qbittorrent-28
SUBDIR += qbittorrent-28-nox11
SUBDIR += qtella
SUBDIR += qtorrent
SUBDIR += rtgui

View File

@ -1,23 +0,0 @@
# New ports collection makefile for: qbittorrent-nox11-26
# Date created: 12 January 2011
# Whom: dougb@FreeBSD.org
#
# $FreeBSD$
#
PKGNAMESUFFIX= -nox11
COMMENT= Bittorrent client using libtorrent-rasterbar, web UI version
MASTERDIR= ${.CURDIR}/../qbittorrent-26
DESCR= ${.CURDIR}/pkg-descr
PLIST= ${.CURDIR}/pkg-plist
MAN1= qbittorrent-nox.1
WITHOUT_NOTIFY= true
QB26_NOX_SLAVE= true
.include "${MASTERDIR}/Makefile"

View File

@ -1,62 +0,0 @@
# New ports collection makefile for: qbittorrent-26
# Date created: 10 January 2011
# Whom: dougb@FreeBSD.org
#
# $FreeBSD$
#
PORTNAME= qbittorrent
PORTVERSION= 2.6.9
PORTREVISION?= 0
CATEGORIES= net-p2p ipv6
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}/
MAINTAINER= dougb@FreeBSD.org
COMMENT?= Bittorrent client using Qt4 and libtorrent-rasterbar
LIB_DEPENDS= execinfo.1:${PORTSDIR}/devel/libexecinfo \
torrent-rasterbar.6:${PORTSDIR}/net-p2p/libtorrent-rasterbar-15
NO_LATEST_LINK= yes
MAKE_JOBS_SAFE= yes
CONFLICTS= qbittorrent-2.[2345789].*
USE_QT_VER= 4
QT_COMPONENTS= corelib network qmake_build moc_build rcc_build
.if !defined(QB26_NOX_SLAVE)
.if defined(WITHOUT_X11)
BROKEN= Use net-p2p/${PORTNAME}-nox11 for the non-GUI version
.endif
LIB_DEPENDS+= GeoIP.5:${PORTSDIR}/net/GeoIP
OPTIONS= NOTIFY "Enable libnotify support" on
QT_COMPONENTS+= gui xml uic_build dbus
INSTALLS_ICONS= yes
.else
CONFIGURE_ARGS+= --disable-gui
.endif
QT_NONSTANDARD= yes
HAS_CONFIGURE= yes
MAN1?= qbittorrent.1
.include <bsd.port.pre.mk>
.if !defined(WITHOUT_NOTIFY)
LIB_DEPENDS+= notify.1:${PORTSDIR}/devel/libnotify
.else
CONFIGURE_ARGS+= --disable-libnotify
.endif
post-install:
.if !defined(QB26_NOX_SLAVE)
@${STRIP_CMD} ${PREFIX}/bin/qbittorrent
.else
@${STRIP_CMD} ${PREFIX}/bin/qbittorrent-nox
${INSTALL_MAN} ${WRKSRC}/doc/qbittorrent-nox.1 ${MANPREFIX}/man/man1
.endif
.include <bsd.port.post.mk>

View File

@ -1,2 +0,0 @@
SHA256 (qbittorrent-2.6.9.tar.gz) = be7e636bca0c42b69e991cd941603060c278e11d651331d40203d376687a7c8e
SIZE (qbittorrent-2.6.9.tar.gz) = 2959811

View File

@ -1,38 +0,0 @@
bin/qbittorrent
share/applications/qBittorrent.desktop
share/icons/hicolor/128x128/apps/qbittorrent.png
share/icons/hicolor/16x16/apps/qbittorrent.png
share/icons/hicolor/192x192/apps/qbittorrent.png
share/icons/hicolor/22x22/apps/qbittorrent.png
share/icons/hicolor/24x24/apps/qbittorrent.png
share/icons/hicolor/32x32/apps/qbittorrent.png
share/icons/hicolor/36x36/apps/qbittorrent.png
share/icons/hicolor/48x48/apps/qbittorrent.png
share/icons/hicolor/64x64/apps/qbittorrent.png
share/icons/hicolor/72x72/apps/qbittorrent.png
share/icons/hicolor/96x96/apps/qbittorrent.png
@dirrmtry share/icons/hicolor/96x96/apps
@dirrmtry share/icons/hicolor/96x96
@dirrmtry share/icons/hicolor/72x72/apps
@dirrmtry share/icons/hicolor/72x72
@dirrmtry share/icons/hicolor/64x64/apps
@dirrmtry share/icons/hicolor/64x64
@dirrmtry share/icons/hicolor/48x48/apps
@dirrmtry share/icons/hicolor/48x48
@dirrmtry share/icons/hicolor/36x36/apps
@dirrmtry share/icons/hicolor/36x36
@dirrmtry share/icons/hicolor/32x32/apps
@dirrmtry share/icons/hicolor/32x32
@dirrmtry share/icons/hicolor/24x24/apps
@dirrmtry share/icons/hicolor/24x24
@dirrmtry share/icons/hicolor/22x22/apps
@dirrmtry share/icons/hicolor/22x22
@dirrmtry share/icons/hicolor/192x192/apps
@dirrmtry share/icons/hicolor/192x192
@dirrmtry share/icons/hicolor/16x16/apps
@dirrmtry share/icons/hicolor/16x16
@dirrmtry share/icons/hicolor/128x128/apps
@dirrmtry share/icons/hicolor/128x128
@dirrmtry share/icons/hicolor
@dirrmtry share/icons
@dirrmtry share/applications

View File

@ -1,23 +0,0 @@
qBittorrent v2 is the closest open source (GNU GPL v2 license) equivalent
to utorrent. It is based on libtorrent-rasterbar.
Features:
Remote control through a Web user interface
* Nearly identical to the regular UI, all in Ajax
Well-integrated and extensible Search Engine
Simultaneous search in most famous BitTorrent search sites
Per-category-specific search requests (e.g. Books, Music, Movies)
All Bittorrent extensions
* DHT, Peer Exchange, Full encryption, Magnet URI
Advanced control over trackers, peers and torrents
* Torrents queueing and prioritizing
* Torrent content selection and prioritizing
UPnP / NAT-PMP port forwarding support
Available in ~25 languages (Unicode support)
utorrent spoofing to bypass private trackers whitelisting
Advanced RSS support with download filters (inc. regex)
IP Filtering (eMule and PeerGuardian compatible)
WWW: http://www.qbittorrent.org/

View File

@ -1 +0,0 @@
bin/qbittorrent-nox

View File

@ -1,2 +0,0 @@
SHA256 (qbittorrent-2.7.3.tar.gz) = 256412dede40645a434fbbbc4582298eaefc1e33c17b8e6b8a88cb86bb2850d5
SIZE (qbittorrent-2.7.3.tar.gz) = 3158727

View File

@ -1,201 +0,0 @@
diff -ur ./src/main.cpp ./src/main.cpp
--- ./src/main.cpp 2011-03-20 06:04:59.000000000 -0700
+++ ./src/main.cpp 2011-04-16 18:06:19.000000000 -0700
@@ -153,6 +153,15 @@
}
#endif
+#ifndef DISABLE_GUI
+void useStyle(QString style){
+ if(!style.isEmpty()) {
+ QApplication::setStyle(QStyleFactory::create(style));
+ }
+ Preferences().setStyle(QApplication::style()->objectName());
+}
+#endif
+
// Main
int main(int argc, char *argv[]){
// Create Application
@@ -277,6 +286,7 @@
}
#ifndef DISABLE_GUI
+ useStyle(pref.getStyle());
app.setStyleSheet("QStatusBar::item { border-width: 0; }");
#endif
diff -ur ./src/preferences/options.ui ./src/preferences/options.ui
--- ./src/preferences/options.ui 2011-04-09 02:12:42.000000000 -0700
+++ ./src/preferences/options.ui 2011-04-16 18:42:55.000000000 -0700
@@ -238,6 +238,45 @@
</widget>
</item>
<item>
+ <widget class="QGroupBox" name="StyleSettingsBox">
+ <property name="title">
+ <string>Style</string>
+ </property>
+ <layout class="QVBoxLayout" name="verticalLayout_41">
+ <property name="bottomMargin">
+ <number>0</number>
+ </property>
+ <item>
+ <layout class="QHBoxLayout">
+ <item>
+ <widget class="QLabel" name="lblStyle">
+ <property name="text">
+ <string>Visual style:</string>
+ </property>
+ </widget>
+ </item>
+ <item>
+ <widget class="QComboBox" name="comboStyle"/>
+ </item>
+ <item>
+ <spacer>
+ <property name="orientation">
+ <enum>Qt::Horizontal</enum>
+ </property>
+ <property name="sizeHint" stdset="0">
+ <size>
+ <width>40</width>
+ <height>20</height>
+ </size>
+ </property>
+ </spacer>
+ </item>
+ </layout>
+ </item>
+ </layout>
+ </widget>
+ </item>
+ <item>
<widget class="QGroupBox" name="groupBox_4">
<property name="title">
<string>Transfer list</string>
diff -ur ./src/preferences/options_imp.cpp ./src/preferences/options_imp.cpp
--- ./src/preferences/options_imp.cpp 2011-03-26 02:05:54.000000000 -0700
+++ ./src/preferences/options_imp.cpp 2011-04-16 18:10:56.000000000 -0700
@@ -36,6 +36,7 @@
#include <QDialogButtonBox>
#include <QCloseEvent>
#include <QDesktopWidget>
+#include <QStyleFactory>
#include <QTranslator>
#include <libtorrent/version.hpp>
@@ -87,6 +88,7 @@
connect(scanFoldersView->selectionModel(), SIGNAL(selectionChanged(QItemSelection,QItemSelection)), this, SLOT(handleScanFolderViewSelectionChanged()));
connect(buttonBox, SIGNAL(clicked(QAbstractButton*)), this, SLOT(applySettings(QAbstractButton*)));
+ comboStyle->addItems(QStyleFactory::keys());
// Languages supported
initializeLanguageCombo();
@@ -127,6 +129,7 @@
// Apply button is activated when a value is changed
// General tab
connect(comboI18n, SIGNAL(currentIndexChanged(int)), this, SLOT(enableApplyButton()));
+ connect(comboStyle, SIGNAL(currentIndexChanged(int)), this, SLOT(enableApplyButton()));
connect(checkAltRowColors, SIGNAL(toggled(bool)), this, SLOT(enableApplyButton()));
connect(checkShowSystray, SIGNAL(toggled(bool)), this, SLOT(enableApplyButton()));
connect(checkCloseToSystray, SIGNAL(toggled(bool)), this, SLOT(enableApplyButton()));
@@ -258,6 +261,10 @@
tabOption->setCurrentIndex(tabSelection->row(current));
}
+void options_imp::useStyle() {
+ QApplication::setStyle(QStyleFactory::create(comboStyle->itemText(comboStyle->currentIndex())));
+}
+
void options_imp::loadWindowState() {
QIniSettings settings(QString::fromUtf8("qBittorrent"), QString::fromUtf8("qBittorrent"));
resize(settings.value(QString::fromUtf8("Preferences/State/size"), sizeFittingScreen()).toSize());
@@ -311,6 +318,8 @@
void options_imp::saveOptions(){
applyButton->setEnabled(false);
Preferences pref;
+ // Apply style
+ useStyle();
// Load the translation
QString locale = getLocale();
if(pref.getLocale() != locale) {
@@ -325,6 +334,7 @@
// General preferences
pref.setLocale(locale);
+ pref.setStyle(getStyle());
pref.setAlternatingRowColors(checkAltRowColors->isChecked());
pref.setSystrayIntegration(systrayIntegration());
pref.setUseMonochromeTrayIcon(checkUseMonoSystrayIcon->isChecked());
@@ -459,6 +469,16 @@
}
}
+QString options_imp::getStyle() const{
+ return comboStyle->itemText(comboStyle->currentIndex());
+}
+
+void options_imp::setStyle(QString style) {
+ int index = comboStyle->findText(style, Qt::MatchFixedString);
+ if(index > 0)
+ comboStyle->setCurrentIndex(index);
+}
+
void options_imp::loadOptions(){
int intValue;
qreal floatValue;
@@ -466,6 +486,7 @@
// General preferences
const Preferences pref;
setLocale(pref.getLocale());
+ setStyle(pref.getStyle());
checkAltRowColors->setChecked(pref.useAlternatingRowColors());
checkShowSystray->setChecked(pref.systrayIntegration());
checkShowSplash->setChecked(!pref.isSlashScreenDisabled());
diff -ur ./src/preferences/options_imp.h ./src/preferences/options_imp.h
--- ./src/preferences/options_imp.h 2011-03-20 06:04:59.000000000 -0700
+++ ./src/preferences/options_imp.h 2011-04-16 18:11:19.000000000 -0700
@@ -63,6 +63,7 @@
void enableMaxConnecsLimitPerTorrent(bool checked);
void enableMaxUploadsLimitPerTorrent(bool checked);
void enableMaxRatio(bool checked);
+ void setStyle(QString style);
void on_buttonBox_accepted();
void closeEvent(QCloseEvent *e);
void on_buttonBox_rejected();
@@ -87,6 +88,7 @@
public slots:
void setLocale(QString locale);
+ void useStyle();
void showConnectionTab();
signals:
@@ -101,6 +103,7 @@
static QString languageToLocalizedString(QLocale::Language language, const QString& country);
// General options
QString getLocale() const;
+ QString getStyle() const;
bool systrayIntegration() const;
bool minimizeToTray() const;
bool closeToTray() const;
diff -ur ./src/preferences/preferences.h ./src/preferences/preferences.h
--- ./src/preferences/preferences.h 2011-03-23 09:50:59.000000000 -0700
+++ ./src/preferences/preferences.h 2011-04-16 18:06:19.000000000 -0700
@@ -77,6 +77,14 @@
setValue(QString::fromUtf8("Preferences/General/Locale"), locale);
}
+ QString getStyle() const {
+ return value(QString::fromUtf8("Preferences/General/Style"), "").toString();
+ }
+
+ void setStyle(const QString &style) {
+ setValue(QString::fromUtf8("Preferences/General/Style"), style);
+ }
+
bool useProgramNotification() const {
return value(QString::fromUtf8("Preferences/General/ProgramNotification"), true).toBool();
}

View File

@ -1,22 +0,0 @@
qBittorrent v2 is the closest open source (GNU GPL v2 license) equivalent
to utorrent. It is based on the Qt4 toolkit and libtorrent-rasterbar.
Features:
Well-integrated and extensible Search Engine
Simultaneous search in most famous BitTorrent search sites
Per-category-specific search requests (e.g. Books, Music, Movies)
All Bittorrent extensions
* DHT, Peer Exchange, Full encryption, Magnet URI
Remote control through a Web user interface
* Nearly identical to the regular UI, all in Ajax
Advanced control over trackers, peers and torrents
* Torrents queueing and prioritizing
* Torrent content selection and prioritizing
UPnP / NAT-PMP port forwarding support
Available in ~25 languages (Unicode support)
uTorrent spoofing to bypass private trackers whitelisting
Advanced RSS support with download filters (inc. regex)
IP Filtering (eMule and PeerGuardian compatible)
WWW: http://www.qbittorrent.org/

View File

@ -1,21 +1,20 @@
# New ports collection makefile for: qbittorrent-nox11-27
# Date created: 16 April 2011
# Whom: dougb@FreeBSD.org
# New ports collection makefile for: qbittorrent-nox11-28
# Date created: 5 June 2011
# Whom: Doug Barton <dougb@FreeBSD.org>
#
# $FreeBSD$
#
PKGNAMESUFFIX= -nox11
COMMENT= Bittorrent client using libtorrent-rasterbar, web UI version
MASTERDIR= ${.CURDIR}/../qbittorrent-27
MASTERDIR= ${.CURDIR}/../qbittorrent-28
DESCR= ${.CURDIR}/pkg-descr
PLIST= ${.CURDIR}/pkg-plist
MAN1= qbittorrent-nox.1
QB27_NOX_SLAVE= true
QB28_NOX_SLAVE= true
.include "${MASTERDIR}/Makefile"

View File

@ -1,12 +1,11 @@
# New ports collection makefile for: qbittorrent-27
# Date created: 16 April 2011
# Whom: dougb@FreeBSD.org
# New ports collection makefile for: qbittorrent-28
# Date created: 5 June 2011
# Whom: Doug Barton <dougb@FreeBSD.org>
#
# $FreeBSD$
#
PORTNAME= qbittorrent
PORTVERSION= 2.7.3
PORTVERSION= 2.8.1
PORTREVISION?= 0
CATEGORIES= net-p2p ipv6
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}/
@ -19,12 +18,12 @@ LIB_DEPENDS= execinfo.1:${PORTSDIR}/devel/libexecinfo \
MAKE_JOBS_SAFE= yes
CONFLICTS= qbittorrent-2.[2345689].*
CONFLICTS= qbittorrent-2.[2345679].*
USE_QT_VER= 4
QT_COMPONENTS= corelib network qmake_build moc_build rcc_build
.if !defined(QB27_NOX_SLAVE)
.if !defined(QB28_NOX_SLAVE)
.if defined(WITHOUT_X11)
BROKEN= Use net-p2p/${PORTNAME}-nox11 for the non-GUI version
.endif
@ -50,11 +49,12 @@ CONFIGURE_ARGS+= --disable-qt-dbus
.endif
post-install:
.if !defined(QB27_NOX_SLAVE)
.if !defined(QB28_NOX_SLAVE)
@${STRIP_CMD} ${PREFIX}/bin/qbittorrent
.else
@${STRIP_CMD} ${PREFIX}/bin/qbittorrent-nox
${INSTALL_MAN} ${WRKSRC}/doc/qbittorrent-nox.1 ${MANPREFIX}/man/man1
.endif
@${CAT} ${PKGMESSAGE}
.include <bsd.port.post.mk>

View File

@ -0,0 +1,2 @@
SHA256 (qbittorrent-2.8.1.tar.gz) = 768f6d8d3e73f74d8408279d51024abc584daeb16d2e219aa47aa4c0693c3c06
SIZE (qbittorrent-2.8.1.tar.gz) = 3306031

View File

@ -0,0 +1,5 @@
****************************************************************************
* To change the appearance of the interface use misc/qt4-qtconfig *
****************************************************************************