Add patch for MySQL 4.1.3 API and unbreak build.
Obtained from: DBD::mysql CVS
This commit is contained in:
parent
78d4c181ab
commit
a8d2e0b5d8
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=112946
14
databases/p5-DBD-mysql/files/patch-mysql.xs
Normal file
14
databases/p5-DBD-mysql/files/patch-mysql.xs
Normal file
@ -0,0 +1,14 @@
|
|||||||
|
--- mysql.xs.orig Fri Oct 17 19:20:50 2003
|
||||||
|
+++ mysql.xs Tue Jun 29 05:03:15 2004
|
||||||
|
@@ -97,7 +97,11 @@
|
||||||
|
}
|
||||||
|
|
||||||
|
if (strEQ(command, "shutdown")) {
|
||||||
|
+#if MYSQL_VERSION_ID < 40103
|
||||||
|
result = mysql_shutdown(sock);
|
||||||
|
+#else
|
||||||
|
+ result = mysql_shutdown(sock, SHUTDOWN_DEFAULT);
|
||||||
|
+#endif
|
||||||
|
} else if (strEQ(command, "reload")) {
|
||||||
|
result = mysql_reload(sock);
|
||||||
|
} else if (strEQ(command, "createdb")) {
|
@ -15,6 +15,4 @@ WANT_MYSQL_VER= 41
|
|||||||
|
|
||||||
MASTERDIR= ${.CURDIR}/../p5-DBD-mysql
|
MASTERDIR= ${.CURDIR}/../p5-DBD-mysql
|
||||||
|
|
||||||
BROKEN= "Does not compile"
|
|
||||||
|
|
||||||
.include "${MASTERDIR}/Makefile"
|
.include "${MASTERDIR}/Makefile"
|
||||||
|
Loading…
Reference in New Issue
Block a user