Fix build failure under FreeBSD-4.11.

PR:		87886
Submitted by:	parv
This commit is contained in:
Cy Schubert 2005-11-09 16:50:18 +00:00
parent 3d3ddd94ad
commit a8c128492a
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=147735
2 changed files with 21 additions and 5 deletions

View File

@ -7,7 +7,7 @@
PORTNAME= fvwm
PORTVERSION= 2.5.14
PORTREVISION= 4
PORTREVISION= 5
CATEGORIES= x11-wm
MASTER_SITES= ftp://ftp.fvwm.org/pub/fvwm/version-2/ \
http://www.fvwm.org/generated/icon_download/
@ -46,10 +46,6 @@ OPTIONS= ICONS "Install default icon set" on \
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 501000
BROKEN= Does not build
.endif
.if !defined(WITHOUT_ICONS)
DISTFILES+= fvwm_icons.tgz
.endif

View File

@ -0,0 +1,20 @@
--- modules/FvwmProxy/FvwmProxy.c.orig Fri Aug 12 08:25:45 2005
+++ modules/FvwmProxy/FvwmProxy.c Wed Nov 9 07:29:08 2005
@@ -719,14 +719,15 @@
{
Bool rc = False;
ProxyWindow *other=proxy->next;
+ int dx, dy;
for (other=proxy->next; other; other=other->next)
{
if(other->desk != deskNumber)
continue;
- int dx=abs(proxy->proxyx-other->proxyx);
- int dy=abs(proxy->proxyy-other->proxyy);
+ dx=abs(proxy->proxyx-other->proxyx);
+ dy=abs(proxy->proxyy-other->proxyy);
if (dx<(proxyWidth+proxySeparation) &&
dy<proxyHeight+proxySeparation )
{