New port for `xblackjack'

This commit is contained in:
Eric L. Hernes 1996-08-16 13:28:47 +00:00
parent 02c59addd7
commit a8adcff438
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=3618
6 changed files with 78 additions and 0 deletions

17
games/xblackjack/Makefile Normal file
View File

@ -0,0 +1,17 @@
# New ports collection makefile for: xblackjack
# Version required: 2.2
# Date created:
# Whom: erich@FreeBSD.org
#
# $Id$
#
DISTNAME= xblackjack-2.2
CATEGORIES+= games
MASTER_SITES= ftp://ftp.x.org/contrib/games/
REQUIRES_MOTIF= yes
USE_IMAKE= yes
MAINTAINER= erich@FreeBSD.org
.include <bsd.port.mk>

View File

@ -0,0 +1 @@
MD5 (xblackjack-2.2.tar.gz) = d8e2114e0d8ee4caece7fbbb53479872

View File

@ -0,0 +1,35 @@
--- Imakefile~ Thu Aug 1 21:41:28 1996
+++ Imakefile Thu Aug 1 21:41:43 1996
@@ -54,7 +54,7 @@
/*
* You may need to remove -lbsd.
*/
- EXTRA_LIBRARIES = -lXm $(DEPLIBS) -lbsd
+ EXTRA_LIBRARIES = -lXm -lXt -lXmu -lXext -lX11
#endif
/*
--- Table.c~ Thu Aug 1 21:39:10 1996
+++ Table.c Thu Aug 1 21:40:50 1996
@@ -229,7 +229,8 @@
/* always_install_accelerators */ False,
#if XmVersion > 1000
/* geo_matrix_create */ NULL,
- /* focus_moved_proc */ XtInheritFocusMovedProc,
+ /* focus_moved_proc */ /*XtInheritFocusMovedProc,*/
+ XtCallAcceptFocus,
#endif
/* extension */ NULL,
},
--- TableP.h~ Thu Aug 1 21:36:01 1996
+++ TableP.h Thu Aug 1 21:38:03 1996
@@ -15,6 +15,9 @@
#include "Table.h"
#include <Xm/XmP.h>
+#include <Xm/TravActI.h>
+#include <Xm/ManagerI.h>
+#include <Xm/BulletinBI.h>
#include <Xm/BulletinBP.h>
/*

View File

@ -0,0 +1 @@
an X11/Motif blackjack game

View File

@ -0,0 +1,21 @@
From The README:
Xblackjack is a MOTIF/OLIT based tool constructed to get you ready for the
casino. It was inspired by a book called "Beat the Dealer" by Edward O.
Thorp, Ph.D. of UCLA. A number of important statistics are maintained for
display, and used by the program to implement Thorp's "Complete Point System"
(high-low system).
Beginners can learn a basic strategy which doesn't require counting. The
best strategy employs a simple card counting technique which can be used to
distinguish favorable situations. Avid players can learn to compute Thorp's
high-low index, which takes the number of unseen cards into account.
The index is used by the program to suggest a bet, indicate when you should
buy insurance, and whether you should stand or hit, etc. You can test the
strategy using a slider to control "autoplay mode". Pressing the message
button below the playing area provides hints; the current count, index
and strategy table are revealed.
eric.
erich@FreeBSD.org

View File

@ -0,0 +1,3 @@
bin/xblackjack
man/man1/xblackjack.1.gz
lib/X11/app-defaults/XBlackjack