- Upgrade to imap-2001.FINAL

- Install additional cclient header files
- Move SSL dependency generation for cclient to post-build
- Bump PORTEPOCH
- Removed -drac PKGNAMESUFFIX,more confusion than extra info
- Remove futile build of imapd/ipop3d/ipop2d in cclient, and libc-client4.a
  in the imap-uw port.
- Respect CFLAGS and CC

PR:		30954
Submitted by:	maintainer
This commit is contained in:
Pete Fritchman 2001-10-05 08:28:52 +00:00
parent 921229802d
commit a88be6b77c
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=48462
13 changed files with 128 additions and 76 deletions

View File

@ -6,7 +6,8 @@
#
PORTNAME= cclient
PORTVERSION= 0106191041
PORTVERSION= 2001
PORTEPOCH= 1
CATEGORIES= mail devel
MASTER_SITES= ftp://ftp.cac.washington.edu/imap/ \
http://www.freenix.no/~anders/ \
@ -14,7 +15,7 @@ MASTER_SITES= ftp://ftp.cac.washington.edu/imap/ \
http://mirror.nucba.ac.jp/mirror/ \
ftp://ftp.nuug.no/pub/anders/distfiles/
MASTER_SITE_SUBDIR= . old
DISTNAME= imap-2001.BETA.SNAP-${PORTVERSION}
DISTNAME= imap-2001.FINAL
EXTRACT_SUFX= .tar.Z
MAINTAINER= anders@fix.no
@ -26,6 +27,8 @@ MAKE_ARGS+= SSLTYPE=unix
USE_OPENSSL= yes
.endif
WRKSRC= ${WRKDIR}/imap-2001.RELEASE-CANDIDATE.1
SHLIBBASE= c-client4
SHLIBMAJ= 8
SHLIBNAME= lib${SHLIBBASE}.so.${SHLIBMAJ}
@ -49,10 +52,20 @@ post-patch:
post-configure:
@${ECHO_MSG} ">> The c-client shared library will be named ${SHLIBNAME}"
HEADERS= dummy.h env.h env_unix.h fdstring.h flstring.h fs.h ftl.h \
imap4r1.h linkage.c linkage.h mail.h misc.h nl.h nntp.h \
osdep.h pop3.h rfc822.h smtp.h tcp.h utf8.h c-client.h
PORTREV_H= ${PREFIX}/include/c-client/portrevision.h
HEADERS= c-client.h dummy.h env.h env_unix.h fdstring.h flocksim.h \
flstring.h fs.h ftl.h imap4r1.h linkage.c linkage.h mail.h \
mbox.h mbx.h mh.h misc.h mmdf.h mtx.h mx.h netmsg.h news.h \
newsrc.h nl.h nntp.h osdep.h phile.h pop3.h pseudo.h rfc822.h \
smtp.h sslio.h tcp.h tcp_unix.h tenex.h unix.h utf8.h
PORTREV_H= ${WRKDIR}/portrevision.h
post-build:
@${ECHO} "#define CCLIENT_PORTVERSION \"${PORTVERSION}\"" >${PORTREV_H}
.if defined(WITH_SSL)
@${ECHO} "#define CCLIENT_SSLENABLED \"yes\"" >>${PORTREV_H}
.else
@${ECHO} "#define CCLIENT_SSLENABLED \"no\"" >>${PORTREV_H}
.endif
do-install:
${MKDIR} ${PREFIX}/include/c-client
@ -66,16 +79,13 @@ do-install:
${PREFIX}/lib/lib${SHLIBBASE}.a
post-install:
@${ECHO} "#define CCLIENT_PORTVERSION \"${PORTVERSION}\"" >${PORTREV_H}
${INSTALL_DATA} ${PORTREV_H} ${PREFIX}/include/c-client
.if defined(WITH_SSL)
@${ECHO} "================================================================================"
@${ECHO} "Warning: You have chosen to include SSL support. Applications/ports that use"
@${ECHO} "the cclient library but do not support SSL may stop working or have problems
@${ECHO} "linking. Linking explicitly with ssl (-lssl -lcrypto) may or may not help."
@${ECHO} "================================================================================"
@${ECHO} "#define CCLIENT_SSLENABLED \"yes\"" >>${PORTREV_H}
.else
@${ECHO} "#define CCLIENT_SSLENABLED \"no\"" >>${PORTREV_H}
.endif
.include <bsd.port.post.mk>

View File

@ -1 +1 @@
MD5 (imap-2001.BETA.SNAP-0106191041.tar.Z) = 119117c9ba437b6de64c68326fe5ddc8
MD5 (imap-2001.FINAL.tar.Z) = b26456af47ba63c5624d0ed434690e4d

View File

@ -1,5 +1,5 @@
--- src/osdep/unix/Makefile.orig Wed Apr 11 00:02:06 2001
+++ src/osdep/unix/Makefile Sat Apr 14 02:59:26 2001
--- src/osdep/unix/Makefile.orig Tue Jul 3 08:02:10 2001
+++ src/osdep/unix/Makefile Mon Oct 1 10:13:43 2001
@@ -22,18 +22,18 @@
EXTRAAUTHENTICATORS=
@ -81,7 +81,7 @@
bsi: # BSD/i386
$(BUILD) `$(CAT) SPECIALS` OS=$@ \
@@ -762,15 +767,26 @@
@@ -762,23 +767,35 @@
# Build it!
@ -108,9 +108,11 @@
+ $(CC) -fpic -DPIC -c $(CFLAGS) ${@:.so=.c} -o $@
+
.c.o:
`$(CAT) CCTYPE` -c `$(CAT) CFLAGS` $*.c
- `$(CAT) CCTYPE` -c `$(CAT) CFLAGS` $*.c
+ $(CC) -c $(CFLAGS) $*.c
@@ -779,6 +795,7 @@
# Cleanup
clean:
sh -c '$(RM) auths.c crexcl.c nfstest.c linkage.[ch] siglocal.c osdep*.[ch] *.o ARCHIVE *FLAGS *TYPE $(ARCHIVE) || true'

View File

@ -1,6 +1,6 @@
--- Makefile.orig Sun Dec 17 23:09:44 2000
+++ Makefile Sun Dec 17 23:08:58 2000
@@ -314,7 +314,7 @@
--- Makefile.orig Tue Jul 3 08:00:09 2001
+++ Makefile Mon Oct 1 09:52:24 2001
@@ -256,7 +256,7 @@
# Make the IMAP Toolkit
@ -9,3 +9,22 @@
c-client:
@echo Not processed yet. In a first-time build, you must specify
@@ -367,7 +367,7 @@
$(TOOLS)/$@ "$(LN)" src/imapd imapd
$(LN) $(TOOLS)/$@ .
-build: OSTYPE rebuild rebuildclean bundled
+build: OSTYPE rebuild rebuildclean
OSTYPE:
@echo Building c-client for $(BUILDTYPE)...
@@ -385,8 +385,7 @@
@sh -c '(test $(BUILDTYPE) = rebuild -o $(BUILDTYPE) = `$(CAT) OSTYPE`) || (echo Already built for `$(CAT) OSTYPE` -- you must do \"make clean\" first && exit 1)'
@echo Rebuilding c-client for `$(CAT) OSTYPE`...
$(TOUCH) c-client/SPECIALS
- $(CD) c-client;$(MAKE) all CC=`$(CAT) CCTYPE` \
- CFLAGS="`$(CAT) CFLAGS`" `$(CAT) SPECIALS`
+ $(CD) c-client;$(MAKE) all CFLAGS="`$(CAT) CFLAGS`" `$(CAT) SPECIALS`
rebuildclean:
sh -c '$(RM) rebuild || true'

View File

@ -3,6 +3,7 @@ include/c-client/dummy.h
include/c-client/env.h
include/c-client/env_unix.h
include/c-client/fdstring.h
include/c-client/flocksim.h
include/c-client/flstring.h
include/c-client/fs.h
include/c-client/ftl.h
@ -10,14 +11,29 @@ include/c-client/imap4r1.h
include/c-client/linkage.c
include/c-client/linkage.h
include/c-client/mail.h
include/c-client/mbox.h
include/c-client/mbx.h
include/c-client/mh.h
include/c-client/misc.h
include/c-client/mmdf.h
include/c-client/mtx.h
include/c-client/mx.h
include/c-client/netmsg.h
include/c-client/news.h
include/c-client/newsrc.h
include/c-client/nl.h
include/c-client/nntp.h
include/c-client/osdep.h
include/c-client/phile.h
include/c-client/pop3.h
include/c-client/pseudo.h
include/c-client/rfc822.h
include/c-client/smtp.h
include/c-client/sslio.h
include/c-client/tcp.h
include/c-client/tcp_unix.h
include/c-client/tenex.h
include/c-client/unix.h
include/c-client/utf8.h
include/c-client/portrevision.h
lib/%%SHLIBNAME%%

View File

@ -6,7 +6,8 @@
#
PORTNAME= imap
PORTVERSION= 0106191041
PORTVERSION= 2001
PORTEPOCH= 1
CATEGORIES= mail
MASTER_SITES= ftp://ftp.cac.washington.edu/imap/%SUBDIR%/ \
ftp://ftp.nuug.no/pub/anders/distfiles/%SUBDIR%/ \
@ -15,12 +16,8 @@ MASTER_SITES= ftp://ftp.cac.washington.edu/imap/%SUBDIR%/ \
http://mirror.nucba.ac.jp/mirror/imap/%SUBDIR%/ \
ftp://ftp.uni-halle.de/pub/mail/pine/%SUBDIR%/
MASTER_SITE_SUBDIR= . old
.if defined(WITH_DRAC)
PKGNAMESUFFIX= -uw-drac
.else
PKGNAMESUFFIX= -uw
.endif
DISTNAME= imap-2001.BETA.SNAP-${PORTVERSION}
DISTNAME= imap-2001.FINAL
DISTFILES= ${DISTNAME}.tar.Z imap-utils.tar.Z
MAINTAINER= anders@fix.no
@ -30,6 +27,8 @@ LIB_DEPENDS= c-client4.8:${PORTSDIR}/mail/cclient
BUILD_DEPENDS= ${LOCALBASE}/lib/libdrac.a:${PORTSDIR}/mail/drac
.endif
WRKSRC= ${WRKDIR}/imap-2001.RELEASE-CANDIDATE.1
MAN8= ipopd.8 imapd.8
ALL_TARGET= bsf
@ -121,7 +120,7 @@ post-install:
.endif
.if defined(WITH_SSL)
@${ECHO} "To create and install a new SSL certificate for imapd and ipop3d, type \"make"
@${ECHO} "cert\"."
@${ECHO} "cert\". Or install manually in ${PREFIX}/certs."
@${ECHO}
@${ECHO} "Example inetd config for SSL only services:"
@${ECHO}

View File

@ -1,2 +1,2 @@
MD5 (imap-2001.BETA.SNAP-0106191041.tar.Z) = 119117c9ba437b6de64c68326fe5ddc8
MD5 (imap-2001.FINAL.tar.Z) = b26456af47ba63c5624d0ed434690e4d
MD5 (imap-utils.tar.Z) = a6453029f201b32e9ed761e662c47b0f

View File

@ -1,5 +1,5 @@
--- src/imapd/Makefile.orig Thu May 10 07:31:46 2001
+++ src/imapd/Makefile Wed Jun 20 02:29:42 2001
--- src/imapd/Makefile.orig Thu Jun 28 19:23:36 2001
+++ src/imapd/Makefile Mon Oct 1 05:00:17 2001
@@ -18,10 +18,10 @@
# CPYRIGHT, included with this Distribution.
@ -24,25 +24,24 @@
# Un-comment this to get somewhat better interoperability with Microsoft
@@ -52,22 +54,25 @@
@@ -61,22 +63,21 @@
# Get local definitions from c-client directory
C = ../c-client
-CCLIENTLIB = $C/c-client.a
+#CCLIENTLIB = $C/c-client.a
CC = `cat $C/CCTYPE`
-CFLAGS = -I$C `cat $C/CFLAGS` $(RFC1730) $(NSBD) $(MSBD) -DANOFILE=\"$(ANO)\" \
+.if defined(WITH_DRAC)
+CFLAGS = `cat $C/CFLAGS` -DANOFILE=\"$(ANO)\" -DETC_DIR=\"$(PREFIX)/etc\" \
+ -DALERTFILE=\"$(ALERT)\" -DUSERALERTFILE=\"$(USERALERT)\" -DDRAC_AUTH \
+ -DSHUTDOWNFILE=\"$(SHUTDOWN)\"
+LDFLAGS = $(EXTRALDFLAGS) `cat $C/LDFLAGS` -ldrac
+.else
+CFLAGS = `cat $C/CFLAGS` -DANOFILE=\"$(ANO)\" \
-DALERTFILE=\"$(ALERT)\" -DUSERALERTFILE=\"$(USERALERT)\" \
-DSHUTDOWNFILE=\"$(SHUTDOWN)\"
-CC = `cat $C/CCTYPE`
-CFLAGS = -I$C `cat $C/CFLAGS` $(RFC1730) $(NSBD) $(MSBD) $(ENBD) \
- -DANOFILE=\"$(ANO)\" -DALERTFILE=\"$(ALERT)\" \
- -DUSERALERTFILE=\"$(USERALERT)\" -DSHUTDOWNFILE=\"$(SHUTDOWN)\"
-LDFLAGS = $(CCLIENTLIB) `cat $C/LDFLAGS`
+LDFLAGS = $(EXTRALDFLAGS) `cat $C/LDFLAGS`
+#CCLIENTLIB = $C/c-client.a
+CFLAGS+= -DNFSKLUDGE -I$(LOCALBASE)/include/c-client -DANOFILE=\"$(ANO)\" \
+ -DALERTFILE=\"$(ALERT)\" -DUSERALERTFILE=\"$(USERALERT)\" \
+ -DSHUTDOWNFILE=\"$(SHUTDOWN)\"
+LDFLAGS+= $(EXTRALDFLAGS) -L$(LOCALBASE)/lib -lc-client4
+.if defined(WITH_DRAC)
+CFLAGS+= -DETC_DIR=\"$(PREFIX)/etc\" -DDRAC_AUTH
+LDFLAGS+= -ldrac
+.endif
+CFLAGS+= $(RFC1730) $(NSBD) $(MSBD)

View File

@ -1,5 +1,5 @@
--- Makefile.old Thu Nov 2 22:04:11 2000
+++ Makefile Sun Dec 31 19:06:58 2000
--- Makefile.orig Tue Jul 3 08:00:09 2001
+++ Makefile Mon Oct 1 03:27:22 2001
@@ -43,6 +43,7 @@
# art AIX 2.2.1 for RT
# asv Altos SVR4
@ -8,7 +8,7 @@
# bs3 BSD/i386 3.0 and higher
# bsd generic BSD 4.3 (as in ancient 1980s version)
# bsf FreeBSD
@@ -153,7 +154,7 @@
@@ -146,7 +147,7 @@
# std system standard (typically passwd file), determined by port
# two try alternative (defined by CHECKPWALT), then std
@ -16,8 +16,8 @@
+PASSWDTYPE=pam
# The following extra compilation flags are defined. None of these flags are
@@ -272,12 +273,12 @@
# SSL type. Defines whether or not SSL support is on this system
@@ -211,12 +212,12 @@
# gradually-increasing intervals, starting at 2800-2900, and becoming
# permanent at 48,300.
@ -32,7 +32,7 @@
# Special make flags (e.g. to override make environment variables)
@@ -314,13 +315,7 @@
@@ -256,13 +257,7 @@
# Make the IMAP Toolkit
@ -43,7 +43,16 @@
- @echo the system type so that the sources are properly processed.
- @false
-
+all: rebuild bundled
+all: bundled
# Note on SCO you may have to set LN to "ln".
@@ -367,7 +362,7 @@
$(TOOLS)/$@ "$(LN)" src/imapd imapd
$(LN) $(TOOLS)/$@ .
-build: OSTYPE rebuild rebuildclean bundled
+build: bundled
OSTYPE:
@echo Building c-client for $(BUILDTYPE)...

View File

@ -1,6 +1,6 @@
--- src/ipopd/Makefile.old Wed Oct 25 01:55:07 2000
+++ src/ipopd/Makefile Sun Dec 31 18:23:16 2000
@@ -19,29 +19,27 @@
--- src/ipopd/Makefile.orig Wed Oct 25 01:55:07 2000
+++ src/ipopd/Makefile Mon Oct 1 03:44:26 2001
@@ -19,29 +19,25 @@
C = ../c-client
@ -10,15 +10,14 @@
# Get local definitions from c-client directory
CC = `cat $C/CCTYPE`
-CC = `cat $C/CCTYPE`
-CFLAGS = -I$C `cat $C/CFLAGS`
-LDFLAGS = $(CCLIENTLIB) `cat $C/LDFLAGS`
+CFLAGS+= -DNFSKLUDGE -I$(LOCALBASE)/include/c-client
+LDFLAGS+= -L$(LOCALBASE)/lib -lc-client4
+.if defined(WITH_DRAC)
+CFLAGS = `cat $C/CFLAGS` -DDRAC_AUTH -DETC_DIR=\"$(PREFIX)/etc\"
+LDFLAGS = `cat $C/LDFLAGS` -ldrac
+.else
+CFLAGS = `cat $C/CFLAGS`
+LDFLAGS = `cat $C/LDFLAGS`
+CFLAGS+= -DDRAC_AUTH -DETC_DIR=\"$(PREFIX)/etc\"
+LDFLAGS+= -ldrac
+.endif
ipopd: ipop2d ipop3d

View File

@ -1,21 +1,19 @@
--- src/mtest/Makefile.orig Tue Apr 14 15:42:04 1998
+++ src/mtest/Makefile Fri Jul 7 00:28:59 2000
@@ -32,24 +32,20 @@
--- src/mtest/Makefile.orig Wed Oct 25 01:55:39 2000
+++ src/mtest/Makefile Mon Oct 1 03:42:11 2001
@@ -19,24 +19,17 @@
C = ../c-client
-CCLIENTLIB = $C/c-client.a
+#CCLIENTLIB = $C/c-client.a
SHELL = /bin/sh
# Get local definitions from c-client directory
CC = `cat $C/CCTYPE`
-CC = `cat $C/CCTYPE`
-CFLAGS = -I$C `cat $C/CFLAGS`
-LDFLAGS = $(CCLIENTLIB) `cat $C/LDFLAGS`
+CFLAGS = `cat $C/CFLAGS`
+LDFLAGS = `cat $C/LDFLAGS`
+
+CFLAGS+= -DNFSKLUDGE -I$(LOCALBASE)/include/c-client
+LDFLAGS+= -L$(LOCALBASE)/lib -lc-client4
all: mtest

View File

@ -1,5 +1,5 @@
--- src/ipopd/ipop3d.c.orig Tue Apr 24 01:31:57 2001
+++ src/ipopd/ipop3d.c Tue Apr 24 01:34:34 2001
--- src/ipopd/ipop3d.c.orig Mon Oct 1 02:53:55 2001
+++ src/ipopd/ipop3d.c Mon Oct 1 02:56:46 2001
@@ -28,6 +28,11 @@
#include <time.h>
#include "c-client.h"
@ -22,7 +22,7 @@
+extern char *getenv ();
+#endif /* DRAC_AUTH */
+
char *version = "2001.76"; /* server version */
char *version = "2001.77"; /* server version */
short state = AUTHORIZATION; /* server state */
short critical = NIL; /* non-zero if in critical code */
@@ -100,7 +111,7 @@

View File

@ -1,6 +1,6 @@
--- src/imapd/imapd.c.orig Wed Jun 20 01:57:16 2001
+++ src/imapd/imapd.c Wed Jun 20 02:01:00 2001
@@ -29,6 +29,11 @@
--- src/imapd/imapd.c.orig Mon Oct 1 02:51:23 2001
+++ src/imapd/imapd.c Mon Oct 1 02:52:59 2001
@@ -29,6 +29,12 @@
#include "c-client.h"
#include <sys/stat.h>
@ -9,10 +9,11 @@
+#include <arpa/inet.h>
+#include <stdlib.h>
+#endif /* DRAC_AUTH */
+
#define CRLF PSOUT ("\015\012") /* primary output terpri */
@@ -173,6 +178,12 @@
@@ -173,6 +179,12 @@
/* Global storage */
@ -22,10 +23,10 @@
+extern char *getenv ();
+#endif /* DRAC_AUTH */
+
char *version = "2001.307"; /* version number of this server */
char *version = "2001.313"; /* version number of this server */
time_t alerttime = 0; /* time of last alert */
time_t sysalerttime = 0; /* time of last system alert */
@@ -1169,6 +1180,45 @@
@@ -1229,6 +1241,45 @@
lasterror ());
return;
}