Add bush 1.0.1, the Business Shell.

This commit is contained in:
Thierry Thomas 2005-01-23 21:57:07 +00:00
parent 797b6b5689
commit a869d5d2cc
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=127152
7 changed files with 177 additions and 0 deletions

View File

@ -8,6 +8,7 @@
SUBDIR += bash-completion
SUBDIR += bash1
SUBDIR += bash2
SUBDIR += bush
SUBDIR += es
SUBDIR += esh
SUBDIR += fd

68
shells/bush/Makefile Normal file
View File

@ -0,0 +1,68 @@
# New ports collection makefile for: bush
# Date created: 20 December 2004
# Whom: Thierry Thomas <thierry@pompo.net>
#
# $FreeBSD$
#
PORTNAME= bush
PORTVERSION= 1.0.1
CATEGORIES= shells
MASTER_SITES= http://www.pegasoft.ca/downloads/ \
http://66.11.182.223/downloads/
EXTRACT_SUFX= -src.tgz
MAINTAINER= ports@FreeBSD.org
COMMENT= The Business Shell
BUILD_DEPENDS= gnatmake:${PORTSDIR}/lang/gnat \
bash:${PORTSDIR}/shells/bash
LIB_DEPENDS= pq.3:${PORTSDIR}/${POSTGRESQL_PORT}
POSTGRESQL_PORT?= databases/postgresql7
HAS_CONFIGURE= yes
USE_GMAKE= yes
MAKE_ARGS= GMAKE=${GMAKE} CPUTYPE=${CPUTYPE} \
PTHREAD_LIBS=${PTHREAD_LIBS}
MAKEFILE= GNUmakefile
USE_MYSQL= yes
BROKEN_WITH_MYSQL= 323
USE_REINPLACE= yes
MAN1= bush.1
PORTDOCS= *
BASH2FIX= examples/benchmark.bash src/testsuite/test.sh
pre-build:
.for FILE in ${BASH2FIX}
@${REINPLACE_CMD} -e "s|/bin/bash|${LOCALBASE}/bin/bash|" ${WRKSRC}/${FILE}
.endfor
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/bush ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/src/bush.1 ${MANPREFIX}/man/man1
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/doc/* ${DOCSDIR}
${MKDIR} ${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/examples/* ${EXAMPLESDIR}
.endif
post-install:
@${ECHO_CMD} ${PREFIX}/bin/bush >> /etc/shells
@${ECHO_MSG} "Updating /etc/shells"
@${CP} /etc/shells /etc/shells.bak
@(${GREP} -v ${PREFIX}/bin/bush /etc/shells.bak ; \
${ECHO_CMD} ${PREFIX}/bin/bush) > /etc/shells
@${RM} /etc/shells.bak
.if defined(MAINTAINER_MODE)
test: build
@(cd ${BUILD_WRKSRC} && \
${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} test)
.endif
.include <bsd.port.mk>

2
shells/bush/distinfo Normal file
View File

@ -0,0 +1,2 @@
MD5 (bush-1.0.1-src.tgz) = 34d8d9ceeb002b61976df99e05325d38
SIZE (bush-1.0.1-src.tgz) = 1355249

View File

@ -0,0 +1,15 @@
--- src/GNUmakefile.orig Sat Jan 8 04:08:31 2005
+++ src/GNUmakefile Fri Jan 21 22:52:36 2005
@@ -5,9 +5,9 @@
# These are filled in by ./configure. If they are incorrect, change them for
# your system...
-CC=gcc
-CPU=i686
-MAKE=gmake
+#CC=gcc
+MAKE=${GMAKE}
+CPU=${CPUTYPE}
GNATMAKE=gnatmake
# RPM Directories For Building an RPM file

View File

@ -0,0 +1,11 @@
--- src/apq-2.1/mysql_incl.orig Wed Sep 24 21:56:27 2003
+++ src/apq-2.1/mysql_incl Fri Jan 21 23:43:18 2005
@@ -1,7 +1,7 @@
#
if [ ! -f config.win32 ] ; then
- echo $(mysql_config --cflags) | sed "s|^.*'\(.*\)'.*$|\1|"
+ echo $(mysql_config --include) | sed 's|^-I||'
else
sed -n '/^MY_UINCL/p' <config.win32 | sed 's|^.*=||;s| *$||'
fi

12
shells/bush/pkg-descr Normal file
View File

@ -0,0 +1,12 @@
BUSH, the Business Shell, is a powerful Linux/UNIX shell for designing
secure, reliable scripts that can be later compiled as a fast executable
programs.
It can also be used an an interactive login shell or to generate Java
Virtual Machine or .Net applications. BUSH is a robust and readable
alternative to BASH, CSH, and (to a certain extent) Python and PERL.
BUSH comes with 12 built-in packages including numerics, string processing,
sound and database access.
WWW: http://www.pegasoft.ca/bush.html

68
shells/bush/pkg-plist Normal file
View File

@ -0,0 +1,68 @@
bin/bush
@exec echo "updating /etc/shells"; cp /etc/shells /etc/shells.bak; (grep -v %D/%F /etc/shells.bak; echo %D/%F) >/etc/shells
@unexec echo "updating /etc/shells"; cp /etc/shells /etc/shells.bak; (grep -v %D/%F /etc/shells.bak) >/etc/shells
%%PORTDOCS%%%%EXAMPLESDIR%%/arrow.wav
%%PORTDOCS%%%%EXAMPLESDIR%%/bats.wav
%%PORTDOCS%%%%EXAMPLESDIR%%/benchdata.txt
%%PORTDOCS%%%%EXAMPLESDIR%%/benchmark.adb
%%PORTDOCS%%%%EXAMPLESDIR%%/benchmark.bash
%%PORTDOCS%%%%EXAMPLESDIR%%/benchmark.bash.bak
%%PORTDOCS%%%%EXAMPLESDIR%%/benchmark.bush
%%PORTDOCS%%%%EXAMPLESDIR%%/benchmark.ksh
%%PORTDOCS%%%%EXAMPLESDIR%%/benchmark.sh
%%PORTDOCS%%%%EXAMPLESDIR%%/bjack.bush
%%PORTDOCS%%%%EXAMPLESDIR%%/bjack.gif
%%PORTDOCS%%%%EXAMPLESDIR%%/bjack.html
%%PORTDOCS%%%%EXAMPLESDIR%%/camel.bush
%%PORTDOCS%%%%EXAMPLESDIR%%/camel.gif
%%PORTDOCS%%%%EXAMPLESDIR%%/camel.html
%%PORTDOCS%%%%EXAMPLESDIR%%/chomp.bush
%%PORTDOCS%%%%EXAMPLESDIR%%/chomp.html
%%PORTDOCS%%%%EXAMPLESDIR%%/chomp2.bush
%%PORTDOCS%%%%EXAMPLESDIR%%/chomp2.html
%%PORTDOCS%%%%EXAMPLESDIR%%/clap.wav
%%PORTDOCS%%%%EXAMPLESDIR%%/database.bush
%%PORTDOCS%%%%EXAMPLESDIR%%/database.gif
%%PORTDOCS%%%%EXAMPLESDIR%%/database.html
%%PORTDOCS%%%%EXAMPLESDIR%%/dos.txt
%%PORTDOCS%%%%EXAMPLESDIR%%/dos2.txt
%%PORTDOCS%%%%EXAMPLESDIR%%/draco_ii.bush
%%PORTDOCS%%%%EXAMPLESDIR%%/draco_ii.gif
%%PORTDOCS%%%%EXAMPLESDIR%%/draco_ii.html
%%PORTDOCS%%%%EXAMPLESDIR%%/draco_score.txt
%%PORTDOCS%%%%EXAMPLESDIR%%/eliza.bush
%%PORTDOCS%%%%EXAMPLESDIR%%/eliza.data
%%PORTDOCS%%%%EXAMPLESDIR%%/eliza.gif
%%PORTDOCS%%%%EXAMPLESDIR%%/eliza.html
%%PORTDOCS%%%%EXAMPLESDIR%%/export.sh
%%PORTDOCS%%%%EXAMPLESDIR%%/files.html
%%PORTDOCS%%%%EXAMPLESDIR%%/game.bush
%%PORTDOCS%%%%EXAMPLESDIR%%/game.gif
%%PORTDOCS%%%%EXAMPLESDIR%%/game.html
%%PORTDOCS%%%%EXAMPLESDIR%%/hello.bush
%%PORTDOCS%%%%EXAMPLESDIR%%/hello.html
%%PORTDOCS%%%%EXAMPLESDIR%%/index.html
%%PORTDOCS%%%%EXAMPLESDIR%%/main.html
%%PORTDOCS%%%%EXAMPLESDIR%%/menu.bush
%%PORTDOCS%%%%EXAMPLESDIR%%/menu.html
%%PORTDOCS%%%%EXAMPLESDIR%%/menu2.bush
%%PORTDOCS%%%%EXAMPLESDIR%%/menu2.html
%%PORTDOCS%%%%EXAMPLESDIR%%/minimal_cgi.bush
%%PORTDOCS%%%%EXAMPLESDIR%%/minimal_cgi.html
%%PORTDOCS%%%%EXAMPLESDIR%%/pit.wav
%%PORTDOCS%%%%EXAMPLESDIR%%/poetry.bush
%%PORTDOCS%%%%EXAMPLESDIR%%/poetry.gif
%%PORTDOCS%%%%EXAMPLESDIR%%/poetry.html
%%PORTDOCS%%%%EXAMPLESDIR%%/postgres_csv.bush
%%PORTDOCS%%%%EXAMPLESDIR%%/postgres_csv.html
%%PORTDOCS%%%%EXAMPLESDIR%%/quest.bush
%%PORTDOCS%%%%EXAMPLESDIR%%/quest.html
%%PORTDOCS%%%%EXAMPLESDIR%%/run.wav
%%PORTDOCS%%%%EXAMPLESDIR%%/scream.wav
%%PORTDOCS%%%%EXAMPLESDIR%%/scripting.c
%%PORTDOCS%%%%EXAMPLESDIR%%/validate_name.bush
%%PORTDOCS%%%%EXAMPLESDIR%%/validate_name.html
%%PORTDOCS%%%%EXAMPLESDIR%%/wumpus.bush
%%PORTDOCS%%%%EXAMPLESDIR%%/wumpus.gif
%%PORTDOCS%%%%EXAMPLESDIR%%/wumpus.html
%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%