MFH: r523239
databases/mysq56-{client, server}: Update to latest release 5.7.29 Bugs Fixed: - InnoDB: os_file_get_parent_dir warnings were encountered when compiling MySQL with GCC 9.2.0. - InnoDB: An internal function (btr_push_update_extern_fields()) used to fetch newly added externally stored fields and update them during a pessimistic update or when going back to a previous version of a record was no longer required. Newly added externally stored fields are updated by a different function. Also, the method used to determine the number of externally stored fields was corrected. - InnoDB: A comparison function found two records to be equal when attempting to merge non-leaf pages of a spatial index. The function was unable to handle this unexpected condition, which resulted in a long semaphore wait and an eventual assertion failure. - Replication: A memory leak could occur when a failed replication group member tried to rejoin a minority group and was disallowed from doing so. - Docker packages were missing the LDAP authentication plugins. More Infos: https://dev.mysql.com/doc/relnotes/mysql/5.7/en/news-5-7-29.html Approved by: mmokhi (maintainer, implicit) Security: a6cf65ad-37d2-11ea-a1c7-b499baebfeaf Sponsored by: Netzkommune GmbH Approved by: ports-secteam (with hat)
This commit is contained in:
parent
c0b66fbeb3
commit
a8417e4033
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/branches/2020Q1/; revision=523298
@ -2,7 +2,7 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= mysql
|
||||
PORTREVISION= 1
|
||||
PORTREVISION= 0
|
||||
PKGNAMESUFFIX= 57-client
|
||||
|
||||
COMMENT= Multithreaded SQL database (client)
|
||||
|
@ -2,8 +2,8 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME?= mysql
|
||||
PORTVERSION= 5.7.28
|
||||
PORTREVISION= 2
|
||||
PORTVERSION= 5.7.29
|
||||
PORTREVISION= 0
|
||||
CATEGORIES= databases
|
||||
MASTER_SITES= MYSQL/MySQL-5.7
|
||||
PKGNAMESUFFIX?= 57-server
|
||||
|
@ -1,3 +1,3 @@
|
||||
TIMESTAMP = 1574613665
|
||||
SHA256 (mysql-boost-5.7.28.tar.gz) = f16399315212117c08f9bdf8a0d682728b2ce82d691bcfbf25a770f413b6f2da
|
||||
SIZE (mysql-boost-5.7.28.tar.gz) = 51409668
|
||||
TIMESTAMP = 1579122971
|
||||
SHA256 (mysql-boost-5.7.29.tar.gz) = 00f514124de2bad1ba7b380cbbd46e316cae7fc7bc3a5621456cabf352f27978
|
||||
SIZE (mysql-boost-5.7.29.tar.gz) = 51417554
|
||||
|
@ -1,16 +1,18 @@
|
||||
--- libmysql/authentication_ldap/CMakeLists.txt.orig 2018-10-04 05:48:22 UTC
|
||||
+++ libmysql/authentication_ldap/CMakeLists.txt
|
||||
@@ -106,11 +106,13 @@ ELSE()
|
||||
--- libmysql/authentication_ldap/CMakeLists.txt.orig 2020-01-16 09:39:09.585385000 +0100
|
||||
+++ libmysql/authentication_ldap/CMakeLists.txt 2020-01-16 09:41:59.054985000 +0100
|
||||
@@ -47,6 +47,7 @@ IF(NOT WIN32 AND NOT HAVE_LBER_H)
|
||||
CROAK_AND_RETURN("Required LBER header is missing.")
|
||||
ENDIF()
|
||||
|
||||
MESSAGE(STATUS "SASL_LIBRARY = ${SASL_LIBRARY}")
|
||||
+IF (WITH_AUTHENTICATION_LDAP)
|
||||
MYSQL_ADD_PLUGIN(authentication_ldap_sasl_client
|
||||
auth_ldap_sasl_client.cc log_client.cc
|
||||
LINK_LIBRARIES ${SASL_LIBRARY}
|
||||
CLIENT_ONLY MODULE_ONLY
|
||||
MODULE_OUTPUT_NAME "authentication_ldap_sasl_client")
|
||||
auth_ldap_sasl_client.cc
|
||||
log_client.cc
|
||||
@@ -57,6 +58,7 @@ MYSQL_ADD_PLUGIN(authentication_ldap_sasl_client
|
||||
CLIENT_ONLY
|
||||
MODULE_ONLY
|
||||
MODULE_OUTPUT_NAME "authentication_ldap_sasl_client")
|
||||
+ENDIF ()
|
||||
|
||||
IF(WIN32)
|
||||
GET_FILENAME_COMPONENT(SASL_DLL_NAME ${SASL_LIBRARY_DLL} NAME)
|
||||
# The plugin may need symbols which are not loaded by the client.
|
||||
IF(STATIC_SASL_LIBRARY)
|
||||
|
Loading…
Reference in New Issue
Block a user