add p5-OpenGL 0.54
Perl module to display 3D data using OpenGL, GLU, GLUT, and GLX
This commit is contained in:
parent
27f74870e7
commit
a7fb7328a9
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=72644
@ -252,6 +252,7 @@
|
||||
SUBDIR += p5-Image-Size
|
||||
SUBDIR += p5-Imager
|
||||
SUBDIR += p5-Imlib2
|
||||
SUBDIR += p5-OpenGL
|
||||
SUBDIR += p5-chart
|
||||
SUBDIR += p5-ming
|
||||
SUBDIR += panorama
|
||||
|
24
graphics/p5-OpenGL/Makefile
Normal file
24
graphics/p5-OpenGL/Makefile
Normal file
@ -0,0 +1,24 @@
|
||||
# ex:ts=8
|
||||
# Ports collection makefile for: p5-OpenGL
|
||||
# Date created: Jan 7, 2003
|
||||
# Whom: ijliao
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= OpenGL
|
||||
PORTVERSION= 0.54
|
||||
CATEGORIES= graphics perl5
|
||||
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
|
||||
MASTER_SITE_SUBDIR= ../by-authors/id/I/IL/ILYAZ/modules
|
||||
PKGNAMEPREFIX= p5-
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
|
||||
PERL_CONFIGURE= yes
|
||||
USE_MESA= yes
|
||||
|
||||
post-patch:
|
||||
@${PERL} -pi -e "s|%%PTHREAD_LIBS%%|${PTHREAD_LIBS}|g" ${WRKSRC}/Makefile.PL
|
||||
|
||||
.include <bsd.port.mk>
|
1
graphics/p5-OpenGL/distinfo
Normal file
1
graphics/p5-OpenGL/distinfo
Normal file
@ -0,0 +1 @@
|
||||
MD5 (OpenGL-0.54.tar.gz) = ff53886f6fc0d81ddde0e40725c8e33b
|
11
graphics/p5-OpenGL/files/patch-Makefile.PL
Normal file
11
graphics/p5-OpenGL/files/patch-Makefile.PL
Normal file
@ -0,0 +1,11 @@
|
||||
--- Makefile.PL.orig Wed Jun 20 16:39:13 2001
|
||||
+++ Makefile.PL Thu Oct 10 22:51:15 2002
|
||||
@@ -17,7 +17,7 @@
|
||||
|
||||
$pm_lib = (grep /^X11$/, @ARGV) ? '' : '-lopengl';
|
||||
|
||||
-$libs = "-lGLU -lGLUT -lGLX $pm_lib -lMesaGLU -lMesaGLUT -lMesaGLX -lglut";
|
||||
+$libs = "-lglut %%PTHREAD_LIBS%%";
|
||||
|
||||
@libs = findlib->ext("$libdirs $libs");
|
||||
|
1
graphics/p5-OpenGL/pkg-comment
Normal file
1
graphics/p5-OpenGL/pkg-comment
Normal file
@ -0,0 +1 @@
|
||||
Perl module to display 3D data using OpenGL, GLU, GLUT, and GLX
|
4
graphics/p5-OpenGL/pkg-descr
Normal file
4
graphics/p5-OpenGL/pkg-descr
Normal file
@ -0,0 +1,4 @@
|
||||
This module provides access to most of the OpenGL 1.0, 1.1, and 1.2 APIs.
|
||||
Some amount of GLU is supported (I'm not quite sure what version it works
|
||||
out to), and GLUT should be completely supported up to API version 3. A
|
||||
small portion of GLX and X11 is supported, as an alternative to GLUT.
|
6
graphics/p5-OpenGL/pkg-plist
Normal file
6
graphics/p5-OpenGL/pkg-plist
Normal file
@ -0,0 +1,6 @@
|
||||
%%SITE_PERL%%/%%PERL_ARCH%%/auto/OpenGL/OpenGL.bs
|
||||
%%SITE_PERL%%/%%PERL_ARCH%%/auto/OpenGL/OpenGL.so
|
||||
%%SITE_PERL%%/%%PERL_ARCH%%/auto/OpenGL/autosplit.ix
|
||||
%%SITE_PERL%%/%%PERL_ARCH%%/auto/OpenGL/.packlist
|
||||
%%SITE_PERL%%/%%PERL_ARCH%%/OpenGL.pm
|
||||
@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/OpenGL
|
Loading…
Reference in New Issue
Block a user