Update to use sendfile-19980228
PR: 5887 Submitted by: Stefan 'Sec' Zehl <sec@42.org>
This commit is contained in:
parent
33849bac0a
commit
a7e7418d16
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=9983
@ -1,23 +1,25 @@
|
||||
# New ports collection makefile for: sendfile
|
||||
# Version required: 2.1
|
||||
# Date created: 23 February 1998
|
||||
# Date created: 30 Oct 1997
|
||||
# Whom: sec@42.org
|
||||
#
|
||||
# $Id$
|
||||
# $Id: Makefile,v 1.1.1.1 1998/02/24 20:28:16 steve Exp $
|
||||
#
|
||||
|
||||
DISTNAME= sendfile-2.1
|
||||
DISTNAME= sendfile-19980228
|
||||
PKGNAME= sendfile-2.1
|
||||
CATEGORIES= net
|
||||
MASTER_SITES= ftp://ftp.uni-stuttgart.de/pub/unix/comm/sendfile/current/
|
||||
|
||||
MAINTAINER= sec@42.org
|
||||
|
||||
WRKSRC= ${WRKDIR}/${PKGNAME}
|
||||
|
||||
HAS_CONFIGURE= yes
|
||||
CONFIGURE_SCRIPT=makeconfig
|
||||
CONFIGURE_ENV= PREFIX="${PREFIX}"
|
||||
|
||||
MAN1= sendfile.1 sendmsg.1 receive.1
|
||||
MAN1= sendfile.1 sendmsg.1 receive.1 fetchfile.1
|
||||
MAN7= fetchfile.7
|
||||
MAN8= sendfiled.8
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
@ -1 +1 @@
|
||||
MD5 (sendfile-2.1.tar.gz) = a8d4fefab7073e0602071512b1362267
|
||||
MD5 (sendfile-19980228.tar.gz) = bb2a3e8c4906b37237fa958a8bf8bb1a
|
||||
|
@ -1,11 +1,10 @@
|
||||
--- makeconfig.org Tue Sep 30 21:54:25 1997
|
||||
+++ makeconfig Tue Sep 30 21:55:50 1997
|
||||
@@ -11,15 +11,15 @@
|
||||
--- makeconfig.orig Sat Feb 28 13:21:59 1998
|
||||
+++ makeconfig Sun Mar 1 19:45:58 1998
|
||||
@@ -11,15 +11,14 @@
|
||||
|
||||
# default compiling settings
|
||||
CC=gcc
|
||||
-CFLAGS=-O2
|
||||
+#CFLAGS=-O2
|
||||
LDFLAGS=-s
|
||||
|
||||
# default installation settings
|
||||
@ -21,11 +20,10 @@
|
||||
INETDCONF=/etc/inetd.conf
|
||||
SERVICES=/etc/services
|
||||
|
||||
@@ -33,7 +33,7 @@
|
||||
#PGP=/usr/local/bin/pgp
|
||||
@@ -35,6 +34,7 @@
|
||||
#RECODE=/usr/local/bin/recode
|
||||
#METAMAIL=/usr/local/bin/metamail
|
||||
-#SENDMAIL=/usr/lib/sendmail
|
||||
#SENDMAIL=/usr/lib/sendmail
|
||||
+SENDMAIL=/usr/sbin/sendmail
|
||||
|
||||
######################### END OF USER CONFIGURATION ##########################
|
||||
|
@ -1,25 +1,9 @@
|
||||
--- develop/install.orig Tue Feb 24 14:06:09 1998
|
||||
+++ develop/install Tue Feb 24 14:09:09 1998
|
||||
@@ -98,31 +98,6 @@
|
||||
if [ "$INETDCONF" = "" ]; then INETDCONF=/etc/inetd.conf; fi
|
||||
if [ "$SERVICES" = "" ]; then SERVICES=/etc/services; fi
|
||||
--- develop/install.orig Fri Feb 27 08:29:16 1998
|
||||
+++ develop/install Sun Mar 1 15:34:53 1998
|
||||
@@ -133,14 +133,6 @@
|
||||
To deinstall the sendfile-daemon, simply type: rm $SERVERDIR/sendfiled
|
||||
|
||||
-cat <<EOD
|
||||
-WARNING: this sendfile install script will create or write to:
|
||||
-
|
||||
- spool directory = $SPOOL
|
||||
- binary directory = $BINDIR
|
||||
- manual directory = $MANDIR
|
||||
- sendfiled directory = $SERVERDIR
|
||||
- configuration files = $CONFIG
|
||||
- $DENY
|
||||
-
|
||||
-In /etc/services and /etc/inetd.conf apropriate ads will be inserted.
|
||||
-In /etc/profile and /etc/csh.login a call to sendfile_check will be added.
|
||||
-
|
||||
-To deinstall the sendfile-daemon, simply type: rm $SERVERDIR/sendfiled
|
||||
-
|
||||
-EOD
|
||||
EOD
|
||||
-echo 'If you are satisfied with these defaults, then type "ok" now:'
|
||||
-read answer
|
||||
-if [ "$answer" != ok ]; then
|
||||
@ -28,11 +12,26 @@
|
||||
- echo
|
||||
- exit
|
||||
-fi
|
||||
-
|
||||
|
||||
umask 022
|
||||
|
||||
echo "checking for directories"
|
||||
@@ -234,33 +209,9 @@
|
||||
@@ -195,6 +187,7 @@
|
||||
echo " there is $SERVERDIR/sendfiled in makeconfig! Check it!"
|
||||
fi
|
||||
echo "installing the sendfile-daemon in $SERVERDIR"
|
||||
+[ -x $SERVERDIR/sendfiled ] && mv $SERVERDIR/sendfiled $SERVERDIR/sendfiled.old
|
||||
cp src/sendfiled $SERVERDIR || exit 1
|
||||
|
||||
NOSENDFILE=`dirname $DENY 2>/dev/null`/nosendfile
|
||||
@@ -240,7 +233,6 @@
|
||||
echo "saft 487/tcp # simple asynchronous file transfer" | niload services .
|
||||
else
|
||||
echo "configuring $SERVICES"
|
||||
- echo "#" >>$SERVICES
|
||||
echo "saft 487/tcp # simple asynchronous file transfer" >>$SERVICES
|
||||
fi
|
||||
fi
|
||||
@@ -253,8 +245,6 @@
|
||||
fi
|
||||
RESTART=true
|
||||
echo "configuring $INETDCONF"
|
||||
@ -41,38 +40,34 @@
|
||||
echo "saft stream tcp nowait root $SFD" >>$INETDCONF
|
||||
fi
|
||||
|
||||
-if [ -f /etc/inetd.sec ]; then
|
||||
- if [ "`grep '^saft' /etc/inetd.sec`" = "" ]; then
|
||||
- echo >> /etc/inetd.sec
|
||||
- echo "saft allow" >> /etc/inetd.sec
|
||||
- fi
|
||||
-fi
|
||||
-
|
||||
-if [ -f /etc/profile ]; then
|
||||
- if [ "`grep check_sendfile /etc/profile`" = "" ]; then
|
||||
- echo "adding check_sendfile to /etc/profile"
|
||||
- echo >>/etc/profile
|
||||
- echo test -x $BINDIR/check_sendfile && $BINDIR/check_sendfile >>/etc/profile
|
||||
- fi
|
||||
-fi
|
||||
-if [ -f /etc/csh.login ]; then
|
||||
- if [ "`grep check_sendfile /etc/csh.login`" = "" ]; then
|
||||
- echo "adding check_sendfile to /etc/csh.login"
|
||||
- echo >>/etc/csh.login
|
||||
- echo test -x $BINDIR/check_sendfile && $BINDIR/check_sendfile >>/etc/profile
|
||||
- fi
|
||||
-fi
|
||||
-
|
||||
if [ ! -d "$SPOOL/OUTGOING" ]; then
|
||||
echo "creating $SPOOL"
|
||||
mkdir_recursive $SPOOL/OUTGOING
|
||||
@@ -303,9 +254,3 @@
|
||||
echo "This will start an outgoing spooling sendfile daemon on boot time"
|
||||
echo "which processes any old files in the outgoing spool."
|
||||
echo
|
||||
-
|
||||
-if [ "$RESTART" = true ]; then
|
||||
@@ -278,7 +268,7 @@
|
||||
echo "adding check_sendfile to /etc/csh.login"
|
||||
echo >>/etc/csh.login
|
||||
echo "test -x $BINDIR/check_sendfile && $BINDIR/check_sendfile" \
|
||||
- >>/etc/profile
|
||||
+ >>/etc/csh.login
|
||||
fi
|
||||
fi
|
||||
|
||||
@@ -318,15 +308,11 @@
|
||||
EOD
|
||||
fi
|
||||
|
||||
-echo
|
||||
-echo "You may want to add the following line to your system bootup script:"
|
||||
-echo " $SERVERDIR/sendfiled -Q"
|
||||
-echo "This will start an outgoing spooling sendfile daemon on boot time"
|
||||
-echo "which processes any old files in the outgoing spool."
|
||||
-echo
|
||||
+echo "[ -x $SERVERDIR/sendfiled ] && $SERVERDIR/sendfiled -Q && echo -n ' sendfiled'">${PREFIX}/etc/rc.d/sendfiled.sh
|
||||
+chmod a+x ${PREFIX}/etc/rc.d/sendfiled.sh
|
||||
|
||||
if [ "$RESTART" = true ]; then
|
||||
- echo
|
||||
- echo "please restart now your inetd ( or simply reboot :-) )"
|
||||
- echo
|
||||
-fi
|
||||
+ kill -HUP `ps auxw|awk '$11 == "inetd" { print $2 } '`
|
||||
+ [ -f $SERVERDIR/sendfiled.old ] && rm -f $SERVERDIR/sendfiled.old
|
||||
fi
|
||||
+true
|
||||
\ No newline at end of file
|
||||
|
@ -1,16 +1,25 @@
|
||||
bin/check_sendfile
|
||||
bin/fetchfile
|
||||
bin/receive
|
||||
bin/sendfile
|
||||
bin/sendmsg
|
||||
bin/sf_cleanup
|
||||
bin/sfconf
|
||||
bin/sfdconf
|
||||
bin/utf7decode
|
||||
bin/utf7encode
|
||||
bin/wlock
|
||||
etc/rc.d/sendfiled.sh
|
||||
etc/sendfile.cf
|
||||
etc/sendfile.deny
|
||||
sbin/sendfiled
|
||||
man/man1/fetchfile.1.gz
|
||||
man/man1/receive.1.gz
|
||||
man/man1/sendfile.1.gz
|
||||
man/man1/sendmsg.1.gz
|
||||
man/man7/fetchfile.7.gz
|
||||
man/man8/sendfiled.8.gz
|
||||
sbin/sendfiled
|
||||
|
||||
@exec mkdir -p /var/spool/sendfile/OUTGOING /var/spool/sendfile/LOG
|
||||
@exec chmod 755 /var/spool/sendfile
|
||||
@exec chmod 1777 /var/spool/sendfile/OUTGOING
|
||||
@ -20,6 +29,7 @@ man/man1/sendmsg.1.gz
|
||||
@exec echo -e 'saft\tstream\ttcp\tnowait\troot\t/usr/local/sbin/sendfiled sendfiled' >> /etc/inetd.conf
|
||||
@exec echo -e 'saft\t\t487/tcp\t# simple asynchronous file transfer'>>/etc/services
|
||||
@exec kill -HUP `ps auxw|awk '$11 == "inetd" { print $2 } '`
|
||||
|
||||
@unexec perl -pi.bak -e '/^saft/ && ($_="")' /etc/inetd.conf
|
||||
@unexec kill -HUP `ps auxw|awk '$11 == "inetd" { print $2 } '`
|
||||
@unexec rm -R /var/spool/sendfile
|
||||
|
Loading…
Reference in New Issue
Block a user