Upgrade to lilypond 2.3.4

fixed same issues as in ports/67984 (fontforge workaround)

PR:		67991
Submitted by:	Patrick Atamaniuk <patrick@mail.frobs.net> (maintainer)
This commit is contained in:
Oliver Eikemeier 2004-06-15 23:05:52 +00:00
parent f4713fae40
commit a7c091026f
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=111556
15 changed files with 682 additions and 673 deletions

View File

@ -4,27 +4,27 @@
# based on print/lilypond originally by trevor
#
# $FreeBSD$
# $$Id: Makefile,v 1.41 2004/02/05 18:29:10 patrick Exp $
# $Id: Makefile,v 1.19 2004/06/15 21:53:22 patrick Exp $
#
PORTNAME= lilypond
PORTVERSION= 2.1.19
PORTVERSION= 2.3.4
CATEGORIES= print audio
MASTER_SITES= http://lilypond.org/download/v2.1/ \
http://www.atabersk.de/lilypond/
MASTER_SITES= http://lilypond.org/download/v2.3/
PKGNAMESUFFIX= -devel
MAINTAINER= atamaniuk-ports@frobs.net
COMMENT= The GNU music typesetter (unstable/development)
COMMENT= The GNU music typesetter (development)
BUILD_DEPENDS= latex:${PORTSDIR}/print/teTeX \
mftrace:${PORTSDIR}/print/mftrace
scrollkeeper-install:${PORTSDIR}/textproc/scrollkeeper
LIB_DEPENDS= guile.15:${PORTSDIR}/lang/guile
RUN_DEPENDS= latex:${PORTSDIR}/print/teTeX
MAN1= abc2ly.1 convert-ly.1 etf2ly.1 lilypond.1 lilypond-bin.1 \
lilypond-book.1 midi2ly.1 mup2ly.1 musedata2ly.1 pmx2ly.1
INFO= lilypond lilypond-internals music-glossary
MAN1= abc2ly.1 etf2ly.1 midi2ly.1 mup2ly.1 lilypond.1 musedata2ly.1 \
convert-ly.1 lilypond-bin.1 lilypond-book.1
INFO= lilypond lilypond-internals \
music-glossary
CONFLICTS= lilypond-2.*
@ -38,16 +38,23 @@ MAKEFILE= GNUmakefile
PKGINSTALL= ${WRKDIR}/pkg-install
CONFIGURE_ARGS+= --with-kpathsea-include=${LOCALBASE}/include \
--with-kpathsea-lib=${LOCALBASE}/lib
--with-kpathsea-lib=${LOCALBASE}/lib \
--infodir=${PREFIX}/info
CONFIGURE_ENV+= "CPPFLAGS=${CPPFLAGS}"
.if defined(WITH_SELFBUILT_FONTS)
BUILD_DEPENDS+= mftrace:${PORTSDIR}/print/mftrace
.else
BUILD_DEPENDS+= wget:${PORTSDIR}/ftp/wget
BUILD_DEPENDS+= rpm2cpio:${PORTSDIR}/archivers/rpm
.endif
# inform kpathsea.h of getopt-prototype version
CFLAGS+= -D__GNU_LIBRARY__
CPPFLAGS+= -I${WRKSRC}/lily/out
CFLAGS+= ${CPPFLAGS}
.include <bsd.port.pre.mk>
MAKE_ENV+= MAKE_PFA_FILES=1
ALL_TARGET= all
.if ${OSVERSION} < 500000
@ -77,23 +84,23 @@ pre-configure:
| ${SED} -e "s=${PREFIX}=\$${PKG_PREFIX}=g" \
> ${PKGINSTALL}
.if !defined(WITH_SELFBUILT_FONTS)
post-configure:
cd ${WRKSRC} && ${GMAKE} -C mf get-pfa
.endif
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR} ${EXAMPLESDIR}/scripts
cd ${WRKSRC}/input ; \
${TAR} -chf - --exclude=out --exclude=CVS --exclude=GNUmakefile . | \
${TAR} -xf - -C ${EXAMPLESDIR};
.for ii in login profile
${INSTALL_SCRIPT} ${WRKSRC}/buildscripts/out/lilypond-${ii} \
${EXAMPLESDIR}/scripts
.endfor
.for ii in lilypond-font-lock.el lilypond-indent.el lilypond-init.el \
lilypond-mode.el lilypond-init.el
${INSTALL_SCRIPT} ${WRKSRC}/elisp/${ii} ${EXAMPLESDIR}/scripts
.endfor
.for ii in lilypond.vim server.el.patch
${INSTALL_SCRIPT} ${WRKSRC}/${ii} ${EXAMPLESDIR}/scripts
.endfor
cd ${WRKSRC}/Documentation/topdocs/out && ${TAR} -chf - \
--exclude=dummy.dep --exclude=CVS --exclude=GNUmakefile . \
| ${TAR} -xf - -C ${DOCSDIR}

View File

@ -1,2 +1,2 @@
MD5 (lilypond-2.1.19.tar.gz) = d1b9616e6f408c03f7ec74798684a5fe
SIZE (lilypond-2.1.19.tar.gz) = 1795785
MD5 (lilypond-2.3.4.tar.gz) = 6f36600cbe117b13f9d6da54e58ce552
SIZE (lilypond-2.3.4.tar.gz) = 1911869

View File

@ -1,16 +0,0 @@
--- GNUmakefile.in.orig Wed Oct 15 15:53:47 2003
+++ GNUmakefile.in Wed Oct 15 15:54:18 2003
@@ -9,12 +9,11 @@
# descent order into subdirectories
#
SUBDIRS = buildscripts python scripts \
- elisp \
flower lily \
mf ly tex ps scm \
po make \
cygwin debian stepmake \
- Documentation input
+ input
#
SCRIPTS = configure aclocal.m4 autogen.sh lexer-gcc-3.1.sh

View File

@ -1,13 +0,0 @@
--- Documentation/user/GNUmakefile.orig Sat Sep 20 00:36:19 2003
+++ Documentation/user/GNUmakefile Sat Sep 20 00:36:30 2003
@@ -24,9 +24,7 @@
INFO_DOCS = lilypond lilypond-internals music-glossary
INFO_FILES = $(INFO_DOCS:%=$(outdir)/%.info)
-STEPMAKE_TEMPLATES=tex texinfo omf documentation
-
-OMF_FILES += $(outdir)/lilypond-internals.html.omf
+STEPMAKE_TEMPLATES=tex texinfo documentation
LOCALSTEPMAKE_TEMPLATES=lilypond ly
LILYPOND_BOOK_FLAGS=--extra-options '-e "(ly:set-option (quote internal-type-checking) \#t)"'

View File

@ -1,19 +0,0 @@
--- Documentation/user/lilypond.tely.orig Sat Sep 27 11:16:47 2003
+++ Documentation/user/lilypond.tely Mon Oct 6 16:04:34 2003
@@ -17,16 +17,6 @@
@direntry
@c ;; prepend GNU for dir, must be unique
* GNU LilyPond: (lilypond). The GNU music typesetter.
-* lilypond: (lilypond)Invoking lilypond:: Titling LilyPond scores.
-* Glossary: (music-glossary). Glossary of music terms.
-* convert-ly: (lilypond)Invoking convert-ly:: Older LilyPond versions.
-* midi2ly: (lilypond)Invoking midi2ly:: Importing MIDI.
-* etf2ly: (lilypond)Invoking etf2ly:: Importing Finale.
-* abc2ly: (lilypond)Invoking abc2ly:: Importing ABC.
-* pmx2ly: (lilypond)Invoking pmx2ly:: Importing PMX.
-* musedata2ly: (lilypond)Invoking musedata2ly::
- Importing Musedata.
-* mup2ly: (lilypond)Invoking mup2ly:: Importing MUP.
@end direntry

View File

@ -1,21 +0,0 @@
--- Documentation/user/music-glossary.tely.orig Mon Oct 6 16:04:06 2003
+++ Documentation/user/music-glossary.tely Mon Oct 6 16:04:24 2003
@@ -2,6 +2,18 @@
@settitle Music Glossary
@setfilename music-glosssary.info
+@ignore
+Distributions will want to install lilypond.info doing:
+
+ ./install-info --info-dir=/usr/share/info out/lilypond.info
+
+@end ignore
+@dircategory GNU music project
+@direntry
+@c ;; prepend GNU for dir, must be unique
+* Music Glossary: (music-glossary). Glossary of music terms.
+@end direntry
+
@ifhtml
This document is also available in @uref{music-glossary.ps.gz,gzipped

View File

@ -0,0 +1,23 @@
--- Documentation/user/lilypond.tely.orig Sun Apr 11 09:44:32 2004
+++ Documentation/user/lilypond.tely Sun Apr 11 09:45:09 2004
@@ -17,14 +17,14 @@
@c prepend GNU for dir, must be unique
@c do not list the `lilypond' node at toplevel, so that `info lilypond'
@c goes to Top.
-@c * lilypond: (lilypond/lilypond)Invoking LilyPond. Titling LilyPond scores.
-* GNU LilyPond: (lilypond/lilypond). The GNU music typesetter.
-* convert-ly: (lilypond/lilypond)Invoking convert-ly. Older LilyPond versions.
-* midi2ly: (lilypond/lilypond)Invoking midi2ly. Importing MIDI.
-* etf2ly: (lilypond/lilypond)Invoking etf2ly. Importing Finale.
-* abc2ly: (lilypond/lilypond)Invoking abc2ly. Importing ABC.
-* musedata2ly: (lilypond/lilypond)Invoking musedata2ly. Importing MuseData.
-* mup2ly: (lilypond/lilypond)Invoking mup2ly. Importing Mup.
+@c * lilypond: (lilypond)Invoking LilyPond. Titling LilyPond scores.
+* GNU LilyPond: (lilypond). The GNU music typesetter.
+* convert-ly: (lilypond)Invoking convert-ly. Older LilyPond versions.
+* midi2ly: (lilypond)Invoking midi2ly. Importing MIDI.
+* etf2ly: (lilypond)Invoking etf2ly. Importing Finale.
+* abc2ly: (lilypond)Invoking abc2ly. Importing ABC.
+* musedata2ly: (lilypond)Invoking musedata2ly. Importing MuseData.
+* mup2ly: (lilypond)Invoking mup2ly. Importing Mup.
@end direntry

View File

@ -0,0 +1,11 @@
--- Documentation/user/music-glossary.tely.orig Sun Apr 11 09:45:14 2004
+++ Documentation/user/music-glossary.tely Sun Apr 11 09:45:23 2004
@@ -4,7 +4,7 @@
@dircategory GNU music project
@direntry
-* Glossary: (lilypond/music-glossary). Glossary of music terms.
+* Glossary: (music-glossary). Glossary of music terms.
@end direntry
@ifhtml

View File

@ -0,0 +1,11 @@
--- config.make.in.orig Sun Apr 11 10:26:32 2004
+++ config.make.in Sun Apr 11 10:26:46 2004
@@ -41,7 +41,7 @@
# move out of config.make.in?
package_datadir = $(datadir)/$(package)
-package_infodir = $(infodir)/$(package)
+package_infodir = $(infodir)
package_libdir = $(libdir)/$(package)
package_docdir = $(docdir)/$(package)
package_omfdir = $(omfdir)/$(package)

View File

@ -1,11 +0,0 @@
--- lily/parser.yy.orig Thu Feb 5 19:50:36 2004
+++ lily/parser.yy Thu Feb 5 19:50:42 2004
@@ -893,7 +893,7 @@
scm_gc_unprotect_object ($2->self_scm ());
$$ = unsmob_music (res);
scm_gc_protect_object (res);
- $$->set_spot (THIS->here_input())
+ $$->set_spot (THIS->here_input());
}
| PARTCOMBINE Music Music {
static SCM proc;

View File

@ -1,11 +0,0 @@
--- make/ly-rules.make.orig Tue Sep 23 20:50:18 2003
+++ make/ly-rules.make Thu Sep 25 10:37:07 2003
@@ -33,7 +33,7 @@
# nfo: info from non-lily texi
$(outdir)/%.info: $(outdir)/%.nexi
- $(MAKEINFO) --output=$(outdir)/$(*F).info $<
+ $(MAKEINFO) --no-split --output=$(outdir)/$(*F).info $<
# nfo: info from non-lily texi
#$(outdir)/%.nfo: $(outdir)/%.nexi

View File

@ -1,11 +0,0 @@
--- scm/documentation-generate.scm.orig Mon Oct 6 15:28:49 2003
+++ scm/documentation-generate.scm Mon Oct 6 15:29:09 2003
@@ -43,7 +43,7 @@
(display
(string-append
"@c -*-texinfo-*-"
- (texi-file-head "LilyPond program-reference" outname "(lilypond-internals.info)")
+ (texi-file-head "LilyPond program-reference" file-name "(lilypond-internals.info)")
"
@ifhtml

View File

@ -1,5 +1,3 @@
This port installs the UNSTABLE development version of LilyPond.
LilyPond is a music typesetter. It produces sheet music using a
high-level description file, which is plain text, as input. You
can use your favorite text editor to enter the description files.

File diff suppressed because it is too large Load Diff

View File

@ -4,7 +4,7 @@ cd ${WRKSRC} || exit 2
echo "Patching for FlexLexer.h <->gcc3 issues"
file=""
candidates=`find /usr/include/ -name FlexLexer.h`
candidates=`find /usr/include -name FlexLexer.h`
#take first found file.
for d in $candidates; do if [ -f $d ]; then file=$d; break; fi; done
if [ -z "${file}" ]; then echo "Cannot find FlexLexer.h"; exit 2; fi