Add pointcloud to the ports tree

A PostgreSQL extension for storing point cloud (LIDAR) data.
PR:	221577
This commit is contained in:
Palle Girgensohn 2017-09-26 17:51:47 +00:00
parent da772adc9e
commit a7aa667e23
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=450685
7 changed files with 70 additions and 0 deletions

View File

@ -660,6 +660,7 @@
SUBDIR += phppgadmin
SUBDIR += pldebugger
SUBDIR += plpgsql_check
SUBDIR += pointcloud
SUBDIR += postgis-jdbc
SUBDIR += postgis20
SUBDIR += postgis21

View File

@ -0,0 +1,28 @@
# Created by: lbartoletti <lbartoletti@tuxfamily.org>
# $FreeBSD$
PORTNAME= pointcloud
PORTVERSION= 1.0.1
DISTVERSIONPREFIX= v
CATEGORIES= databases geography
MAINTAINER= lbartoletti@tuxfamily.org
COMMENT= LIDAR types for PostgreSQL
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/COPYRIGHT
BUILD_DEPENDS= ${LOCALBASE}/include/laz-perf/las.hpp:archivers/lazperf
LIB_DEPENDS= libght.so:devel/libght
USES= cmake pgsql
WANT_PGSQL= server
CMAKE_ARGS+= -DWITH_TESTS:BOOL=FALSE
CFLAGS+= -I${LOCALBASE}/include
USE_GNOME= libxml2
USE_LDCONFIG= yes
USE_GITHUB= yes
GH_ACCOUNT= pgpointcloud
.include <bsd.port.mk>

View File

@ -0,0 +1,3 @@
TIMESTAMP = 1502912568
SHA256 (pgpointcloud-pointcloud-v1.0.1_GH0.tar.gz) = 3fac2efe1263b0876c26fc77e28f3664b56aa1e142c92383f9eb5b828999d0e7
SIZE (pgpointcloud-pointcloud-v1.0.1_GH0.tar.gz) = 281146

View File

@ -0,0 +1,19 @@
--- CMakeLists.txt.orig 2015-08-09 08:58:06 UTC
+++ CMakeLists.txt
@@ -79,7 +79,7 @@ exec_program(${PG_CONFIG} ARGS --include
exec_program(${PG_CONFIG} ARGS --pkglibdir OUTPUT_VARIABLE PGSQL_PKGLIBDIR)
exec_program(${PG_CONFIG} ARGS --sharedir OUTPUT_VARIABLE PGSQL_SHAREDIR)
exec_program(${PG_CONFIG} ARGS --bindir OUTPUT_VARIABLE PGSQL_BINDIR)
-exec_program(${PG_CONFIG} ARGS --cppflags OUTPUT_VARIABLE PGSQL_CPPFLAGS)
+exec_program(${PG_CONFIG} ARGS --cflags OUTPUT_VARIABLE PGSQL_CFLAGS)
exec_program(${PG_CONFIG} ARGS --ldflags OUTPUT_VARIABLE PGSQL_LDFLAGS)
exec_program(${PG_CONFIG} ARGS --libs OUTPUT_VARIABLE PGSQL_LIBS)
@@ -90,7 +90,7 @@ find_package (LibXml2 REQUIRED)
mark_as_advanced (CLEAR LIBXML2_INCLUDE_DIR)
mark_as_advanced (CLEAR LIBXML2_LIBRARIES)
include_directories (${LIBXML2_INCLUDE_DIR})
-
+link_directories (${CMAKE_INSTALL_PREFIX}/lib)
#------------------------------------------------------------------------------

View File

@ -0,0 +1,11 @@
--- pgsql/pc_access.c.orig 2015-08-09 08:58:06 UTC
+++ pgsql/pc_access.c
@@ -315,7 +315,7 @@ Datum pointcloud_agg_transfn(PG_FUNCTION
if (fcinfo->context && IsA(fcinfo->context, AggState))
{
- aggcontext = ((AggState *) fcinfo->context)->aggcontext;
+ aggcontext = ((AggState *) fcinfo->context)->aggcontexts;
}
else if (fcinfo->context && IsA(fcinfo->context, WindowAggState))
{

View File

@ -0,0 +1,3 @@
A PostgreSQL extension for storing point cloud (LIDAR) data.
WWW: https://github.com/pgpointcloud/pointcloud/

View File

@ -0,0 +1,5 @@
lib/postgresql/pointcloud.so
share/postgresql/extension/pointcloud--1.0.1.sql
share/postgresql/extension/pointcloud.control
share/postgresql/extension/pointcloud_postgis--1.0.sql
share/postgresql/extension/pointcloud_postgis.control