math/clp: Update 1.16.10 -> 1.17.3

PR:		220232
Submitted by:	pfg
Approved by:	co9co9@gmail.com (maintainer's timeout; 2+ years)
This commit is contained in:
Yuri Victorovich 2019-12-21 22:55:31 +00:00
parent 1f5ca43d81
commit a7973a9061
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=520583
6 changed files with 23 additions and 106 deletions

View File

@ -2,11 +2,11 @@
# $FreeBSD$
PORTNAME= Clp
PORTVERSION= 1.16.10
PORTREVISION= 8
DISTVERSION= 1.17.3
CATEGORIES= math
MASTER_SITES= http://www.coin-or.org/download/source/${PORTNAME}/ \
http://www.mavetju.org/download/adopted/
PKGNAMEPREFIX= coin-or-
MAINTAINER= co9co9@gmail.com
COMMENT= Linear Programming Solver
@ -14,23 +14,22 @@ COMMENT= Linear Programming Solver
LICENSE= EPL
USES= blaslapack compiler:c++11-lang fortran libtool pathfix tar:tgz
CXXFLAGS+= -ffast-math
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
TEST_TARGET= unitTest
TEST_WRKSRC= ${WRKSRC}/${PORTNAME}
INSTALL_TARGET= install-strip
CONFIGURE_ARGS= --with-lapack-lib="${LAPACKLIB} -L${LOCALBASE}/lib" \
--with-blas-lib="${BLASLIB} -L${LOCALBASE}/lib" \
--datadir=${DATADIR}
TEST_TARGET= unitTest
TEST_WRKSRC= ${WRKSRC}/${PORTNAME}
OPTIONS_DEFINE= DEBUG DOCS
PORTDOCS= *
CXXFLAGS+= -ffast-math
DEBUG_CXXFLAGS= -fomit-frame-pointer
post-install:
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/*.so
.include <bsd.port.mk>

View File

@ -1,3 +1,3 @@
TIMESTAMP = 1475286033
SHA256 (Clp-1.16.10.tgz) = 5cd880f2afcffd79d223fb8b0a448119600a3edee98409c7e989f3246d2f3acd
SIZE (Clp-1.16.10.tgz) = 9968182
TIMESTAMP = 1576960990
SHA256 (Clp-1.17.3.tgz) = a13bf54291ad503cf76f5f93f2643d2add4faa5d0e60ff2db902ef715c094573
SIZE (Clp-1.17.3.tgz) = 9983267

View File

@ -1,66 +0,0 @@
--- Clp/src/AbcSimplex.cpp.orig 2018-04-16 06:55:57 UTC
+++ Clp/src/AbcSimplex.cpp
@@ -368,19 +368,19 @@ AbcSimplex::gutsOfInitialize(int numberR
// say Steepest pricing
abcDualRowPivot_ = new AbcDualRowSteepest();
abcPrimalColumnPivot_ = new AbcPrimalColumnSteepest();
- internalStatus_ = newArray(reinterpret_cast<unsigned char *>(NULL),
+ internalStatus_ = newArray(nullptr,
sizeArray+maximumNumberTotal_);
- abcLower_ = newArray(reinterpret_cast<double *>(NULL),sizeArray);
- abcUpper_ = newArray(reinterpret_cast<double *>(NULL),sizeArray);
- abcCost_ = newArray(reinterpret_cast<double *>(NULL),sizeArray+maximumNumberTotal_);
- abcDj_ = newArray(reinterpret_cast<double *>(NULL),sizeArray);
- abcSolution_ = newArray(reinterpret_cast<double *>(NULL),sizeArray+maximumNumberTotal_);
- //fromExternal_ = newArray(reinterpret_cast<int *>(NULL),sizeArray);
- //toExternal_ = newArray(reinterpret_cast<int *>(NULL),sizeArray);
- scaleFromExternal_ = newArray(reinterpret_cast<double *>(NULL),sizeArray);
- offset_ = newArray(reinterpret_cast<double *>(NULL),sizeArray);
- abcPerturbation_ = newArray(reinterpret_cast<double *>(NULL),sizeArray);
- abcPivotVariable_ = newArray(reinterpret_cast<int *>(NULL),maximumAbcNumberRows_);
+ abcLower_ = newArray(nullptr,sizeArray);
+ abcUpper_ = newArray(nullptr,sizeArray);
+ abcCost_ = newArray(nullptr,sizeArray+maximumNumberTotal_);
+ abcDj_ = newArray(nullptr,sizeArray);
+ abcSolution_ = newArray(nullptr,sizeArray+maximumNumberTotal_);
+ //fromExternal_ = newArray(nullptr,sizeArray);
+ //toExternal_ = newArray(nullptr,sizeArray);
+ scaleFromExternal_ = newArray(nullptr,sizeArray);
+ offset_ = newArray(nullptr,sizeArray);
+ abcPerturbation_ = newArray(nullptr,sizeArray);
+ abcPivotVariable_ = newArray(nullptr,maximumAbcNumberRows_);
// Fill perturbation array
setupPointers(maximumAbcNumberRows_,maximumAbcNumberColumns_);
fillPerturbation(0,maximumNumberTotal_);
@@ -554,19 +554,19 @@ AbcSimplex::createSubProblem(int numberC
subProblem->maximumNumberTotal_= maximumAbcNumberRows_+numberColumns;
subProblem->numberTotalWithoutFixed_= subProblem->numberTotal_;
int sizeArray=2*subProblem->maximumNumberTotal_+maximumAbcNumberRows_;
- subProblem->internalStatus_ = newArray(reinterpret_cast<unsigned char *>(NULL),
+ subProblem->internalStatus_ = newArray(nullptr,
sizeArray+subProblem->maximumNumberTotal_);
- subProblem->abcLower_ = newArray(reinterpret_cast<double *>(NULL),sizeArray);
- subProblem->abcUpper_ = newArray(reinterpret_cast<double *>(NULL),sizeArray);
- subProblem->abcCost_ = newArray(reinterpret_cast<double *>(NULL),sizeArray+subProblem->maximumNumberTotal_);
- subProblem->abcDj_ = newArray(reinterpret_cast<double *>(NULL),sizeArray);
- subProblem->abcSolution_ = newArray(reinterpret_cast<double *>(NULL),sizeArray+subProblem->maximumNumberTotal_);
- //fromExternal_ = newArray(reinterpret_cast<int *>(NULL),sizeArray);
- //toExternal_ = newArray(reinterpret_cast<int *>(NULL),sizeArray);
- subProblem->scaleFromExternal_ = newArray(reinterpret_cast<double *>(NULL),sizeArray);
- subProblem->offset_ = newArray(reinterpret_cast<double *>(NULL),sizeArray);
- subProblem->abcPerturbation_ = newArray(reinterpret_cast<double *>(NULL),sizeArray);
- subProblem->abcPivotVariable_ = newArray(reinterpret_cast<int *>(NULL),maximumAbcNumberRows_);
+ subProblem->abcLower_ = newArray(nullptr,sizeArray);
+ subProblem->abcUpper_ = newArray(nullptr,sizeArray);
+ subProblem->abcCost_ = newArray(nullptr,sizeArray+subProblem->maximumNumberTotal_);
+ subProblem->abcDj_ = newArray(nullptr,sizeArray);
+ subProblem->abcSolution_ = newArray(nullptr,sizeArray+subProblem->maximumNumberTotal_);
+ //fromExternal_ = newArray(nullptr,sizeArray);
+ //toExternal_ = newArray(nullptr,sizeArray);
+ subProblem->scaleFromExternal_ = newArray(nullptr,sizeArray);
+ subProblem->offset_ = newArray(nullptr,sizeArray);
+ subProblem->abcPerturbation_ = newArray(nullptr,sizeArray);
+ subProblem->abcPivotVariable_ = newArray(nullptr,maximumAbcNumberRows_);
subProblem->setupPointers(maximumAbcNumberRows_,numberColumns);
// could use arrays - but for now be safe
int * backward = new int [numberFullColumns+numberRows_];

View File

@ -1,11 +0,0 @@
--- Clp/src/ClpModel.cpp.orig 2018-04-16 06:43:28 UTC
+++ Clp/src/ClpModel.cpp
@@ -3845,7 +3845,7 @@ ClpModel::writeMps(const char *filename,
writer.setMpsData(*(matrix_->getPackedMatrix()), COIN_DBL_MAX,
getColLower(), getColUpper(),
objective,
- reinterpret_cast<const char*> (NULL) /*integrality*/,
+ nullptr /*integrality*/,
getRowLower(), getRowUpper(),
columnNames, rowNames);
// Pass in array saying if each variable integer

View File

@ -1,11 +0,0 @@
--- Clp/src/OsiClp/OsiClpSolverInterface.cpp.orig 2018-04-16 06:57:00 UTC
+++ Clp/src/OsiClp/OsiClpSolverInterface.cpp
@@ -1448,7 +1448,7 @@ OsiClpSolverInterface::setupForRepeatedU
if (stopPrinting) {
CoinMessages * messagesPointer = modelPtr_->messagesPointer();
// won't even build messages
- messagesPointer->setDetailMessages(100,10000,reinterpret_cast<int *> (NULL));
+ messagesPointer->setDetailMessages(100,10000,nullptr);
}
#endif
}

View File

@ -3,6 +3,7 @@ include/coin/CbcOrClpParam.cpp
include/coin/CbcOrClpParam.hpp
include/coin/ClpCholeskyBase.hpp
include/coin/ClpCholeskyDense.hpp
include/coin/ClpCholeskyPardiso.hpp
include/coin/ClpConfig.h
include/coin/ClpConstraint.hpp
include/coin/ClpConstraintLinear.hpp
@ -26,6 +27,11 @@ include/coin/ClpNetworkMatrix.hpp
include/coin/ClpNode.hpp
include/coin/ClpNonLinearCost.hpp
include/coin/ClpObjective.hpp
include/coin/ClpPEDualRowDantzig.hpp
include/coin/ClpPEDualRowSteepest.hpp
include/coin/ClpPEPrimalColumnDantzig.hpp
include/coin/ClpPEPrimalColumnSteepest.hpp
include/coin/ClpPESimplex.hpp
include/coin/ClpPackedMatrix.hpp
include/coin/ClpParameters.hpp
include/coin/ClpPdcoBase.hpp
@ -121,22 +127,22 @@ include/coin/OsiSolverParameters.hpp
include/coin/OsiUnitTests.hpp
lib/libClp.so
lib/libClp.so.1
lib/libClp.so.1.13.10
lib/libClp.so.1.14.3
lib/libClpSolver.so
lib/libClpSolver.so.1
lib/libClpSolver.so.1.13.10
lib/libClpSolver.so.1.14.3
lib/libCoinUtils.so
lib/libCoinUtils.so.3
lib/libCoinUtils.so.3.10.13
lib/libCoinUtils.so.3.11.2
lib/libOsi.so
lib/libOsi.so.1
lib/libOsi.so.1.12.7
lib/libOsi.so.1.13.4
lib/libOsiClp.so
lib/libOsiClp.so.1
lib/libOsiClp.so.1.13.10
lib/libOsiClp.so.1.14.3
lib/libOsiCommonTests.so
lib/libOsiCommonTests.so.1
lib/libOsiCommonTests.so.1.12.7
lib/libOsiCommonTests.so.1.13.4
libdata/pkgconfig/clp.pc
libdata/pkgconfig/coindatanetlib.pc
libdata/pkgconfig/coindatasample.pc