- Fix build with Tcl 8.6

Reported by:	miwi (Tcl/Tk 86 exp-run)
This commit is contained in:
Pietro Cerutti 2013-05-13 15:42:49 +00:00
parent 9131361612
commit a78c39b47e
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=318112
2 changed files with 18 additions and 7 deletions

View File

@ -1,9 +1,5 @@
# New ports collection makefile for: tix
# Date created: 22 December 1996
# Whom: Thomas Gellekum <tg@freebsd.org>
#
# Created by: Thomas Gellekum <tg@freebsd.org>
# $FreeBSD$
#
PORTNAME= tix
PORTVERSION= 8.4.3
@ -23,7 +19,9 @@ CONFIGURE_ARGS= --enable-shared --enable-sam \
--with-tclconfig="${TCL_LIBDIR}" \
--with-tkconfig="${TK_LIBDIR}" \
--with-tclinclude="${TCL_INCLUDEDIR}" \
--with-tkinclude="${TK_INCLUDEDIR}"
--with-tkinclude="${TK_INCLUDEDIR}" \
--prefix=${PREFIX} \
--exec-prefix=${PREFIX}
# this should probably be added to bsd.port.mk
CONFIGURE_ENV= PREFIX=${PREFIX}
MANN= TixIntro.n compound.n pixmap.n tix.n tixBalloon.n \
@ -49,7 +47,7 @@ pre-extract:
pre-configure:
@(cd ${WRKSRC} && \
CC="${CC}" ac_cv_path_CC="${CC}" CFLAGS="${CFLAGS}" \
INSTALL="/usr/bin/install -c -o ${BINOWN} -g ${BINGRP}" \
INSTALL="${INSTALL} -c -o ${BINOWN} -g ${BINGRP}" \
INSTALL_PROGRAM="${INSTALL_PROGRAM}" \
INSTALL_SCRIPT="${INSTALL_SCRIPT}" \
${CONFIGURE_ENV} ./${CONFIGURE_SCRIPT} ${CONFIGURE_ARGS})

View File

@ -0,0 +1,13 @@
--- generic/tixGrSort.c.orig 2013-05-13 10:52:04.000000000 +0200
+++ generic/tixGrSort.c 2013-05-13 10:53:38.000000000 +0200
@@ -447,8 +447,8 @@
* Parse the result of the command.
*/
- order = strtol(sortInterp->result, &end, 0);
- if ((end == sortInterp->result) || (*end != 0)) {
+ order = strtol(Tcl_GetStringResult(sortInterp), &end, 0);
+ if ((end == Tcl_GetStringResult(sortInterp)) || (*end != 0)) {
Tcl_ResetResult(sortInterp);
Tcl_AppendResult(sortInterp,
"comparison command returned non-numeric result",