security/gvm-libs: fix build on armv7 (+)
- add missing type casts for sizeof(time_t) > sizeof(long) - neuter -Werror as per policy - while we are at it, pet portlint Approved by: maintainer timeout (acm) Submitted by: Robert Clausecker PR: 266725 MFH: 2022Q4
This commit is contained in:
parent
42e0e17c2b
commit
a774bfbbb0
@ -1,11 +1,11 @@
|
||||
PORTNAME= gvm
|
||||
DISTVERSION= 22.4.0
|
||||
DISTVERSIONPREFIX= v
|
||||
DISTVERSION= 22.4.0
|
||||
CATEGORIES= security
|
||||
PKGNAMESUFFIX= -libs
|
||||
|
||||
MAINTAINER= acm@FreeBSD.org
|
||||
COMMENT= libraries module for the GVM solution
|
||||
COMMENT= Libraries module for the GVM solution
|
||||
WWW= https://github.com/greenbone/gvm-libs
|
||||
|
||||
LICENSE= GPLv2+
|
||||
@ -23,11 +23,10 @@ LIB_DEPENDS= libassuan.so:security/libassuan \
|
||||
libpaho-mqtt3a.so:net/libpaho-mqtt3
|
||||
RUN_DEPENDS= doxygen>0:devel/doxygen
|
||||
|
||||
USES= cmake gnome pkgconfig
|
||||
USE_GITHUB= yes
|
||||
GH_ACCOUNT= greenbone
|
||||
GH_PROJECT= ${PORTNAME}${PKGNAMESUFFIX}
|
||||
|
||||
USES= cmake gnome pkgconfig
|
||||
USE_GNOME= glib20 libxml2
|
||||
USE_LDCONFIG= yes
|
||||
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- CMakeLists.txt.orig 2021-10-11 09:38:23.000000000 -0500
|
||||
+++ CMakeLists.txt 2021-11-04 10:31:40.191911000 -0500
|
||||
@@ -134,7 +134,7 @@
|
||||
--- CMakeLists.txt.orig 2022-07-18 08:40:56 UTC
|
||||
+++ CMakeLists.txt
|
||||
@@ -136,7 +136,7 @@ if (SYSCONF_INSTALL_DIR)
|
||||
endif (SYSCONF_INSTALL_DIR)
|
||||
|
||||
if (NOT SYSCONFDIR)
|
||||
@ -9,7 +9,7 @@
|
||||
endif (NOT SYSCONFDIR)
|
||||
|
||||
if (NOT EXEC_PREFIX)
|
||||
@@ -174,7 +174,7 @@
|
||||
@@ -176,7 +176,7 @@ if (NOT DATADIR)
|
||||
endif (NOT DATADIR)
|
||||
|
||||
if (NOT GVM_RUN_DIR)
|
||||
@ -17,8 +17,8 @@
|
||||
+ set (GVM_RUN_DIR "${LOCALSTATEDIR}/run/gvm")
|
||||
endif (NOT GVM_RUN_DIR)
|
||||
|
||||
if (NOT GVM_PID_DIR)
|
||||
@@ -187,7 +187,7 @@
|
||||
if (NOT GVM_SYSCONF_DIR)
|
||||
@@ -185,7 +185,7 @@ endif (NOT GVM_SYSCONF_DIR)
|
||||
|
||||
|
||||
if (NOT REDIS_SOCKET_PATH)
|
||||
@ -27,3 +27,11 @@
|
||||
endif ()
|
||||
|
||||
add_definitions (-DREDIS_SOCKET_PATH="${REDIS_SOCKET_PATH}")
|
||||
@@ -208,7 +208,6 @@ set (
|
||||
-std=c11 \
|
||||
-Wall \
|
||||
-Wextra \
|
||||
- -Werror \
|
||||
-Wpedantic \
|
||||
-Wmissing-prototypes \
|
||||
-Wshadow \
|
||||
|
@ -1,5 +1,5 @@
|
||||
--- boreas/alivedetection.c.orig 2020-12-30 23:49:07.498953000 -0500
|
||||
+++ boreas/alivedetection.c 2020-12-30 23:50:37.570417000 -0500
|
||||
--- boreas/alivedetection.c.orig 2022-07-18 08:40:56 UTC
|
||||
+++ boreas/alivedetection.c
|
||||
@@ -39,7 +39,12 @@
|
||||
#include <netinet/ip6.h>
|
||||
#include <netinet/ip_icmp.h>
|
||||
@ -14,3 +14,14 @@
|
||||
#include <pcap.h>
|
||||
#include <pthread.h>
|
||||
#include <stdlib.h>
|
||||
@@ -290,8 +295,8 @@ scan (alive_test_t alive_test)
|
||||
|
||||
gettimeofday (&end_time, NULL);
|
||||
|
||||
- g_message ("Alive scan %s finished in %ld seconds: %d alive hosts of %d.",
|
||||
- scan_id, end_time.tv_sec - start_time.tv_sec,
|
||||
+ g_message ("Alive scan %s finished in %lld seconds: %d alive hosts of %d.",
|
||||
+ scan_id, (long long)(end_time.tv_sec - start_time.tv_sec),
|
||||
g_hash_table_size (scanner.hosts_data->alivehosts),
|
||||
number_of_targets);
|
||||
g_free (scan_id);
|
||||
|
13
security/gvm-libs/files/patch-boreas_cli.c
Normal file
13
security/gvm-libs/files/patch-boreas_cli.c
Normal file
@ -0,0 +1,13 @@
|
||||
--- boreas/cli.c.orig 2022-09-30 08:26:50 UTC
|
||||
+++ boreas/cli.c
|
||||
@@ -162,8 +162,8 @@ run_cli_scan (scanner_t *scanner, alive_test_t alive_t
|
||||
scanner->hosts_data->alivehosts);
|
||||
gettimeofday (&end_time, NULL);
|
||||
if (scanner->print_results == 1)
|
||||
- printf ("Alive scan finished in %ld seconds: %d alive hosts of %d.\n",
|
||||
- end_time.tv_sec - start_time.tv_sec,
|
||||
+ printf ("Alive scan finished in %lld seconds: %d alive hosts of %d.\n",
|
||||
+ (long long)(end_time.tv_sec - start_time.tv_sec),
|
||||
number_of_targets - number_of_dead_hosts, number_of_targets);
|
||||
|
||||
return error;
|
Loading…
Reference in New Issue
Block a user